Ubuntu

Natty Screensaver freezes system after some period of inactivity

Reported by Carlos Lerzundy on 2011-04-16
920
This bug affects 229 people
Affects Status Importance Assigned to Milestone
acpi
New
Undecided
Unassigned
xf86-video-intel
Confirmed
Undecided
Unassigned
gnome-screensaver (Ubuntu)
High
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-screensaver

When selecting "Floating Ubuntu" screensaver, after a period of inactivity greater than 40min, the systems locks itself and becomes unresponsive.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-screensaver 2.30.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Sat Apr 16 13:04:12 2011
EcryptfsInUse: Yes
GconfGnomeSession:
 idle_delay = 5
  /desktop/gnome/session/required_components:
   windowmanager = gnome-wm
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-screensaver
UpgradeStatus: Upgraded to natty on 2011-04-15 (1 days ago)
WindowManager: gnome-wm

Carlos Lerzundy (arepaking) wrote :
dFlyer (ggaribaldi) wrote :

Also happens on my wifes computer a gateway and on my dell studio 1735. This has been happening for the past week.

Manjul Apratim (manzdagratiano) wrote :

I have a similar issue on my Dell Vostro V13; in fact, certain screensavers have been sluggish ever since the upgrade to natty, notably "Helios" - there was no such issue on Maverick. Also notable is the point that I have observed no such issue on my Sony Vaio VGNAR520E, which has also been upgraded to natty. The Vaio has an nvidia GeForce 8400, while the V13 has the onboard intel video, which might be related to the issue. When the screen freezes, I can log onto a virtual console using Alt + Ctrl + F1 and issue "sudo pkill X" from there to restart the X server, at which time gdm loads and allows me to log-in.

The freezing occurs with any screensaver as far as I have noticed - sluggish or not; Helios was visibly bad; Hufo's Tunnel is normal but it freezes similarly.

Carlos Lerzundy (arepaking) wrote :

Just a quick update.
I discovered that the computer will not freeze if "blank" is chosen for the screensaver.

Manjul Apratim (manzdagratiano) wrote :

There were no freezes after I disabled the screensaver on the Vostro V13. Also, while the screensaver was enabled and X froze, after killing X through a virtual console and restarting it, it could be seen in the gnome system monitor that Hufo's Tunnel was using ~ 100% CPU; moreover, Helios was also present on the task list, even though I had selected Hufo's Tunnel as the screensaver (then again, it might have to do with the fact that I have not rebooted that machine since).

Dimis (dimis) wrote :

I have the same problem with GLslideShow screensaver on my laptop Sony VAIO VPCB1.
I have updated from 10.10 to 11.04 yesterday and today got this problem.

tony addyman (tony-addyman) wrote :

This work around works for me when the bug hits: Use Ctrl-Alt-F1 to get a text login prompt and login as the same user that you were using with Unity/Gnome. Use top to find the process number of the screensaver process. It will likely be at the top of the list as it will be running 98-100% CPU utilisation. Issue kill -9 on the process. Logout and switch back to your GUI session using Ctrl-Alt-F7.

Botond Szász (boteeka) wrote :

It could be that I am hit by some other problem, but most of the symptoms seem to be the same.

My experience is that Unity freezes even when "Blank screen" is selected as screensaver.
Whenever the freeze hits I switch to a terminal with Ctrl-Alt-F1, log in and then issue the following commands:

sudo killall -w -s KILL compiz

DISPLAY=:0.0 compiz --replace

and switch back to X with Ctrl-Alt-F7 and see Compiz restarting.

Sometimes I need to repeat this two or three times in a row to succeed.

W. Scott Howard (wscotthoward) wrote :

I get a similar issue, the screen saver works fine until I enter my password to unlock. at which time the screen freezes on the last screen saver image until I kill the gnome-screensav process

Russell Wing (wingfamily) wrote :

Similar issue where screensaver hangs machine when running for a while. 11.04 with INTEL GMA4500 chipset. Some screensavers also seem sluggish as mentioned by others. CTRL+ALT+BACKSPACE to restart X solves the problem, but a bit drastic as a sustainable fix :-)

Ken_Kaniff (kkaniff) wrote :

Hi, same problem here on my ThinkPad running Natty. The laptop freezes on any screensaver with radio or movie playing underneath.

Andy (andy-andypc) wrote :

Running Natty on Intel DH55TC. After enabling screensaver, screen freezes, and I have to power down to restart. Also system fans have started to run faster at the same time. Will disable screensaver and report back.

I have also experienced the same problem on my Sony VAIO (VGN22E), It happened both in Ubuntu and Ubuntu classic desktop. It was the floating ubuntu logo and matrix screensavers that I have tried so far.

Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
importance: Undecided → High
MikeCz (mikec-busworks) wrote :

Put me on the list as well:

Running a Compaq Presariu CQ60 (I thinks its the 211DX but I don't have it handy to verify):

2.16Ghz Intel Celeron 585
2gig RAM
Intel Graphics Media Accelerator 4500M

Running the fiberlight screensaver graphic.

I have it set to 'do nothing' if the lid is closed.

I typically let it sit running the Transmission bit torrent client, and often if it sits for long periods with the lid closed, when I open it back up the screen is on the desktop with no screen saver running. I can move the mouse but it doesn't respond to the keyboard or any mouse clicks. I have to drop to a virtual terminal (typically ctrl-alt-F2) and do a straignt ctrl-alt-del to reboot (I tried killing the screensaver process but that didn't work; didn't try restarting X yet seperate from a reboot). This same set up ran 9.10 fine, BTW; the current set up was a fresh install of 11.04 (An upgrade install failed so I had to wipe and start from scratch).

Just adding my little bit to the info; I will try the 'blank screen' workaround though in the meantime before just deciding to go with Mint XFCE.... ;-)

mdmcginn (mcweb) wrote :

Using Blank Screen at the office, I can't always get a terminal prompt with Ctl-Alt-F2 and Ctl-Alt-Delete doesn't work either. Pressing the power button does....

Using Pictures Folder at home, I was greeted with one of my pictures, and the cursor moved, even changed to a hand sometimes. Music was still playing. But I couldn't get the picture to go away by using my mouse or keyboard. I could use Ctl-Alt-F2 then Ctl-Alt-Delete. Because of monitor settings/problems, I can't see the terminal prompt, and I haven't tried any other commands to work around the issue at home.

MikeCz (mikec-busworks) wrote :

Additional note: Switching to the Blank screensaver did not make a difference, though it seems to be correlated to having the lid of my laptop closed for approx 20 minutes, and it is more noticable if I have things running onscreen when it happens.

Manually killing gnome-screensaver and compiz doesn't seem to make a difference; nothing short of a full reboot seems to bring it back to normal. Haven't tried it with just the blank Unity desktop.

For now I've just disabled the screensaver until I get word that this is fixed.

MikeCz (mikec-busworks) wrote :

More info: after several tries, with only the Unity desktop running and letting the machine sit for approx 20 minutes with the lid closed, the screen kept flickering between the unlock screen and the blank desktop. I ran a ps -eaf from a virtual termial and saw a line related to the lock screen, but did not write down the command for the process (will try to duplicate it again and capture that.

It too my unlock password, and it stopped flickering and went to the blank desktop, and after killing gnome-screensaver and Compiz I had to reboot the machine (via init 6).

MikeCz (mikec-busworks) wrote :

OK, it is locked up as before, and I see some relevant lines:

username ProcessID Parent ID command

<me> 1535 1 /usr/bin/gnome-screensaver --no-daemon
<me> 1726 1535 /usr/lib/gnome-screensaver/gnome-screensaver-dialog --status-message= --enable-switch
<me> 1906 1535 /usr/lib/xscreensaver/fiberlamp -root

And when I do a ctrl-alt-F7, it won't redraw the screen, even after killing these processes.

And now I'll go back to disabling the screensaver until this gets fixed; I'm not that good with X.

Rafael Rubio (rafa-rubio-s) wrote :

I don't think it's a screensaver problem. Even disabling screensaver, when the screen goes down because of inactivity the screen freezes. In a tty, if I kill Xorg, the screen restores and I can log in again, but with a new session and all my work is lost

Sean Fenton (bobodod) wrote :

ThinkPad T500, Natty 64bit: I turned off the screensaver entirely & set the screen to sleep after 5min. Now it doesn't lock up every time, but still locks up. Often, the screen will wake up & the GUI will all be frozen.

I just tried the "Alt + SysRq + r + s + e + i + u + b" trick & it wouldn't reboot. All the steps appeared to work until the "b" for reboot. Bug 303601 might be relevant here.

I don't have time right now to learn why it didn't reboot for me just now, but I'll do that next. Also, there's another key combination with "Alt + PrintScreen + r + e + i + s + u + b", which is the way I always remember it.

micred (tict) wrote :

I think the cause of this bug was misunderstood by someone.
I also get hanging after screen goes blank in 11.04 (natty) but switching to VT1 and killing gnome-screensaver doesn't help (and I don't even think it's the cause).

Every time I notice this problem the last line of Xorg.0.log was like:
"[ 1914.240] (II) AIGLX: Suspending AIGLX clients for VT switch".

Problem can be easily reproduced in my system: set 1 minute display timeout on Power Management and wait.
It doesn't hang every time screen goes black, but every time it hang, Xorg.0.log contains that message.
Maybe is more frequent if the browser is playing Flash content.

Chipset: Intel(R) GM45
Video card: Intel 4500MHD

micred (tict) wrote :

The problem I describe (and probably also of Sean Fenton and others upgrading to natty) seam the same of Bug 780653.
What do you think about it?

Sorry for my bad english.

MikeCz (mikec-busworks) wrote :

One other oddity: I just had my machine lock up despite having deactivated the screensaver.

The lid on my laptop was closed for approx 2 hours, and I was running the Transmission bittorrent client minimized. The power setting to blank the screen may be to blame, since the gnome-screensaver process is still running and may be what is blanking the screen. It may in fact be related to having the Transmission client running, though I've had the machine running overnight in the same configuration and had no issue.

Just one other small bit of info.

Jmadero (jmadero) wrote :

MikeCz, I noticed the same thing, I've probably had to hard reboot at least 50 times since installing 11.04. I disabled the screensaver but am still seeing the issue, just had a freeze right now. This is a serious problem and can easily result in some broken hard drives. I'm tempted to downgrade but hoping a fix is released in the next couple days

MikeCz (mikec-busworks) wrote :

I'm personally waiting until June before I consider going to another distro.

Peter Newcomb (peter-petesbox) wrote :

I was experiencing this problem (screen freezes except mouse pointer, but can still Ctrl-Alt-F1 to a terminal) regularly until a few days ago when I went into power manager and set "Put display to sleep when inactive for:" to Never (for both AC and battery). Since then, I have not had the problem at all, though of course my display also never goes to sleep. :-)

MikeCz (mikec-busworks) wrote :

Peter: I never run on batteries and the AC power profile is also set to 'never' but I will try that nevertheless.

Jmadero (jmadero) wrote :

I have noticed the same so far, turning turn display off to never so far has solved the problem but of course it's a waste of electricity and having a monitor on when I'm just listening to music doesn't make sense. Thanks all for the hard work

Walter Méndez (waltmenz) wrote :

A couple of minutes ago, my computer with the screen-saver disable was with the screen turn off, but it received an update notification during the time when the screen was turn off and it freeze, also a few days ago the screen was turn off and I was listening music, and I press a key to go to the next song and it also freeze.
In both cases, I can move the mouse but when I tried to click an application using Unity of Ubuntu Classic it does not work, also, I can press Ctrl + Alt F1 and write top to see what it's happening but everything seen normal.
I upgraded from Ubuntu (64)10.10 to 11.04.
Thanks for helping us with this issue.

John Speight (jgdspeight) wrote :

Count me in!
Acer aspire 5732z, 4GB RAM intel pentium T4300 intel GMA4500 graphics. Upgraded from Maverick(64) to Natty(64), and get the same freeze after inactivity. Seems to happen regardless of screensaver. Curiously, while cursor appears, to move, Key combinations only seem to work part of the time.
In my case, it might have something to do with the fairly rough and ready workarounds to get the backlight working properly...
Am playing with power settings now, to try and get to the bottom of this...

David Gillies (daveg) wrote :

I've been having the same problem as well. My machine is using the onboard graphics of an Intel H67 sandybridge motherboard. Based off micred's comment of it possibly being the same issue as in Bug 780653, I tried enabling the option "Lock screen when screensaver is active" in the screensaver settings. After that I haven't had the screen exhibit the same behaviour as everyone else has mentioned.

Peter Newcomb (peter-petesbox) wrote :

Well, looks like the power manager tweak didn't eliminate it after all. However, I'm now starting to suspect full-screen video as a contributing factor, as my most recent "freeze" happened only after I watched a full-screen video for the first time since the power-manager tweak, and I had had inklings that full-screen video might be involved even before that tweak.

I'll try to run some more tests over the next few days...

BTW, I'm running on a Lenovo X201.

Mark Wilkinson (mhw) wrote :

A quick run through the comments suggests that the Intel graphics adaptor might be a common factor here. Is anyone having this problem on a system that isn't using Intel graphics? If not, that may implicate xserver-xorg-video-intel.

micred (tict) wrote :

Peter, you were viewing video using Flash?
I notice much more hangs playing Flash content and every time last line of Xorg.0.log was "AIGLX: Suspending AIGLX clients for VT switch" .
Someone expert of AIGLX, Xorg, intel video cards can suppose where the bug can be?

luca (l-savio) wrote :

Hi, seems that the issue is just on Intel graphics adapters with natty 64: my Acer Extensa 5635z has this issue ramdomly, the eeepc 900 with natty 32 works fine.

Jmadero (jmadero) wrote :

This definitely isn't video related as it happens to me all the time and I have no video running. It seems like it happens more when I have banshee going BUT this could just be because I have banshee going a lot of the day. I haven't had a freeze in 24 hours with screen saver and "turn off monitor" both disabled. This is despite me listening to banshee for at least 5 hours in the last 24. Also full screen VLC, Banshee and Flash have no caused any freezes for me

Alf (antonio-floresta) wrote :

I am having this problem too and I am running Natty 32bit on a desktop (Lenovo ThinkCentre 8810-AA5) with an Intel onboard graphics card (00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)).
The workaround that I am using is:
- switch to a console using Ctrl-Alt-F1.
- ps aux|grep gnome-screensaver to get the process ID
- kill -9 <pid>
- switch back to the X

Peter Newcomb (peter-petesbox) wrote :

Yes, I'm pretty sure I was using Flash, but I haven't experienced any problems while watching videos, it's just that it seems like the hang only happens sometime after I had viewed a video in full-screen mode.

FWIW, I'm running 2.6.38-8-generic-pae i386, though my processor is an i5 (and therefore 64-bit).

MikeCz (mikec-busworks) wrote :

I think it may also have something to do with the screen locking: I had my laptop sitting, screensaver disabled via the screen saver control panel and in both the AC and battery profiles (the machine was running on AC power at the time), and I was running the Transmission bittorrent client. I opened the screen after about 5 minutes of it being closed (and it has been running continuously all day with me periodically opening the lid to check email and whatnot), and though it seemed to be responding, the mouse pointer and the whole screen seemed to flicker. That is, until I entered my password as if to unlock the screen, and then things went back to normal.

In a previous posting I made above I did notice a behavior similar to this before when the screen flickered between the screen saver and the lock screen.

MikeCz (mikec-busworks) wrote :

Oh, and after all of my comments and troubleshooting, I never mentioned specifically what version of Natty I was running!

32bit Natty Narwhal 11.04, fresh install from a burned ISO downloaded on 4/28/11 (IE, the actual release verison ,not an RC
or beta).

Dimis (dimis) on 2011-05-25
tags: added: intel
Claude Gagné (miltiad) on 2011-05-31
Changed in gnome-screensaver (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Extender (msveshnikov) on 2011-06-15
Changed in xserver-xorg-video-intel:
status: New → Confirmed
Changed in gnome-screensaver (Ubuntu):
status: Confirmed → Incomplete
Changed in gnome-screensaver (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Brad Figg (brad-figg) on 2011-07-18
Changed in linux (Ubuntu):
status: New → Incomplete
52 comments hidden view all 132 comments

apport information

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Simon Frettlöh (ubuntu-sf) wrote :

Running Ubuntu 11.04 (64 Bit, up to date for today's date) on a Sandy Bridge System (using CPU-integrated graphics) I also discover bevhaviour like reported here, but in variations. After recommend here to provoke bug, I set screen saver (blank) timeout to 1 minute, the same with energy saving of monitor. After several power-offs of the monitor due to energy saving and coming back of desktop without problems I encountered following:

Monitor was off due to power-saving. I moved mouse to get back againg (I am using no screen locking). But only mouse cursor/arrow appeared, nothing else. Thus, I switched to console (Ctrl + Alt + F1), trying to kick off apport-collect, which did not help, because I was not able to get this link into a browser. Tried "apport-cli --save bug.762918" but did not work because it told me it did not find a crash report. I saved current Xorg.log, which I will attach here. Afterwards killing compiz with signal "-9" brought back desktop, but mouse did not work, I was also not able to use e.g. Alt+Tab to switch applications. But, fortunately "Ctrl+Alt+T" worked and I started a terminal. I tried then to use "xwininfo --all" as suggest here, but ending up with an error message "xwininfo: error: Can't grab the mouse.", see screenshot attaced to next post which I was at least able to manage.

Any suggestions how to further investigate this or how I can help developers? This is a rather annoying bug rendering Ubuntu nearly to useless for users which are not able to issue kill commands on the console.

1 comments hidden view all 132 comments
josechu (josechu2004) wrote :

Eureka!

I think that comment #82 by Aitor Guevara has solved my freezes too.

Aitor Guevara (aitorciki) wrote on 2011-07-17: #82

https://bugs.launchpad.net/acpi/+bug/762918/comments/82

At least I've been without freezes for more than 50+ hours, after applying his very simple guidelines.

Let's hope that not much people has bought another computer thinking this was a hardware problem.

The solution is also here:

http://ubuntu4beginners.blogspot.com/2011/04/unity-choppy-with-ati-graphics-card-and.html

It works for me, although I have an Intel 3100 graphics card instead of an AMD one.

Josechu

wwiser (wwiser) wrote :

I am also experiencing this bug on 11.04 (2.6.38-10-generic) with a i3-2100. I'm using the onboard video (vga).

Looking in /var/log/Xorg.0.log.old I see alot of these messages:

[100341.245] (WW) intel(0): intel_uxa_prepare_access: bo map failed: Input/output error

with one:

[100341.184] (II) AIGLX: Suspending AIGLX clients for VT switch

in the middle. These messages appear right before I restarted my pc.

Broco (broco2002) wrote :

https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/762918/comments/4
That's wrong for me, even with blank selected it crashed.

https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/762918/comments/82
Worked for me so far, thanks.
This even boosts some effects and Fullscreen-OpenGL-Applications (e.g. Braid) now work fine (they were crashing before).

Maybe this option should be disabled by default.

Michael Alexander (ftmichael) wrote :

Disabling 'sync to vblank' hasn't worked for me at all. Certain screensavers (Fuzzy Flakes, GLText, and occasionally AntSpotlight, GLBlur, and possibly one or two others) keep crashing while others seem to be fine. I'm at a loss at this point.

Wayne Rodrigues (waynerod10) wrote :

Recently, this problem occurs on and off (randomly). Can't really say what causes it.
"Ctrl+Alt+Bkspace" fixes it.

I'm running "GLMatrix" as my screensaver.

Ian Will (icwill) wrote :

I've got the problem too. Looks like a segfault in gnome-screensaver or libcairo.

1) lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

2) apt-cache policy gnome-screensaver
Installed: 3.2.0-0ubuntu1
Candidate: 3.2.0-0ubuntu1
Version table:
*** 3.2.0-0ubuntu1 0
  500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
  100 /var/lib/dpkg/status

3) When the screen is locked, typically it should resume after mouse movement or keyboard input and provide a log-in prompt.
4) When mouse or keyboard event happen after screen lock, the cursor will move around but the screen is blank. I am able to access a non-X terminal via ctrl-alt-F1, but the X server is hung and must be killed.

The output of dmesg | tail is

[16621.910506] [<ffffffff8117939a>] do_vfs_ioctl+0x8a/0x340
[16621.910508] [<ffffffff811796e1>] sys_ioctl+0x91/0xa0
[16621.910512] [<ffffffff815f22c2>] system_call_fastpath+0x16/0x1b
[16621.910514] ---[ end trace ce3b9456974e9ef8 ]---
[16625.532183] usb 2-5.3.4: USB disconnect, device number 9
[16627.125468] usb 2-5.3.5: reset high speed USB device number 10 using ehci_hcd
[16627.309145] usb 2-5.3.7: reset full speed USB device number 11 using ehci_hcd
[16627.512684] usb 3-1: reset full speed USB device number 2 using uhci_hcd
[16638.426057] gnome-screensav[2108]: segfault at 5 ip 00007f5e47fda859 sp 00007fff7fe06690 error 4 in libcairo.so.2.11000.2[7f5e47fa1000+b9000]
[20241.656554] gnome-screensav[8820]: segfault at 5 ip 00007fad73a01859 sp 00007fffd2f02b10 error 4 in libcairo.so.2.11000.2[7fad739c8000+b9000]

Running Ubuntu 11.10 (upgraded from 11.04) 64-bit on Intel Core i7 2600 (SandyBridge). I am not using the integrated graphics but using ATI Radeon HD 5450. Random freezes occurring while trying to unlock from locked screen. Initially could use Ctrl+Alt+F1 to get a console. Tried to kill my previous session using skill -KILL . Got back the login screen after this. But when I tried to login, entire system just froze. Couldn't even open the console with Ctrl+Alt+F1.

1 comments hidden view all 132 comments
Mark Appier (appier) wrote :

Like the other person above, I have installed Ubuntu 11.10 on the Intel Core i72600 (SandyBridge), but I am using the integrated graphics. Running into exactly the same problem in both the Unity and Xubuntu Desktops.

Curt (kc8ste) wrote :

Notice most comments are about Natty however I experience the same problem in Lynx especially if I select F-Spot pictures or just Pictures as the screen saver. I've run Hypertorus for hours without a lock up. When it locks I have to shut down to clear. Tried backing up two or three kernels to no effect.

Phil Ayres (ayres-phil) wrote :

Just like appier, I have experienced this with Xubuntu 11.10 too. I'm therefore not in a hurry to blame Compiz. I moved to Xubuntu because my performance with the regular Ubuntu / Unity mix on one PC led to slowdowns (fewer complete lockups).

I'm trying the power management tricks, as I think that is the most likely, and ties with my experience so far.

Add to this some other triggers based on the discussion:

1) in the past I've had some nasty experiences with ecryptfs home directory encryption causing OpenOffice / Libre Office failures and other nastiness.
2) things only seem to get bad once I start hitting the page file (too much Gimp work)
3) if I get to Ctrl Alt F1, then after a few minutes I get a message that Chrome is being killed (or at least certain windows within the browser) since it appears to have run away
4) similarly, Thunderbird gives me messages about long running scripts
5) CPU may not always run away, but if I do sudo iotop then I'll see kswapd0 hogging the system (or possibly just indicating that something else is desperately trying to switch / fork and failing?)
6) I also run Banshee a lot
7) Flash performance is dire on this PC (surprised? not really)

I was trying to blame Chrome or Thunderbird, but I think this is either ecryptsfs (again), power management on this Intel barebones system, or some scary background process that doesn't report failures in dmesg.

Details:

Intel Atom 4 core w/ 2GB RAM
Intel 945GC onboard graphics
Intel ICH7 South Bridge
Kernel: 3.0.0-16-generic

Daniel van Vugt (vanvugt) wrote :

If you're using the radeon driver, please look at bug 914773.

Bella's Bells (sandyd) wrote :

12.04.
Its still here, and annoying as always.

Using Intel 3000HD on a Core i5.

Changed in gnome-screensaver (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
kenn (nnek) wrote :

The same bug affects me, no fix yet?

kenn,
you can try this, it fixed my problem but I'm not sure whether it's related to this bug or
not...

edit /etc/X11/xorg.conf and insert:

Section "ServerFlags"

     Option "BlankTime" "0"

     Option "StandbyTime" "0"

     Option "SuspendTime" "0"

     Option "OffTime" "0"

EndSection

logoff / login to load the new settings.

in my case it was the resume from suspension / standby causing the X freeze, not the
screen saver...
hope this helps

Ste

kenn ha scritto:
> The same bug affects me, no fix yet?
>

kenn (nnek) wrote :

Thank you Ste! I did what you wrote, I hope it works. I ll post the result.

kenn (nnek) wrote :

Unfortunately it won't work. While I was watching a movie on the browser, I stopped it and left, when I came back screen froze, I had to restart my laptop manually. It might be a flash issue

Hi there,

two days ago I started a new job and was allowed to install a Linux distribution of my liking on a Fujitsu machine with Core i3. I chose the 64bit Xubuntu 12.04 LTS version and tweaked it by running "compiz" and "avant-window-navigator".

The software setup is basically identical to the setup on my desktop machine at home and my notebook, which are working perfectly.

I experienced my work machine to occasionally (once a day) freeze the "X server", i.e. no response to keyboard input or mouse clicks, but the mouse cursor is still movable. In my case this has always happened while I was working on the local desktop of the machine.

As mentioned in the duplicate bug #760769 remote access is working fine; I can even restart "lightdm" without getting rid of the problem. The log file /var/log/Xorg.0.log shows no hard evidence.

BS-Harou (harou2) wrote :

Hi,
this happens to me also in Ubuntu 13.04. Sometimes it happens when the screensaver is active, but sometimes it happens even when I'm working with the computer. In the second case I can go to console and restart the lightdm service, but in the first case I have to REISUB to make things work again.

Ariel Ann Brock disappeared around 12:30 on 23 July 2013. We have been
looking everywhere. Please help us find her. Here is a picture taken on
July 4th.

--
Tom Brock, MCSA, MCTS, MCP
1480 Lake Christopher Drive
Virginia Beach, VA 23464
757.831.7499

Displaying first 40 and last 40 comments. View all 132 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.