Ubuntu

USB Devices and Some CDs cause gnome-power-manager to fail

Reported by Chad Wright on 2010-04-15
330
This bug affects 68 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Casey Greene

Bug Description

Binary package hint: gnome-power-manager

On every boot, after entering my password to log in, I get a message window saying:

The window is titled: "A program is still running":

"Power Manager not responding" with three buttons, "Lock Screen", "Cancel", "Logout anyway".

If I click "Cancel" the screen locks, and the only thing I can do is restart, by clicking on the "power" button in the lower right corner. If I click "Logout anyway", it continues to logon. If I do nothing the log on continues within a few seconds.

It appears to only happen after boot. If I logout and log back in, it does not occur.

Let me know if there are any logs that will help?

Edit: It only happens on original boot. It does not happen on logout/login, or on a restart, only on a complete shutdown/restart.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-power-manager 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Apr 15 09:05:42 2010
EcryptfsInUse: Yes
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
MachineType: Dell Inc. XPS M1330
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic root=UUID=183636c6-59ba-44e8-88dc-3fadc908b17c ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-power-manager
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.

Chad Wright (deerewright) wrote :
description: updated
Chad Wright (deerewright) wrote :
description: updated
madone1 (kjelenek) wrote :

I have identical problem.

ShaunS (shauns) wrote :

Hi,

I have the same problem.

The first login will also be slow 20 seconds + between password and desktop being displayed. All subsequent logins will have the desktop up in a few seconds.

Thanks,
Shaun

tj (mm02b-tky) wrote :

I'm seeing exactly the behaviour - installed 10.04-amd64 - Beta1 3/28 and have upgraded through rather than reinstall. As far as I can recall, the problem has been there since Beta1.

This is a desktop, so AC-powered. I can provide any information required.

Brooks Tellekamp (mtellekamp3) wrote :

I am experiencing the same problem.

Donatello (donatellogiraudo) wrote :

i'm too.

And after the computer is very slow and the led's disk is ever on.
I have disabled the service.

My computer is a desktop.
I have upgraded from 9.10 to 10.04 RC

Thanks

Donatello (donatellogiraudo) wrote :

In the installation i have see, a fast screen, a configuration error in the GDM installation. (if i mean right)

it' possible that it was the problem?

thanks

kbro (kevin-broadey) wrote :

me2. Using 10.4 i386 final release downloaded and installed a couple of hours ago. Also had same problem with release candidate a couple of weeks ago. Again, it's a desktop machine (AMD Sempron 3000+).

khuang (khuang) wrote :

I have the same problem on a clean install of 10.04 64-bit Final. Did not have any problems on previous install of 8.04 32-bit on same notebook (Acer Aspire 5580)

AndreK (andre-k) wrote :

Same problem here.
very annoying, how can I disable this service ?

also, this is same bug as 575337

Worked until some days before release of 10.04 - 9.10 and 9.04 worked fine also.
Travelmate 4233

boksic (afi-mailbox) wrote :

I have the same problem on my Acer Travelmate 4220 after a clean install of 10.04 32bit. As a workaround, try to disable the power manager at system->preferences->startup applications.

Ryan Keyes (musicman374) wrote :

I am having the same issue on amd64 version, an HP pavilion. I don't have any laggy logon though like some of you. I simply wait for the window to go away on its own and it logs me on just as fast as any other boot. It does NOT happen on the netbook version, I tried that on my netbook, it's just the desktop version. Would love a fix, it is a bit annoying.

If it is of any relevance when you run the application in windows it comes up with eight error dialogues before actually opening the install app, even though I decided to install independently from windows anyway.

Alex (af1987) wrote :

hi guys,
I have the same problem!!! I've it since I updated to 2.6.32-22 kernel... It wasn't a problem with the previous 2.6.32-21...
Now I solved with a
sudo apt-get --reinstall install gnome-power-manager

Hope the same for you!! Bye
Alex

AndreK (andre-k) wrote :

good try, but it did not help me.

Alex (af1987) wrote :

sorry men but I solved only for one day!! today I'm affected again!! damn!

Alex (af1987) wrote :

I'm here again after hours of tries and now I believe that I solved definitively (at least for me)... I understood the problem!!! According to me the gspca_vc032x is the problem!! I opened the blacklist file:
sudo gedit /etc/modprobe.d/blacklist.conf

and i've added the following line:
blacklist gspca_vc032x

and now i'm able to login fast, without any prolem....and my pc is faster!
Hope it's useful for you too...try and let me know...
bye

AndreK (andre-k) wrote :

Thank you, blacklisting gspca_vc032x worked fine for me.
- but camera stopped working.

luvr (luc-vanrompaey) wrote :

For me, blacklisting gspca_vc032x doesn't change a thing: Booting still takes a long time, then on logon, I get the "Power Manager not responding" window.

More annoying is that sometimes the "Shutdown" item on my panel gets disabled: It changes from red to gray, and it no longer responds. There's no longer any way to shutdown or restart the computer from the desktop environment. I can switch to a character-mode console, stop gdm, and then run a reboot or halt command. However, the computer then often appears to hang before it completely shuts down the operating system; <Ctrl>-<Alt>-<Delete> still works at that point, though.

Alex (af1987) wrote :

@AndreK: I know...the gspca is the camera module and blacklisting it means disabling camera...but is the only solution i've found...
@luvr: try to blacklist you camera module... maybe isn't gspca_vc032x for you!!

Alex (af1987) wrote :

...your camera module...

Michael (null-pointer-us) wrote :

This affects me, too. I installed Ubuntu Desktop 10.04 (amd64) Final. This problem was present at the first boot. No updates have fixed or affected the problem. I have not tried any further troubleshooting steps (such as blacklisting gspca_vc032x, above).

When the warning dialog occurs, hitting Cancel will leave GDM unresponsive indefinitely (it just says "Canceling..." and the user/password area remains frozen). Hitting Logout leaves the system with extremely poor disk performance. It literally crawls.

If this performance issue also affects the live CD, it may explain why my live CD and CD installation boot speeds (even just to do the media check) were unusually slow (e.g. minutes instead of seconds).

Waiting a while at the GDM login screen seems to prevent the "power manager is still running" warning from popping up. It seems like the power manager service is hanging (i.e. timing out) on some device, so I'm attaching my lspci -v and lsusb -v device lists.

Michael (null-pointer-us) wrote :
Michael (null-pointer-us) wrote :

Same problem here. But the power management appears every time I try to log in and log in process takes much longer than before. The problem showed up when I installed updates yesterday after a clean installation of Lucid. I used GRUB to boot with pre-updated Linux system but the problem persisted. Now I'm about to remove power management from my start up options to see if it works - I use a desktop.

Removing power management from start up programs did NOT solve the problem. It still takes ages to see the login window and takes even longer to be logged in.

Seems that updating to 2.6.32-22 kernel is the problem but as mentioned before booting with 2.6.32-21 kernel is no relief.

Also as mentioned in bug #575337 a significant delay in showing panels was observed.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
ando (woop-kanjo) wrote :

similar bug here, originally I thought it was due to nvidia graphic card driver but this is not the issue at fault

ando (woop-kanjo) wrote :

also this does not effect my m1330 but does effect my dimension e520

Twilight zone: I've disabled the power manager from the sturtup but I still get the same message! This thing runs by itself. I am not sure if the problem is associated with the 32-22 kernel or with the power manager package itself. I was thinking that one solution could be to completely remove the current version of the power manager and install an older one but I do not know how to find an older one.

Wrong idea. If I try to completely remove the power manager the synaptic says it should remove the ubuntu-desktop also!

AndreK (andre-k) wrote :

read the thread, the problem is not the power manager but camera driver...

luvr (luc-vanrompaey) wrote :

I'm noticing that the message window doesn't show up if I wait long enough before I log in--"long enough" being until I hear the Ubuntu startup sound.
Apart from this little glitch, the system appears to be working fine, so, at least for the time being, I can live with it.

Indeed with Alex's line in the blacklist there is no problem and the boot time has been dramatically improved; no camera of course. I am a new newbie and I just wrote that the power manager might be the problem because it doesn't use the latest upower version (0.9.4) but a previous one. I've tried to update the upower but then I encountered a problem with the glib that was not found (! although I can see it in the synaptics). In any case at this point speed is more important to me than the camera.

arjat (arjat) wrote :

i think i solved, at least for me. disconnecting al the usb active on start e.g. bluetooth, wireless lan, camera, or card reader.
i connected all usb later, after start.

In order to disable a driver, do you only need to add "blacklist driver_name" to /etc/modprobe.d/blacklist.conf"? I've blacklisted this way both gspca_vc032x and uvcvideo, but there have been no benefits. I still have the "Power Manager is still running" windows at login.

xose (dissenymac) wrote :

same problem. With first fresh install, all ok. After updating, the problem appears. At Login, keyboard and mouse doesn't works. After a while, keyboard does, but noothing with mouse. I takes a long time to run desktop, and then the mous is active. Exactly when power manager flash item appears on top panel right icons, the mous starts working. The mouse is usb ones. It's like until power-manager loads, keyb and mouse usb doesn't works. Sorry for my english, it's poor. Thanks.

Alick Wilson (alickwilson) wrote :

It seems to be a problem with USB and Lucid but not USB and Karmic.

I have dual boot installations of Karmic and Lucid.

I have a powered USB hub with a number of devices attached.

The problem occurs when booting Lucid with USB hub attached. The problem does not occur with Lucid without USB attached, and not with Karmic at all.

Alick Wilson (alickwilson) wrote :

Further to comment #38, what appears to be a permanent fix in my case at least.

I disconnected one of the three devices attached to the USB hub and rebooted Lucid. Problem remains.

I disconnected the second of the three devices attached to the USB hub and rebooted Lucid. Problem remains.

I disconnected the third of the three devices attached to the USB hub and rebooted Lucid. Problem disappears.

I reconnected all three devices attached to the USB hub (in different USB slots) and rebooted Lucid. No problem.

I powered off and rebooted a number of times. Problem has gone away.

It does still seem that the problem is related to USB. Might it be something to do with USB enumeration?

sdowney717 (sdowney717) wrote :

seriously slows down the boot for me, takes 4 times longer than karmic to get to the desktop.
I have to select 'logout anyway' or it locks up the screen. The mouse moves and you can select cntrl-alt-F1 thru F4 etc... to get to a console login prompt.

It is really really slow to boot up with Lucid and that was something I thought was supposed to be fast.

xose (dissenymac) wrote :

Shut down the computer -> reset CMOS -> Turn on computer -> still the problem?

Neil (kingfisher) wrote :

My box is making me wonder if the boot sequence order is just starting gnome-power-manager at just the wrong moment.

Reinstall gnome-power-manager, problem goes away, install updates, problem comes back, reinstall gnome-power-manager, problem goes away etc.

b0ggyb33 (rl406) wrote :

In response to #39. This seems to be the fix for me. Changing the USB slots used for external devices (in this case a wireless dongle) gives fast boot and no power-manager fail.

Jonny (jonnyalt119) wrote :

I also have this bug, but only when I have a CD inserted.

OberonKing (oberonking) wrote :

#44 same for me.... when I have a cd or a dvd on the dvd-rw I get this issue... if take off the cd/dvd the issue is gone....

[ 1.710276] ata5.00: ATAPI: HL-DT-STDVD-RAM GH22NS30, 1.02, max UDMA/100
[ 1.942331] scsi 4:0:0:0: CD-ROM HL-DT-ST DVD-RAM GH22NS30 1.02 PQ: 0 ANSI: 5

Casey Greene (casey-s-greene) wrote :

It seems to matter for me what CD is in the drive. I can trigger it on every boot with one CD (Civilization 4). I am unable to trigger it on boot with Sid Meier's Alpha Centauri. I have not tried others.

(It would seem that I am on a Sid Meier game kick).

owen (williams-owen) wrote :

I had the same problem on my 10.4 AMD64 install (update from 9.10).

I can confirm that removing the DVD before booting from cold fixes the problem for me. I no longer see power manager screen and get quicker boot.

Here is what I think is going on. The boot sequence has become increasingly more parallel in the last few releases. When we see the login screen - X is up and running but things are still booting in the background. If you have a few devices that are unusually slow (e.g. DVD or USB) and you log in quickly your computer still has a fair bit more to do before you get to your desktop.

Sure, the Power Manager screen shouldn't show up the way it does. That's a bug. But as others have said, it does disappear on its own if you leave it 10 seconds. But the fix may simple be to hide that screen.

To add a little support to my case. If I do the following:
1) Boot with DVD
2) Log in appears, don't log in yet
3) After 5 seconds the DVD spins up (for the second time, it has already spun up once in the boot process)
4) After another 10 seconds the DVD stops
5) Now login
6) There is no power manager screen and login to desktop time is very quick.

It sounds like others are having problems with slow initialising of USB peripherals. My personal opinion is that these slow inits are longer than expected and the boot sequence hasn't been coded for this eventuality.

Owen

For

luvr (luc-vanrompaey) wrote :

I agree with owen, above.

When the login screen appears, the boot sequence may still be going on in the background.

The end of the boot sequence is signalled audibly with the drum sound (provided, of course that you have sounds on), so the system knows perfectly well when it is done booting. Perhaps the "Login" button on the login screen should simply be kept disabled until the boot sequence is completed? There's no harm in letting the user type in the username and password while the boot process is still running (I do that all the time); it's just that the user should not hit the "Login" button until the computer is fully booted up (I have gotten into the habit of waiting until I hear the drum sound, and only then hitting "Login"; I haven't had any problems since).

I have had the same problem. I upgraded to Lucid 10.04 from Ubuntu 9 and things have been great for about a week. iSuddenly today, I had this identical issue & I cannot resolve it. I tried different solutions, logging into recovery mode, but I still end up with a box coming up saying "Install problem! The configuration defaults for GNOME Power Manager have not been installed correctly." I have a desktop computer & I've never changed any settings, I dont even know what gnome power manager is, so this is a big issue for me. I cannot sign into my computer at all, what do i do now? Thanks.

Neil (kingfisher) wrote :

You could try booting to a command line and:

sudo apt-get install --reinstall gnome-power-manager

Paddy Launch (paddylaunch) wrote :

I experienced this bug briefly just now. My report is similar to owen's above.

My steps to reproduce:

1. Set BIOS boot order to: (1) CD Drive (2) HDD
2. Insert FreeDOS CD and boot
3. Select 'q' to quit the FreeDOS boot and boot from HDD
4. Log in and get the dialog "A program is still running..." as outlined in the bug description above.

Removing the CD Drive from the BIOS boot order (which is my usual setting, when I'm not trying to flash my BIOS) solved the problem for me.

Hey Neil: I did do exactly that yesterday. It did not solve my problem, however. I had to re-install Ubuntu 8.10 on a separate hard drive & upgrade to Karmic Koala. I can't use Ubuntu One Music Store now because I am afraid to upgrade this newer Ubuntu install to Lynx because I don't want a repeat of the same bug. I even tried just installing kubuntu-desktop at the command line & though it did install kubuntu desktop, it would not let me sign in under my usual name & password, so now I have a useless operating system with a kubuntu desktop that I can't sign into. I guess I'll end up having to delete that whole partition unless I can fix this bug.

TuxMe (ddnet473) wrote :

I also have this bug and I confirm so that removing CD/DVD before booting fixe this problem.

TonyM (tonymck) wrote :

I have tried:
1. Removing disk from CD drive. 2. Changing boot order to HDD first
3. Removing all USB devices. 4. Blacklisting gspca_vc032x
5. Removing PM from startup list 6. Reinstalling PM
None of them worked for me. The only thing that I can add to the discussion is that I had an OK install of 10.4 on a HP (desktop) and then (for non related reasons) moved the HDD to a tower with a Gigabyte MB. The problem appeared as soon as I switched on the tower. The tower has an AGP card and I tried removing that and using the onboard video (similar to the HP machine), but didn't change the problem. I put another drive in the tower and did a fresh install of 10.4 and the problem was still there.

I have actually installed xubuntu-desktop & then kubuntu-desktop to try & rid myself of the problem, but it only made things worse. I am now not even able to log in. I still haven't figured out a solution or a cause for this issue. I'm using Koala 9.10 for now until this issue gets worked out.

Allan Branch (megamanexent7) wrote :

I have only recently seen this bug, but reading the comments made me think it might be my USB peripherals. I had an iPod connected the most recent reboots & when I got to login ALL my USB items had not mounted/loaded. Is there any way to disable gnome-power at login? I agree with owen that the computer has not fully started-up as I still see a lot of HDD activity at login.

Allan Branch (megamanexent7) wrote :

I can report that removing the iPod solved the problem. I must say, I suspect any thing that uses a lot of power slows down gnome-power-manager at boot ( charging iPods, CD/DVD drive use, USB hubs, cameras ) and thats why we all see that warning. In Jaunty, however, I did not observe this behavior (I triple boot, so its the same machine).

TonyM (tonymck) wrote :

A question / comment - is this problem associated with the GNOME interface? Has anyone found the problem with KDE? It seems clear that the power manager loads early in the boot process - before the program reads that power manager has been "disabled". I have fixed my instance of this problem by changing machines. As well as that, I am a bit committed to GNOME as I am about to change my wife's machine to Linux and I am not familiar with KDE.

Jomon John (jomonjohn) wrote :

Same Problem Here

Alessandro Cuttin (a-f-cuttin) wrote :

I noticed to have this problem only when my ipod was connected to the usb.

Could other people re-test this and confirm if the issue is Ipod/Iphone related?

Alessandro: please could you confirm what type/model of Ipod it is that you are using to plug in and cause the g-p-m failure?

summary: - When logging on power manager fails
+ Connected Ipod(?) causes g-p-m tofail
summary: - Connected Ipod(?) causes g-p-m tofail
+ Connected Ipod(?) causes g-p-m to fail
Casey Greene (casey-s-greene) wrote :

I can confirm that I do not have an ipod or iphone, but I do get this error with certain CDs in the drive (as described above). It is reproducible with the given CD and does not occur without it. I don't think the name/summary should be changed unless we are looking at a number of separate bugs here (in which case new bugs should be filed to cover the specific circumstances).

Golder (golder) wrote :

I have no webcam plugged in, nothing byt my mouse and my keyboard, no cd in the cd drive and I have *incredible* problems to get the computer to even boot, even with the failsafex, it works 1/10 of the time. It is extremely stressing. I've managed to make failsafex work this time, I'm saving up datas and coming back to XP for the time being :(
I'm using Lucid Lynx, with a 2.53GHz intel core duo, 4GHz ram, intel 5350 with 1Gb and a 1Tb hard drive. I have absolutely no idea what to do beside going back to windows until this is fixed

Jim Kay (jnk49er) wrote :

@Paul Sladen

The problem is not Iphone/Ipod specific. The problem is with a bunch of different media hardware, no one has yet made the connection with all this different media. Some people have problems with inserted DVD's, others with certain USB devices. (cameras, Ipods, ect.)

I'm getting the same error and my problem is my Belkin F7D1101 USB wireless adapter. When it is unplugged during boot, the error doesn't exist. When it's plugged in during boot, I get the 'Power Management Not Responding' error.
I use this wireless adapter for my internet, so it's irritating having to keep unplugging it.

I'm going to tinker with the Power Management package. If I'm able to fix it, I'll post back my solution.

I've noticed it with my iPod as well. For the record, I'm running Xfce with Xfce Power Manager, so it's not just the Gnome one. I'll just be careful not to connect the iPod before login.

Spoilerhead (spoilerhead) wrote :

just happend to me, too
ipod mini was connected on boot.

velain (velain-email) wrote :

Same problem here. No ipod, no webcam, but some usb devices (printer, usb-tv-card)
Ubuntu 10.04 on AMD64
power-manager error at logon
very slow in showing boot user choice at login and (after password) to show desktop and bars...

The Mole (plioceneray) wrote :

Xubuntu 10.10 AMD64 fresh install.
Whenever I get the dreaded message Samba does not offer my shared printers (one parallel, one USB) to the network. The message appears at about 50% of boot-ups.

Chad Wright (deerewright) wrote :

running 10.04 AMD64, I noticed it happened anytime any removeable storage device was connected (i.e., usb hdd, usb flash, SD flash, CD in CD drive). Without these, it would not occur. Now with 10.10 it appears to be solved for me.

The Mole (plioceneray) wrote :

Xubuntu 10.10 AMD64
My Ubuntu drive is one of several.
If I disconnect the other (WinXP) and make my Ubuntu the main and only bootable drive, so that I do not have to call the boot menu from bios when booting up, the problem goes away.

summary: - Connected Ipod(?) causes g-p-m to fail
+ USB Devices and Some CDs cause gnome-power-manager to fail
Tyreke Gibbs (cipher-gmx) wrote :

This seems to be a problem with USB and other peripherals.

On my pc, a power outage while I was booting fried my northbridge to some extent. Only a few of my USB ports work and it take BIOS a full minute to test my memory. I noticed this bug in Ubuntu right after the outage.

Wenzhuo Zhang (wenzhuo) wrote :

I also have this problem only when iPod Touch is connected to a USB port. I can confirm that disconnecting iPod Touch solves the problem.

Rodders101 (stirling-roderick) wrote :

Very odd, been running this release (10.04) with the same hardware configuration for well over a year, - problem started today, looking at logs seems to be the external DVD RW causing the problem, but as indicated earlier has been connected for 12 + months and working fine

i have been using 10.4 since it was released > never had this problem
today i installed a number of updates (via update manager) and the problem started (only with CD in the drive)

in att you can find the install log ( var/log/apt/term.log) of the upgrades is did today (there are 2 upgrades in fact, but i did not reboot inbetween, so i dont know what part of the upgrade caused this)

i did a quick search on 'power' and there are a few matches :

Preparing to replace libdevkit-power-gobject1 1:0.9.1-1 (using .../libdevkit-power-gobject1_1%3a0.9.1-1ubuntu1_amd64.deb) ...
Unpacking replacement libdevkit-power-gobject1 ...
...
Preparing to replace libupower-glib1 0.9.1-1 (using .../libupower-glib1_0.9.1-1ubuntu1_amd64.deb) ...
Unpacking replacement libupower-glib1 ...
...
Setting up libdevkit-power-gobject1 (1:0.9.1-1ubuntu1) ...
Setting up libupower-glib1 (0.9.1-1ubuntu1) ...
...
Preparing to replace upower 0.9.1-1 (using .../upower_0.9.1-1ubuntu1_amd64.deb) ...
Unpacking replacement upower ...
...
Setting up upower (0.9.1-1ubuntu1) ...

Poliltimmy (poliltimmy) wrote :

I have no problems with a iConcepts USB wireless keyboard and mouse. Boots fine. The problem occurs with a disk in the tray at boot.

as2000 (as2000) wrote :

This bug just showed up after updating to the latest kernel. After entering the password, said power manager screen appears and clicking on logout anyway the system lags and then starts normally.

Andres (andyhelloween) wrote :

Just happened to me out of nowhere! I'm running Lucid 10.04. I had plugged in an external USB drive + wireless mouse.

Upgrading to last kernel (2.6.32-40) and reinstalling the package with "sudo apt-get --reinstall install gnome-power-manager" appears to solve the issue so far...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers