session active, not inhibited, screen idle message

Bug #423694 reported by sam tygier on 2009-09-03
282
This bug affects 57 people
Affects Status Importance Assigned to Milestone
gnome-power
Fix Released
Medium
gnome-power-manager (Ubuntu)
High
Chris Coulson
Nominated for Karmic by Gabriel Bauman

Bug Description

Binary package hint: gnome-power-manager

after coming back to my computer after the screen had blanked, and waking by wiggling the mouse i spotted a new icon in the notification panel. mousing over gave the following message.

"Session active, not inhibited, screen idle.
If you can see this text, your display server is broken and you should notify you distributer.
Please see http://blogs.gnome.org/hughsie/2009/08/17/gnome-power-manager-and-blanking-removal-of-bodges/ for more information."

i am running karmic, plus the xorg-edgers PPA.

ProblemType: Bug
Architecture: amd64
Date: Thu Sep 3 13:56:06 2009
DistroRelease: Ubuntu 9.10
Package: gnome-power-manager 2.27.91-0ubuntu1
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
SourcePackage: gnome-power-manager
Uname: Linux 2.6.31-9-generic x86_64

sam tygier (samtygier) wrote :
sam tygier (samtygier) wrote :
Chris Coulson (chrisccoulson) wrote :

As quoted in Richard's blog, this is a Xorg bug, It seems we need to apply his IDLECOUNTER patches to our version of Xorg.

affects: gnome-power-manager (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
importance: Undecided → High
Chris Coulson (chrisccoulson) wrote :

Hmmm, we already have those patches and you say the screen blanked ok. Re-assigning back to g-p-m for now then

affects: xorg-server (Ubuntu) → gnome-power-manager (Ubuntu)
Changed in gnome-power-manager (Ubuntu):
importance: High → Low
sam tygier (samtygier) wrote :

just to be clear, my xserver-xorg-core is 2:1.6.3+git20090805+server-1.6-branch.f274e595-0ubuntu0sarvatt from https://launchpad.net/~xorg-edgers/+archive/ppa should the patch be included upstream?

Alexander Sack (asac) wrote :

this takes precious space in my tray and it cannot do anything with it (no left no right click). Also it talksa bout scary things like "your display server is broken " ... marking as High.

Changed in gnome-power-manager (Ubuntu):
importance: Low → High
status: New → Confirmed
Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 397839 , so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

The tray icon was to inform the user that the problem is due to xorg. this is not a gpm bug. it has been fixed in gpm.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Fix Released
Alexander Sack (asac) wrote :

this is not a dupe of bug 397839 which is the main cause atm for this widget/tray thing to show up.

This bug is about this tray feature on its own. Either don't display anything, or make it more useful. just displaying that your screen is broken without allowing to take any action is bad.

Changed in gnome-power-manager (Ubuntu):
status: Fix Released → Confirmed
Alexander Sack (asac) wrote :

> The tray icon was to inform the user that the problem is due to xorg. this is not a gpm bug. it has been fixed in gpm.

Right. But as of now it does a pretty bad job of informing the user about that.

I am a technical guy and had absolutely no clue that this was caused by my regular screen flickering bug. I couldn't click on it and it took precious space from my desktop. Also it talked about scary things and didn't allow me to get more information. The URL was too long to remember or type, so I didn't bother. Even if it was, I don't think that displaying a mail thread url is the right way to educate end-users about problems - especially if there is no workaround etc.

IMO, we shouldn't display it at all and should ensure that it does not happen for other issues :). If there are ways to make it more useful that would be fine too of course. But for this particular bug I don't see how it can be use for the user.

Chris Coulson (chrisccoulson) wrote :

I don't think this is a duplicate either. The tooltip in the other bug was a different one about a different issue with Xorg. The tooltip in this bug refers to a problem in Xorg which is already fixed in Ubuntu by the inclusion of Richard's patches, so it might be a g-p-m bug that this tooltip is displaying at all. Do people experiencing it see any other strange behaviour with display blanking, or do things seem to be working correctly otherwise?

Vish (vish) wrote :

asac:
this started happening since > gnome-power-manager (2.27.5-0ubuntu3) to 2.27.91-0ubuntu1
I agree it is difficult to actually get to the webpage by just clicking the icon.
But surely it is not supposed to stay , if the xorg applies the patches.

Also, the icon *does* go away once the session and the screen catch up.

I would say it was very kind of Richard to notify the problem. maybe the implementation was wrong. probably he didnt plan for it to take so long for the xorg side to fix it.

But a status "High" ;)

Chris Coulson : yes, i still have the blanking problems , the icon is to inform that it is not a gpm bug but rather and xorg bug.

Vish (vish) wrote :

Also , i dont think the OP reported since he didnt like the implementation of the icon. ;)
But , seems more because the icon warned to inform the distribution...
So in principle i think it is a dup of bug 397839

If the bug is to be dealt about the wrong implementation of the icon , then the bug description needs to be changed,
 but wouldnt this problem just be solved if the xorg was fixed ;p

sam tygier (samtygier) wrote :

i think i was just seeing this because i was using xorg from the xorg-edgers ppa, and the that package does not have the patch yet. the ubuntu xorg is patched, so no one should ever see the message.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Invalid
323232 (323232) wrote :

On a fully updated Karmic install the message is shown now and then.
Between 30 to 60 minutes after boot the screen flickers to black an to normal. At the same time the " square icon" with the message appears in the notification area.
So the problem is not solved.
Got the normal ubuntu Xorg packages: 1.7.4+3ubuntu5. System uses open source radeon driver (working fine).

I'm not 100 % sure but i thing the foloowing messages in the Xorg.conf are related:

disable LVDS
disable LVDS
enable LVDS

Jörn Horstmann (jhorstmann) wrote :

I am also seeing this on an up to date karmic install. It happened about 30 minutes after awaking from hibernate. I did not see any related messages in any log file.

Package versions that may be related:

xserver-xorg 1:7.4+3ubuntu7
xserver-common 2:1.6.4-2ubuntu3
xserver-xorg-core 2:1.6.4-2ubuntu3
xserver-xorg-video-intel 2:2.9.0-1ubuntu2

gnome-power-manager 2.28.1-0ubuntu1
devicekit-power 011-1ubuntu1
powermgmt-base 1.30+nmu1

Albert Cardona (cardona) wrote :

This bug is also affecting a MacBookPro 5,5 with ubuntu 9.10 amd64 dist-upgraded to today.

Lasse Vinther Tyron (lasse) wrote :

Bug hit my notebook today.

Upgraded to 9.10 a few days ago.
Packet Manager updated a few packets today. Bug showed up an hour after restart.

Lenovo ideapad S10e.

Haggai Eran (haggai-eran) wrote :

I have also encountered this bug today, on karmic.

The screen blanked in the middle of my work, and after touching the keyboard, I saw this tray icon.

Chris Coulson (chrisccoulson) wrote :

I'm currently also seeing this when user-switching to an inactive session. Does anyone seeing this icon experience any other side-effects, or does everything else related to screen blanking seem to be working as expected?

Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Invalid → Confirmed
Vish (vish) wrote :

@Chris Coulson and others : Pls also see bug #397839

While the blanking issue seems fixed for many, users seem to be facing the blanking too...
But this icon seems to detect the mismatch in *probably* the "idle time counter" , so there still seems to exist the some mismatch.

I just got this a few minutes after resuming from S4. The screen blanked for a second and when it came back I saw the tray icon.

323232 (323232) wrote :

I don't know if there is a relation but......

When I play Solitaire the memory use of Xorg grows and grows (see bug 469172).

This bug (the blanking of the screen) mostly happens when Solitaire is started or sometimes afterwards. (the memoryuse of Xorg remains high after closing solitaire)

Could be that those two things are not related but it is remarkeble

Jimmy (jimmy-axenhus) wrote :

I just got this bug with the exact the same message as the reporter. If you follow the link from the notification you will see this:
"If you hit this 50ms race (which some people seem able to do, me included) then gnome-power-manager misses the reset event, and if configured to do so, gnome-power-manager will still think your idle, and then go on to suspend your system."

Well it seems like I hit that limit. I was sitting at the comp when the screensaver was about to activate when I moved my mouse. The screen got black for less than a sec and when everything was back I noticed the small tray icon. After some minutes it was gone.

I'm running Karmic with latest updates as of this date.

Just ran into this bug - latest patches as of this date, am not using any xorg PPA's. Damn right annoying this is.

Jeremy Wilkins (jer-wilkins) wrote :

Completely up-to-date Karmic install, same bug.
Happened when I resumed from hibernate.

Jack Leigh (leighman) wrote :

As per comment #25
Fully up-to-date Karmic. Only happens after the computer has been hibernating.

Joachim (joachimrs) wrote :

happend to me, when my computer returned from "Sleep" - i.e. _not_ Hibernate.

I am using amd64 on a HP tx2500 tablet.

Artyom Smirnov (smirnoffjr) wrote :

>happend to me, when my computer returned from "Sleep"
Same for me.

Jeff Fortin Tam (kiddo) wrote :

Chris, any progress or further upstream discussions on finding what causes this?

I'm still experiencing issues with my netbook randomly not being able to go idle (and thus, no screen dimming, dpms off, or auto suspend...). I couldn't pinpoint the cause, it usually works the first few times after a fresh login. AFAIK the totem, hamster and eog bugs that prevented idling have been patched.

On rare occasions I see the weird little icon in the notification area, but it immediately disappears, I've never been able to mouse over it to see what it said.

It seems to happen only on my netbook, which obviously has a lid and suspends/resumes quite often. AFAICT my desktop doesn't "forget" to idle.

I wish I could be more of help and get this damn idling+power saving+inhibition crap working "just like it used to" in time for the next ubuntu LTS release, which will be installed on many computers I maintain... but I just don't know how to troubleshoot this clusterbug anymore, I'm lost.

If there's some kind of automated test suite I can run, or a detailed step by step investigation guide for this, I'd be interested.

Jimmy (jimmy-axenhus) wrote :

Once again I can confirm this bug, but this time I was working when the screen suddenly become black and then reappeared with the error message. I was moving my mouse all the time before this bug reappeared.

Chris Coulson (chrisccoulson) wrote :

I don't know if everybody here is experiencing the same issue, but I found a race in gpm that might cause this issue for some people (it causes it for me). I've reported it upstream and sent a patch there which fixes it too

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
Chris Coulson (chrisccoulson) wrote :

FWIW - if anybody wants to try the patch, you can find it here: https://bugzilla.gnome.org/attachment.cgi?id=153600

I'm not uploading this to Lucid tonight, as I'm finished for the evening now.

Chris Coulson (chrisccoulson) wrote :

This is now fixed upstream

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Committed
Matt Joiner (anacrolix) wrote :

I just started getting this today. A little icon appears in the system tray and tells me I shouldn't be able to see it.

edu-cr (indiodesnudo) on 2010-02-22
Changed in gnome-power-manager (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Chris Coulson (chrisccoulson) wrote :

The patch has been backed out upstream, as it caused some issue. So, I need to find another way to fix it

Changed in gnome-power-manager (Ubuntu):
status: Fix Committed → In Progress

I also experienced this, just after returning from hibernation.

xserver-xorg:
  Installed: 1:7.4+3ubuntu10
gnome-power-manager:
  Installed: 2.28.1-0ubuntu1.3

Arkapravo (arkapravobhaumik) wrote :

Even I experienced it ! .... still not able to rid of it ! :(

Changed in gnome-power-manager (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.29.91-0ubuntu5

---------------
gnome-power-manager (2.29.91-0ubuntu5) lucid; urgency=low

  * debian/patches/18-fix-idletime-reset-race.patch:
    - Fix a race condition where we might miss the idle reset alarm,
      causing unwanted display blanking later on (LP: #423694)
 -- Chris Coulson <email address hidden> Fri, 05 Mar 2010 18:44:26 +0000

Changed in gnome-power-manager (Ubuntu):
status: Fix Committed → Fix Released
SB (sonny-benshimon) wrote :

I see that this bug is fixed for lucid, but does that mean that it won't be fixed in karmic?

Chris Coulson (chrisccoulson) wrote :

I'd prefer to let this bake in Lucid for a little while before we consider backporting the change to Karmic

Konstantin Lavrov (lacosta) wrote :

Could not confirm this bug is fixted in Lubuntu A3

Still I could read this message on the screen.

Konstantin Lavrov (lacosta) wrote :

I found it fixed only with gnome-power-manager - 2.30.0

filippo colombo (thelion85) wrote :

On my updated ubuntu 9.10 this bug is not fixed.

jesseay (jesseay) wrote :

Interesting part of the bug, when I open my system menu and select preferences, the screen flicker stops immediately, may come back later, but usually not.

jesseay (jesseay) wrote :

to update gnome-power-manager on my 9.10 system :

I downloaded gnome-power-manager 2.30 from here
http://linux.softpedia.com/get/Desktop-Environment/Tools/GNOME-Power-Manager-3684.shtml

unpacked the tar- sudo tar xvf gnome...tar.gz

after installing dependencies one at a time (ouch)

sudo ./configure
sudo make
sudo make install

on restart, there is no more flickering :)

I don't know if this is the best way to solve this, but it seems to be good for me

jesseay (jesseay) wrote :

My bad, problem was not solved with gnome-power-manager 2.30
it's fine on start up, but when I close the screen and re open (physically) the flicker is there.

Still fixed temporarily by open the system menu on the desktop

Paul van Genderen (paulvg) wrote :

I had this today on Ubuntu 9.10, but not after hibernating, sleeping or anything. The PC is a Dell T3400, quite the opposite of a netbook. Anyway, this bug doesn't seem to meet the SRU criteria so those who are annoyed by this may want to upgrade to 10.04 (which is just around the corner).

@jesseay: Don't use sudo for configure and make, and you'll probably find your gpm in /usr/local so it's likely that you aren't running it. But above all, don't do that. If you want to backport packages, you can try prevu. Be sure to know what you are doing, though.

[karmic]
I was actively working the computer (hands on the keyboard), when the screen went blank. It automatically came up after a couple of seconds. This was the first and only time it has happened to me.

Please backport this to karmic. I'm using the current updates.

gnome-power-manager:
  Installed: 2.28.1-0ubuntu1.3
  Candidate: 2.28.1-0ubuntu1.3
xserver-xorg-core:
  Installed: 2:1.6.4-2ubuntu4.3
  Candidate: 2:1.6.4-2ubuntu4.3

Changed in gnome-power:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.