Cannot unmount by right clicking (in certain places)

Bug #4188 reported by agro1986 on 2005-11-11
82
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Won't Fix
Wishlist
Nautilus
Fix Released
Wishlist
gnome-panel (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

In the desktop, we can right click a mounted device (CD-ROM Drive, USB Drive, etc) and choose unmount/eject. However we cannot do the same on:

1) Places menu (the menu located on the top panel): right clicking a device opens nautilus instead
2) Places sidebar in nautilus: right clicking a device does nothing useful

This is inconsistent with the desktop behaviour and with the behaviour on the nautilus tree sidebar.

Sebastien Bacher (seb128) wrote :

Thanks for your bugs. Please use one page by bug, you describe 2 issues here:
1- is a gnome-panel issue: http://bugzilla.gnome.org/show_bug.cgi?id=172749
2- is a nautilus issue: http://bugzilla.gnome.org/show_bug.cgi?id=316184

Andrew Jorgensen (ajorg) wrote :

This bug is much more important to fix if we are going to not have mounted volumes on the desktop by default.

I think that's a great idea, by the way. It's much more consistent with the otherwise empty default desktop.

Changed in nautilus:
status: Unconfirmed → Confirmed
Changed in gnome-panel:
status: Unconfirmed → Confirmed
Duncan Lithgow (duncan-lithgow) wrote :

As the filer of duplicate bug 29563 I'll just mention that I agree with Andrew and agro1986 this is actually pretty important. In windows a little icon appears in the 'active processes' thingy which should be clicked to unmount - at the moment the default in Dapper is that absolutely nothing happens - and nothing tells us that we should unmount, let along _how_ to unmount.

At the least there should be a popup of some sort (with a 'don't show this again') which tells me each time automount mounts - what it has mounted and that it's important to unmount before removing it. Windows have sensibly called it 'safely removing' to underscore that it's dangerous not to do it.
29563
Does anyone here _really_ expect my mum to know where , why and how to unmount her new Digital Camera with USB conneciton? I think not.

Duncan

Sebastien Bacher (seb128) wrote :

Duncan, that's the issue by using an unstable distribution. Users who don't want that kind of issue use a stable version of the distribution and have icons on the desktop making easier to unmount/eject them, that part of the issue will be fixed for dapper

Changed in gnome-panel:
assignee: gnome → desktop-bugs
Changed in gnome-panel:
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unconfirmed → Fix Released
Chris Rose (chris-vault5) wrote :

Related is bug 75244.

agro1986 (agro1986) wrote :

Update for 7.04 final:
Issue (1) (gnome-panel) is still not fixed
Issue (2) is fixed. We can right-click and now there is an unmount option.

Changed in gnome-panel:
status: Confirmed → Triaged
ma2412ma (ma2412ma) wrote :

I don't t think that issue (1) should be fixed - I've never seen that right-clicking on a menu entry works, so I suggest that this bug can be closed as resolved.

Changed in gnome-panel:
importance: Unknown → Wishlist
Changed in nautilus:
importance: Unknown → Wishlist
Jack Leigh (leighman) wrote :

Could be solved by having an unmount icon in the menu, as suggested in some of the upstream mockups.

Changed in gnome-panel:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.