Ubuntu

Workspace switcher shows single workspace only on all non-Metacity window managers

Reported by Lukas Hejtmanek on 2009-07-16
82
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Medium
Unassigned
Karmic
Medium
Unassigned

Bug Description

I'm using ubuntu/Karmic. After today's update, Openbox application does not work with gnome workspace switcher applet. The Openbox is using 10 workspaces, the gnome workspace switcher shows only 1 workspace. It used to work pretty well.

Openbox: 3.4.7.2.-4
Gnome-session-bin: 2.26.2-1ubuntu
gnome-panel: 2.26.3-0ubuntu2
gnome-applets 2.27.3-0ubuntu2

x86_64 architecture.

Related branches

Harrison Chapman (hchaps) wrote :

I have the same exact problem.

Harrison Chapman (hchaps) wrote :

I should have been more specific, I'm sorry (first time actually using the Launchpad bug stuff).. I'm amd64 Karmic as well and I update rather often, and the Gnome Workspace Switcher hasn't been working under my Openbox session with gnome-panel.

Jeremy Nickurak (nickurak) wrote :

Per the bug I just filed as a duplicate of this one:

> gnome-panel 2.27.4-0ubuntu3 contains patch 16_compiz_workspace_switcher.patch which is stupid.
>
> It produces code:
> static void
> pager_update (PagerData *pager)
> {
> wnck_pager_set_orientation (WNCK_PAGER (pager->pager),
> pager->orientation);
> wnck_pager_set_n_rows (WNCK_PAGER (pager->pager),
> pager->n_rows);
>
> if (pager->wm == PAGER_WM_METACITY) {
> wnck_pager_set_show_all (WNCK_PAGER (pager->pager),
> pager->display_all);
> wnck_pager_set_display_mode (WNCK_PAGER (pager->pager),
> pager->display_mode);
> } else {
> wnck_pager_set_show_all (WNCK_PAGER (pager->pager),
> FALSE);
> wnck_pager_set_display_mode (WNCK_PAGER (pager->pager),
> WNCK_PAGER_DISPLAY_CONTENT);
> }
> }
>
> Every other WM than METACITY is forced to show only the current workspace, e.g. Openbox WM. This is definitely not what users want. It should be fixed or completely removed.

I can confirm that removing this patch corrects the behavior of openbox under gnome with karmic.

It seems like:

1) Compiz has a bug with respect to workspaces
2) A patch was introduced which changed the default behavior of the workspace switcher, and then reverted the behavior when metacity was present

My interpretation of that:

(1) is a bug in compiz, which should really be addressed
(2) is just odd. Ideally, the workspace switcher shouldn't contain any code specific to particular window managers. As a workaround until (1) is solved, it could change its behavior specifically when compiz is present.

Martin Ling (martin-launchpad) wrote :

Okay, I think I have this sussed.

The problem appeared in gnome-panel 1:2.26.0-0ubuntu8. As a fix for bug #385220, 16_compiz_workspace_switcher.patch was modified to disable wnck_pager_set_show_all() for Compiz. The problem is that the fix applied this not specifically to Compiz, but to everything other than Metacity. This disabled multiple workspace display for other window managers for which it had previously worked fine, including openbox and xmonad.

The attached patch modifies 16_compiz_workspace_fixer.patch to apply this change specifically for PAGER_WM_COMPIZ, rather than everything other than PAGER_WM_METACITY. Therefore bug #385220 should remain fixed, but multiple workspace display will continue work for other window managers which show up as PAGER_WM_UNKNOWN, as it does in previous and upstream versions.

Applying this meta-patch to the 1:2.28.0-0ubuntu3 source package solves the problem for me with xmonad. It also applies cleanly to the source package version in bzr.

Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → gnome-panel (Ubuntu)
Changed in gnome-panel (Ubuntu):
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
summary: - openbox + gnome workspace switcher does not work
+ Workspace switcher shows single workspace only on all non-Metacity
+ window managers
Jeremy Nickurak (nickurak) wrote :

I'll confirm that Martin's updated patch, in conjunction with the fix for the zero-rows bug, has brought the gnome workspace switcher back to completely normal behavior using Openbox.

Thanks muchly Martin!

Iakov Davydov (iakov-davydov) wrote :

This patch fixes the issue for me.
Thanks.

Iakov Davydov (iakov-davydov) wrote :

Update: everything works fine if I perform openbox --replace; but if change WM through /desktop/gnome/session/required_components/windowmanager I get only one workspace.

Martin Ling (martin-launchpad) wrote :

Jeremy, did you mean to post comment #8 on a different bug? The launchpad link you gave is back to this bug, and the bug referenced in the RedHat bugzilla seems to be a different issue.

Jeremy Nickurak (nickurak) wrote :

I did mean to post to this bug, but i meant to link to http://bugzilla.icculus.org/show_bug.cgi?id=4040

I believe Iakov's issue may be caused by the problem discussed at that redhat bug and this openbox request. It can look a lot like this bug, but is an independant issue. (I don't know if it's filed anywhere here on launchpad)

Iakov Davydov (iakov-davydov) wrote :

Thanks Jeremy. My last problem is related to https://bugs.launchpad.net/ubuntu/+source/openbox/+bug/435638 . This is separate bug.

tags: added: regression-potential
affects: gnome-panel (Ubuntu) → libwnck (Ubuntu)
Martin Ling (martin-launchpad) wrote :

This bug just got reassigned to libwnck. I'm reassigning it back to gnome-panel. Please let's be clear on the issues here:

There is a libwnck issue somewhere, which is the underlying cause of bug #385220.

There is a workaround for that bug, which was introduced in gnome-panel 1:2.26.0-0ubuntu8.

There is a bug in that workaround. This bug report relates to the bug in the workaround.

If the libwnck issue gets fixed, then the workaround can be removed completely, along with its bug.

But there is no change which can be made to libwnck alone that will solve the problem in this report. This bug is specifically in the Ubuntu packaging of gnome-panel.

affects: libwnck (Ubuntu) → gnome-panel (Ubuntu)
Steve Langasek (vorlon) wrote :

Marking this bug as triaged and subscribing ubuntu-main-sponsors, since it looks like this fix just needs uploaded.

Changed in gnome-panel (Ubuntu):
importance: Undecided → Medium
Changed in gnome-panel (Ubuntu Karmic):
status: Confirmed → Triaged
Changed in gnome-panel (Ubuntu Karmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.28.0-0ubuntu6

---------------
gnome-panel (1:2.28.0-0ubuntu6) karmic; urgency=low

  * debian/patches/16_compiz_workspace_switcher.patch:
    - updated by Martin Ling to work correctly on openbox
      (lp: #400301)

 -- Sebastien Bacher <email address hidden> Mon, 19 Oct 2009 15:23:08 +0200

Changed in gnome-panel (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in gnome-panel (Ubuntu Karmic):
assignee: Ubuntu Desktop (ubuntu-desktop) → nobody
Julius Thor (joolli) wrote :

Seems like this bug is back in Lucid

Julius Thor (joolli) wrote :

Actually, scratch that! It's probably a different bug. It shows the workspaces but doesn't display the applications in them.

Jim Kay (jnk49er) wrote :

I'm having the same issue (with the being stuck with 1 workspace with OpenBox) on a clean fresh install of Ubuntu 10.04 Lucid Lynx

I know there's a patch for it here, but can you please update the repo packages for it?
I'm somewhat of a newbie, and AFAIK, patches can only be applied to built source packages.

I have no idea how to do this, and it is too complicated for someone like me.

I'm thinking about uninstalling OpenBox and using Metacity because of this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers