Ubuntu

gnome-gmail doesn't work in current natty

Reported by Jeremy Bicha on 2011-03-04
88
This bug affects 16 people
Affects Status Importance Assigned to Milestone
GNOME Gmail
Undecided
Unassigned
gnome-gmail (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-gmail

I tried installing this today because the idea sounded cool but Gmail does not show up in my Gnome Preferred Applications as an option for mail reader.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-gmail 1.7-1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
Date: Fri Mar 4 16:33:02 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-gmail
UpgradeStatus: Upgraded to natty on 2011-01-01 (62 days ago)

Jeremy Bicha (jbicha) wrote :
David Steele (daves) wrote :

It looks like Natty has changed how Emailers are registered. They aren't in /usr/share/gnome-control-center/default-apps/gnome-default-applications.xml anymore, and the OS is ignoring the value of the gconf variable desktop->gnome->url-handlers->mailto->command. Must be a Unity thing. I'd be willing to look into it, if someone could provide a pointer.

v1.7.2, which has been released upstream, will offer to install itself as the Preferred Email application when it is launched (from the Applications->Internet menu). But, it does that using a configuration variable that is being ignored.

This feels like "embrace and extend".

Jeremy Bicha (jbicha) wrote :

Nope, not a Unity thing. It looks like a Gnome 3.0 thing. Natty is part Gnome 2.32 and part Gnome 3.0. See bug 708382.

Jeremy Bicha (jbicha) wrote :

Just add a line like this to your gnome-gmail.desktop:

MimeType=application/mbox;message/rfc822;x-scheme-handler/mailto

Adding that and running update-desktop-database (like would normally be done when it installs) works for me.

David Steele (daves) wrote :

Thanks for the information. That change makes GNOME Gmail available as a Preferred Email application again, which then handles mailto URLs.

But that is not all that is needed. The File Browser does not have 'email' registered as a delivery option, even though I have a valid email option. And there is still a "Set Up Mail..." menu item on the Desktop, tied to Evolution. Do you have pointers on where to deal with these issues?

Jeremy Bicha (jbicha) wrote :

I think the information you need is in the /usr/share/applications/evolution.desktop file . Use the Ubuntu one because it looks to me like it has a few extra lines that have the Messaging Menu specific stuff. I'll go ahead and attach it because I don't know if you have a Natty install around.

I think Send by Email was present in previous Gnome 2 releases but isn't in Gnome 3.

Jeremy Bicha (jbicha) wrote :

Check out the /usr/share/indicators/messages/applications/ folder. It looks like in the case of Pidgin, a simple pointer is created here and a shortcut is then automatically added to the bottom of the messaging menu without anything else needed to be added to the .desktop file.

It looks like the evolution.desktop I posted in the previous message shows you how to add groups to Ubuntu's messaging indicator which may not be what you want.

David Steele (daves) wrote :

This patch adds gnome-gmail back to the preferred applications dialog.

David Steele (daves) on 2011-03-29
Changed in gnome-gmail (Ubuntu):
status: New → Confirmed
Alex Murray (alexmurray) wrote :

This is really a duplicate of bug #708382 in gnome control center, marking as such.

David Steele (daves) wrote :

Actually not so much a dup of #708382. The original entry for that bug is about not being able to specify custom configurations. This is about the issue of the xml files in /usr/share/gnome-control-center/ being deprecated, which is mentioned later in that thread.

The xml files are replaced with MIME entries in the desktop file, per the patch in #8.

David Steele (daves) wrote :

Removing duplicate of bug #708382. That one is a wishlist fix against GNOME - this is a real issue. The package with the patch is in the PPA at https://launchpad.net/~daves/+archive/daves

tags: added: patch
David Steele (daves) on 2011-04-05
Changed in gnome-gmail:
status: New → Confirmed
Dave Walker (davewalker) wrote :

Hi David, thanks for your work on this.

I see you are the Debian Maintainer for this, could I ask that you upload it do Debian soon (if possible, keeping the LP: bug reference), and then we do a sync?

This avoid us diverging too much with Debian on this package.

Thanks again.

David Steele (daves) wrote :

I don't want to burden Debian (and other distributions) with an extra release for a problem that only affects Ubuntu. The packages should merge with the next release.

Jeremy Bicha (jbicha) wrote :

It's not a Ubuntu-specific problem; it's a Gnome 3 problem so it will affect Debian experimental, Fedora 15, etc.

David Steele (daves) wrote :

To clarify, I don't have upload rights to put this on Debian, and only Ubuntu needs this fix in the short to medium term. See bug #773765 for a subsequent release candidate with a Unity fix.

jastastruct (justinjoseph24) wrote :

Thanks for the patch, David! Works for me now on Natty. Excellent.

Michael Park (mejpark) wrote :

Thanks for providing a patch for this. But:

$ locate gnome-gmail.desktop
/home/mike/.local/share/applications/gnome-gmail.desktop
/usr/share/app-install/desktop/gnome-gmail.desktop
/usr/share/applications/gnome-gmail.desktop

Which of the above gnome-gmail.desktop files needs to be patched and how do I apply the patch file?

Good question.

The one that is installed with the package is
/usr/share/applications/gnome-gmail.desktop.

It needs to have the MimeType line added, with the x-scheme-handler tag.

Or you can enable the PPA to get the patched version

https://bugs.launchpad.net/ubuntu/+source/gnome-gmail/+bug/729357/comments/11

Jeremy Bicha (jbicha) wrote :

Dave, are you going to release a new version? since this has been broken on Ubuntu & Fedora for months and it would be a shame for it to be broken in the next release too.

Dave Steele (dsteele-gmail) wrote :

I'm not aware of it being broken on Fedora. The packager there added the
MimeType line with the last release.

I have released patches to fix this in Ubuntu, and to add a Unity message
indicator. There is also a PPA with a version that works.

The next upstream release is held up by a pair of blocker bugs in Debian.

     http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=638794

and one that behaves like

     https://bugs.launchpad.net/ubuntu/+source/nautilus-sendto/+bug/765847

The next step is currently out of my hands.

Jeremy Bicha (jbicha) wrote :

Oh, ok, it's good to hear that Fedora patched this. For Ubuntu users, it's far more useful to get your patches into the Ubuntu repositories than into just a PPA.

One way to do that is to submit a merge proposal and then we can subscribe ubuntu-sponsors to the bug or set them as the merge reviewer. Then we can find someone with commit access to approve the merge proposal.

If you need help, you can ask here or in #ubuntu-motu.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-gmail - 1.8.1-1

---------------
gnome-gmail (1.8.1-1) unstable; urgency=low

  * Fix setting gnome-gmail as default mailer, using dconf

gnome-gmail (1.8-1) unstable; urgency=low

  * GNOME 3 compatibility (LP: #729357)
  * Messages with attachments open directly, instead of the Drafts folder
  * Fixed "Send Document as Email" in LibreOffice (LP: #774055)
  * Added python-glade2 dependency for Oneiric (LP: #833355)
  * Translation improvementsa(LP: #783005)
  * Unity message indicator (LP: #773765)

gnome-gmail (1.7.3) unstable; urgency=low

  * Switch to native package as debian/ is maintained upstream
  * Add libgconf2-dev, autotools-dev, and dh-autoreconf to Build-Depends
  * Migrate to simplified dh based debian/rules (these last two changes fixes a FTBFS)
  * Include the non-Debian changelog in the package
 -- David Steele <email address hidden> Wed, 07 Sep 2011 22:45:34 +0000

Changed in gnome-gmail (Ubuntu):
status: Confirmed → Fix Released
David Steele (daves) on 2011-09-08
Changed in gnome-gmail:
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :

Thanks David!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.