Send to Email is missing on Natty

Bug #765847 reported by Javier Rivera on 2011-04-19
250
This bug affects 56 people
Affects Status Importance Assigned to Milestone
nautilus-sendto (Ubuntu)
Medium
Unassigned
Natty
High
Mathieu Trudel-Lapierre

Bug Description

Binary package hint: nautilus-sendto

SRU JUSTIFICATION:
This is a very low risk rebuild of nautilus-sendto to correctly link against libebook-1.2.so.10; which will re-enable the "Send to... Email" item in nautilus-sendto dialog. There are no other changes required but a rebuild of the application.

This is considered low risk because the application is small and easy to test; along with the fix being a simple rebuild.

This bug was already fixed in the development release by updating nautilus-sendto and evolution libraries through the normal process for development releases; a different issue was later fixed in development but does not affect the current stable release in any way (in the later version in development; the libnstevolution.so file to provide the "Email" option was not being installed).

TEST CASES:
1) open "nautilus-sendto <file>" from a Terminal or right-click a file, then click "Send To...".
2) select the "Email" item in the drop-down for "Send As:"
3) enter an email address or name (and possibly wait for contact auto-completion)
4) click Send
5) Verify that a new email is opened

Also: verify the other items still show in the "Send As:" drop-down: Instant Message (Empathy), CD/DVD Creator, Removable disks and shares, Bluetooth (OBEX Push).

A test case failure would be triggered should the "Email" Send As item would not show, or any of the previously available items were to not be available.

--------

When you right click on a file inside nautilus, and select "Send to" it will open the usual window. But I can only select "Bluetooth", "Empathy", "Disk burner" and "Removable disks" (1). In older versions there used to be an option to send it as e-mail.

It's always repoducible, and some other people seems to be suffering it: http://askubuntu.com/questions/35871/ubuntu-11-04-beta-2-left-button-send-to-no-option-to-send-the-file-as-an-a and http://ubuntuforums.org/showthread.php?p=10643452

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nautilus-sendto 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Tue Apr 19 14:23:58 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110304)
ProcEnviron:
 LANGUAGE=gl_ES:en
 LANG=gl_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus-sendto
UpgradeStatus: No upgrade log present (probably fresh install)

Javier Rivera (javier-isotecsl) wrote :
description: updated
David Steele (daves) wrote :

Seconded. Unanswered question as to whether this is a feature at https://answers.launchpad.net/ubuntu/+source/nautilus/+question/151705.

teimcrr (marco-carrarini) wrote :

Confirmed here, fresh install of Ubuntu 11.04 beta 2
Hope this will be corrected soon

Alexey Golovin (spidermc) wrote :

Yes, no such option now.

Changed in nautilus-sendto (Ubuntu):
status: New → Confirmed
Matthijs (tijs) wrote :

The solution mentioned in the fifth post of this thread is restoring the send to email menu:
http://ubuntuforums.org/showthread.php?t=1722178

Simon (simon-west-family) wrote :

followed ln -s instructions in http://ubuntuforums.org/showthread.php?t=1722178 and even rebooted to make sure Nautilus was re-reading everything but still no "email" in send to menu for files.

root@simon-Aspire-5810T:~# ls -l /usr/lib/libebook-1.2.so.*
lrwxrwxrwx 1 root root 22 2011-05-01 06:54 /usr/lib/libebook-1.2.so.10 -> libebook-1.2.so.10.3.1
-rw-r--r-- 1 root root 211168 2011-04-08 11:14 /usr/lib/libebook-1.2.so.10.3.1
lrwxrwxrwx 1 root root 27 2011-05-03 14:07 /usr/lib/libebook-1.2.so.9 -> /usr/lib/libebook-1.2.so.10
root@simon-Aspire-5810T:~# ls -l /usr/lib/libebook*
lrwxrwxrwx 1 root root 22 2011-05-01 06:54 /usr/lib/libebook-1.2.so.10 -> libebook-1.2.so.10.3.1
-rw-r--r-- 1 root root 211168 2011-04-08 11:14 /usr/lib/libebook-1.2.so.10.3.1
lrwxrwxrwx 1 root root 27 2011-05-03 14:07 /usr/lib/libebook-1.2.so.9 -> /usr/lib/libebook-1.2.so.10
root@simon-Aspire-5810T:~# ls -l /usr/lib/libedataserver*
lrwxrwxrwx 1 root root 28 2011-05-01 06:54 /usr/lib/libedataserver-1.2.so.14 -> libedataserver-1.2.so.14.0.0
-rw-r--r-- 1 root root 133792 2011-04-08 11:14 /usr/lib/libedataserver-1.2.so.14.0.0
lrwxrwxrwx 1 root root 30 2011-05-01 06:54 /usr/lib/libedataserverui-1.2.so.11 -> libedataserverui-1.2.so.11.0.0
-rw-r--r-- 1 root root 208528 2011-04-08 11:14 /usr/lib/libedataserverui-1.2.so.11.0.0
root@simon-Aspire-5810T:~#

I used this quite often until it broke in Natty

Michele (mikelito) wrote :

ln -s instructions in http://ubuntuforums.org/showthread.php?t=1722178 worked for me. this is a quite serious regression, in particular if for someone the simple workaround does not suffice.

teimcrr (marco-carrarini) wrote :

the above workaround didn't work form me.
The "Email" option appears in "send to.." menu, but it doesn't actually do anything.

The workaround did work for me. I am really disappointed in the quality of Natty.

orzeh (orz3h) wrote :

confirmed, workaround is working here on 11.04

Joel (figwort) wrote :

Workaround does not work for me, like teimcrr wrote, it doesn't bring up a mail message, it brings evolution to focus if it is open but nothing else, this is a critical bug in my opinion, the importance should not read undecided and it should not be unassigned. My wife is beside herself, this is a common activity in order to send photos out via shotwell.

chreko (chreko) wrote :

I confirm Joel's statement. So "send to" mails is still not working here on my Ubuntu natty amd64 machine

Joel (figwort) wrote :

While the workaround provided the "sendto email" option, I also had data migration failures (.evolution ---> .local/share/evolution) with this upgrade from Maverick, I could not get past evolution hanging after "send to" email, it was identical to loicjacquard's post in bug #773121

Did a export backup of evolution, and installed a fresh copy of Natty, workaround is currently working, the sendto option is available and brings up the mail message w/attachment.

Michele (mikelito) wrote :

What Joel reports sounds interesting. I also experienced troubles in the migration of settings and mails from .evolution to .local/share/evolution. What about the others who are experiencing this bug? Are we finding a pattern?

perezxolote (perezxolote) wrote :

Same Bug here. fresh Natty install, old home partition, after workaround functionality reestablished. BUT: when typing an email address, nautilus-sendto is not reading my address-book from Evolution, i.e. addresses are not being suggested.

Same problem as perezxolote I am afraid. This seems to be a problem with migration from Maverick to Natty. I am using Evolution.

Changed in nautilus-sendto (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Seems like enough users get the issue than it should be investigated

Changed in nautilus-sendto (Ubuntu Natty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → High
status: New → Confirmed

I also had the exact problem. Tried the symbolic link trick. After this the email option was added but it does not work. When evolution is closed it does nothing. When evolution already was open it gets focus but does not do much more.

Is there a workaround (by resinstalling something) while waiting for the final solution?

non (federico-gazaba) wrote :

Have this same issue since upgrade from 10.04 from usblive instalation. I remove and reinstall some archives related to "send-to" in synaptic but whitout positive results.

Changed in nautilus-sendto (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
Changed in nautilus-sendto (Ubuntu Natty):
assignee: Sebastien Bacher (seb128) → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-sendto - 3.0.0-1ubuntu2

---------------
nautilus-sendto (3.0.0-1ubuntu2) oneiric; urgency=low

  * debian/rules: remove the bits removing the evolution plugin. We want to
    install it again; it seems to work fine. (LP: #765847)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 30 Jun 2011 08:06:32 -0400

Changed in nautilus-sendto (Ubuntu):
status: Triaged → Fix Released
Changed in nautilus-sendto (Ubuntu Natty):
status: Confirmed → Triaged
Bruce Crowther (bwucie) wrote :

Will this fix be built for Natty, or are we waiting for Octember and Oneiric?

Nah, it will be fixed, I'm working on it ;)

nautilus-sendto just needs to be rebuilt on Natty to pick up the different version of the libebook library; I'm about to upload the "fix" to natty-proposed.

description: updated
description: updated
Changed in nautilus-sendto (Ubuntu Natty):
status: Triaged → In Progress
kylea (kylea) wrote :

Will it use Thunderbird if that is the Preferred Email Client?

Pedro Villavicencio (pedro) wrote :

This is about the option being missed on Natty if you want to ask something non related like Thunderbird being on next relase or not please use the desktop mailing list, launchpad is for tracking bugs.

kylea (kylea) wrote :

Yes know that I have noticed it is missing and I looked for a bug before filing one in the process in noticed references to Evolution ad the email client , given the potential move to Thunderbird cannot see why the question is out Of place

David Steele (daves) wrote :

Will this fix work for the GNOME Preferred Email client, even if it is something other than Evolution?

Earlier entries in this thread imply that an Evolution library is involved with the fix. If the fix is Evolution-specific, that represents a regression relative to Maverick.

This bug is assigned to nautilus-sento and Natty, not Evolution. The question is appropriate here.

Yes, the plugin uses the preferred client, depending on what it is.

Hello Javier, or anyone else affected,

Accepted nautilus-sendto into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus-sendto (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Bruce Crowther (bwucie) wrote :

No difference: nothing happens unless Evolution is running, when clicking "Send" in the Send to dialog will bring Evolution into focus. No new email is created. (Dell C521, 11.04 AMD 64)

Martin Pitt (pitti) on 2011-07-06
tags: added: verification-failed
removed: verification-needed

I have received the update today.

The test case works, either starting it by right clicking or in the terminal. I have tested both cases with Evolution open and closed (4 tests in total), all worked (i.e. email window pops up with the file attached, all other items still there).

So this is a Works for Me.

Bruce problem is different from the original bug, the bug was about missing the send-to entry, Bruce problem is about this entry working incorrect. I suspect that this is a complete different problem and another bug should be opened with all the relevant data.

Martin Pitt (pitti) on 2011-07-06
tags: added: verification-done
removed: verification-failed
Bruce Crowther (bwucie) wrote :

Works for me on my netbook, but stubbornly refuses to happen on the desktop. I have no idea what the difference is (yet!)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-sendto - 2.32.0-0ubuntu1.1

---------------
nautilus-sendto (2.32.0-0ubuntu1.1) natty-proposed; urgency=low

  * Rebuild to fix crash in libnstevolution (build against libebook-1.2.so.9.
    (LP: #765847)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 01 Jul 2011 11:14:47 -0400

Changed in nautilus-sendto (Ubuntu Natty):
status: Fix Committed → Fix Released
chreko (chreko) wrote :

I am using nautilus-sendto (2.32.0-0ubuntu1.1) on AMD64. As before and as described in comment #29, nothing will happen after Evolution starts. I have purged and reinstalled all relevant packages including libebook and libedataserver; the latter because of the workaround in #7 I tried.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers