glChess has no 3D

Bug #71593 reported by Wade Menard on 2006-11-13
124
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-games (Baltix)
Undecided
Unassigned
gnome-games (Ubuntu)
Wishlist
Robert Ancell
Nominated for Jaunty by Fabián Rodríguez
Nominated for Lucid by Fabián Rodríguez

Bug Description

Binary package hint: gnome-games

The new GLChess game in the 2.17.2-0ubuntu1 package in the feisty repo has the "3D" option grayed out for me. Seems to be a compile time issue.

Intel 945GM video chipset

Sebastien Bacher (seb128) wrote :

Thank you for your bug. The 3D option require python-gtkglext which is not packaged at the moment

Changed in gnome-games:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Wade Menard (wade-ezri) wrote :

Is this a compile-time or run-time dependency?

Sebastien Bacher (seb128) wrote :

runtime, that's a python program, there is no "compile-time" option

Eduardo Cereto (dudus) wrote :

So this package should be added as needing for a maintainer right?

Sebastien Bacher (seb128) wrote :

That python module should be packaged by somebody

Robert Ancell (robert-ancell) wrote :

python-gtkglext1 has been added to Debian unstable in the last week:
http://packages.debian.org/unstable/python/python-gtkglext1

The glchess packaged version is slightly better as it builds the bindings for all the installed versions of Python (though I suspect this change will be added to the Deb Unstable version soon).

Hopefully it will be picked up for Feisty+1? Once Ubuntu has picked up the package I get to stop maintaining it :)

pirast (pirast) wrote :

Sebastien, could it maybe even be added to Feisty?

pirast (pirast) wrote :

Hm, the Debian version does not install on Ubuntu, it depends on Python before 5:

[dep] python (<< 2.5)
python (>= 2.4)

Sebastien Bacher (seb128) wrote :

Martin, that's detail to one game, it's really low priority on my list of things to work on at the moment. You are welcome to get the package uploaded, accepted by MOTU and file the MIR request for the package if you want, having it for feisty would be nice!

Andrew Conkling (andrewski) wrote :

For me, that doesn't quite do it. After installing python-gtkglext (from glchess' Sourceforge page), I still can't run in 3D. The message mentions also needing "OpenGL Python bindings" (assumedly http://pyopengl.sourceforge.net?).

@Andrew Conkling

1. Install the python-gtkglext1 package above:
 http://downloads.sourceforge.net/glchess/python-gtkglext1_1.1.0-2feisty_i386.deb?modtime=1172631048&big_mirror=0

2. Install the python-opengl bindings from the repository

  sudo aptitude install python-opengl

Works for me.

Yes, that workaround worked for me as well.

Eugenia Loli-Queru (eloli) wrote :

This wrapper must be installed by default, otherwise people will be disappointed if it doesn't work as they expect it.

pirast (pirast) wrote :

Maybe it should just get greyed out for Feisty?

Eugenia Loli-Queru (eloli) wrote :

Maybe they should just include the pygtkglext package in feisty?

Andrew Conkling (andrewski) wrote :

On 3/16/07, Eugenia Loli-Queru <email address hidden> wrote:
> Maybe they should just include the pygtkglext package in feisty?

Have we passed UVF yet for Feisty?

mikko (mikko-) wrote :

>1. Install the python-gtkglext1 package above:
>http://downloads.sourceforge.net/glchess/python-gtkglext1_1.1.0-2feisty_i386.deb?modtime=1172631048&big_mirror=0

It worked but this is what I get: (maybe because of my laptop and poor via unichrome pro)

eppy 1 (choppy121212) wrote :

Ubuntu question # 6644 also mentions that a 64 bit package of python-gtkglext1 (and of course for other architectures) is needed.

https://answers.launchpad.net/ubuntu/+ticket/4469

Ori Avtalion (salty-horse) wrote :

I filed bug 103642 for packaging of the gtkglext python bindings.

Gleidson Lacerda (gleidsonlm) wrote :

The package python-gtkglext1 depends libgtkglext1. My how-to enable 3D on glChess:

1. sudo apt-get install python-opengl libgtkglext1
2. wget -c http://downloads.sourceforge.net/glchess/python-gtkglext1_1.1.0-2feisty_i386.deb?modtime=1172631048&big_mirror=0
3. sudo dpkg -i python-gtkglext1_1.1.0-2feisty_i386.deb

The Universe repository must be enable too.

Dmitry Hazin (dhazin) wrote :

is it possible to make amd64 packages also? Ive installed the Debian version of the package, but 3D still doesn't work with exactly the same message; maybe your package will help?

Michael R. Head (burner) wrote :

This is fixed in gutsy, right? I noticed that http://packages.ubuntu.com/gutsy/python/python-gtkglext1 is in the universe.

but this won't work for feisty anyway :( I tried installing with
--force-all and chess crashed when trying to turn on 3d.

2007/6/28, Michael R. Head <email address hidden>:
> This is fixed in gutsy, right? I noticed that
> http://packages.ubuntu.com/gutsy/python/python-gtkglext1 is in the
> universe.
>
> --
> glChess has no 3D
> https://bugs.launchpad.net/bugs/71593
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Qwerty Maniac (qwertymaniac) wrote :

Yes, it works in Gutsy Gibbon. Haven't tested it again on Feisty yet.

Ubuntu 7.04 amd64 with OpenGL and GTKGL bindings installed.

Result: Failure. Application complains that OpenGL and GTKGL aren't installed.

(Used --force-architecture on the i386 package)

VF (vfiend) wrote :

force-architecture won't work for this because the 64bit application has to load a 64bit library, not a 32bit one.

Dmitry Hazin (dhazin) wrote :

amd64 package doesn't help :(( it has unsatisfiable dependencies and
if to force installation chess crashes when trying to turn on 3d.

2007/7/8, VF <email address hidden>:
> force-architecture won't work for this because the 64bit application has
> to load a 64bit library, not a 32bit one.
>
> --
> glChess has no 3D
> https://bugs.launchpad.net/bugs/71593
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Shouldn't this be marked as fixed if it is fixed in Gutsy?

Andrew Conkling (andrewski) wrote :

So it would appear. I'm closing this; anyone can reopen if the problem persists.

Changed in gnome-games:
status: Confirmed → Fix Released

Surely gnome-games should recommend or suggest python-gtkglext1.

Even nicer would be using the same install thingy that shared folders uses.

Robert Persson (ireneshusband) wrote :

I installed glchess today but python-gtkglext1 did not get pulled in with it and the the 3D option remained greyed out. When I installed python-gtkglext1 the 3D option at least showed up in the "view" menu, but selecting it made no difference – the board always displays in 2D.

Changed in gnome-games:
status: Fix Released → New
Robert Persson (ireneshusband) wrote :

Oops. Sorry. I didn't realise that I had to install python-opengl as well. Nevertheless if a package has "gl" in its name it is not reasonable to consider 3D functionality to be optional;. There are plenty of 2D chess front ends. glchess's 3D functionality needs to be enabled by default.

Andrew Conkling (andrewski) wrote :

Robert: This bug is about gnome-games, not glchess. So adding it as a dependency doesn't seem best, but maybe it could be added to the 'suggests' or 'recommends'?

Fred (eldmannen+launchpad) wrote :

Yes, I agree this is rather low priority.
But it sounds like something easy to fix...

Matthew Woerly (nattgew) wrote :

Both python-opengl and python-gtkglext1 are in the repos for Hardy.

Fred (eldmannen+launchpad) wrote :

Nattgew,
Maybe so. But they're not installed by default. When I try to switch to 3D mode, I get error. :(

Matthew Woerly (nattgew) wrote :

Yes that's true the bug is still there but at least both packages are in the repos... the fix seems a little closer.

Matthew Woerly (nattgew) wrote :

I think this has been established...

Changed in gnome-games:
status: New → Confirmed
Michael R. Head (burner) wrote :

gnome-games already recommends python-gtkglext1 and python-opengl

It doesn't need those packages to run -- they just enhance the functionality -- so it doesn't actually "depend" on them. This sounds like correct packaging to me.

Fred (eldmannen+launchpad) wrote :

Then glChess should have an "Install those packages" when it say I don't have those packages.

Fred (eldmannen+launchpad) wrote :

$ sudo apt-get install python-gtkglext1
$ sudo apt-get install python-opengl

3D chess works now. But it does not have anti-aliasing. It has ugly rendering.
It does not look as good as Chess Titans on Vista. :(
* http://en.wikipedia.org/wiki/Chess_Titans

Matthew Woerly (nattgew) wrote :

Agreed... but it's oddly faster than the non-3D...
If Michael is correct, then can we close this?
The relevant bug would now seem to be
https://bugs.launchpad.net/ubuntu/+source/gnome-games/+bug/160766

Sebastien Bacher (seb128) wrote :

The bug has been fixed, there is an another one about the message not being clear and easy installation

Changed in gnome-games:
status: Confirmed → Fix Released
ubby (kostas-sytske) wrote :

When I want to start the 3D chess game I get a message that there are some missing packages.
I had installed them by doing the following:
sudo apt-get install python-opengl python-gtkglext1

But Chess in 3D still not work.

I use Ubuntu 8.04
I hope this problem will be solved in the next Ubuntu.

komputes (komputes) wrote :

Sebastien, has this bug been fixed upstream by gnome, will the fixed version be included in the Intrepid Release? I am currently testing this and it still seems to still be an issue in Hardy. The workaround provided (install python-opengl python-gtkglext1) give me 3D chess pieces until I make a move, then only the background color is displayed. (see attached screenshots)

Fabián Rodríguez (magicfab) wrote :

Still having the same issue in Ubuntu Jaunty Beta.

The bug about having a friendly message indicating the needed packages is Bug #160766.

Fabián Rodríguez (magicfab) wrote :

*AND* the workaround doesn't work for me. Installing the missing packages and enabling 3D, then restarting glchess makes it crash. And ubuntu-bug doesn't know how to report a bug on it.

zika (4zika4) wrote :

http://ubuntuforums.org/showthread.php?p=7296949#post7296949

in Jaunty 3D in chess does not work on ASUS AH 3650 (a.k.a. ATI Radeon HD 3650) with radeon driver (open source) even though python-{opengl,gtkglext1} are installed ...

it accepts 3D being checked but when You start it it just flashes and go to oblivion, leaving program in ps list.

I had to go to gconf-editor to change it back so I could have chess back ... :) of course I had to kill chess process ... :)

Abel Puertas (puertas-abel) wrote :
Download full text (4.2 KiB)

I've installed the packages python-opengl python-gtkglext1 and them glchess crash.
I've restarted the process in terminal. This is the error message:
======================================

abel@tierra:~$ glchess
/var/lib/python-support/python2.6/glchess/network.py:73: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  print 'Failed to load GGZ config: %s' % e.message
Failed to load GGZ config:
Using OpenGL:
VENDOR=DRI R300 Project
RENDERER=Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
VERSION=1.3 Mesa 7.4
EXTENSIONS=GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_MESAX_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow_ambient GL_SUN_multi_draw_arrays
Traceback (most recent call last):
  File "/var/lib/python-support/python2.6/glchess/gtkui/chessview.py", line 168, in __expose
    self.view.feedback.renderGL()
  File "/var/lib/python-support/python2.6/glchess/display.py", line 489, in renderGL
    self.scene.controller.render()
  File "/var/lib/python-support/python2.6/glchess/scene/opengl/opengl.py", line 396, in render
    self.drawPieces()
  File "/var/lib/python-support/python2.6/glchess/scene/opengl/opengl.py", line 897, in drawPieces
    piece.draw()
  File "/var/lib/python-support/python2.6/glchess/scene/opengl/opengl.py", line 143, in draw
    self.chessSet.drawPiece(self.name, state, self.scene)
  File "/var/lib...

Read more...

Josmar (josmar) wrote :

To fix this problem, u have to install mgltools-opengltk too.

Like this:
$ sudo apt-get install python-opengl python-gtkglext1 mgltools-opengltk

Source in brazilian portuguese:
http://gdpufes.blogspot.com/2009/06/linux-habilitar-o-xadrez-do-ubuntu-em.html

Fabián Rodríguez (magicfab) wrote :

Interesting. glChess has now been removed from the default games in Lucid. The problem is still there, however.

This workaround remains valid:
sudo apt-get install python-opengl python-gtkglext1

mgltools-opengltk can't be installed in Lucid (yet):
The following packages have unmet dependencies:
  mgltools-opengltk: Depends: python2.5 but it is not installable
E: Broken packages

Changed in gnome-games (Ubuntu):
status: Fix Released → Confirmed
Fabián Rodríguez (magicfab) wrote :

So, adding dependencies to python-opengl python-gtkglext1 seems to be what's missing.

Fred (eldmannen+launchpad) wrote :

Well python-opengl and python-gtkglext1 are not "dependences" because they are optional.
They are only needed for 3D, so they're not dependencies.
Chess should prompt to install them upon user try switch to 3D mode.

Chess is no longer installed by default?
What is this?
Chess is the most popular and successful game ever in history!
Ubuntu must have chess! Windows have it!

Fabián Rodríguez (magicfab) wrote :

Fred, i am not sure why the required 3D libs can't be included as dependencies. Do they require 3D acceleration as Desktop Effects (compiz) does, for example ? If no, they should be dependencies. If yes, I'd agree this could use the same mechanism as other non-free stuff uses when proposing to install missing pieces. Overall it makes for a broken end-user experience when it's not there by default, specially if you're offline.

Robert Ancell (robert-ancell) wrote :

Fred, the number of default installed games were reduced for Lucid, see:
https://wiki.ubuntu.com/DesktopTeam/Specs/Lucid/DefaultsApps

(You can still install Chess from the software-center)

Robert Ancell (robert-ancell) wrote :

Fabian, the dependency was not added because Chess was on the CD and there is limited space. Now chess is no longer on the CD and is separately packaged from the other games the dependency can be added.

Changed in gnome-games (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games - 1:2.30.0-0ubuntu6

---------------
gnome-games (1:2.30.0-0ubuntu6) lucid; urgency=low

  * debian/control.in:
    - Change glchess suggests python-gtkglext1, python-opengl to recommends as
      no longer on the CD (LP: #71593)
 -- Robert Ancell <email address hidden> Tue, 13 Apr 2010 16:06:02 +0800

Changed in gnome-games (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers