Broken "el" translation of help file

Bug #216789 reported by Matthew East on 2008-04-13
94
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Games
Fix Released
Medium
gnome-control-center
Invalid
Undecided
Unassigned
gnome-games (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Latest Hardy

Binary package hint: gnome-games-data

scrollkeeper-rebuilddb throws up this error message:

///usr/share/gnome/help/blackjack/el/blackjack.xml:402: parser error : Entity 'Βοήθεια' not defined

Matthew East (mdke) on 2008-04-13
description: updated
Matthew East (mdke) wrote :

Here's a patch to fix it. Probably should go upstream too if possible.

Changed in gnome-games:
importance: Undecided → Medium
status: New → Confirmed
Na9er (ana-na9er) wrote :

I'm facing the same bug ..

thanks for the patch but can u explain how to use it please?

nash (nash-nash) wrote :

I wonder if this should be higher then medium. This break affects scrollkeeper, and possibly even prevents other documentation from being updated. Additionally it generates an email to users monthly until it is fixed. It's also been reported multiple times.

Also it's an easy fix, just fix a single occurance of an ampersand.

Sebastien Bacher (seb128) wrote :

the bug is only a warning displayed on the command line, it doesn't make anything crash or break upgrades, that's only a cosmetic issue for people not using the graphical tools

curtHendzell (curthendzell) wrote :

I had the same problem when I upgraded from Gutsy to Hardy, I ended up canceling the upgrade and just deleting the offending blackjack.xml file (it's not from a language that I speak, so I didn't feel I needed it). Afterward the upgrade went fine, but I think Sebastian is right on this one, as scrollkeeper still took a long time to upgrade, just giving any error. If it bothers you alot I'd say delete the .xml file (how often will you use the Blackjack help anyways), but it should just get past it if you wait.

nash (nash-nash) wrote :

I should probably also point out that the offending message is mailed to you because it fails under cron.monthly.

So any spurious messages sent to the user on a monthly basis are generally considered a bad thing. [Insert rant about bombaded user with spurious messages to train user to ignore messages when they are serious and general bad security]

I've attached the email I received.

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream and the change will be available in the next update

Changed in gnome-games:
assignee: nobody → desktop-bugs
status: Confirmed → Fix Committed
Changed in gnome-games:
status: Unknown → Fix Released
Alex Ruddick (alexrudd0) on 2008-05-02
Changed in gnome-control-center:
status: New → Fix Released
Matthew East (mdke) on 2008-05-02
Changed in gnome-control-center:
status: Fix Released → Invalid
Sebastien Bacher (seb128) wrote :

new versions have been uploaded to hardy and intrepid

Changed in gnome-games:
status: Fix Committed → Fix Released
Changed in gnome-games:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.