Pink layer on taken screenshots (gnome-screenshot)

Bug #743176 reported by UbuntuFlo on 2011-03-26
266
This bug affects 50 people
Affects Status Importance Assigned to Milestone
gnome-flashback (Ubuntu)
Undecided
Unassigned
gnome-screenshot (Ubuntu)
Undecided
Unassigned
gnome-utils (Ubuntu)
Low
Chris Coulson

Bug Description

Binary package hint: gnome-utils

After having taken a screenshot of a part of my screen (gnome-screenshot) which is marked/shown by a pink layer, this pink layer can be seen on the screenshot itself.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-screenshot 2.32.0-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Date: Sat Mar 26 16:19:48 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110316)
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-utils
UpgradeStatus: No upgrade log present (probably fresh install)

UbuntuFlo (ubuntuflo) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gnome-utils (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

I have found a patch which looks like it might work around this problem, and bug 683093 too (rather than the workaround in that bug which disables the animation)?

http://mail.gnome.org/archives/commits-list/2011-March/msg03805.html

Changed in gnome-utils (Ubuntu):
assignee: nobody → Lee Williams (lee-willy1977-williams)
Alistair Buxton (a-j-buxton) wrote :

Per Popey's found email, this has already been fixed upstream. The fix is in GNOME Utilities 2.91.91:

http://git.gnome.org/browse/gnome-utils/commit/?id=1b236792d927149ff88aac09adefd6b7bd988cf2

Changed in gnome-utils (Ubuntu):
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

the commit doesn't apply as it to the natty version, does anybody want to backport the other commits required or update this one?

Whilst I don't mind picking it up and doing the work I'm ok with coding but I have no experience with using linux source control/branches and ubuntu dev in general... I thought a low priority might be a good starting point - if I'm wrong I'll happily step down from this bug for now...?

Sebastien Bacher (seb128) wrote :

You are welcome to work on that, any source diff will work no need to bother with packaging issues, let us know if you need any guidance on how to do that

UbuntuFlo (ubuntuflo) wrote :

Just installed B1 and wanted to let you know that the screenshots are still pink.

Sebastien Bacher (seb128) wrote :

Do you still plan to work on that or should somebody else pick it up to backport those?

Sorry, I can't help for coding but I would like to mention that I have also this problem on Natty beta 1.
It happens only in an "Ubuntu" or "Ubuntu Classic" session, but not in an "Ubuntu Classic (No Effects)" or "Ubuntu (Safe Mode)", I guess because compiz is not active in the latter cases.

Yes, I am still looking at this backport work.

From what I can tell I'm still getting the pink area captured with those items in the code - I'm continuing to do a bit more digging in case I've missed something from the original patches.

Joaquin (jknvv13) wrote :

I'm affected too.
I'm using Unity 2D with compiz enabled

Changed in gnome-utils (Ubuntu):
assignee: Lee Williams (lee-willy1977-williams) → Chris Coulson (chrisccoulson)
Changed in gnome-utils (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-utils - 2.32.0-0ubuntu5

---------------
gnome-utils (2.32.0-0ubuntu5) natty; urgency=low

  * Fix LP: #743176 - Selection window is captured in screenshots. Backport
    2 upstream GIT commits to work around this
    - add debian/patches/07_screenshot_select_area_fix.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Tue, 19 Apr 2011 20:42:53 +0100

Changed in gnome-utils (Ubuntu):
status: Fix Committed → Fix Released
Swapnil Bhartiya (swapnil) wrote :

I am still facing the issue. Running all updates.

Ralf Hersel (ralf.hersel) wrote :

Issue is not fixed in 11.04 final release.

UbuntuFlo (ubuntuflo) wrote :

There are still reports of users (http://forum.ubuntuusers.de/post/3116507 – German only) that the problem is still persistant in Natty after having installed all upcoming updates.

Michael MacEachern (maceach-b) wrote :

This is still apparently happening in Ubuntu 14.10, but NOT Xubuntu 14.10. How annoying that after all this time this hasn't truly been fixed yet.

Adolfo Jayme (fitojb) on 2015-02-03
no longer affects: compiz (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2015-02-03
affects: gnome-utils → compiz (Ubuntu)
no longer affects: compiz (Ubuntu)
midopa (midopa) wrote :

Still happens in 14.04

Greg Holst (gregory-holst) wrote :

Still a problem in Ubuntu 14.04.

"[Bug 7436] Re: Pink layer on taken screenshots (gnome-screenshot)"
Ralf Hersel doc

Julian Haagsma (jhaagsma) wrote :

This is also a problem in 16.04 in gnome-flashback

HB9DTX (ubuntu-yvesoesch) wrote :

I confirm, still annoying on Ubuntu 16.04.

HB9DTX (ubuntu-yvesoesch) wrote :

I confirm, still annoying on Ubuntu 16.04.

"[Bug 7436] Re: Pink layer on taken screenshots (gnome-screenshot)"
Ralf Hersel doc

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-flashback (Ubuntu):
status: New → Confirmed
Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → Confirmed
no longer affects: gnome-settings-daemon
BDSword (thetruebloodsword) wrote :

Is this bug fixed? It's still there on my 16.04.

I found it's related to the delay timeout here.

https://github.com/GNOME/gnome-screenshot/blob/master/src/screenshot-area-selection.c#L296

Although this is not the code in gnome-utils package, similar code can be found in gnome-utils package. (Try to search the number 200 in the source code.)

One workaround is to set this timeout to a larger number.

Another solution is to change the behavior of area-selection, for example:

1. Cover the whole screen with pink layer.
2. Transparent the user-selected area.
3. Take a screenshot with the selected area.

Here is a simple example to fix this issue:

https://github.com/bdsword/gnome-screenshot/commit/4648caedd1ac621e0663ffd6618b376513e0e0d7

The attachment is the result of above patch.

tags: added: trusty xenial
strangedata (rcteigao) wrote :

Affects me too on 17.10.

Timothée Manaud (timothee) wrote :

Still present on my system:
Linux laptop 4.10.0-42-generic #46~16.04.1-Ubuntu SMP Mon Dec 4 15:57:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
I'm sorry to rumble, but 7 years regressions are what prevents users switching to linux.

Mikko (mikser) wrote :

Still present on my system:
Linux Mint 17.3 Cinnamon 64-bit
Cinnamon Version 2.8.8
Linux Kernel 3.19.0-32-generic
Graphics Card Nvidia GeForce GTX 650.

The same bug is also reported here:
https://bugs.launchpad.net/ubuntu/+source/gnome-screenshot/+bug/1406538
https://bugs.launchpad.net/ubuntu/+source/gnome-screenshot/+bug/1574398

Raph (mraph) wrote :

Issue present on my system :
Ubuntu 17.10 64-bit
GNOME Shell 3.26.1
Linux Kernel 4.13.0-32-generic

I noticed something interesting and that might resonate with comment #31 above (https://bugs.launchpad.net/ubuntu/+source/gnome-utils/+bug/743176/comments/31).

I have two screens, and the problem occurs on only one of my screen.
Furthermore, on the screen where the problem occurs, depending if I quickly take the screenshot or not, the pink area will either fully cover the screenshot or for example only 90% of the area if I click-drag and release mouse button quickly...

I can provide more information if needed.

Hi!
No idea if this is a significant discovery or a statement of the obvious but will post anyway. Running Ubuntu 16.04 here; for whatever reason for the past roughly six months I have been been having random lock-ups: display freezes except for the mouse point (usually) and the processes (DejaDup, the Virtual Machine running Windows XP, etc.) also usually continue to work.

Recently found a work-around: boot, log-out (via the gear icon at the upper right), log back in but first click on the foot icon and select a different option. Here I have Gnome, Gnome Flashback (Compiz), Gnome Flashback (Metacopy), and Ubuntu (default). I selected the ‘Compiz’ one and my lockups magically went away! <cartwheels!!>

According to the post I was following this reduced/eliminated video hardware acceleration. ...The side effect, at least for me, is area screen shots (Shift_PrintScreen) now have the pink overlay.

What I’m wondering is in Post #31 BDSword suggest an increase of the 200 value in “g_timeout_add (200, emit_select_callback_in_idle, cb_data)”, something about a delay timeout. I’m wondering if there is a connection between this value and it has effectively been slowed down by my changing from the Ubuntu option to the Compiz option, the latter supposedly turning off video acceleration.

Just a WAG, but may help the developers and troubleshooters to find the solution. (Now to try increasing that 200 value – to what??! And from my notes what file?)

Hi Folks!

Updates on the above. I have not found where BDSword's suggestion for (in comment #31) changing that 200 value in the g_timeout line goes -- it doesn't appear to be a clear text file.

Did find using the Metacity option does not have the pink overlay option like the Compiz option does, or at least here. I just started testing with Metacity but so far Compiz and Metacity look the same, so for others if one gives a pink overlay try the other as a workaround.

tib (tipcsi) wrote :

Funny that in 2019 it's still an issue...

Fabien S (neurotox67) wrote :

I have the same issue (ubuntu 18.04, fresh install) and it seems to be related to my second screen too.
I've taken multiple screenshots from my 2nd screen and all had this pink layer.
Then I started "googling" to find similar issues and read this bug report (and Raph comment) : I took a new screenshot using the other screen (tagged #1 / secondary screen in configuration) and pink layer was gone.
I tested several times and it's a real workaround.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.