gnome-appearance-properties causes CPU spike in Hardy

Bug #236778 reported by James Schriver on 2008-06-02
90
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-desktop (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Undecided
Unassigned
Intrepid
Medium
Ubuntu Desktop Bugs
nautilus (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: nautilus

Recent updates in hardy-proposed (now pushed out to updates) causes a significant cpu spike when using gnome-appearance-properties to change desktop backgrounds. Selecting the background wallpaper by using a mouse is very slow and responsive, however using the keyboard arrows is more responsive. gnome-appearance-properties also takes up much of the CPU during this process. There were recent changes in nautilus and gnome-desktop that fix issues with backgrounds, but seem to have introduced a regression.

It appears that now a fix for this is in -proposed.

lanzen (lanzen) wrote :

Confirming. Same bug here. Others are reporting this in ubuntu.it mailing list.

Sebastien Bacher (seb128) wrote :

thank you for your bug report

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

there is also an another small svn change to not use a null variable

lanzen (lanzen) wrote :

The patch fixed it, but now I get 4 updates, the same I've just installed. Well, it actually looks that I've applied the patch to older packages... the updates are 2.22.2-0ubuntu2, while the patched are 2.22.2-0ubuntu1.

I did "apt-get source gnome-desktop". Where did I go wrong?

Sorry, but it's the first time ever I tried patching.

Pedro Villavicencio (pedro) wrote :

it's a gnome-desktop bug not a nautilus one. rejecting this task.

Changed in nautilus:
status: New → Invalid
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in nautilus:
status: New → Invalid
Changed in gnome-desktop:
status: New → Fix Committed
lanzen (lanzen) wrote :

It's fixed with 2.22.2-0ubuntu3. You've been was very quick, thank you.

Pedro Villavicencio (pedro) wrote :

Confirming lanzen comments, the bug is fixed with gnome-desktop 1:2.22.2-0ubuntu3 ; thanks.

The bug still exists.
I'm using UbuntuStudio 8.04, updated with recent kernel (2.6.24-18-rt).
Already tried installing the 2.22.2-0ubuntu3 version of the gnome-desktop-data package from -proposed.

Conky reading shows that CPU still stays at 100% and I'm still unable to choose the wallpaper with mouseclick.

Early AM June 4th update from Hardy Proposed fixed the bug!

Wow! That was fast!

It Is fixed now after installing nautilus and nautilus-data package from hardy-proposed.

Thank you very much.

Michael Rooney (mrooney) on 2008-06-06
description: updated

I don't get updates from Hardy proposed yet I notice this bug today. Did it get released into normal updates, and if so, am I understanding correctly that now a fix is proposed?

Martin G Miller (mgmiller) wrote :

I also just noticed this bug. Everything worked fine 2 days ago when I changed my desktop wall paper. Now top reports gnome-appearanc using 96% cpu and I can't change wallpapers. I do not have hardy proposed enabled. I do have backports enabled, though.

The fixed package is in the hardy-proposed repos. I would think that it would be placed into the main updates within a day or two.

Sebastien Bacher (seb128) wrote :

are you sure your tried the hardy-proposed update, the description update is misleading, several people confirmed that the current update fixes the issue, it should be moved to hardy-updates on monday but might be blocked since some of the comment describe that the new update doesn't fix the issue

Sebastien Bacher (seb128) wrote :

reading again the change description it seems that the description has just been reformated, does anybody still get the issue using the hardy-proposed version?

James Schriver (dashua) wrote :

Sebastian,

The issue is resolved with the gnome-desktop update in hardy-proposed. Confirmed.

Savvas Radevic (medigeek) wrote :

confirming, problem resolved for me too

pclinux (pclinux) wrote :

Yes, I having the same problem. The CPU spike to 100%.

Magnus S (magnuss) wrote :

The 2.22.2-0ubuntu3 version from hardy-proposed did NOT fix my problems at all.

magnus@magnus-laptop:~$ top | grep gnome-app
 6679 magnus 20 0 45396 31m 12m R 100 1.1 12:40.07 gnome-appearanc

magnus@magnus-laptop:~$ uname -a
 Linux magnus-laptop 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GNU/Linux

//magnus

Michael Rooney (mrooney) wrote :

Hi Sebastien. I have edited the title to reflect my understanding of this bug. I *think* what happened is that the original problem appeared in hardy-proposed and this bug was filed. Regardless of this bug the -proposed was pushed to updates, and as such people are commenting about having the issue without -proposed (I can confirm I have this issue without -proposed). THEN a fix for this issue was put in -proposed, so now proposed is fixed, while it is broken in an updated Hardy (reversed from initially when the bug was filed). Does that make sense? Can anyone confirm?

description: updated
Sebastien Bacher (seb128) wrote :

> The 2.22.2-0ubuntu3 version from hardy-proposed did NOT fix my problems at all.

you might have an another issue, could be bug #147045 for example

Magnus S (magnuss) wrote :

> you might have an another issue, could be bug #147045 for example

Nope, that bug is not a problem for me. I am pretty sure that it is this issue i am suffering from. The description fits perfectly, and what Mike Rooney says makes sense to me.
I first got this problem after an update(not hardy-proposed) a few days ago. So i tried 2.22.2-0ubuntu3 from hardy-proposed, but that didn't fix the problem for me...

//magnus

Sebastien Bacher (seb128) wrote :

the issue is fixed for everybody else so you will have to investigate what is different on your configuration, do you have the bug using an another user configuration? does downgrading to the hardy version fixes the issue?

Michael Rooney (mrooney) wrote :

Sebastien, could you clarify "fixed for everybody?" Do you mean everyone who has enabled -proposed and is updated in that respect? Because I do not use -proposed, and definitely DO have this bug on my end with normal updates.

Martin G Miller (mgmiller) wrote :

As Mike Rooney said:

"I *think* what happened is that the original problem appeared in hardy-proposed and this bug was filed. Regardless of this bug the -proposed was pushed to updates, and as such people are commenting about having the issue without -proposed (I can confirm I have this issue without -proposed). THEN a fix for this issue was put in -proposed, so now proposed is fixed, while it is broken in an updated Hardy (reversed from initially when the bug was filed). Does that make sense? Can anyone confirm?"

Confirmed. This is exactly my situation. I have never had -proposed enabled, only -backports. The problem still exists for me. I have not tried to enable -proposed in an effort to fix it.

Savvas Radevic (medigeek) wrote :

Guys, the -proposed are proposed updates, if they work, they go as official updates in -updates.
If you choose to add proposed in your repos you can choose to update only the gnome desktop related files, log out and log in again, and you'll see that it's fixed. You don't have to update everything. On the other hand, you can be a bit patient and wait for the fix to be officially released in -updates, then try it out.
There's no cpu spike on my dual core processor after the update in -proposed (compare it with the GIMP loading on the attached screenshot)

JainMJ (jainmjo) wrote :

I had the same problem and i couldn't set the wallpapers even with keyboard. The wallpaper changes. I can see the new wallpaper at startup. But after startup, only background is visible. No wallpaper. I updated gnome-desktop-data and libgnome-desktop-2. Now I can select wallpaper with mouse. But has no effect.

Savvas Radevic (medigeek) wrote :

Jain, do this in gnome terminal: apt-cache policy gnome-desktop-data

The updated version should say:
"gnome-desktop-data: Installed: 1:2.22.2-0ubuntu3"

FrenchNux (christophe-pauc) wrote :

CPU and memory 50% used and impossible to change wallpaper by clicking

I had the same problem and i installed gnome-desktop-data 1:2.22.2-0ubuntu3.

JainMJ (jainmjo) wrote :

ya. It says:
"gnome-desktop-data: Installed: 1:2.22.2-0ubuntu3"

There is no cpu spike now. But cannot set wallpaper; neither by clicking nor arrow keys.

Michael Rooney (mrooney) wrote :

I updated to 1:2.22.2-0ubuntu3 but still notice the high CPU/lag issue, particularly when using the mouse to select.

Sebastien Bacher (seb128) wrote :

> I updated to 1:2.22.2-0ubuntu3 but still notice the high CPU/lag issue, particularly when using the mouse to select.

does downgrading to the hardy version fix the issue?

Michael Rooney (mrooney) wrote :

> does downgrading to the hardy version fix the issue?

I noticed the issue in the standard hardy version in the first place which prompted me to try the version in -proposed, but both act in the same CPU intensive and sluggish manner, especially when using the mouse.

Sebastien Bacher (seb128) wrote :

the issue you are having is a different one then, could be bug #147045

Hi,

This problem happens on my Thinkpad R61 too. I'm using Ubuntu Hardy fully updated.

Thanks.

confirmed.
installing gnome-desktop-data 1:2.22.2-0ubuntu3 does not change the behavior of gnome-appearance-properties - still high ~80% cpu usage and difficulties with selecting different wallpaper

JainMJ (jainmjo) wrote :

there is no cpu/memory spike. I can change desktop background color. But wallpaper is not showing.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gnome-desktop:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Please apply the fix to Intrepid ASAP.

Changed in gnome-desktop:
milestone: none → intrepid-alpha-1
status: Confirmed → Fix Committed
Demosthenes (demosthenes) wrote :

I have updated to the latest Gnome-Desktop-Data package as suggested above with no luck - CPU spike disappears after close however. What information is required from me to assist diagnosis?

Martin G Miller (mgmiller) wrote :

I have updated to the latest packages from Hardy Updates and the bug is resolved on my system. It worked without logging off and back on. I also tried logging off and on and the bug remains resolved. Mouse changes wallpapers as expected. Thank You.

Michael Rooney (mrooney) wrote :

Since there has been a lot of discussion regarding the status of this, I just want to confirm that the latest fix downloaded earlier today fixed the issue on my end.

Magnus S (magnuss) wrote :

I had some problems a few days ago with the gnome-desktop-data 1:2.22.2-0ubuntu3 from -proposed which didn't work. However, after todays system update the bug is fixed for me.

Thanks
//magnus

Savvas Radevic (medigeek) wrote :

That's odd, the package didn't change, maybe you didn't upgrade all
the gnome-related packages
Anyway, thanks for the fix! :)

Steve Langasek (vorlon) on 2008-06-27
Changed in gnome-desktop:
milestone: intrepid-alpha-1 → intrepid-alpha-2
Sebastien Bacher (seb128) wrote :

there is a newer version in intrepid now

Changed in gnome-desktop:
status: Fix Committed → Fix Released

I've applied all fixes and still experience the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers