Wacom tablet not recognized in Settings > Devices

Bug #1753525 reported by buggycub on 2018-03-05
This bug affects 19 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)

Bug Description

I have the same problem with Ubuntu 18.04 developing branch as described for Ubuntu 16.04 in
I can draw, e.g., with tuxpaint, I can use stylus and graphic tablet "Wacom Intuos Art Black Pen + Touch S" like a touchpad with mouse (left, muddle, right button), but I cannot access the pad via Settings > Devices > Wacom Tablet: "Stylus not recognized". So, no reprogramming of stylus buttons and tablet buttons :(

Hopefully this will be resolved till the final version of 18.04 in April?

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-control-center 1:3.26.2-0ubuntu5
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Mar 5 16:48:48 2018
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2018-03-05 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180304)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

buggycub (smusnmr) wrote :
buggycub (smusnmr) wrote :

My solution, sort of:

sudo apt update
sudo apt install ubuntu-gnome-desktop
sudo apt install --reinstall gnome-control-center

Reboot, login into 'Gnome on xorg', Wacom now programmable with Settings > Devices > Wacom Tablet

Log out, login on 'Ubuntu', now Ubuntu does it too :)

Jason Gerecke (killertofu) wrote :

The "stylus not recognized" part of this issue is almost certainly https://bugzilla.gnome.org/show_bug.cgi?id=793499.

No access to the pad device on the other hand is not an issue I'm familiar with. The old unity-control-center bug that OP linked do was due to an issue with GNOME not being compatible with tablets whose pens don't have an eraser. That issue was fixed in GNOME 3.16, however, and shouldn't be present in the current version of the gnome-control-center.

I do see a reference to somebody else having similar pad issues upstream at https://bugzilla.gnome.org/show_bug.cgi?id=789287 but it doesn't look like anyone has begun to dig into the bug. My own (Arch Linux) system doesn't exhibit the pad issue with an Intuos Art Medium (CTH-690) and GNOME 3.26, for what its worth.


linuxcub: You should have both a "Stylus" and "Tablet" button at the top of the Wacom control panel, next to "Test your Settings". The "Stylus" button shows "Stylus not Recognized", but what message appears when the "Tablet" button is pressed? Or are the buttons missing? That might give a place to start digging...

buggycub (smusnmr) wrote :

@Jason Gerecke

> You should have both a "Stylus" and "Tablet" button at the top of the Wacom control panel

No, I don't! My Wacom looks like this

"About Wacom Intuos"

" >> Assign Settings in Wacom Tablet Properties" shows the stylus with its two buttons

The tablet has 4 buttons, at each top corner, two on the left, two on the right. If I press one of teh bottons, a menu appears, like "Show onscreen help, assign keystroke, etc."

I'll attach screenshots from my Ubuntu with the next post.

buggycub (smusnmr) wrote :

@Jason Gerecke

Here are the screenshots from my Ubuntu 18.04:

buggycub (smusnmr) wrote :

Programming the tablet

buggycub (smusnmr) wrote :

Map tablet buttons

buggycub (smusnmr) wrote :

Tablet buttons menu that opens when button is klicked.

Keep in mind, this all fuctioned only after I had my Bionic gnome-ized as described.

Ok, bye for now

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
buggycub (smusnmr) wrote :

@Sebastien Bacher:

Please help! At https://bugzilla.gnome.org/enter_bug.cgi I am presented with these options to start with:
 All: Show all products

Bindings: Bindings part of the GNOME 3 set (C++, Java, Javascript, Perl, Python, etc)
Core: Core Desktop functionality software part of the GNOME 3 set
Platform: Low-level software part of the GNOME 3 set (Platform and Extended Platform)
Infrastructure: Infrastructure related queries (servers, services hosted, websites, Bugzilla, release engineering)
Applications: Applications that are not part of GNOME 3 Core or GNOME 3 (Extended) Platform
Other: Other software not covered by the other classifications
Deprecated: Deprecated and unmaintained software

Which option should I choose in my case? I am completely helpless! I never used this website before!



buggycub (smusnmr) wrote :

Edit: to be more precise on my tablet:

"Wacom CTH-450/K Intuos Art Black Pen & Touch S"

buggycub (smusnmr) wrote :

Here is the link: https://bugzilla.gnome.org/show_bug.cgi?id=794159

However, is it really a Gnome bug? After all, after I installed ubuntu-gnome-desktop it was ok. Sounds, like the missing ubuntu-gnome-desktop did it, didn't it?

buggycub (smusnmr) wrote :

It is not a Gnome issue, it is an Ubuntu issue: https://bugzilla.gnome.org/show_bug.cgi?id=794159#c1

buggycub (smusnmr) wrote :

Usually I use my Wacom Intuos CTH-450/K with Gimp. Now I tested it with Krita. Seems that all functions of the board are supported, including varying line width with varying stylus pressure. But only after I installed gnome, see above https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1753525/comments/2
This will still give the developers something to work till April.

buggycub (smusnmr) wrote :

Correction: my graphics tablet is a > CTH-490/K <

Jason Gerecke (killertofu) wrote :

linuxcub, my apologies for not replying sooner -- I don't think I got a notification of your messages for some reason...

Its odd that installing/reinstalling portions of Ubuntu seem to fix the issue. It looks like the Bionic beta only relased IOSs for Kubuntu, Budgie, Kylin, MATE, and Xubuntu. I wonder if their GNOME flavor is still in development and was updated to a broken version when you installed. Force-installing the ubuntu-gnome-desktop and gnome-control-center packages may have brought down a fixed version? Without an official GNOME ISO for me to test, it'll be hard for me to replicate your issue to see if its still present.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
en (b21enu) wrote :

The Wacom Intuos S Tablet (Model: ctl 4100) is not recognised in the wacom section in the control center, though basic mouse functionality works.

en (b21enu) wrote :

The Wacom Intuos S Tablet (Model: ctl 4100) is not recognised in the wacom section in the gnome control center on ubuntu bionic, though basic mouse functionality works.

en (b21enu) wrote :

By the linux kernel (again on ubuntu bionic) it's recognised as:
Bus 001 Device 002: ID 056a:0374 Wacom Co., Ltd

en (b21enu) wrote :

and by
Name=Wacom Serial Tablet WACf004


Luis Vásquez Rugama (lvaskz) wrote :

Hi, I am in Ubuntu 18.04 release, my wacom model is Wacom Cintiq 15x PL-550, I can use the tablet, but I can not calibrate, set buttons stylus, etc.

The tablet is not recongnized.

When will be fix it?

Carsten Aevermann (4-carsten) wrote :

Same with me, on two different CPUs (old 2009 macbook and an amd desktop) both running 18.04.

Linux MyCPU 4.15.0-22-generic #24-Ubuntu SMP Wed May 16 12:15:17 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Also tried the reinstall thingy as suggested in post#2 with no difference.


Bus 008 Device 002: ID 056a:00dd Wacom Co., Ltd Bamboo Pen (CTL-470)
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

..shows the tablet, it works like a mouse but no pressure nor access through control panel

amonpaike (amonpaike) wrote :

every new version of ubuntu you make me cry with this damn graphic tablet.
please update the list of graphics tablets

my tablet is not recognized by the settings panel
Bus 005 Device 003: ID 056a:00d4 Wacom Co., Ltd Bamboo Pen (CTL-460)

EricDHH (ericdhh) wrote :

Ubuntu 18.04.1

The internal wacom on my thinkpad X200 tablet is also ditched and does not work. But did up to uuntu 17.10.

Serge Gavrilov (serge-pdmi) wrote :

The same problem: 056a:00d1 Wacom Co., Ltd Bamboo Pen & Touch (CTH-460-DE)

Serge Gavrilov (serge-pdmi) wrote :

And the same with ID 056a:00d4 Wacom Co., Ltd Bamboo Pen (CTL-460)

Serge Gavrilov (serge-pdmi) wrote :

In both cases the tablets are recognized, but not styluses

Serge Gavrilov (serge-pdmi) wrote :

I have check this with latest installation image of 18.10. The situation is even worse there. Attempt to detect a stylus crashes the ubuntu session in 18.10.

Serge Gavrilov (serge-pdmi) wrote :

This is definitely not a ubuntu specific bug.


056a:00d1 Wacom Co., Ltd Bamboo Pen & Touch (CTH-460-DE)
056a:00d1 Wacom Co., Ltd Bamboo Pen & Touch (CTH-460-DE)

it reproducible also with Gentoo ~amd64 (based on gnome 3.24) as well as 18.04.

At the same time I have Lenovo Yoga 2nd gen laptop with integrated wacom device and the stylus is recognizable there (with 18.04).

It looks like this is a linuxwacom bug related with some models of tablets.

Serge Gavrilov (serge-pdmi) wrote :

I mean with

ID 056a:00d4 Wacom Co., Ltd Bamboo Pen (CTL-460)
056a:00d1 Wacom Co., Ltd Bamboo Pen & Touch (CTH-460-DE)

mika (mic-schaller) wrote :

since upgrade from 16.04 to 18.04 I have this issue.

gnome desktop on xorg

intuos CTH-480M-S

on startup tablet is in absolute mode, i have to open settings wacom tablet -> stylus not recognised;

if just clicking on tablet tab button, the tablet switches back to the set setting (relative).

I had restarted with an older kernel & it was the same so I'd thought it is a ubuntu issue related top 18.04. I 'll double check that though.

Will Ethridge (gamerminstrel) wrote :

I just attempted the upgrade from 16.04 to 18.04 and have this issue as well.

Default Ubuntu desktop (gnome desktop on xorg)

Cintiq Companion Hybrid 13HD (DTH-A1300)

Since the update, I have no touch nor stylus input, nor are the hardware buttons detected when pressed.
In Gnome control center's Wacom Settings Applet, no stylus is detected, but the tablet is detected.

I cannot remap inputs or calibrate the stylus because they are not detected.

I am the same problem that

My device is ctl-4100-s no styp¡lus is detected, but tablet is detected.
Mi SO is Debian 9

virgosun (hdefendme) wrote :

same here Ubuntu 18.04, Wacom ISDv4 104, builtin i2c tablet work but no stylus setting

My CTL-4100 just works on propperties setting on Unity

Sebastien Bacher (seb128) wrote :

if that's still an issue for some configs on Ubuntu (GNOME) 18.04/18.10 the best would be to report it upstream on https://gitlab.gnome.org/GNOME/gnome-control-center/issues

e-fernbach (e-fernbach) wrote :

on Jul 16 2020 I still have the same problem. The pad is perfectly recognized when using terminal commands but not detected in the device dialog under settings>devices>Wacom Tablet. When I hit Test your settings I can input but have to use high pressure. I did install the most recent drivers from source following this link https://linuxwacom.github.io/ , installing input wacom from source and building the Xdriver. Installing input wacom went without error messages and installing the Xdriver gave the message that the installed driver is already the newest one. When I try to use the tablet with Xournal it sometimes works and sometime doesn't rebooting usually fixes the "not working". "Not working" symptoms are: when drawing a line it gets interrupted, the pressure has to be extremely high, the cursor jumps around wildly, switching between eraser and pen is not controllable, the cursor can not be mapped to a specific monitor. I am on Ubuntu 18.04.3 The tablet is a Wacom Intuos BT S The output from xsetwacom --get "Wacom Co.,Ltd. Intuos BT S stylus" all is:
Option "Area" "0 0 15200 9500"
Button: Actions are not supported by xorg.conf. Try shell format (-s) instead.
Button: Actions are not supported by xorg.conf. Try shell format (-s) instead.
Button: Actions are not supported by xorg.conf. Try shell format (-s) instead.
Button: Actions are not supported by xorg.conf. Try shell format (-s) instead.
Option "DebugLevel" "0"
Option "CommonDBG" "0"
Option "Suppress" "2"
Option "RawSample" "4"
Option "PressCurve" "0 0 100 100"
Option "Mode" "Absolute"
Option "TPCButton" "off"
Option "Touch" "off"
Property 'Wacom Hardware Touch Switch' does not exist on device.
Option "Gesture" "off"
Option "ZoomDistance" "0"
Option "ScrollDistance" "0"
Option "TapTime" "250"
Property 'Wacom Proximity Threshold' does not exist on device.
Option "Rotate" "none"
Property 'Wacom Wheel Buttons' does not exist on device.
Property 'Wacom Wheel Buttons' does not exist on device.
Property 'Wacom Wheel Buttons' does not exist on device.
Property 'Wacom Wheel Buttons' does not exist on device.
Property 'Wacom Wheel Buttons' does not exist on device.
Property 'Wacom Wheel Buttons' does not exist on device.
Property 'Wacom Strip Buttons' does not exist on device.
Property 'Wacom Strip Buttons' does not exist on device.
Property 'Wacom Strip Buttons' does not exist on device.
Property 'Wacom Strip Buttons' does not exist on device.
Option "Threshold" "26"
Option "Serial" "0"
Option "PressureRecalibration" "on"
Option "PanScrollThreshold" "1300"

anxiety scroll (anxietyscroll) wrote :

Reporting the bug from ubuntu 18.04.4 LTS. The tablet works and the pointer moves as expected but the settings->devices->wacom configuration does not recognize the tablet. Also, I report this same tablet and same computer was working properly before, but not sure if it was on 18.04 or 19.something. The thing is it was working well before doing a clean reinstall of 18.04.4

anxiety scroll (anxietyscroll) wrote :

Solved after deleting custom installation of lib-wacom and then installing xserver-xorg-input-wacom, libwacom2, and libwacom-common. Showing on the settings page after rebooting.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.