Intuos Art / Intuos Draw 2015 isn't detected by the wacom properties window

Bug #1575887 reported by Ivan on 2016-04-27
136
This bug affects 28 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
Medium
Unassigned

Bug Description

The section in system configuration called "Wacom Tablet" isn't detecting my Wacom Intuos Art Small 2015, i'm using Ubuntu 16.04 with 4.4 kernel, i installed the drivers of linux wacom but the issue continue.I expected that ubuntu will detect the tablet and the wacom properties setting will work.

INFO:
Description: Ubuntu 16.04 LTS
Release: 16.04

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1575887/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
tags: added: xenial
affects: ubuntu → xorg (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Jason Gerecke (killertofu) wrote :

Bug is in unity-control-center. Upstream gnome-control-center had an issue with not displaying tablets that had no eraser, such as the newest generation of Wacom's Intuos tablets: "Intuos Draw" and "Intuos Art"(models CTL-490, CTH-490, CTL-690, CTH-690). The issue appears to have been fixed for GNOME 3.16 -- the upstream bug report can be found at https://bugzilla.gnome.org/show_bug.cgi?id=746117

See also the bug filed at the linuxwacom project: https://sourceforge.net/p/linuxwacom/bugs/320/

affects: xorg (Ubuntu) → unity-control-center (Ubuntu)
summary: - Intuos Art 2015 isn't detected by the wacom propierties window
+ Intuos Art / Intuos Draw 2015 isn't detected by the wacom propierties
+ window
summary: - Intuos Art / Intuos Draw 2015 isn't detected by the wacom propierties
+ Intuos Art / Intuos Draw 2015 isn't detected by the wacom properties
window
Changed in unity-control-center (Ubuntu):
importance: Undecided → Medium
Ivan (ivanx507) wrote :

I tried with the GNOME 3.20, the problem still active, the tablet isn't recognized by the gnome-control-center and unity-control-center.

Ivan (ivanx507) wrote :

Well the tablet works with gnome 3.20, but in ubuntu the problem persist.
I didn't have the xf86-input-wacom installed in antergos :p so i thinked that gnome 3.20 wasn't detecting the tablet. I installed and it works!!! in Gnome 3.20.
So the problem is only in the unity-control-center.
Sorry for the confusion.
xP

Ivan (ivanx507) wrote :

I watched the source code of gnome and unity control center, in testwacom.c i found that the only difference between unity and gnome its that unity has a eraser word in one of the functions of the code, its easy to see only compare the two codes, i don't if is this the solution but maybe can, but i prefer like you see it and try it, you now more about this than me.

Enno Gotthold (schoolguy) wrote :

I am also affected. My plain Ubuntu does not recognize the tablet in the system settings, but I can use it. Same is in Kubuntu, with the little difference that I am able to see it as a joystick.

Enno Gotthold (schoolguy) wrote :

Sry forgot to mention that I have the CTH-490. Sensitivity works in GIMP fine.

Eugenio Perea (eugenio-perea) wrote :

I have the same issue: the tablet works but is not detected by System Settings. Is there a workaround, should I wait until the bug is fixed, or do something else?
I've updated the kernel driver and the X driver, but I'm holding off installing libwacom until I understand what is the best course of action.

Jason Gerecke (killertofu) wrote :

Eugenio, the three workarounds I'm aware of are:

  * Use the GNOME desktop environment instead of Unity.
  * Use the command-line based `xsetwacom` utility instead of the GUI.
  * Use a different tablet.

I suppose could try getting in touch with the Ubuntu team (e.g. through IRC) to make sure they're both aware that this bug exists and that it has been fixed in upstream GNOME for a while. Recent news is that Ubuntu will be switching to using GNOME instead of Unity in 2018, so even if this bug never gets fixed it should be less visible as fewer people use Unity...

Vaclav Cermak (disnel) wrote :

It is the same with Intuos 2.

I also have this issue, using CTL-490 tablet is not recognised in system settings, but works fine for the most part. Have been using it with MyPaint and no issues with sensitivity. Only annoying thing is that the buttons on the tablet do not seem to work at all, and I am not certain on how to configure this. But hopefully, when we migrate to Gnome over Unity, this will no longer be an issue.

linuxcub (smusnmr) wrote :

I have the same problem with Ubuntu 18.04 developing branch. I can draw, e.g., with tuxpaint, I can use stylus and graphic tablet "Wacom Intuos Art Black Pen + Touch S" like a touchpad with mouse (left, muddle, right button), but I cannot access the pad via Settings > Devices > Wacom Tablet: "Stylus not recognized". So, no reprogramming of stylus buttons and tablet buttons :(

Hopefully this will be resolved till the final version of 18.04 in April?

Jason Gerecke (killertofu) wrote :

linuxcub, the "Stylus not recognized" is actually a different issue than the one described here. The upstream bug filed for that particular issue can be found at https://bugzilla.gnome.org/show_bug.cgi?id=793499

You should file a new issue against Ubuntu 18.04 (specifically the ) which references the GNOME bug I linked to. This will ensure the Ubuntu developers can track the bug and hopefully work with GNOME upstream to get it fixed before the April release. The bug likely affects *all* lower-end tablets (i.e. non-Pro Intuos and Bamboo) based on the diagnosis.

It would be appreciated if you could give me a link to the bug you end up filing against 18.04. I'd like to subscribe to it for updates.

linuxcub (smusnmr) wrote :

Jason,

here is the link: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1753525

Hopefully some other uses with Wacom tablets try Bionic. I doubt it, it is a development branch.

The strange thing with Bionic is, the gnome-control-center was already installed in my version (daily build plus all updates), but this did not help as it did with my Ubuntu 16.04.

Please note that not only the stylus is not recognized but also the 4 buttons could not be programmed, like they could be programmed in my gnome-modified Ubuntu 16.04.

As an aside, my Debian - Debian GNU/Linux 9 (stretch) 64-bit Gnome 3.22.2 - does these things out-of-the-box, no trickery needed.

Thanks,

Siggi

linuxcub (smusnmr) wrote :

This helped with my Wacom CTH-490/K both with Ubuntu 16.04 and 18.04:

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1753525

viz.,
-----------------------
sudo apt update
sudo apt install ubuntu-gnome-desktop
sudo apt install --reinstall gnome-control-center

Reboot, login into 'Gnome on xorg', Wacom stylus and tablet now recognized

Log out, login on 'Ubuntu', now Ubuntu does it too :)
-----------------------

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.