Gnome's Activities Overview search is always in English, regardless of the system language

Bug #1491787 reported by sojusnik on 2015-09-03
112
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
Ubuntu Translations
Undecided
Unassigned
gnome-control-center
Fix Released
Medium
gettext (Ubuntu)
Low
Unassigned
Artful
Undecided
Unassigned
gnome-control-center (Ubuntu)
Low
Iain Lane
Artful
Undecided
Unassigned
gnome-shell (Ubuntu)
Low
Unassigned
Artful
Undecided
Unassigned

Bug Description

[ Description ]

In GNOME's activities overview, search entries from gnome-control-center aren't translated.

[ Fix ]

setlocale() wasn't being called until after the model that supplies search results was constructed. We fix the initialisation code to run slightly later, after setlocale() has been called.

[ QA ]

1. Open a session in a non-English locale which has gnome-control-center translations (French works).
2. Hit super and type an "a"
3. There should be some results from "Settings". They should be in French (or whatever language you're using).

[ Regression potential ]

If we misunderstood when the initialisation phases in GtkApplication ran then there could be a race condition. You'd see that manifesting as either a crash in the search provider or no results being returned. Make sure there aren't crahes reported in errors.u.c.

[ Original description ]

Hey,

I'm referring to this issue on AskUbuntu: http://askubuntu.com/questions/600656/change-language-of-the-gnome-shell-overview

On my Ubuntu Gnome 15.04 system all entries from the gnome-control-center are shown in English in the Gnome-Shell overview (see screenshot in the above mentioned link), even though my system language is German. The entries in the gnome-control-center itself are however in German.

Is this due to a bug or missing translations?

Gunnar Hjalmarsson (gunnarhj) wrote :

Run these commands on my 15.04 machine:

$ LANGUAGE=de
$ echo $(gettext -d gnome-control-center-2.0 Details)
Informationen
$ echo $(gettext -d gnome-control-center-2.0 'View information about your system')
Informationen über Ihr System anzeigen
$

Looks like this is a bug in gnome-shell(?) rather than a translation issue.

affects: ubuntu-translations → gnome-shell (Ubuntu)
sojusnik (sojusnik) wrote :

So how to proceed next then?

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2015-09-03 16:20, sojusnik wrote:
> So how to proceed next then?

Two options: Either dig into the source of the applicable package(s) and write a patch, or wait and hope that a GNOME developer take a closer look soon.

Tim Lunn (darkxst) on 2015-09-03
Changed in ubuntu-gnome:
milestone: none → wily-ppa
Tim Lunn (darkxst) wrote :

sojusnik, does this affect any of the other search providers or only gnome-control-center?

Changed in ubuntu-gnome:
milestone: wily-ppa → wily
sojusnik (sojusnik) wrote :

It seems to affect only gnome-control-center.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
ericc (eric-cheminot) wrote :

I have the same problem with current 15.10 (still beta), even though with French (see attached screenshot).

sojusnik (sojusnik) wrote :

Problem persists even after a clean install of Ubuntu 15.10.

Tim Lunn (darkxst) on 2016-01-04
Changed in ubuntu-gnome:
milestone: wily → xenial
sojusnik (sojusnik) wrote :

Are they still in English even in the most recent 16.04 Ubuntu version?

Yes. The bug is still out there.

2016-04-20 13:55 GMT+02:00 sojusnik <email address hidden>:

> Are they still in English even in the most recent 16.04 Ubuntu version?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1491787
>
> Title:
> System language isn't applied to gnome-control-center in Gnome-Shell
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-gnome/+bug/1491787/+subscriptions
>

Hadrien Dussuel (dbkblk) wrote :

Yes, the bug is still out there.

I also can confirm that the bug is still alive...

sojusnik (sojusnik) wrote :

This bug is still present in Ubuntu 16.04 with Gnome 3.18.

sojusnik (sojusnik) wrote :

Cmon, this is still present in 16.10. Please fix this.

sojusnik (sojusnik) wrote :

Let's hope, that the devs will finally fix this, when Gnome-Shell will become the default DE in Ubuntu *fingers crossed*

tags: added: xenial yakkety
tags: added: zesty
Daniel van Vugt (vanvugt) wrote :

Note that 'Settings' is two different apps depending on which shell you're using:

Unity7: unity-control-center
Gnome Shell: gnome-control-center

affects: gnome-shell (Ubuntu) → gnome-control-center (Ubuntu)
sojusnik (sojusnik) wrote :

Still in English in Ubuntu 17.10 ...

Mauro Sassi (maurosassi82) wrote :

I also experience the same bug in freshly installed Artful (17.10). Italian locale is set but items from settings are displayed in english and application search seems to be based on english keywords.

tags: added: artful
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
sojusnik (sojusnik) wrote :

@Sebastien Bacher
Why only "low"? It obviously affects every non-English user and seems easy to fix. Imho, it should be at least medium, if not high.

Mauro Sassi (maurosassi82) wrote :

I agree. Although this is not a critical bug and I could decide to switch to an English locale, it still is a major limitation for non-English speaking users ruining their Gnome shell workflow. Just consider, as an example the attached screenshots of "Impostazioni" window ("Settings"). If one wants to quickly open the "Sfondo" (background) tab using <SUPER>+string through the search bar he has to remember to digit "background" to obtain any results. The same applies to "Energia" (digit "power").

Sebastien Bacher (seb128) wrote :

It's a bug indeed but it's not really that important, most users go to the settings to browse the categories and don't go to the overview to look for a specific section. Would be nice to get fixed still though

AsciiWolf (asciiwolf) wrote :

I think this bug definitely deserves bigger priority. It can be a small issue, but it makes Ubuntu look bad in the eyes of any regular (non-English) user.

I totally agree with AsciiWolf, this is this kind of polish that made me to
give up on Ubuntu Gnome in the past.

2017-10-31 14:34 GMT+01:00 AsciiWolf <email address hidden>:

> I think this bug definitely deserves bigger priority. It can be a small
> issue, but it makes Ubuntu look bad in the eyes of any regular (non-
> English) user.
>
> ** Also affects: ubuntu-translations
> Importance: Undecided
> Status: New
>
> ** Also affects: gnome-shell (Ubuntu)
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1491787
>
> Title:
> System language isn't applied to gnome-control-center in Gnome-Shell
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-gnome/+bug/1491787/+subscriptions
>

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Mauro Sassi (maurosassi82) wrote :

My personal opinion is that the bug nature, its details and effect on gnome-shell are clearly outlined now. I am not a developer and certainly not in the position to evaluate a bug importance or its priority. Unless a patch is proposed, simple complaining does not help. Likely, as more users move to GNOME, the bug would gather higher priority as an effect of more people being affected.

summary: - System language isn't applied to gnome-control-center in Gnome-Shell
+ Gnome's Activities Overview search is always in English, regardless of
+ the system language
coolspot (coolspot) wrote :

Same problem for me for french traduction.

http://image.noelshack.com/fichiers/2017/44/3/1509546937-bug-ko.png

It's not critical bug but I hope it will be fixed more quick now than ubuntu gnome and ubuntu are same team now.

Renê Barbosa (renebarbosa) wrote :

+1 Ubuntu 16.04.3 and Brazilian Portuguese Traduction.

Dominik (dominalien) wrote :

Same bug in Ubuntu 17.10, system set to Polish, settings are searched in English.

AsciiWolf (asciiwolf) on 2017-11-09
tags: added: bionic
Mauro Sassi (maurosassi82) wrote :

Today I was testing the live session of Fedora 26 (Gnome 3.24) and this bug is not present there. After setting the localization and restarting the session, settings and search are translated correctly as supposed. I hope this could help to address the problem.

AsciiWolf (asciiwolf) wrote :

This is probably not an upstream GNOME bug, it's most likely a bug in the gettext Ubuntu package.

AsciiWolf (asciiwolf) on 2017-11-23
tags: added: l10n
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2017-11-20 12:10, AsciiWolf wrote:
> ... it's most likely a bug in the gettext Ubuntu package.

Don't think so. Please see comment #1.

Sebastien Bacher (seb128) wrote :

it's rather an issue in the gnome-control-center shell provider code not dealing with the Ubuntu way of using gettext for desktop file instead inline translations

AsciiWolf (asciiwolf) wrote :

Ah. So, it's an upstream or Ubuntu issue?

Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed
AsciiWolf (asciiwolf) wrote :

Piotr Drąg's comment from the upstream bug report: It works in every distribution except Ubuntu, which doesn’t put translations directly in .desktop files (what it does instead, I do not know). So either this is an upstream bug and g-c-c’s search provider needs to deal with Ubuntu’s special case, or a downstream bug and Ubuntu needs to start using standard .desktop files like everyone else.

Sebastien Bacher (seb128) wrote :

Iain wrote a patch on the upstream bug

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: Confirmed → In Progress
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
Changed in gettext (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Changed in gnome-control-center:
status: Confirmed → Fix Released
Iain Lane (laney) on 2017-12-11
description: updated
Iain Lane (laney) wrote :

Uploaded to A (needs manually accepting) + B. Thanks!

Changed in gettext (Ubuntu Artful):
status: New → Invalid
Changed in gnome-shell (Ubuntu Artful):
status: New → Invalid
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
Changed in gnome-control-center (Ubuntu Artful):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.26.2-0ubuntu2

---------------
gnome-control-center (1:3.26.2-0ubuntu2) bionic; urgency=medium

  * debian/patches/search-provider-locale.patch: Backport patch from upstream
    to set up the search provider such that setlocale() has been called early
    enough for results to be translated. (LP: #1491787)

 -- Iain Lane <email address hidden> Mon, 11 Dec 2017 14:21:54 +0000

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released

Hello sojusnik, or anyone else affected,

Accepted gnome-control-center into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.26.2-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful

SRU verification for Artful:
I have reproduced the problem with gnome-control-center 1:3.26.2-0ubuntu0.1 in artful-updates and have verified that the version of gnome-control-center 1:3.26.2-0ubuntu0.2 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Iain Lane (laney) on 2017-12-23
Changed in gnome-control-center (Ubuntu Artful):
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed

The verification of the Stable Release Update for gnome-control-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.26.2-0ubuntu0.2

---------------
gnome-control-center (1:3.26.2-0ubuntu0.2) artful; urgency=medium

  * debian/patches/search-provider-locale.patch: Backport patch from upstream
    to set up the search provider such that setlocale() has been called early
    enough for results to be translated. (LP: #1491787)

 -- Iain Lane <email address hidden> Mon, 11 Dec 2017 12:07:01 +0000

Changed in gnome-control-center (Ubuntu Artful):
status: Fix Committed → Fix Released
AsciiWolf (asciiwolf) on 2018-02-01
Changed in ubuntu-translations:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.