Ubuntu

In System Settings preference tool/keyboard layouts page automaticaly wrong language selectedGNOME

Reported by Attila Hammer on 2012-08-10
86
This bug affects 27 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Unknown
Medium
Baltix
Medium
Mantas Kriaučiūnas
gnome-control-center (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

[Impact]
GNOME/Cinnamon users that use the "keyboard layout" preference pane, are presented with a list of languages in which none of them is selected. When moving to the next tab, the first in the list is selected, which causes the whole system to switch to Chinese/Bengali/Whichever language was alphabetically first. This is saved immediately, but only applied after logging out and in again.

[Test case]
In a GNOME session of a machine with some alphabetically lower than English language pack installed (e.g. language-pack-aa), open "System Settings", select the "Keyboard Layout" pane, then move to the next tab and back.

If the bug is present, the first language in the list will be selected. If it's not, the current language will be selected.

[Regression potential]
The fix consists of uncommenting a small piece of code that adds a new entry for the current language and marks it as selected. This means that the current language is duplicated, however, the current fix considers preferable to have a double entry for the current language than cause the user's session to be suddenly changed to Chinese.

------------------------------------------------
[Original description]

Dear Developers,

I using Ubuntu 12.04 with GNOME3 fallback session.
I found a bug with System settings preference tooll the Keyboard Layouts preference pane:
If launch System settings, choosing keyboard layouts preference pane, the first awailable page tab is the language page tab. When I moving the dialog with TAB and SHIFT+TAB key, the language tree table wrong language are default selected, not the current used language.
Reproducation steps, I verified with Ubuntu 12.04 daily live CD in GNOME3 fallback session:
1. Boot Ubuntu 12.04 daily live CD.
2. In the language list select a non english language.
3. Click try Ubuntu button.
4. Enable the universe and multiverse repositoryes, and install gnome-session-fallback package.
5. Log out, and log in with Gnome Classic (no effects) session.
6. Launch System settings application.
7. Click keyboard layouts.
8. Press two TAB key, and you will be see the default selected language is not equals your prewious selected language.
9. For example jump the keyboard layouts page with CTRL+ALT+PAGEUP key combination without you correct the wrong selected language.
10. Click All settings button without you change the automated selected language. Log out, and log in again. Your system language will be changing.

In Unity and Unity 2d this problem not happening, because in Keyboard Layout preference tool the language page tab are disabled.

I sending six screenshot with showing this problem real happening. First screen shot shoving original language output (hungarian), other screen shots shoving the language changed with English the next login. Installed Ubuntu 12.04 system I reproduced this issue.

Attila

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.4.2-0ubuntu0.4
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic-pae 3.2.24
Uname: Linux 3.2.0-29-generic-pae i686
ApportVersion: 2.0.1-0ubuntu12
Architecture: i386
Date: Fri Aug 10 10:29:31 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120327)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu3
 deja-dup 22.0-0ubuntu2
 gnome-bluetooth 3.2.2-0ubuntu5
 indicator-datetime 0.3.94-0ubuntu2

Attila Hammer (hammera) wrote :

An interesting test result for officialy Ubuntu 12.04 hungarian language
localized CD image:
This CD image containing only hungarian language related language
packages and language support related packages.
If I enable universe and multiverse repositoryes, installed
gnome-session-fallback package, logout and log in with GNOME Classict No
effects session, I experienced following:
If I launch system settings application, choose keyboard layout
preference tool, navigate TAB key the language list table, the selected
language is Chinese. I don't no keyboard layout preference tool how can
detect chinese language, because chinese related language packs are of
course not installed the hungarian 12.04 CD image.
After I activated the all settings button, log out and login back the
GNOME Classic No effects session, language related environments values
is following:
LANG=zh_CN.UTF-8
LANGUAGE=zh_CN:hu:en

This buggy language related setting change resulted a mixed
chinese/hungarian language desktop. For example, in the live system
desktop icon names changed with chinese names, but GNOME application
menu elements are keeped the hungarian menu translations.
This problem happening only when I using keyboard navigation the
keyboard layout preference pane. Unfortunately visualy impaired screen
reader users need using the keyboard navigation to navigate all dialogs.
Before users not land the language list table in keyboard layouts
preference pane unable to switch the layouts page tab with
CTRL+ALT+PAGEUP or CTRL+ALT+PAGEDOWN key combinations. If I click direct
with layouts page with Orca Screen Reader left click flat review command
(this is equals with left mouse button click with layouts page tab), the
problem doesn't happening.

If not have better fix alternative, please disable the language and
formats related page tabs in GNOME Fallback sessions, similar with Unity
and Unity 2d shells.

Attila

Attila Hammer (hammera) wrote :

I opened an upstream report this problem related, sure by sure:
https://bugzilla.gnome.org/show_bug.cgi?id=681682

Attila

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Gunnar Hjalmarsson (gunnarhj) wrote :

The code affecting this resides in the Ubuntu patch 10_keyboard_layout_on_unity.patch, so I don't think this is an upstream issue. In the linked merge proposal I have simplified that patch in a way that ought to address this bug for any Ubuntu based distribution, i.e. including Baltix.

The underlying thought is that as long as the OS/distro is Ubuntu, with e.g. Ubuntu's version of accountsservice, the Keyboard Layout UI should show the Layout tab only.

For the case you want to test, I have requested for my ppa (https://launchpad.net/~gunnarhj/+archive/misc) Precise builds of gnome-language-selector with the simplified 10_keyboard_layout_on_unity.patch. Sooner or later they should be available, but as regards the amd64 build it seems to take several hours.

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Triaged → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Not a Baltix bug, but the Ubuntu fix ought to fix the issue also for Baltix. If not, please feel free to reopen the Baltix task.

Changed in baltix:
status: New → Invalid
Gunnar Hjalmarsson (gunnarhj) wrote :

Correction of comment #4:

s/gnome-language-selector/gnome-control-center/

Attila Hammer (hammera) wrote :

Hy Gunnar,

Your fix working good, but right if disabled following page tabs in
GNOME fallback session the Keyboard Layout preference pane?
"Language", "Formats", "System".
In Ubuntu Precise and Ubuntu Quantal only a bug resulting prewious this
page tabs are presented if I click the Keyboard Layout renamed
preference pane in GNOME Control Center if I using GNOME Fallback
Session? Original upstream GNOME Control Center 3.4.2 and 3.6 the
original preference pane name is Region And Language, and this
preference name renamed I think with Keyboard Layout in Ubuntu level. I
newer understand prewious why not presenting in Unity desktop
environment this wrote page tabs and why presented with other desktop
environment sessions.

Attila

Gunnar Hjalmarsson (gunnarhj) wrote :

Attila,

To be honest, I don't quite understand what your remaining concerns are.

Please note that in Ubuntu, at least up to quantal, you are supposed to use Keyboard Layout only for modifying your keyboard layout settings, while Language Support is there for setting language and regional formats.

Upstream GNOME, OTOH, has Region and Language with all four tabs.

Attila Hammer (hammera) wrote :

Sorry, I known only Precise awailable preference panes in GNOME Control
Center.
In personal category in Precise now awailable following preference panes:
Keyboard Layout, Brightness and lock, private area, appereance, Language
support, Online Accounts, Ubuntu One.
Sorry if not all preference pane names translated right with English.

Attila

Gunnar Hjalmarsson (gunnarhj) wrote :

@Attila
Sounds right to me. Anyway, thanks for letting us know that my proposed fix works for you.

Attila Hammer (hammera) wrote :

What repository you would like future uploading this fix? Only Quantal,
or Precise and Quantal?

Attila

Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Incomplete
Attila Hammer (hammera) wrote :

Why changed this bug status with incomplete? I forgot doed any test?

Attila

Gunnar Hjalmarsson (gunnarhj) wrote :

Attila Hammer wrote:
> What repository you would like future uploading this fix? Only Quantal,
> or Precise and Quantal?

At least Quantal. Changing a stable release such as Precise must follow certain procedures and be considered important enough: https://wiki.ubuntu.com/StableReleaseUpdates

So it's not only what I would like. ;-)

But I have also discussed the proposal on IRC (#ubuntu-desktop), trying to convince a few other developers that it's the best short term solution.

> Why changed this bug status with incomplete?

It's the upstream GNOME part of the bug that has been marked as such; personally I'd say that that part of the bug is invalid. The 'main bug task', i.e. "gnome-control-center (Ubuntu)" is still "In Progress". No need to worry.

Gunnar Hjalmarsson (gunnarhj) wrote :

I have talked with seb128 and jbicha on IRC about my proposed fix of this bug, and they let me know that there is a wish as regards GNOME Remix (https://wiki.ubuntu.com/UbuntuGNOME/ReleaseNotes/12.10Beta) to replace "Language Support" in System Settings with the upstream "Region and Language" capplet. As a measure when considering that possibility I prepared two special variants of the gnome-control-center and gnome-settings-daemon packages, which are available in my PPA at https://launchpad.net/~gunnarhj/+archive/misc

If you install those special variants, you can test how "Region and Language" currently works on a standard Ubuntu 12.10 installation. I assume that the behavior would be the same on a GNOME Remix installation.

The reason why I mention the above in this bug comment is to show that there is a need to include (at least) modified g-c-c and g-s-d packages in the GNOME Remix distribution if you want to exchange "Language Support" for "Region and Language". Consequently, irrespective of which route the people involved in GNOME Remix take, GNOME Remix shouldn't reasonably need to block the proposed solution of this bug.

Attila Hammer (hammera) wrote :

Hy Gunnar,

I added your PPA with my Ubuntu Quantal development system, and install
awailable upgrades your PPA.
After restart I experienced following test results when I launch system
settings preference tool:
1. When I click Language support and goto language list, list correct
focused the actual used system language (hungarian). So, this is working
correct.
If I goto the local formats page, current selected format is right
hungarian.

2. If I click Region and language preference pane, press two TAB key to
goto language list, independent with my actual used language and locale
is hungarian the language list default selected item is english, so this
bug is exist in you doed Region and language pane unfortunately.

Hope this test results help you,

Attila

Gunnar Hjalmarsson (gunnarhj) wrote :

@Attila
Thanks for testing and letting us know about it! What you say confirms my own observations.

AFAIK gnome-control-center's "Region and Language" capplet has not yet been adapted to work smooth on an Ubuntu OS/distro. The "gremix" versions in my PPA contain only a couple of small modifications to make it possible to test "Region and Language" without installing GNOME Remix. (My attempts to install the latter failed.) I suppose that the developers behind GNOME Remix will need to decide how much of buggy behavior and loss of functionality is acceptable to be able to drop language-selector in Quantal.

My personal view is that also GNOME Remix ought to stick to language-selector + the "Keyboard Layout" capplet in Quantal. It's too late in the cycle to do anything else.

Margarita Manterola (marga-9) wrote :

Hi,

I tested the patch and it indeed "solves" the same issue for me. However, the solution is only to not display the Language window at all. What was wrong with the Language window that it didn't pre-select the current selected language? I think that fixing that behaviour would be better, since it doesn't remove functionality as the proposed patch does.

Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Margarita, and thanks for testing!

I'm not sure I understand what you mean by removing functionality. Please note that Language Support is still the Ubuntu tool for language/locales settings, and it's available in System Settings even if you choose to use a GNOME desktop. Considering that, what's the point of showing the Language tab in the capplet named Keyboard Layout? (Who looks for it there?)

Margarita Manterola (marga-9) wrote :

Hi,

Ok, I've looked at it a bit more, and I guess you are right. Do you have any idea if/when this patch is going to get applied to precise?

Changed in baltix:
status: Invalid → Triaged
importance: Undecided → Medium
status: Triaged → In Progress
assignee: nobody → Mantas Kriaučiūnas (mantas)
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2012-10-09 11:36, Margarita Manterola wrote:
> Ok, I've looked at it a bit more, and I guess you are right. Do you
> have any idea if/when this patch is going to get applied to precise?

No, I'm afraid I haven't.

There has been some talk in the #ubuntu-desktop IRC channel; this is from yesterday:
http://people.ubuntu.com/~gunnarhj/jbicha-gunnarhj-gnome-disc-121008.txt

So at this point I can't even tell if it's going to make it into quantal.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Mantas Kriaučiūnas
I noticed that you changed the status of the Baltix task to "In Progress". Does it mean that this kind of change needs to be fixed separately in Baltix? Just asking since I don't know much about the Baltix distribution.

Mantas Kriaučiūnas (mantas) wrote :

Hi Gunnar,

This Gnome-Control-Center problem doesn't need to be fixed separately in
Baltix distro, because Baltix is based on Ubuntu and all Ubuntu fixes automatically go to Baltix GNU/Linux.
I've changed the status of the Baltix task to "In Progress" because I've
copied your patched gnome-control-center packages to Baltix software repository :)

On Tue, Oct 09, 2012, Gunnar Hjalmarsson wrote:
> I noticed that you changed the status of the Baltix task to "In Progress".
> Does it mean that this kind of change needs to be fixed separately in Baltix? Just asking since I don't know much about the Baltix distribution.
>
> Title:
> In System Settings preference tool/keyboard layouts page automaticaly
> wrong language selectedGNOME

--
Labanaktis/Good luck,
Mantas Kriaučiūnas Jabber ID: <email address hidden> GPG ID: 43535BD5
Public organization "Open Source for Lithuania" - www.akl.lt
Geriausios biuro programos verslui ir namams - http://openoffice.lt
Prekyba naujais ir atnaujintais kompiuteriais su Linux OS - http://tinklas.eu
Naudok Baltix GNU/Linux sistemą savo kompiuteryje - http://baltix.lt

On 2012-10-09 20:57, Mantas Kriaučiūnas wrote:
> This Gnome-Control-Center problem doesn't need to be fixed separately
> in Baltix distro, because Baltix is based on Ubuntu and all Ubuntu
> fixes automatically go to Baltix GNU/Linux.

Thanks, that's what I thought.

> I've changed the status of the Baltix task to "In Progress" because
> I've copied your patched gnome-control-center packages to Baltix
> software repository :)

Ok. FYI: The proposed fix won't be included in the Ubuntu 12.10 release, since I failed to convince those who could have approved it.

Mantas Kriaučiūnas (mantas) wrote :

Gunnar, your patched Gnome-Control-Center deb packages are very big size because each package contain unnecessary changelog.gz files (1.5 Mb size) in /usr/share/doc/ , see :

https://launchpad.net/~gunnarhj/+archive/misc/+sourcepub/2701509/+listing-archive-extra

Look at the size of official Ubuntu package and yours:
ubuntu@ubuntu:/var/cache/apt/archives$ ls -lh gnome-control-center_1%3a3.4.2-0ubuntu0.*
 647K Rgs 12 23:04 gnome-control-center_1%3a3.4.2-0ubuntu0.5_i386.deb
 2,1M Spa 9 13:27 gnome-control-center_1%3a3.4.2-0ubuntu0.6~ppa_i386.deb

AFAIK this is because pkgstripfiles command isn't used automatically in PPA builds, now I'm trying one workaround, see https://launchpad.net/~baltix/+archive/oem-archive/

Changed in baltix:
importance: Medium → High
Mantas Kriaučiūnas (mantas) wrote :

Gunnar,

Could you rebuild your patched gnome-control-center_3.4.2-0ubuntu0.6~ppa and remove big upstream changelog file from the sources?
Workaround to enable pkgstripfiles command in my PPA doesn't work (see bug #602579) and I need to release new Ubuntu-based distribution (Baltix) version but now new release can't fit into CD because of 1.5 MB changelog.gz files :(

> your patched Gnome-Control-Center deb packages are very big size because each package contain unnecessary changelog.gz files (1.5 Mb size) in /usr/share/doc/ , see :
>
> https://launchpad.net/~gunnarhj/+archive/misc/+sourcepub/2701509/+listing-archive-extra
>
> Look at the size of official Ubuntu package and yours:
> ubuntu@ubuntu:/var/cache/apt/archives$ ls -lh gnome-control-center_1%3a3.4.2-0ubuntu0.*
 > 647K Rgs 12 23:04 gnome-control-center_1%3a3.4.2-0ubuntu0.5_i386.deb
 > 2,1M Spa 9 13:27 gnome-control-center_1%3a3.4.2-0ubuntu0.6~ppa_i386.deb

Changed in gnome-control-center (Ubuntu Quantal):
importance: Undecided → Low
status: New → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Hello Mantas!

Sure, I could try to build it locally. I don't know if that would make a difference with respect to the unnecessary files, though. Or you could fetch my branch at https://code.launchpad.net/~gunnarhj/gnome-control-center/bug-1035219 and build it yourself.

However, I see another problem with this. If you would distribute a package named e.g. gnome-control-center_3.4.2-0ubuntu0.6~ppa, and since my proposed fix hasn't been accepted, that package would be replaced at next update of the gnome-control-center package, and the fix would get lost.

Mantas Kriaučiūnas (mantas) wrote :

Hello Gunnar,

I've rebuild your packages using higher version number - gnome-control-center_3.4.2-0ubuntu0.6~precise and second time pkgstripfiles command in Baltix oem-archive PPA works fine (see https://launchpad.net/~baltix/+archive/oem-archive and bug #602579), so you can simply copy packages to your PPA: https://launchpad.net/~baltix/+archive/oem-archive/+copy-packages

Gunnar Hjalmarsson (gunnarhj) wrote :

Mantas,
Is it Precise we are discussing?

Wouldn't 3.4.2-0ubuntu0.6~precise be replaced by an SRU with the version number 1:3.4.2-0ubuntu0.6? Or would the missing prefix "1:" prevent that from happening?

OTOH, if you use a higher version number to prevent that SRUs replace the shipped package, it means that you shut yourself off from possibly important updates (unless you fix them manually).

Jeremy Bicha (jbicha) wrote :

Ok, so here's an alternative fix. I uncommented the "Add current language section" of 52_ubuntu_language_list_mods.patch. It creates a cosmetic bug where the current language is listed twice but that is not near as serious as the "Ubuntu is suddenly in Chinese" bug. It is also a much better solution for the Ubuntu GNOME Remix than the earlier proposal.

By the way, before I tested my fix, I got this output on the terminal with the broken language panel:
(gnome-control-center): common-cc-panel-WARNING **: Could not find current language '\x90]\xa7\xe6\xa8\u007f' in the treeview

Changed in gnome-control-center:
status: Incomplete → Unknown
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks, James, for submitting bug 1074838. I marked it as a duplicate of this bug.

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2012-11-03 04:45, Jeremy Bicha wrote:
> Ok, so here's an alternative fix. I uncommented the "Add current
> language section" of 52_ubuntu_language_list_mods.patch.

Sounds to me as if you have found a way (even if it's hackish) to limit the importance of this bug. Will you SRU the fix?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu3

---------------
gnome-control-center (1:3.6.3-0ubuntu3) raring; urgency=low

  * debian/patches/60_ubuntu_nav_bar.patch:
    - restore the navigation bar interface
 -- Sebastien Bacher <email address hidden> Wed, 21 Nov 2012 21:36:46 +0100

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-control-center (Ubuntu):
assignee: Gunnar Hjalmarsson (gunnarhj) → nobody
Sebastien Bacher (seb128) wrote :

the workaround used is:
http://bazaar.launchpad.net/~ubuntu-desktop/gnome-control-center/ubuntu/revision/505

likely worth SRUing, it's not perfect but way better than the bug

Margarita Manterola (marga-9) wrote :

Hi,

The entry shown here by the launchpad editor is actually misleading. It's not patch 60, but patch 52 that fixes the issue, and actually a small change in patch 52. this patch included a section that commented out re-inserting the current language, because the language showed up twice. The fix is to leave this section as it was, so that even though the current language shows up twice, at least one of them is selected.

This was applied in raring. I'm adding patches for precise and quantal that simply reapply the fix. I have tested these patches. They apply cleanly and fix the problem by making an extra selected entry for the current language.

description: updated
Sebastien Bacher (seb128) wrote :

Uploaded to both quantal and precise, thanks Marga!

Changed in gnome-control-center (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Low

Hello Attila, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.4.2-0ubuntu0.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Hy,

I tested the new uploaded version in GNOME3 fallback session:
The fix works good. When I activated in GNOME Control Center the
Keyboard Layouts page and navigate TAB key the language list, the actual
used hungarian language are selected proper the language list. Real
presenting duplicated the current used language (two hungarian languages
have the language list, but if this is not matter, the fix absolute
works properly.

Attila

Brian Murray (brian-murray) wrote :

I'm setting this to verification-done based of Atilla's comment.

tags: added: verification-done-precise
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu0.8

---------------
gnome-control-center (1:3.4.2-0ubuntu0.8) precise-proposed; urgency=low

  * Backported change from Jeremy Bicha in 1:3.6.3-0ubuntu1:
    debian/patches/52_ubuntu_language_list_mods.patch:
    - Don't disable adding current language to the list. While this
      fix shows the current language twice, at least it avoids the
      "Ubuntu suddenly in Chinese" bug (LP: #1035219)
 -- Margarita Manterola <email address hidden> Fri, 07 Dec 2012 15:11:48 +0100

Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in baltix:
status: In Progress → Fix Committed
importance: High → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.