Moving the mouse cursor over the gnome-system-monitor temporarily causes network and disk usage to become zero

Bug #102921 reported by Byron Knoll on 2007-04-04
102
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Gnome System Monitor
Expired
Medium
gnome-applets (Ubuntu)
Low
Ubuntu Desktop Bugs
Declined for Jaunty by Sebastien Bacher

Bug Description

Binary package hint: gnome-system-monitor

Repeatedly moving the mouse cursor on and off over the gnome-system-monitor will cause network usage and disk usage to remain at 0%.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. What version of Ubuntu do you use? What do you mean? It'll make your computer stop doing any work?

Changed in gnome-system-monitor:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info
Byron Knoll (byronknoll) wrote :

I use Edgy Eft, gnome-system-monitor 2.16.1-0ubuntu1. It doesn't affect the performance of my computer, the problem is that the monitor reports 0% network/disk usage under certain conditions:

When the mouse cursor enters or exits the system-monitor panel applet window.
Moving the cursor between the different areas of the system-monitor (e.g. between Memory and Network).

If the cursor is stationary within the window, the graph acts normally.
If the cursor is outside the window, the graph acts normally.

I have also confirmed the bug on a system running Fiesty Fawn, gnome-system-monitor 2.18.1-0ubuntu1.

Sebastien Bacher (seb128) wrote :

tooltip incorrect then, that looks like bug #97190

Byron Knoll (byronknoll) wrote :

No, its not the tooltip which displays the incorrect information, but the graphs on the panel itself. In the attached screenshot, the network graph shows a drop to almost 0% near the middle, even though my network usage was actually remaining relatively constant. This drop in the graph was caused by moving my mouse cursor repeatedly on and off over the system-monitor.

Sitsofe Wheeler (sitsofe) wrote :

No this does not appear to be a dup of bug #97190. I've just reproduced by flood pinging my router using the following:
sudo ping -M dont -s 10000 -f router
This filled the graph. I double clicked the graph opening gnome-system-monitor and clicked on the resources tab so I had another network graph to compare to. That graph showed sent packets were between 90-100%. I then rapidly moved over and then below the system-monitor applet with the mouse pointer and the graph would stop reaching to the the top of the applet despite remaining between 90-100% on gnome-system-monitor.

Sitsofe Wheeler (sitsofe) wrote :

Confirming.

Changed in gnome-system-monitor:
status: Needs Info → Confirmed
Changed in gnome-system-monitor:
status: Unknown → Confirmed
Adam Dunn (dunnadam) wrote :

I took a video of the problem with Istanbul.
At 7-12 seconds I move the mouse around inside the network graph to show that moving the mouse inside the graph is not sufficient to create the problem.
At 15-25 seconds I move the mouse in and out of the graph area a couple times to show the reproduction of the problem.
At 25-32 seconds I move the mouse over the other graphs in gnome-system-monitor applet to show that popping the mouse over any graph will cause the network graph to go down.
At 35-40 seconds, a demonstration that tooltips in other Gnome Panel icons don't reproduce, nor does partially covering the graphs with a tooltip.
Finally, at 40-46 seconds I move the mouse in and out of the graph area repeatedly (though it's hard to tell in the video), to show that this can create a long valley in the graph.
Note that System Monitor is running below to show what the graphs should approximately look like. I tried screencasting just the relevant portion of my screen, but Istanbul's area recording isn't working at the moment, so you get the entire desktop instead.

Sebastien Bacher (seb128) wrote :

That's not clear there is an actual error in the graph, it might just coincide with an activity change

Changed in gnome-system-monitor:
status: Confirmed → Triaged
Ilmari Vacklin (wolverian) wrote :

I can confirm this on an up-to-date Hardy. Moving the mouse cursor onto the network usage graph makes a dip in the graph a few pixels wide. The graph then recovers. This happens every time I move the mouse onto the graph, so it really doesn't seem to be just a coincidence.

This bug does not seem to be the same as the one marked as upstream.

I can also confirm this - it isn't just the graph itself dropping though - network throughput is actually dropping. Kick off any application that gives an instantaneous and continually updating report of what bandwidth is being used, then rapidly scroll the mouse back & forth over the _edge_ of the window (that is, in and out of it) and watch your BW go to zero, as reported by the independent application.

      -dave-

Sitsofe Wheeler (sitsofe) wrote :

vDave420:
This sounds highly unlikely unless the apps sending/receiving the packets are GUI based. Try watching the output of something like
wget http://cdimage.ubuntu.com/daily/current/hardy-alternate-i386.iso
while doing
watch --interval=1 /sbin/ifconfig <networkinterfacehere>
in another window.

krlhc8 (krlhc8) wrote :

I can confirm this as well. It's rather annoying, yet it's of lower importance. To all the skeptics, open up the system monitor and then move your cursor around over the network monitor panel applet and observe the applet monitor dip yet the actual graph from the system monitor not change...

Jean-Paul (jeanpaul145) wrote :

I'm having this problem as well on 8.04.1, and I had it on Gutsy and Feisty as well.
It doesn't actually seem to _change_ the disk and network activity levels (I'm downloading the 8.10 rc right now via bittorrent, and the speed remains the same when I'm moving my cursor on top of it), but it gives the user the idea that the speed collapses.

Kimiko Koopman (kimiko) wrote :

Confirm: this bug is still present in v2.25.1 (Jaunty)

Kendrick (kendrick90) wrote :

What I don't understand is how it can say something like 50% network in use. If I'm on a 100MBps lan does that mean I am moving 50MBps. No, certainly not. It could be an issue of scaling the graph. Maybe when you mouse over the applet it looks back at what your capacity and usage is and makes the graph of that. So we would likely see near zero percent. Otherwise maybe it looks at peak traffic information and scales from there, 50% of peak network usage. I think my main question is how does it know how tall to make the graph of network usage given that I never have even approached 100% of my network's capacity.

Simone Tolotti (simontol) wrote :

I have a similar issue on Jaunty, except that I can't see no activity at all. Works for me in gnome-system-monitor and in Intrepid.

Simone Tolotti (simontol) wrote :

Some additional info:
The issue only happens when I'm connected with a 3G modem (ppp0 interface).
When using eth0 interface the network monitor works correctly.
It could be that the applet is only monitoring "wired" connections?

I was connected to a wifi network.
It was pretty funny to see the effect of the mouse hover to reset the graph
measure.

Nicolas Dufour
<email address hidden>

On Mon, Mar 9, 2009 at 9:56 AM, Simone Tolotti <email address hidden>wrote:

> Some additional info:
> The issue only happens when I'm connected with a 3G modem (ppp0 interface).
> When using eth0 interface the network monitor works correctly.
> It could be that the applet is only monitoring "wired" connections?
>
> --
> Moving the mouse cursor over the gnome-system-monitor temporarily causes
> network and disk usage to become zero
> https://bugs.launchpad.net/bugs/102921
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Sitsofe Wheeler (sitsofe) wrote :

Still here in Jaunty.

Version information:
Ubuntu 9.04
gnome-applets 2.26.0-0ubuntu4

Changed in gnome-system-monitor:
status: Confirmed → Invalid
Sitsofe Wheeler (sitsofe) wrote :

Setting status from triaged -> confirmed because comments in the upstream bug ( http://bugzilla.gnome.org/show_bug.cgi?id=347901#c8 ) say it is a different issue to the one here.

Changed in gnome-applets (Ubuntu):
status: Triaged → Confirmed
gumbeto (gumbeto) wrote :

I can confirm the same problem on Ubuntu Karmic.

Sitsofe Wheeler (sitsofe) wrote :

Still here in Ubuntu Lucid.

Version information:
Ubuntu 10.04 LTS
gnome-applets 2.30.0-0ubuntu2

Changed in gnome-system-monitor:
importance: Unknown → Medium
status: Invalid → Expired

The upstream watch bug is invalid - it's a different issue.

Changed in gnome-applets (Ubuntu):
status: Confirmed → Triaged
LightCrystal (elldissin) wrote :

Confirming this bug in Ubuntu Lucid.

Version information:
 Ubuntu 10.04 LTS, 2.6.32-33

Affected System monitor 2.30.0

Changed in gnome-applets (Ubuntu):
status: Triaged → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.