Ubuntu

Gimp: Print preview and printout are blank pages

Reported by dinky on 2010-09-12
262
This bug affects 49 people
Affects Status Importance Assigned to Milestone
The Gimp
Fix Released
Medium
gimp (Ubuntu)
High
Unassigned
Declined for Natty by Mathias Gug
Maverick
High
Bilal Akhtar

Bug Description

Binary package hint: gimp

Using the gimp package from the 10.10beta, when I try to print an image, the output of the preview window is blank. I also notice that printing to pdf from Gimp using cups-gimp gives blank page output, the same as the preview.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gimp 2.6.10-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Sun Sep 12 21:42:58 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Beta i386 (20100902.1)
ProcEnviron:
LANG=en_US.utf8
SHELL=/bin/bash
SourcePackage: gimp

Impact: Printing doesn't work from Gimp (all hardware) - a work around of using the gimp-gutenprint plugin and selecting the alternative print menus has been said to work.
Justification for backport: It's a fairly basic feature that doesn't work, although not essential it does complicate the lives of users and is a regression.
How the bug is addressed: The bug is fixed in upstream 2.6.11 (see gnome-bugs #631199)
Patch: See comments 13, and 34 and is gimp git commit 6be41a6675007a0c7328453c654bcda5a2b875b0
How to reproduce: Open an image in gimp, select print, select print preview - the result is blank.
                                         select print, print to a printer - the result is blank.
Regression potential: The changes are minimal changes to routines in the printing code; since this code is already broken the regression potential seems minimal.

TEST CASE: 1) Open GIMP and open an image.
2) Open the Print Preview
3) Print the image.

VERIFICATION DONE: The Print preview and printout should not be blank.

Related branches

dinky (curious-mitchell) wrote :
Andreas Olsson (andol) wrote :

I can confirm this behavior, both the empty preview and the empty printed pdf.

Have you tested printing against an actual printer?

Changed in gimp (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Pavle (igram-oxyd) wrote :

II had this problem in Arch linux. Print preview in program GThumb also didn't work. I resolved it by downgrading Cairo library from 1.10.0 to 1.8.10.

  I'll give that a try. Just confirming that trying to print when having
the preview blank results in a blank document. To print from gimp I'm
needing to save as a Jpeg and open that in the image viewer. Prints fine
from there though.

On 09/13/2010 09:15 AM, Pavle wrote:
> II had this problem in Arch linux. Print preview in program GThumb also
> didn't work. I resolved it by downgrading Cairo library from 1.10.0 to
> 1.8.10.
>

dinky (curious-mitchell) wrote :

  Can you be more specific to the packages you used, and what that would
be on Ubuntu? I have several Cairo libraries.

On 09/13/2010 09:15 AM, Pavle wrote:
> II had this problem in Arch linux. Print preview in program GThumb also
> didn't work. I resolved it by downgrading Cairo library from 1.10.0 to
> 1.8.10.
>

I am having the same issue, but with Gimp 2.7 and on a 64-bit.

Running Ubuntu 10.10.

frankie (frankie-etsetb) wrote :

Same here, printing from Gimp only prints a blank page. Printing the same image from Eye of Gnome works fine.

This is Ubuntu 10.10,

Gimp 2.6.10-1ubuntu3
libcairo2 1.10.0-1ubuntu1

frankie (frankie-etsetb) wrote :

I downloaded and installed older libcairo2 and libdirectfb from here:

  http://packages.ubuntu.com/lucid/i386/libcairo2/download
  http://packages.ubuntu.com/lucid/i386/libdirectfb-1.2-0/download

It keeps printing a blank page and I have broken some dependencies. My big issues are for evince ,and f-spot. So I'll upgrade again to the 10.10 release of libcairo2.

jnns (jnns) wrote :

I have the same problem with libcairo2-1.10.0-1ubuntu2, libcairo2-1.10.0-1ubuntu1 and gimp-2.6.10-1ubuntu3. Strangely, it works using the image viewer Eye Of Gnome (eog).

Dave Gilbert (ubuntu-treblig) wrote :

This happens with a real printer as well; gimp->Epson C86 - it prints a blank page. Note the page prints incredibly quickly - so it's not as if it's misrendering it, it's just spitting the page out.

Shotwell and Firefox print fine.

Dave

Dave Gilbert (ubuntu-treblig) wrote :

'Company' on #gtk+ reckons that Cairo 1.10 is much more fussy about missing calls to cairo_surface_mark_dirty than earlier versions. I can see gimp is making some calls to that - whether it's making all the right ones, well that's a different question.

Dave

Changed in gimp:
importance: Unknown → Medium
status: Unknown → New
Dave Gilbert (ubuntu-treblig) wrote :

Sven Neumann upstream has added a patch that fixes this, I've patched the 2.6.10 package and tested it and it seems good.

(I've just pushed it to a ppa here https://launchpad.net/~ubuntu-treblig/+archive/gimpfixes )

I've also attached the patch below (Sven's patch from Gnome git 6be41a6675007a0c7328453c654bcda5a2b875b0 didn't want to directly apply; I think just because of a little too much fuzz?)

Dave

zombiepig (nyall-zombiepigs) wrote :

I can confirm that the version in Dave's ppa fixes the problem.

Changed in gimp:
status: New → Fix Released
zombiepig (nyall-zombiepigs) wrote :

Is this bug incorrectly marked as 'fix released'? While a fix is available (and included in gimp 2.6.11), it hasn't been included in the ubuntu package yet and isn't available through the repositories.

Dave Gilbert (ubuntu-treblig) wrote :

Hi Zombiepig,
  No, it's marked that it's fix released in the upstream gimp, if you look at the gimp (Ubuntu) line it still shows as Confirmed.

Dave

zombiepig (nyall-zombiepigs) wrote :

Ahh thanks - I missed that. I'm guessing we'll need to wait for the post-release updates for this to be released to Ubuntu now?

Dave Gilbert (ubuntu-treblig) wrote :

Yes ZP, or you could try my PPA here where I applied the fix: https://launchpad.net/~ubuntu-treblig/+archive/gimpfixes

Horst Schirmeier (horst) wrote :

GIMP not printing looks like a mission-critical bug to me, maybe you shouldn't wait until after the release? Dave's gimpfixes PPA solves the problem for me, thanks.

frankie (frankie-etsetb) wrote :

I am sorry it still won't print for me. I still get a blank page.

Am I missing something ?

ii gimp 2.6.10-1ubuntu999dag The GNU Image Manipulation Program
ii gimp-data 2.6.10-1ubuntu999dag Data files for GIMP
ii gimp-gmic 1.3.5.7+dfsg-1 GIMP plugin for GREYC's Magic Image Converter
ii gimp-help-common 2.4.1-2 Data files for the GIMP documentation
ii gimp-help-en 2.4.1-2 Documentation for the GIMP (English)
ii gimp-help-es 2.4.1-2 Documentation for the GIMP (Spanish)
ii gimp-plugin-registry 3.2-1 A repository of optional extensions for The GIMP
ii libgimp2.0 2.6.10-1ubuntu999dag Libraries for the GNU Image Manipulation Program
ii libgtk2-perl 2:1.222-1 Perl interface to the 2.x series of the Gimp Toolkit library

Dave Gilbert (ubuntu-treblig) wrote :

Hi Frankie,
  Hmm, that fix seems to work for everyone else; I wonder what's different about your setup.
Can you confirm that printing from eog or some other gnome program (to the same printer) still works for you?
I see from the earlier messages you had tried rolling back libcairo etc - have you got everything back to the normal
Maverick set of packages except for my ppa?

Dave

frankie (frankie-etsetb) wrote :

Hi Dave,
  Yes, I can print from eog.

My libcairo2 is 1.10.0-1ubuntu2. I manually installed libcairo2 with dpkg just in case but keeps printing a blank page. I tried two different printers. I don't know what else can I do.

Dave Gilbert (ubuntu-treblig) wrote :

I've not got the plugin-registry installed that you have; I wonder if a plugin that you have is breaking it?
(I also don't have gimp-gmic).

Dave

frankie (frankie-etsetb) wrote :

I removed and purged: plugin-registry and gimp-gmic. It keeps doing the same.

I created a fresh user and tried to print. It printed right !
I tried again with my username, and I got a blank page. So it is definetaly something in my profile. Maybe the bug it is not a show-stopper, because it only happens to me. But I was able to print before maverick.

Dave Gilbert (ubuntu-treblig) wrote :

What happens if you move the .gimp* directories out of the way in your home directory? Is it something in one of those?

Dave

frankie (frankie-etsetb) wrote :

It worked. I will try to isolate the different files and find out what could trigger the blank page.

frankie (frankie-etsetb) wrote :

I found the problem comes from two config files in .gimp-2.6:

 - print-page-setup
 - print-settings

If I copy those two config files from my former .gimp-2.6.old it prints a blank page. If I only copy one of those files, it prints right. So it is a combination of what is in both that goes wrong.

- print-page-setup is not in a fresh .gimp-2.6.

I copied print-page-setup and tried the different options in print-settings untill I found the guilty one. I spotted scale=967 quite bigger than scale=100 in the fresh one. It was that. It looks like my print-page-setup and a huge scale setting makes the image go off limits from the page.

Maybe it is a normal behaviour given those settings but I'm pretty sure I could print from gimp when I was in lucid.

I attach my print-page-setup.

Dave Gilbert (ubuntu-treblig) wrote :

Hi Frankie,
  OK I think in that case your problem is separate - I still think this particular fix is a valid one then for most peoples setup.

Dave

Hi Everybody,

I had the same problem: empty preview in window and empty printout on a physical printer with GIMP and Ubuntu 10.10 Maverick Meerkat.

I can confirm that the above mentioned Dave's PPA provides solution. After installing the following updates from the PPA both preview and printing from GIMP works.

gimp 2.6.10-1ubuntu999dag
gimp-data 2.6.10-1ubuntu999dag
libgimp2.0 2.6.10-1ubuntu999dag

Thanks Dave!

Cheers!
Jukka

Ubuntu 10.10, 64bit on Sony Vaio, printer: Samsung CLX-3175FW

summary: - Gimp won't print preview
+ Gimp: Print preview and printout are blank pages
Changed in gimp (Ubuntu):
importance: Medium → High
milestone: none → maverick-updates
roadrash (roadrash) wrote :

Dave PPA solution worked for me too in 10.10 maverick meerkat.
I stumbled on this bug fix after lots of searching. I kept my installation up to date with the latest updates so when will there be a proper fix so others don't get stuck with this problem.

tags: added: patch
Jeff (jdorenbush) wrote :

How about for Gimp 2.7?

Changed in gimp (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: Confirmed → In Progress
assignee: Bilal Akhtar (bilalakhtar) → nobody
status: In Progress → Triaged
Changed in gimp (Ubuntu Maverick):
assignee: nobody → Bilal Akhtar (bilalakhtar)
importance: Undecided → High
milestone: none → maverick-updates
status: New → In Progress
Changed in gimp (Ubuntu):
milestone: maverick-updates → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.6.10-1ubuntu4

---------------
gimp (2.6.10-1ubuntu4) natty; urgency=low

  * Manually import fix from GIMP git 6be41a6675007a0c7328453c654bcda5a2b875b0
    by Sven Neumann to fix printing (LP: #636329)
 -- <email address hidden> (Dr. David Alan Gilbert) Sun, 03 Oct 2010 15:52:56 +0100

Changed in gimp (Ubuntu):
status: Triaged → Fix Released
mihai007 (mihai-ile) wrote :

I noticed I had this bug today, and saw the fix was published 6h ago, but is this patch going to be available for ubuntu 10.10? I sat that it is available for the 11.04 already...

Bilal Akhtar (bilalakhtar) wrote :

Please sponsor this debdiff. It fixes this bug.

Bilal Akhtar (bilalakhtar) wrote :

Un-assigning myself since I need a sponsor.

Changed in gimp (Ubuntu Maverick):
assignee: Bilal Akhtar (bilalakhtar) → nobody
Alex Demko (ademko) wrote :

Just me a "me too". gimp + real printer prints blanks. eog works fine.

A 10.10 fix would be super, as this really makes gimp useless for printing...

Added Ubuntu SRU team, as Bilal Akhtar's patch is an SRU for Maverick.

Mathias Gug (mathiaz) wrote :

To get an Stable Release Update pushed to maverick step 2 of the SRU Procedure [1] needs to be done:

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Update the bug report description and make sure it contains the following information:

   1. A statement explaining the impact of the bug on users and justification for backporting the fix to the stable release
   2. An explanation of how the bug has been addressed in the development branch, including the relevant version numbers of packages modified in order to implement the fix.
   3. A minimal patch applicable to the stable version of the package. If preparing a patch is likely to be time-consuming, it may be preferable to get a general approval from the SRU team first.
   4. Detailed instructions how to reproduce the bug. These should allow someone who is not familiar with the affected package to reproduce the bug and verify that the updated package fixes the problem. Please mark this with a line "TEST CASE:".
   5. A discussion of the regression potential of the patch and how users could get inadvertently affected.

Dave Gilbert (ubuntu-treblig) wrote :

Hi Mathias,
  I've made those changes to the description - is that what you need?

Dave

description: updated
description: updated
Bilal Akhtar (bilalakhtar) wrote :
Bilal Akhtar (bilalakhtar) wrote :

The above (newer) patch works well. The problem with the previous patch was that I used a quilt patch in it (this one is cdbs). Confusion was caused by what-patch saying 'quilt' when package was using cdbs+simple-patchsys.

Benjamin Drung (bdrung) wrote :

uploaded to maverick-proposed

Changed in gimp (Ubuntu Maverick):
status: In Progress → Fix Committed

Accepted gimp into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Xandros Pilosa (folivora) wrote :

I am confirming that gimp 2.6.10-1ubuntu3.1 from maverick-proposed resolves the issue.
It does not pull dependent packages libgimp2.0 and gimp-data to the corresponding new version (2.6.10-1ubuntu3.1) though, but it's merely cosmetic issue and doesn't matter in this case.
Many thanks to all who chimed in and made it work.

Regards

Phil Stone (philstone) wrote :

I'm on the road and can't test with my office printers, won't be home for a few weeks.
I can confirm that the fix for gimp in maverick-proposed does generate
.pdf files with the correct graphical content.

Thanks for the fix.
Phil

Martin Pitt (pitti) on 2010-11-15
tags: added: verification-done
removed: verification-needed
Giovanni Mellini (merlos) wrote :

The package in proposed queue fix the issue for me, tks a lot

Also works for me with the proposed package on Maverick.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.6.10-1ubuntu3.1

---------------
gimp (2.6.10-1ubuntu3.1) maverick-proposed; urgency=low

  * debian/patches/01_add_missing_calls_to_cairo_surface_mark_dirty.patch:
    - Add missing calls to function cairo_surface_mark_dirty to fix the
      problem of prints and print previews coming up as blank pages.
      (LP: #636329)
 -- Bilal Akhtar <email address hidden> Wed, 10 Nov 2010 23:39:24 +0100

Changed in gimp (Ubuntu Maverick):
status: Fix Committed → Fix Released

Thank you.

El 19/11/10 13:50, Launchpad Bug Tracker escribió:
> This bug was fixed in the package gimp - 2.6.10-1ubuntu3.1
>
> ---------------
> gimp (2.6.10-1ubuntu3.1) maverick-proposed; urgency=low
>
> * debian/patches/01_add_missing_calls_to_cairo_surface_mark_dirty.patch:
> - Add missing calls to function cairo_surface_mark_dirty to fix the
> problem of prints and print previews coming up as blank pages.
> (LP: #636329)
> -- Bilal Akhtar<email address hidden> Wed, 10 Nov 2010 23:39:24 +0100
>
> ** Changed in: gimp (Ubuntu Maverick)
> Status: Fix Committed => Fix Released
>

--
Alberto.

:)

Bilal Akhtar (bilalakhtar) wrote :

Assigning myself back, now that its sponsored.

Changed in gimp (Ubuntu Maverick):
assignee: nobody → Bilal Akhtar (bilalakhtar)
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.