/usr/lib/cups/filter/pdftoraster failed

Bug #539708 reported by Ernst on 2010-03-16
228
This bug affects 57 people
Affects Status Importance Assigned to Milestone
GS-GPL
Fix Released
High
ghostscript (Fedora)
Fix Released
High
ghostscript (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: cups

I tried to print some file using Chromium. I got the message that printing has failed. After diagnosing, I get the message:
/usr/lib/cups/filter/pdftoraster failed.
This is on a Canon iP4500 printer. Printing to the pdf printer still works. Also, a test page does work. So, I guess it has something to do with the printed file.

(which is created using Chromium and GMail:
- start chromium
- go to gmail
- select conversation
- click print in drop down menu)

I noticed a couple of things:
- Printing the file directly from Chromium does not work.
- Printing from Chromium to pdf and printing the created pdf does not work also.
- However, printing from Firefox does work!
- Another webpage is printed fine using Chromium

As the file contains some private information, I cannot attach it here.

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 16 17:56:42 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100122)
Lpstat:
 device for Canon-iP4500-series: usb://Canon/iP4500%20series
 device for Canon-iP4500-series-2: usb://Canon/iP4500%20series
 device for PDF: cups-pdf:/
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD MS-7512
Package: cups 1.4.2-9
Papersize: letter
PpdFiles:
 Canon-iP4500-series: Canon PIXMA iP4500 - CUPS+Gutenprint v5.2.5
 PDF: Generic CUPS-PDF Printer
 Canon-iP4500-series-2: Canon PIXMA iP4500 - CUPS+Gutenprint v5.2.5 Simplified
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=0f104604-00b2-4b97-962f-b48f8c29db01 ro quiet splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: cups
Uname: Linux 2.6.32-16-generic x86_64
dmi.bios.date: 03/09/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V3.4
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P45 Neo2-FR (MS-7512)
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV3.4:bd03/09/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7512:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnP45Neo2-FR(MS-7512):rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7512
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD

Description of problem:
After updating to ghostscript-8.70-5.fc12.x86_64, the printer only prints black pages with small vertical lines and some patterns on it. After downgrading to ghostscript-8.70-2.fc12.x86_64.rpm, everything works fine again.

Version-Release number of selected component (if applicable):
ghostscript-8.70-5.fc12.x86_64
cups-1.4.2-20.fc12.x86_64
turboprint-2.12-1.x86_64 (from http://www.turboprint.de/)

How reproducible:
Always

Steps to Reproduce:
1. Update to ghostscript-8.70-5.fc12.x86_64
2. Print something (e.g. a PDF file or a test page).

Actual results:
The printed page is mostly black with only some vertical stripes and patterns on it.

Expected results:
The page is printed correctly.

Additional info:
I am using turboprint as driver for my Canon Pixma IP 4000. I don't know if this is a bug in ghostscript or an incompatibility with turboprint. Anyhow I could reproduce this behaviour on two Fedora 12 x86_64 machines.

Please attach the PPD for the queue you are using. You can find this in the /etc/cups/ppd directory.

Created attachment 390356
ppd of the printer queue

Thanks. This is some kind of regression in the ghostscript cups driver.

Created attachment 390508
in.ps.bz2 (PostScript input for reproducer)

This file, along with the PPD, shows the problem.

1. bunzip2 in.ps.bz2
2. PPD=tp0.ppd gs -sDEVICE=cups -r600x600 -dSAFER -dNOPAUSE -dBATCH -sOutputFile=out.rast
3. rasterview out.rast

*** Bug 565804 has been marked as a duplicate of this bug. ***

ghostscript-8.70-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ghostscript-8.70-6.fc12

ghostscript-8.70-6.fc12 fixes the bug for me. Thank you!

ghostscript-8.71-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ghostscript-8.71-1.fc12

8.71-1.fc12 works for me

ghostscript-8.71-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ghostscript-8.71-2.fc12

Using Fedora 12 and turboprint-2.13-2.i586.rpm. Update from ghostscript-8.70-2.fc12.i686.rpm to ghostscript-8.70-5.fc12.i686.rpm started the black print page problem.

Update to ghostscript-8.71-1.fc12.i686.rpm initially fixed it but after reboot black page again. Tried ghostscript-8.71-2.fc12.i686.rpm but still black page.

Dropped back to ghostscript-8.70-2.fc12.i686.rpm and works again (had to remove ghostscript and all dependencies first). My printer is a Canon MP780 and installed as local using tpu://Canon/MP780 .

Error in /var/log/messages :-

Feb 19 18:14:41 mail kernel: tpu[3334]: segfault at 64 ip 00d53bed sp b7809154 error 4 in libpthread-2.11.1.so[d4c000+16000]
Feb 19 18:14:41 mail abrtd: Directory 'ccpp-1266603281-3323' creation detected
Feb 19 18:14:41 mail abrtd: Lock file '/var/cache/abrt/ccpp-1266603281-3323.lock' is locked by process 3356
Feb 19 18:14:42 mail abrt[3356]: saved core dump of pid 3323 (/usr/lib/cups/backend/tpu) to /var/cache/abrt/ccpp-1266603281-3323/coredump (11063296 bytes)
Feb 19 18:14:42 mail abrtd: Executable '/usr/lib/cups/backend/tpu' doesn't belong to any package
Feb 19 18:14:42 mail abrtd: Corrupted or bad crash, deleting

ghostscript-8.71-2.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update ghostscript'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1891

Still only ghostscript-8.71-1.fc12 showing on yum update. Tried to install ghostscript-8.71-2.fc12.i686.rpm manually but got the same error which meant I had to completely uninstall ghostscript and dependencies first :-

sudo rpm -Uvh /data/ghostscript-8.71-2.fc12.i686.rpm
error: Failed dependencies:
 libgs.so is needed by ghostscript-8.71-2.fc12.i686
 libgs.so.8 is needed by (installed) libspectre-0.2.3-1.fc12.i686

sudo yum provides /usr/lib/libgs.so.8

ghostscript-8.70-2.fc12.i686 : A PostScript interpreter and renderer.
Repo : installed
Matched from:
Other : Provides-match: /usr/lib/libgs.so.8

Which has nothing to do with libspectre. 8.70-1 installs fine. Should 8.70-2 really be checking for libgs.so ?

rpm -qlp /data/ghostscript-8.71-2.fc12.i686.rpm | grep libgs
/usr/lib/libgs.so.8
/usr/lib/libgs.so.8.71

Removed ghostscript and dependencies, e.g.turboprint using sudo yum remove ghostscript. Still complaining about libgs.so , so

sudo rpm -Uvh --nodeps ghostscript-8.71-2.fc12.i686.rpm
sudo rpm -Uvh turboprint-2.12-2.i586.rpm

This time nothing actually get sent to the printer and no error messages. Turboprint print monitor just shows "Printer: USB error". Reinstalled 8.70-2 and works fine, monitor says "Printer: idle".

ghostscript-8.71-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ghostscript-8.71-4.fc12

Installed ghostscript-8.71-4.fc12 successfully and tested ok before and after a reboot. Thanks, John.

8.71-4.fc12 finally worked for me, too, older version segfaulted with turboprint

gs[18071]: segfault at 2 ip 00000002 sp bfd20b64 error 4 in gs[755000+1000]
gs[18077]: segfault at 9 ip 00000009 sp bfd861c4 error 4
gs[18114]: segfault at 2 ip 00000002 sp bfdd4264 error 4
gs[18119]: segfault at 9 ip 00000009 sp bff1b694 error 4

ghostscript-8.71-4.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update ghostscript'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-2576

ghostscript-8.71-4.fc12 has been pushed to the Fedora 12 stable repository. If problems still persist, please make note of it in this bug report.

In ghostscript-8.71-5.fc12 I've reintroduced the change that originally caused this, but with a fix for this particular issue.

ghostscript-8.71-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ghostscript-8.71-6.fc11

ghostscript-8.71-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ghostscript-8.71-6.fc12

ghostscript-8.71-9.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ghostscript-8.71-9.fc13

Ernst (ernst-blaauw) wrote :

Here is a pdf (without too much private info) causing the error. Does this
work for you?

Anton Kraus (done) wrote :

I have the same problem with an Epson Stylus DX 4050.
Printing a test page works, but trying to print a pdf always fails with the same error.

Ernst (ernst-blaauw) wrote :

I've set the status to 'confirmed' because 2 users have this issue.

Changed in cups (Ubuntu):
status: New → Confirmed
affects: cups (Ubuntu) → ghostscript (Ubuntu)
Changed in gs-gpl:
status: Unknown → New
Anton Kraus (done) wrote :

When I attached my printer (see above) to a Windows PC, I received an ink level warning. I then found out that Epson doesn't allow B/W printing as soon as one of the colour cartridges is empty, no matter how full the black cartridge is.

Could it be that the pdftoraster error is actually caused by the printer's refusal to activate itself?

Ernst (ernst-blaauw) wrote :

Here that's not the case, as some other pages print fine (like the page '
www.nu.nl': it is printed fine using Chromium)! Also, the same e-mail
message I attached above is printed fine using Firefox, so the hardware is
not the problem I think.
Btw, I have a Canon iP4500 and all cartridges have enough inkt left.

On Wed, Mar 17, 2010 at 19:51, Anton Kraus <email address hidden> wrote:

> When I attached my printer (see above) to a Windows PC, I received an
> ink level warning. I then found out that Epson doesn't allow B/W
> printing as soon as one of the colour cartridges is empty, no matter how
> full the black cartridge is.
>
> Could it be that the pdftoraster error is actually caused by the
> printer's refusal to activate itself?
>
> --
> /usr/lib/cups/filter/pdftoraster failed
> https://bugs.launchpad.net/bugs/539708
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Till Kamppeter (till-kamppeter) wrote :

Anton Kraus, it is for sure not a hardware problem, as if I run the file which Ernst has attached through the Ghostscript command line in http://bugs.ghostscript.com/show_bug.cgi?id=691014, Ghostscript gives an error or a segmentation fault.

ghostscript-8.71-6.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update ghostscript'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ghostscript-8.71-6.fc12

ghostscript-8.71-6.fc11 has been pushed to the Fedora 11 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update ghostscript'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ghostscript-8.71-6.fc11

Anton Kraus (done) wrote :

I see. So the ink levels are an additional problem with my printer, but not the cause of the pdftoraster error discussed here.

James Walmsley (james.walmsley) wrote :

I have the same problem, with an Epson RX425. I don't think its a printer problem, something is failing converting the PDF to raster.

Can't print my dissertation! I think this must be a regression, because it seemed to work a few days ago, before I did an update.

James

sboetsch (sebastien-boetsch) wrote :

I don't want to change the bug status but since the 10.04 update of tonight (I guess it is related to package hplip-cups version 3.10.2-1ubuntu2). I can now print with my Epson Stylus DX4250 (before I was ony able to print the test page).

The error has gone.

Thanks guys!

ghostscript-8.71-9.fc13 has been pushed to the Fedora 13 stable repository. If problems still persist, please make note of it in this bug report.

HPLIP is only for HP printers, what has solved your problem was probably the recent update of the Ghostscript package.

Ernst (ernst-blaauw) wrote :

Yesterday, I had to print again from Chrome. Now, I did not get a error
message beforehand, but only after the page was printed - which was, instead
of an e-mail, a totally black page. The error message was not clear to me,
it just seem to say 'finished printing page 1'.

$ apt-cache policy ghostscript
ghostscript:
  Installed: 8.71.dfsg.1-0ubuntu4
  Candidate: 8.71.dfsg.1-0ubuntu4
  Version table:
 *** 8.71.dfsg.1-0ubuntu4 0
        500 http://nl.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

On Mon, Mar 29, 2010 at 13:32, Daniel J Blueman <email address hidden>wrote:

> These PDFs may also be relevant test-cases - with the Epson R220 CUPS
> filter, I see ghostscript hit with SEGV:
>
> http://cimg.sourceforge.net/CImg_flyer.pdf
> ftp://ftp.numerical.rl.ac.uk/pub/talks/Arioli-NAG-Warwick.pdf
> http://www.stdout.org/~winston/latex/latexsheet-a4.pdf
> http://www.brunel200.com/downloads/launch_leaflet.pdf
>
> http://www.cambridgeaudio.com/assets/documents/AP227921Azur540RV3SerialControlProtocolV1.pdf
>
> --
> /usr/lib/cups/filter/pdftoraster failed
> https://bugs.launchpad.net/bugs/539708
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Ernst (ernst-blaauw) wrote :

This pdf: http://www.werkstudent.nl/downloads/werkbrief.pdf results in a
total black page.

On Wed, Mar 31, 2010 at 10:22, Ernst Blaauw <email address hidden> wrote:

> Yesterday, I had to print again from Chrome. Now, I did not get a error
> message beforehand, but only after the page was printed - which was, instead
> of an e-mail, a totally black page. The error message was not clear to me,
> it just seem to say 'finished printing page 1'.
>
> $ apt-cache policy ghostscript
> ghostscript:
> Installed: 8.71.dfsg.1-0ubuntu4
> Candidate: 8.71.dfsg.1-0ubuntu4
> Version table:
> *** 8.71.dfsg.1-0ubuntu4 0
> 500 http://nl.archive.ubuntu.com/ubuntu/ lucid/main Packages
> 100 /var/lib/dpkg/status
>
>
> On Mon, Mar 29, 2010 at 13:32, Daniel J Blueman <email address hidden>wrote:
>
>> These PDFs may also be relevant test-cases - with the Epson R220 CUPS
>> filter, I see ghostscript hit with SEGV:
>>
>> http://cimg.sourceforge.net/CImg_flyer.pdf
>> ftp://ftp.numerical.rl.ac.uk/pub/talks/Arioli-NAG-Warwick.pdf
>> http://www.stdout.org/~winston/latex/latexsheet-a4.pdf
>> http://www.brunel200.com/downloads/launch_leaflet.pdf
>>
>> http://www.cambridgeaudio.com/assets/documents/AP227921Azur540RV3SerialControlProtocolV1.pdf
>>
>> --
>> /usr/lib/cups/filter/pdftoraster failed
>> https://bugs.launchpad.net/bugs/539708
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
>

Ernst, I have tried it out by printing it into a PDF file with evince first (to get an Evince-rerendered version) and try to render that one directly with Ghostscript. Ghostscript errors out before sending the first pixel of the CUPS Raster output to the driver. So probably the driver interprets the missing input data as black pixels instead of erroring out by itself.

Can you please provide an error_log as described in the "CUPS error_log" section of https://wiki.ubuntu.com/DebuggingPrintingProblems.

If you need your files printed, try to avoid evince. Use Adobe Reader, Okular, XPDF, gv, direct printing with "lpr", ... for printing PDF files.

Ernst (ernst-blaauw) wrote :

I created the log with the file I provided above (org_chromium_ANn03F.pdf).
As stated above, after printing the file (or actually: during the printing),
I get a GUI saying that there was a printing error and that I can diagnose
it (Still, I get a totally black page :-O). Some versions of gs ago, this
popup came before the printing, that saved a lot of ink :-).
*
*
On Thu, Apr 1, 2010 at 10:13, Till Kamppeter <email address hidden>wrote:

> Ernst, I have tried it out by printing it into a PDF file with evince
> first (to get an Evince-rerendered version) and try to render that one
> directly with Ghostscript. Ghostscript errors out before sending the
> first pixel of the CUPS Raster output to the driver. So probably the
> driver interprets the missing input data as black pixels instead of
> erroring out by itself.
>
> Can you please provide an error_log as described in the "CUPS error_log"
> section of https://wiki.ubuntu.com/DebuggingPrintingProblems.
>
> If you need your files printed, try to avoid evince. Use Adobe Reader,
> Okular, XPDF, gv, direct printing with "lpr", ... for printing PDF
> files.
>
> --
> /usr/lib/cups/filter/pdftoraster failed
> https://bugs.launchpad.net/bugs/539708
> You received this bug notification because you are a direct subscriber
> of the bug.
>

According to the error_log the printing process behaves as I thought. At the beginning of the page Ghostscript crashes and there is no output to the next filter any more. Even without getting input, the rastertogutenprint filter and the backend continue working and they seem to fill the missing input with zeros which means black in your case.

According to the Ghostscript command line in your error_log you are using "Grayscale" as "Color Model" setting. Can you try other settings here and see whether they work?

Changed in ghostscript (Ubuntu):
status: Confirmed → Incomplete
Ernst (ernst-blaauw) wrote :

Also with color model "RGB", I get a black page. However, I don't get an error. Here is the error log. I removed all the lines already present in my previous log.

Changed in ghostscript (Ubuntu):
status: Incomplete → Confirmed
Ernst (ernst-blaauw) wrote :

I've set the status to 'confirmed' because I still get the black page.

It has the same error (you find the error near the beginning of the error_log). Ghostscript crashes before sending the first pixels of the page bitmap. Driver and backend continue running again with the driver not receiving input data.

Can you try the following now: Choose a color model where zero means white, CMYK, CMY, or KCMY. Does it also give black output pages?

Ernst (ernst-blaauw) wrote :

I just tried KCMY - I get a totally white page. That's a cheaper error :-).

On Fri, Apr 2, 2010 at 18:13, Till Kamppeter <email address hidden>wrote:

> It has the same error (you find the error near the beginning of the
> error_log). Ghostscript crashes before sending the first pixels of the
> page bitmap. Driver and backend continue running again with the driver
> not receiving input data.
>
> Can you try the following now: Choose a color model where zero means
> white, CMYK, CMY, or KCMY. Does it also give black output pages?
>
> --
> /usr/lib/cups/filter/pdftoraster failed
> https://bugs.launchpad.net/bugs/539708
> You received this bug notification because you are a direct subscriber
> of the bug.
>

ghostscript-8.71-6.fc12 has been pushed to the Fedora 12 stable repository. If problems still persist, please make note of it in this bug report.

ghostscript-8.71-6.fc11 has been pushed to the Fedora 11 stable repository. If problems still persist, please make note of it in this bug report.

nicoduck (nico-vthadden) wrote :

i have the same problem, but only when printing more then 3 pages:
i printed a pdf, set it to print 2 pages on one sheet of paper and the printer stops after the third sheed of paper (6th page in pdf)
then selecting page 7-12 works without problems (printing 7-14 stops after page 12) - always printing 2 pages on one sheet of paper

syslog always says
Apr 27 13:09:08 xaser kernel: [58984.827174] gs[30796]: segfault at 7fffe5fb11c0 ip 00007fdcac2edd55 sp 00007fffebe10168 error 4 in libgs.so.8.71[7fdcac154000+511000]

only the positions are different (where the segfault is)
I have a canon pixma ip4200 printer using CUPS+Gutenprint v5.2.5

Changed in ghostscript (Ubuntu):
importance: Undecided → High
milestone: none → lucid-updates

SRU for Lucid prepared and uploaded to the -proposed queue, waiting for approval.

The fix makes all files mentioned in this bug report rendering correctly and probably also fixes many other reported Ghostscript crash problems (please mark other bugs as duplicate of this one if the proposed SRU fixes them).

Changed in ghostscript (Ubuntu Lucid):
status: Confirmed → Fix Committed
Changed in gs-gpl:
status: New → Fix Released

Accepted ghostscript into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Leo Milano (lmilano) wrote :

Hi all

I just tested the hpcups driver from the proposed repository in my system (Kubuntu Lucid, HP Deskjet F380), and the bug is fixed. I no longer get the black background.

Great work everyone involved! Cheers,
 -- Leo

Martin Pitt (pitti) on 2010-05-04
tags: added: verification-done
removed: verification-needed

Leo Milano's original bug report is bug 553573.

jmrbachiller (jmrbachiller) wrote :

I'm having problem with my Epson SX210.

I've upgraded to Lucid recently (reinstalling all the so) With karmic I was able to print without problem (well, configuring my printer as SX100 and having very poor printing speeds).

When printing from OpenOffice.org Writer my printer ejects one paper and nothing is printed. No error messages.
I exported the document to PDF and try to print from Evince. A message box is shown, the diagnose utility notifies the status messasge "/usr/lib/cups/filter/pdftoraster failed".

I've tried downgrading to ghostscript from karmic, with no results.

I have printed a GIF file (I probe it two times, and no problems), but when trying with other image (JPEG or GIF), the printing fails again.

I've attached the PDF document properties.

jmrbachiller, can you try out the fix proposed in comment #24 in this bug report?

jmrbachiller (jmrbachiller) wrote :

I've installed

ghostscript_8.71.dfsg.1-0ubuntu5.1_amd64.deb
libgs8_8.71.dfsg.1-0ubuntu5.1_amd64.deb
ghostscript-cups_8.71.dfsg.1-0ubuntu5.1_amd64.deb
ghostscript-x_8.71.dfsg.1-0ubuntu5.1_amd64.deb

from lucid-proposed as indicated. No changes at all :(

Thanks for all the work!

PD: the error message when printing from OO-Writer is "/usr/lib/cups/filter/pstopdf failed"

jmrbachiller (jmrbachiller) wrote :

God news!

I've discovered that aparently the problems with my ODT document and the PDF (generated from it) were generatad by OTF the fonts included. This looks like a bug in OO.org + new OTF support.

When I uses the two OTF fonts installed the printing fails as I described above. When I replace the font everything works fine.
I've tried to print several images (JPG, PNG) withoout problems.

So, sorry for my incomplete tests of yesterday (I was tired of testing), because I didn't test the image files, and only try with the ODT and PDF with the OTF fonts.

The new revisions from lucid-proposed seems to solve my problems!
Than you!

PD: I can give the logs from gs, when trying

# gs -sDEVICE=cups -dNOPAUSE -dBATCH -sOutputFile=out bad_otf_file.pdf

or similar.

jmrbachiller (jmrbachiller) wrote :

And sorry again for my devilish english...

(God news! ...Yes, directly from heaven!)

jmrbachiller, so please report a new bug on the OTF fonts. Thank you.

Djoko (djk-srs) wrote :

Thanks for all the effort that has been done :)

I have upgrade with proposed repo's, but my Epson T20E still can't produce any output.
No error message and no error_log recorded.

regards
Djoko Srs

Djoko, your problem is most probably not the problem described in this bug report. Please post a new bug report. Thanks.

Lars Volker (lv) wrote :

jmrbachiller, could you please give some description on which packages to install from lucid-proposed, to get the OTF font inclusion problem fixed?

jmrbachiller (jmrbachiller) wrote :

Lars,

the packages installed from lucid-proposed repo were:

ghostscript_8.71.dfsg.1-0ubuntu5.1_amd64.deb
libgs8_8.71.dfsg.1-0ubuntu5.1_amd64.deb
ghostscript-cups_8.71.dfsg.1-0ubuntu5.1_amd64.deb
ghostscript-x_8.71.dfsg.1-0ubuntu5.1_amd64.deb

This upgrade have solved some of my problems. I can now print as in karmic (using SX100 indeed SX210, and obtaining very slow speeds with text and images, but I can print! I think it twice before buy next printer, Epson surely loses one client)

But the upgrade didn't repair the problems with OTF fonts in OpenOffice documents and the PDF generated from them.

Jose Manuel.

jmrbachiller, thank you for your testing, please report a new bug for the OTF font problem, this is independent.

Lars Volker (lv) wrote :

The OTF problem is already known upstream and will be fixed in OpenOffice 3.2.1. I also filed a bug to watch the process. See #577043.

Link to OTF font bug: bug 577043

Martin Pitt (pitti) wrote :

Copied to maverick and lucid-updates.

Changed in ghostscript (Ubuntu):
status: Fix Committed → Fix Released
Changed in ghostscript (Ubuntu Lucid):
status: Fix Committed → Fix Released
echo-e (jamesrudee) wrote :

I am up to date with the ghostscript packages listed above, but I am encountering some variant of this bug. i.e. I get the
/usr/lib/cups/filter/pdftoraster failed error when I try to print (on my Canon ix4000) certain pdf files (using acroread in this case). Are there any other bug I should be following that generate this error?

echo-e, your problem is most probably not the one described here. Please post a new bug report and follow the instructions under "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems.

James Clemence (jvc26) wrote :

/usr/lib/cups/filter/pdftoraster failed. This is back on Maverick. Doesn't look fixed yet.

J

James Clemence's problem is handled in bug #628030.

Petr Lacek (petr-lacek) wrote :

I had the same problem with my printer Canon MP520, when I was printing a bank statement - in PDF, using Document Viewer 2.30.3 in Gnome, Ubuntu Lucid.
I have solved the problem by saving the document to PostScript format, then opening the PostScript file (in the Viewer too) and printing it. All was OK. It may not be a solution for all such problems but you can try it.
Good luck! Petr

Hunter Laux (jolting) wrote :

pdftoraster is used only when using the cups raster API. This only effects printers that don't understand postscript. Not all printers use this. Cups uses poppler to convert from pdf to ps. The problem is pdftoraster uses ghostscript. Ghostscript has problems with TONS of pdf files. That is why cups switched and is now using poppler. The pdftoraster is part of ghostscript.

The solution is simple. Convert from pdf to ps with poppler and then convert from ps to raster with ghostscript.

tszanon (tszanon) wrote :

I've got the same error message (pdftoraster failed), but with a different printer (Epson Stylus TX420W). It happens no matter what I try to print. Even the test page fails. Should I report a new bug? How can I help?

tszanon, please report a new bug and attach the error_log of a failed job as described in "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems. Attach also your /var/log/syslog file.

Changed in gs-gpl:
importance: Unknown → High
Hacky (dahacky) wrote :

I'm always getting this error when i try to print the attached file.

Hacky (dahacky) wrote :

I'm always getting this error when i try to print the attached file.

David Tombs (dgtombs) wrote :

Hacky, this particular issue has been fixed. Please report a new bug with 'ubuntu-bug cups' and mention your printer model.

Changed in ghostscript (Fedora):
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.