no mouse cursor

Bug #563555 reported by teJECSke on 2010-04-15
126
This bug affects 27 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gdm

there is no visible mouse cursor on login screen

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gdm 2.30.0-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.32-21.31-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Apr 15 07:02:56 2010
ProcEnviron:
 LANG=hu_HU.utf8
 SHELL=/bin/bash
SourcePackage: gdm

teJECSke (attila-jecs) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in gdm (Ubuntu):
status: New → Incomplete
importance: Undecided → Low

2010. 04. 15, csütörtök keltezéssel 08.55-kor Sebastien Bacher ezt írta:
> Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
>
> * Is this reproducible?
yes. every time i boot my system or log out there is gdm mouse working
but has no cursor so it is hard to use.
> * If so, what specific steps should we take to recreate this bug?
dunno, i just installed ubuntu 9.10 and updated to lucid and updating it
every day. a few days ago the cursor disappeared. if i logged in i have
no problems with mouse so i think it has something to do with gdm theme
or something like that but i never changed gdm config
>
> This will help us to find and resolve the problem.
>
> ** Changed in: gdm (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: gdm (Ubuntu)
> Importance: Undecided => Low
>

--
Jecs Attila <email address hidden>
StarGate Command

Christian (tschanzc) wrote :

I have the exact same issue. No visible cursor.
I have Intel Graphics and a x86_64 system (on 10.04).

I have the same problem. I installed the Beta a while ago and after updating every day my mouse cursor suddenly disappeared.
I can use it to select my user, but there's just no visual mouse pointer.

I'm running on an Intel GMA950.

Strangely enough, my Asus EeePC 701 (with a GMA900) has no problems with this at all.

Sebastien Bacher (seb128) wrote :

do you get the issue on boot or when switcher user later?

crom (waniorek) wrote :

I have the same issue, Netbook edition on samsung nc10.
It also occurs if I switch users.

crom (waniorek) wrote :

Directly after the gdm menu disappears, the X-shaped cursor is shortly visible, then the normal cursor appears.

jejbarr (jejbarr) wrote :

I have this exact issue. It is completely reproducible in that any time the GDM login screen is present (regardless of fresh boot, return from suspend, switching users, etc...) there is no mouse pointer. As has been noted, the mouse actually seems to be working, there's just no visible indicator.

I sometimes get the brief X cursor as crom notes just as GDM goes away -- not sure if this is true every single time.

I have nvidia 7150M if that matters...

Koos van Helden (koosvh) wrote :

Just installed Ubuntu 10.04 from alternate and i386 and live CD 32 bit; no cursor, only square. Ubuntu starts up very slow and runs evry slow then it hangs. I run Ubuntu since 2007, April without a single hitch.

SamyCookie (samycookie) wrote :

I had the same bug as all of you. I installed my Ubuntu Lucid from a minimal install (https://help.ubuntu.com/community/Installation/MinimalCD) and after installed GDM, it worked fine but without cursor !

After some tests, I found that if I install the metacity package too, the gdm cursor is back.
I hope that my solution work for the others. Anyway, if that is the solution, metacity is a missing and strange to GDM.

crom (waniorek) wrote :

I can confirm this, my metacity package got lost somehow, after reinstalling it, the cursor is there.

Changed in gdm (Ubuntu):
status: Incomplete → Confirmed
Yves Dorfsman (dorfsmay) wrote :

Same problem here.

The package metacity is already installed, so apt-get won't install it.

I did find one work-around:
ctrl-alt-F1 then ctrl-alt-F7

And you get the cursor on the loging screen, until the next suspend/resume cycle.

JQ (qkchuah) wrote :

I upgraded from 9.10 to 10.04.My cursor become invisible. Each time I have to open Terminal,type a few things and the mouse cursor will appear.I use ctrl-alt-F1 then ctrl-alt-F7 then the mouse cursor will appear. It is hard to use without the mouse cursor.May have to revert back to 9.10 if the problem is not solve.Boot time is not fast, system feel sluggish when opening 2 or 3 windows.My system is a Pentium 1.8 with 768 RAM.Is the sluggish feel got anything to do with not having enough RAM in it to run 10.04?What is the minimum hardware requirement for 10.04 to run smoothly?With all the problems at the moment,i dare not update my another pc(Dell Vostro) to 10.04.

Gerry O'Rourke (gorourke) wrote :

Reporting same problem as Yves.
Dell Optiplex GX260, was running 8.04 LTS with no problems.

Upgraded to 10.04 & immediately had "no mouse cursor" problem after login.

Workaround = ctrl-alt-F1 then ctrl-alt-F7

Yves Dorfsman (dorfsmay) wrote :

On 10-05-15 07:12 AM, Gerry O'Rourke wrote:
> Reporting same problem as Yves.
> Dell Optiplex GX260, was running 8.04 LTS with no problems.
>
> Upgraded to 10.04& immediately had "no mouse cursor" problem after
> login.
>
> Workaround = ctrl-alt-F1 then ctrl-alt-F7
>

Hey, did you click on "this bug affects me"?
The more people registered that they are affected the more chances we get that
somebody looks at it.

--
Yves. http://www.SollerS.ca/
                                                        xmpp:<email address hidden>

jejbarr (jejbarr) wrote :

I just wanted to say that reinstalling metacity did indeed fix this for me. Sounds like this isn't the case for everyone though.

Reinstalling metacity did not help me. The problem seems to be with gdm.

As soon as gdm as been started, my laptop goes in standby mode (don't ask me why) and when it has been manually resumed, the mouse pointer is not visibile.

Additional information: once logged in, if I manually put my laptop in standby mode, the mouse pointer is visible when it resumes.

Jesusfreak (launchpad-bikelab) wrote :

I can also confirm that installing the metacity package helps. Now the cursor is there and works as expected.

Nick Sharp (njsharp) wrote :

I have this problem: no mouse cursor after login, repeatable by logout login again.

AFAIK I already had the metacity package as evidenced by CONFIG EDITOR/APPS (metacity present)

WORK AROUND:

BLINDLY!!:...

1 Move the mouse around, clicking left, until the cursor is clearly on Accessories then choose Terminal
2 Click in the terminal window and hit return
3 The mouse cursor appears and seems to stay until logout login again

NOW that you can see the cursor, hit System/Preferences/Mouse and tick LOCATE POINTER, so that you get some temporary flashing rings round where the cursor is on the screen, just by pressing CTRL.

This will help you do 1-3 next time.

Sucks, but better than nothing!

I look forward to a proper solution! I have had no such problems on other machines, so I reckon it might be specific to Dell Optiplex 260's Intel graphics hardware. I believe GPUs include some HW specific to showing the mouse pointer. Perhaps 10.04 is not treating this GPU properly.

Yves Dorfsman (dorfsmay) wrote :

> it might be specific to Dell Optiplex 260's Intel graphics hardware

No. I have the same problem on Thinkpads T60 with ATI graphic cards.

Craig D Burkey Jr (cburkey1) wrote :

Also having exact same problem, running Intel 82845G/GL/GE graphics built in on HP pavilion 532w, my first experience with ubuntu, and I love the OS other than this one rather annoying little bug!

Gerry O'Rourke (gorourke) wrote :

Tried re-installing metacity , did not fix the problem.

Gerry O'Rourke (gorourke) wrote :

Bug #566324 (Xorg crash) also affects me, I tried the following to remedy the frequent screen crashes:-

echo options i915 modeset=1 | sudo tee /etc/modprobe.d/i915-kms.conf

This does help reduce the number of Xorg crashes, but more importantly, it does affect the cursor.
After doing this, the cursor is present on every bootup without the need to do anything else to restore it,

Not really sure what this is doing to graphics performance though.

Dell Latitude C400 here, got the same with Ubuntu 10.04 and before that Ubuntu 9.04. Specifically, after booting, and logging in the first time, there is no mouse pointer. If I lock the screen (by leaving it idle for a while or by finding the lock screen widget that I've set up for this purpose) then the pointer reappears when I'm back at the GDM login prompt.

The problem was not present with Ubuntu 10.04 immediately after installation, or even after the first few system updates, but appeared later. I think something similar happened with 9.04 - not present on fresh installation but appeared after a while.

rqau (rqau) wrote :

I observed this behavior after installing Ubuntu 10.04 to a new hard drive. The cursor was working properly initially, but disappeared when I changed the screen resolution. After that, it behaved as noted above -- locate cursor worked, mouse buttons worked, ctrl-alt-F1 then ctrl-alt-F7 restored cursor, etc.

The installation of Ubuntu 10.04 on my old disk did not have this behavior. I checked that old file system, and there was an xorg.conf file there. The new system did not have xorg.conf. When I copied the old system's xorg.conf into the new system, the cursor returned with no problems, even after changing resolutions or rebooting.

Unfortunately, the old xorg.conf only uses the generic VESA driver. I may have had to use that driver because of problems when I first set up Ubuntu; it's too long ago to remember. The new xorg.conf generated as described in https://help.ubuntu.com/community/BinaryDriverHowto uses the Intel driver for my system (Intel 82845G/GL/GE). With that xorg.conf, the mouse cursor disappears.

Mouse pointer gone too after upgrade from 9.10 to 10.04.
But pointer was still there for the other users on my system.

Maybe this has got something to do with the fact that my xorg.conf
was changed by me, to make Ubuntu recognize my (ancient, but
huge resolution) Dell P991 monitor.

Got the pointer back when resolution was at 1024x768.
Selected 1600x1200, but saw no pointer. Selected "Keep this",
still no pointer. Pressed Apply and got my pointer again.

Unfortunately, after reboot, the pointer was missing again.
Could fix it again in the same way ... ;-(

Theo Heusser (theo-heusser) wrote :

(Ubuntu 10.04; AMD Athlon 1152x864 resolution; changed to Ubuntu 10.04 from kubuntu 8.04 LTS)
No mouse cursor after login, but only sometimes. The last few weeks the system worked fine, but now almost every second boot results in a screen without mouse cursor after login. Within the login window everything works fine.
Any idea , how to overcome this?

Patrick (patrick-mandic) wrote :

No mouse cursor on GDM. The workaround Ctrl+Alt+F1, Ctrl+Alt+F7 doesn't work for me either.

When a session is started the cursor works fine.

Installed fresh from Ubuntu 10.04

labiloute (labiloute) wrote :

No visible mouse cursor on many of our Ubuntu's.
Seems to be after an upgrade from 8.04 to 10.04.

No xorg.conf defined
1024x768 resolution
nvidia chipset but default driver used (vesa?)
No compiz.

max (maxozilla) wrote :

Just started having this problem following upgrade from 10.10 to 11.04

max (maxozilla) wrote :

Installing metacity seems to fix the problem.

Had the same problem for a couple of days, on 11.04. Installing metacity did fix it!

SM Fahmid (smfahmid2009) wrote :

I accidentally deleted one of the metacity themes for Linux Mint and it went missing.
Copying over the themes from my laptop again. Good thing I have a backup plan!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers