Login screen face browser should respond to keyboard as well as a mouse click

Bug #447049 reported by Jane Silber on 2009-10-09
206
This bug affects 37 people
Affects Status Importance Assigned to Milestone
gdm
Unknown
Medium
gdm (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: gdm

(Karmic Beta) The face browser requires you to mouse click on the person you want to login as. It should also allow you to proceed by pressing <enter> when the desired person is highlighted (i.e, not require the mouse).

Richard Hansen (rhansen) wrote :

I used to be able to hit enter to select a user, but now I have to click with the mouse. There's apparently no way to log in if you don't have a mouse.

Changed in gdm (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in gdm (Ubuntu):
assignee: nobody → Desmond (des)
importance: Undecided → Low
status: Confirmed → Incomplete
assignee: Desmond (des) → Ubuntu Desktop Bugs (desktop-bugs)
Sebastien Bacher (seb128) wrote :

using enter on the login screen works just fine there, do you want to select the default user? what happens when you use enter?

Changed in gdm (Ubuntu):
status: Incomplete → Confirmed
milestone: none → ubuntu-9.10
Sebastien Bacher (seb128) wrote :

The behaviour started recently but gdm didn't change which is weird

Changed in gdm (Ubuntu):
importance: Low → High
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Canonical Desktop Team (canonical-desktop-team)
importance: High → Low
Martin Pitt (pitti) wrote :

I get this as well. Indeed it's intended to be able to just press enter, or typeahead your user name, but it recently broke.

It seems to correlate with bug 439138; in the situations where gdm is misbehaving, I also get the "X uses 100% CPU" bug. After restarting X, it seems to work again.

It is conceivable that both bugs have the same source: X desperately trying to claim the VT, which cryptsetup also holds, and there's a conflict with both things wanting to grab the keyboard/console.

Can anyone confirm this? Please add the system monitor applet for watching the CPU usage. When you get the bug, do you get a constant 100% CPU usage? If you log out and back in, is it fixed, and does gdm react to just pressing enter for the user name?

Changed in gdm (Ubuntu Karmic):
status: Confirmed → Incomplete
Matthew Paul Thomas (mpt) wrote :

On a clean Karmic installation, I experience the GDM problem but do not experience bug 439138.

I do not get the 100% CPU bug, just no keyboard response until I click the name. Was fine, now broken since recent updates (within 4 days).

Using Nvidia non-free, AMD64, Logitech USB wireless mouse/keyboard.

summary: - face browser should respond to <enter> as well as a mouse click
+ Login/face browser should respond to keyboard as well as a mouse click

I reported the bug originally, but haven't been able to reproduce it
since this morning's updates (12 Oct). Of course those updates may be
unrelated - will let you know if I experience it again. It sounds like
others are still seeing it though, at least intermittently.

summary: - Login/face browser should respond to keyboard as well as a mouse click
+ Login screen face browser should respond to keyboard as well as a mouse
+ click
Alexey Kotlyarov (koterpillar) wrote :

This always happens on my system with only one user; however, does not happen on another with multiple users.

Alexey Kotlyarov (koterpillar) wrote :

No, it happens on both machines.

Bernhard (b.a.koenig) on 2009-10-12
Changed in gdm (Ubuntu Karmic):
status: Incomplete → Confirmed
Dave Stroud (bigdavesr) wrote :

this affects me also. But on auto log in it should not show up when booting. It never did before any way.It is also extremely hard to read. Its way too dark.

This effecting me on my netbook (running UNR) but on my desktop.

Changed in gdm (Ubuntu Karmic):
assignee: Canonical Desktop Team (canonical-desktop-team) → Robert Ancell (robert-ancell)

Robert, could you please take a look and see if any GDM changes may have triggered this?

Tormod Volden (tormodvolden) wrote :

I think this has nothing to do with #439138. The login face browser list simply does not have input focus. I can click around and nothing changes unless I click in the list and it gets focus.

The input focus is lost again if I click on the Accessibility icon and then dismiss its dialog with the top-right cross.

If there is no work around for this, this effectively blocks some users from being able to log into Karmic. Note that some users do not have the capability of using a mouse due to circumstances such as physical disabilities.

Changed in gdm (Ubuntu Karmic):
importance: Low → High

Providing some info for robert_ancell at his request:
1. reboot -> no focus
2. use session menu to "switch user" -> no focus
3. switch to VT 9 -> focus
4. switch back to VT 7, use session menu to "switch user" -> focus

I can confirm it looks to just be a focus issue - if you press control+alt+tab you can alternate between the login window and the panel and effectively login without a mouse again.

Note that removing xsplash allows the GDM greeter to have focus on start up ... this is a sufficient work around to ship, in my opinion ... though it's still an annoying bug that should be fixed or at least worked around.

Robert Ancell (robert-ancell) wrote :

You can also loose focus by opening the accessibility dialog and closing it - nothing has focus after this

Robert Ancell (robert-ancell) wrote :

Fixed, the cause was the login window had the DOCK hint which was stopping metacity from giving it focus.

Changed in gdm (Ubuntu Karmic):
assignee: Robert Ancell (robert-ancell) → nobody
status: Confirmed → New
Daniel Holbach (dholbach) wrote :

Looks good, but fails to build on karmic amd64 here.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.28.0-0ubuntu15

---------------
gdm (2.28.0-0ubuntu15) karmic; urgency=low

  * debian/patches/23_login_window_hint.patch:
    - Don't put a type hint on the login window as this causes it not to get
      focus (LP: #447049)
  * debian/patches/16_gdmserver_user_manager.patch:
    - Don't show users with UID < 1000 (LP: #427462)

 -- Robert Ancell <email address hidden> Tue, 13 Oct 2009 15:56:41 +1100

Changed in gdm (Ubuntu Karmic):
status: New → Fix Released
Changed in gdm:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.