SRU: GDebi - installation of deb-packages with gdebi-gtk not working at all

Bug #1946499 reported by Norbert
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
High
Unassigned
Impish
High
Unassigned
vte2.91 (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Install Ubuntu MATE 21.10
2. Open Firefox, navigate to discord.com
3. Download deb-file. At time of writing from the https://dl.discordapp.net/apps/linux/0.0.16/discord-0.0.16.deb link
4. Open Caja in ~/Downloads folder and use GDebi to install the discord-0.0.16.deb file
5. In the GDebi window click Install button

Expected results:
* Gdebi quietly install discord package, there are no error messages in its terminal

Actual results:
* Gdebi terminal shows the error in the last line

```
Selecting previously unselected package gconf2-common.
(Reading database ... 457178 files and directories currently installed.)
Preparing to unpack .../0-gconf2-common_3.2.6-7ubuntu2_all.deb ...
Unpacking gconf2-common (3.2.6-7ubuntu2) ...
Selecting previously unselected package libgconf-2-4:amd64.
Preparing to unpack .../1-libgconf-2-4_3.2.6-7ubuntu2_amd64.deb ...
Unpacking libgconf-2-4:amd64 (3.2.6-7ubuntu2) ...
Selecting previously unselected package gconf-service-backend.
Preparing to unpack .../2-gconf-service-backend_3.2.6-7ubuntu2_amd64.deb ...
Unpacking gconf-service-backend (3.2.6-7ubuntu2) ...
Selecting previously unselected package gconf-service.
Preparing to unpack .../3-gconf-service_3.2.6-7ubuntu2_amd64.deb ...
Unpacking gconf-service (3.2.6-7ubuntu2) ...
Selecting previously unselected package libappindicator1.
Preparing to unpack .../4-libappindicator1_12.10.1+20.10.20200706.1-0ubuntu1_amd64.deb ...
Unpacking libappindicator1 (12.10.1+20.10.20200706.1-0ubuntu1) ...
Selecting previously unselected package libunwind-13:amd64.
Preparing to unpack .../5-libunwind-13_1%3a13.0.0-2_amd64.deb ...
Unpacking libunwind-13:amd64 (1:13.0.0-2) ...
Selecting previously unselected package libc++abi1-13:amd64.
Preparing to unpack .../6-libc++abi1-13_1%3a13.0.0-2_amd64.deb ...
Unpacking libc++abi1-13:amd64 (1:13.0.0-2) ...
Selecting previously unselected package libc++1-13:amd64.
Preparing to unpack .../7-libc++1-13_1%3a13.0.0-2_amd64.deb ...
Unpacking libc++1-13:amd64 (1:13.0.0-2) ...
Selecting previously unselected package libc++1:amd64.
Preparing to unpack .../8-libc++1_1%3a13.0-53~exp1_amd64.deb ...
Unpacking libc++1:amd64 (1:13.0-53~exp1) ...
Setting up libappindicator1 (12.10.1+20.10.20200706.1-0ubuntu1) ...
Setting up gconf2-common (3.2.6-7ubuntu2) ...

Creating config file /etc/gconf/2/path with new version
Setting up libunwind-13:amd64 (1:13.0.0-2) ...
Setting up libc++abi1-13:amd64 (1:13.0.0-2) ...
Setting up libc++1-13:amd64 (1:13.0.0-2) ...
Setting up libc++1:amd64 (1:13.0-53~exp1) ...
Setting up gconf-service (3.2.6-7ubuntu2) ...
Processing triggers for libc-bin (2.34-0ubuntu2) ...
Processing triggers for sgml-base (1.30) ...
Setting up libgconf-2-4:amd64 (3.2.6-7ubuntu2) ...
Setting up gconf-service-backend (3.2.6-7ubuntu2) ...
Processing triggers for libc-bin (2.34-0ubuntu2) ...
dpkg: error: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor
```

and as the result Discord package is not installed .

ProblemType: Bug
DistroRelease: Ubuntu 21.10
Package: gdebi 0.9.5.7+nmu5ubuntu1
ProcVersionSignature: Ubuntu 5.13.0-16.16-generic 5.13.13
Uname: Linux 5.13.0-16-generic x86_64
ApportVersion: 2.20.11-0ubuntu70
Architecture: amd64
CasperMD5CheckResult: pass
CurrentDesktop: MATE
Date: Fri Oct 8 18:17:36 2021
InstallationDate: Installed on 2021-10-08 (0 days ago)
InstallationMedia: Ubuntu-MATE 21.10 "Impish Indri" - Daily amd64 (20211008)
PackageArchitecture: all
SourcePackage: gdebi
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.default.apport:
 # set this to 0 to disable apport, or to 1 to enable it
 # you can temporarily override this with
 # sudo service apport start force_start=1
 enabled=0
mtime.conffile..etc.default.apport: 2021-10-08T15:41:41.001986

Revision history for this message
Norbert (nrbrtx) wrote :
description: updated
Revision history for this message
Norbert (nrbrtx) wrote :

There is something wrong with gdebi-gtk.

Discord package installed normally using CLI:

```
$ sudo gdebi ~/Downloads/discord-0.0.16.deb
[sudo] password for i:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Reading state information... Done

Chat for Communities and Friends
 Discord is the easiest way to communicate over voice, video, and text. Chat,
 hang out, and stay close with your friends and communities.
Do you want to install the software package? [y/N]:y
/usr/bin/gdebi:113: FutureWarning: Possible nested set at position 1
  c = findall("[[(](\S+)/\S+[])]", msg)[0].lower()
Selecting previously unselected package discord.
(Reading database ... 457359 files and directories currently installed.)
Preparing to unpack discord-0.0.16.deb ...
Unpacking discord (0.0.16) ...
Setting up discord (0.0.16) ...
Processing triggers for mailcap (3.69ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.5+21.10.20210710-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
```

but it is not user-friendly. GUI way is simpler and more friendly.

Revision history for this message
Norbert (nrbrtx) wrote :

Round-tripping using

```
sudo apt autopurge discord
```

with

```
gdebi-gtk ~/Downloads/discord-0.0.16.deb
```

leads to the same error in Gdebi terminal:

```
dpkg: error: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor
```

So GDebi-Gtk is broken.

summary: - installation Discord with Gdebi shows "dpkg: error: unable to read
- filedescriptor flags for <package status and progress file descriptor>:
- Bad file descriptor" in gdebi terminal
+ installation of deb-packages with gdebi-gtk shows "dpkg: error: unable
+ to read filedescriptor flags for <package status and progress file
+ descriptor>: Bad file descriptor" in gdebi terminal, package is not
+ installed
Revision history for this message
Norbert (nrbrtx) wrote : Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor" in gdebi terminal, package is not installed

The same happens with normal official package from the repository:

```
cd ~/Downloads
apt download mc
gdebi-gtk mc_3%3a4.8.26-1.1_amd64.deb
```

shows the following in the Gdebi terminal:

```
Selecting previously unselected package mc-data.
(Reading database ... 456803 files and directories currently installed.)
Preparing to unpack .../mc-data_3%3a4.8.26-1.1_all.deb ...
Unpacking mc-data (3:4.8.26-1.1) ...
Setting up mc-data (3:4.8.26-1.1) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
dpkg: error: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor
```

Revision history for this message
Norbert (nrbrtx) wrote :

As 3 years before in bug 1756238 the root of the problem is VTE library.

Downgrading VTE to version 2.91_0.62.3-1ubuntu1 ( https://packages.ubuntu.com/source/hirsute/vte2.91 ) fixes the issue.

Changed in vte2.91 (Ubuntu):
status: New → Confirmed
Changed in gdebi (Ubuntu):
status: New → Confirmed
no longer affects: dpkg (Ubuntu)
Changed in ubuntu-mate:
status: New → Won't Fix
status: Won't Fix → Confirmed
Norbert (nrbrtx)
Changed in ubuntu-mate-meta (Ubuntu):
status: New → Confirmed
Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

From the recent changelog I see 91_keep_fds.patch in vte2.91 was refreshed.

vte2.91 (0.64.2-1ubuntu1) impish; urgency=medium

  * Merge with debian experimental. Remaining changes:
    - Add 91_keep_fds.patch since gdebi still requires it (LP: #1756238)
    - Breaks/Replaces with libvte-2.91-0 (<= 0.60.0-2ubuntu1)
    - Ubuntu gbp.conf and debian/control VCS information
  * Refresh 91_keep_fds.patch

gunnarhj can you confirm that gdebi fail to install debs?

Changed in vte2.91 (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

The only difference in 91_keep_fds.patch between vte2.91 (0.62.3-1ubuntu1) and vte2.91 (0.64.2-1ubuntu1) is this:

164,165c164,165
< auto op = new vte::base::SpawnOperation{spawn_context_from_args(pty,
< working_directory,
---
> auto op = std::make_unique<vte::base::SpawnOperation>
> (spawn_context_from_args(pty,

Revision history for this message
Norbert (nrbrtx) wrote :

It fails, see screen-cast, this is with latest gdebi and latest VTE from Impish.
Proposed is not enabled (if this matters).

```
$ dpkg -l | grep -E "vte|gdebi"
ii gdebi 0.9.5.7+nmu5ubuntu1 all simple tool to view and install deb files - GNOME GUI
ii gdebi-core 0.9.5.7+nmu5ubuntu1 all simple tool to install deb files
ii gir1.2-vte-2.91:amd64 0.64.2-1ubuntu1 amd64 GObject introspection data for the VTE library
ii libvte-2.91-0:amd64 0.64.2-1ubuntu1 amd64 Terminal emulator widget for GTK+ 3.0 - runtime files
ii libvte-2.91-common 0.64.2-1ubuntu1 amd64 Terminal emulator widget for GTK+ 3.0 - common files
```

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Hi!

I can confirm the problem with gdebi-gtk, as already described by Norbert.

The patch is apparently a workaround since nobody has had the time to adapt gdebi. My refresh in the latest Ubuntu upload of vte2.91 was a minimum change to make it still apply after upstream had made changes. Maybe I did a mistake when doing so.

Wonder if gdebi-gtk works on Debian (which does not have 91_keep_fds.patch.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Confirmed that gdebi-gtk works on Debian testing (without 91_keep_fds.patch). So the need for that patch is Ubuntu specific somehow. (Not sure how that helps, but I thought it was worth checking.)

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

This is an attempt at a fix which does not work:

https://launchpad.net/~gunnarhj/+archive/ubuntu/vte2.91/+packages

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :
Changed in vte2.91 (Ubuntu):
assignee: Gunnar Hjalmarsson (gunnarhj) → nobody
Revision history for this message
Norbert (nrbrtx) wrote (last edit ):

Downgrading VTE to hirsute's version solves the issue. Could anyone downgrade it for Impish?

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Probably not. The hirsute version of vte2.91 does not even build on impish.

For gdebi-gtk to keep working, somebody probably needs to

* rewrite 91_keep_fds.patch, or

* fix gdebi so it works without that patch.

Also I can't stop wondering why gdebi-gtk works on Debian testing without 91_keep_fds.patch.

Revision history for this message
Norbert (nrbrtx) wrote :
Download full text (26.2 KiB)

The following method of VTE compilation does not work:

```
sudo sed -i "s/# deb-src/deb-src/g" /etc/apt/sources.list
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get build-dep vte2.91

cd ~/Downloads
wget http://archive.ubuntu.com/ubuntu/pool/main/v/vte2.91/vte2.91_0.62.3.orig.tar.gz
tar -xf vte2.91_0.62.3.orig.tar.gz
cd vte-0.62.3
wget http://archive.ubuntu.com/ubuntu/pool/main/v/vte2.91/vte2.91_0.62.3-1ubuntu1.debian.tar.xz
tar -xf vte2.91_0.62.3-1ubuntu1.debian.tar.xz
rm vte2.91_0.62.3-1ubuntu1.debian.tar.xz

dpkg-buildpackage -us -us -b
```

with the following errors:

```
dpkg-buildpackage: info: source package vte2.91
dpkg-buildpackage: info: source version 0.62.3-1ubuntu1
dpkg-buildpackage: info: source distribution hirsute
dpkg-buildpackage: info: source changed by Gunnar Hjalmarsson <email address hidden>
dpkg-buildpackage: info: host architecture amd64
 dpkg-source --before-build .
 debian/rules clean
dh clean
   debian/rules override_dh_auto_clean
make[1]: Entering directory '/home/i/Downloads/vte-0.62.3'
dh_auto_clean --builddirectory=build-deb
make[1]: Leaving directory '/home/i/Downloads/vte-0.62.3'
   dh_gnome_clean
   debian/rules override_dh_clean
make[1]: Entering directory '/home/i/Downloads/vte-0.62.3'
rm -f debian/libvte-2.91-common.install.kfreebsd
rm -f debian/libvte-2.91-common.install.hurd
dh_clean
make[1]: Leaving directory '/home/i/Downloads/vte-0.62.3'
 debian/rules binary
dh binary
   dh_update_autotools_config
   dh_autoreconf
   debian/rules override_dh_auto_configure
make[1]: Entering directory '/home/i/Downloads/vte-0.62.3'
dh_auto_configure --builddirectory=build-deb -- -Ddocs=true -Dgir=true -Dgnutls=true
 cd build-deb && LC_ALL=C.UTF-8 meson .. --wrap-mode=nodownload --buildtype=plain --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=lib/x86_64-linux-gnu -Ddocs=true -Dgir=true -Dgnutls=true
The Meson build system
Version: 0.56.2
Source dir: /home/i/Downloads/vte-0.62.3
Build dir: /home/i/Downloads/vte-0.62.3/build-deb
Build type: native build
Project name: vte
Project version: 0.62.3
Using 'CFLAGS' from environment with value: '-g -O2 -ffile-prefix-map=/home/i/Downloads/vte-0.62.3=. -flto=auto -ffat-lto-objects -fstack-protector-strong -Wformat -Werror=format-security'
Using 'LDFLAGS' from environment with value: '-Wl,-Bsymbolic-functions -flto=auto -Wl,-z,relro -Wl,-z,now -Wl,-O1 -Wl,-z,defs'
Using 'CPPFLAGS' from environment with value: '-Wdate-time -D_FORTIFY_SOURCE=2'
C compiler for the host machine: cc (gcc 11.2.0 "cc (Ubuntu 11.2.0-7ubuntu2) 11.2.0")
C linker for the host machine: cc ld.bfd 2.37
Using 'CXXFLAGS' from environment with value: '-g -O2 -ffile-prefix-map=/home/i/Downloads/vte-0.62.3=. -flto=auto -ffat-lto-objects -fstack-protector-strong -Wformat -Werror=format-security'
Using 'LDFLAGS' from environment with value: '-Wl,-Bsymbolic-functions -flto=auto -Wl,-z,relro -Wl,-z,now -Wl,-O1 -Wl,-z,defs'
Using 'CPPFLAGS' from environment with value: '-Wdate-time -D_FORTIFY_SOURCE=2'
C++ compiler for the host machine: c++ (gcc 11.2.0 "c++ (Ubuntu 11.2.0-7ubuntu2) 11.2.0")
C++ linker for the host machine: c++ ld.bfd 2.37
Using 'CFLAGS' from environment with value: '-g -O2 -ffile...

Revision history for this message
Norbert (nrbrtx) wrote :

Tried to compile package from debian bookworm as follows:

```
sudo sed -i "s/# deb-src/deb-src/g" /etc/apt/sources.list
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get build-dep vte2.91

cd ~/Downloads
wget http://deb.debian.org/debian/pool/main/v/vte2.91/vte2.91_0.64.2.orig.tar.gz
tar -xf vte2.91_0.64.2.orig.tar.gz
cd vte-0.64.2
wget http://deb.debian.org/debian/pool/main/v/vte2.91/vte2.91_0.64.2-3.debian.tar.xz
tar -xf vte2.91_0.64.2-3.debian.tar.xz
rm vte2.91_0.64.2-3.debian.tar.xz

rm debian/patches/build-Fix-build-on-non-linux-systems.patch
sed -i "/build-Fix-build-on-non-linux-systems.patch/d" debian/patches/series

dpkg-buildpackage -us -us -b
sudo apt-get install ../*.deb
```

Then when `gdebi-gtk file.deb` is executed, then terminal shows the following

```
(gdebi-gtk:14343): VTE-WARNING **: 13:31:00.005: (../src/vtepty.cc:669):bool _vte_pty_spawn_sync(VtePty*, const char*, const char* const*, const char* const*, GSpawnFlags, GSpawnChildSetupFunc, gpointer, GDestroyNotify, GPid*, int, GCancellable*, GError**): runtime check failed: ((spawn_flags & forbidden_spawn_flags()) == 0)
```

Could it be an issue?

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2021-10-14 12:31, Norbert wrote:
> Tried to compile package from debian bookworm

That was one of the first things I tried, but IIRC I still got the "unable to read filedescriptor flags" error. Which is a bit weird, considering that it works in a Debian environment.

> Then when `gdebi-gtk file.deb` is executed, then terminal shows
> the following
>
> ```
> (gdebi-gtk:14343): VTE-WARNING **: 13:31:00.005: (../src/vtepty.cc:669):bool _vte_pty_spawn_sync(VtePty*, const char*, const char* const*, const char* const*, GSpawnFlags, GSpawnChildSetupFunc, gpointer, GDestroyNotify, GPid*, int, GCancellable*, GError**): runtime check failed: ((spawn_flags & forbidden_spawn_flags()) == 0)
> ```
>
> Could it be an issue?

Also that looks familiar.

Revision history for this message
Norbert (nrbrtx) wrote :

Possible way to compile VTE version from Hirsute on Impish is the following:

```
sudo sed -i "s/# deb-src/deb-src/g" /etc/apt/sources.list
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get build-dep vte2.91

cd /tmp
apt-get source vte2.91

cd ~/Downloads
wget http://archive.ubuntu.com/ubuntu/pool/main/v/vte2.91/vte2.91_0.62.3.orig.tar.gz
tar -xf vte2.91_0.62.3.orig.tar.gz
cd vte-0.62.3
wget http://archive.ubuntu.com/ubuntu/pool/main/v/vte2.91/vte2.91_0.62.3-1ubuntu1.debian.tar.xz
tar -xf vte2.91_0.62.3-1ubuntu1.debian.tar.xz
rm vte2.91_0.62.3-1ubuntu1.debian.tar.xz

cp -v /tmp/vte2.91-0.64.2/src/vtetypebuiltins.{h,cc}.template src/

dpkg-buildpackage -uc -us -b

```

and then we can install this older VTE version on Impish as follows:

```
sudo apt-get install ../*vte*.deb
```

As the result it will work as expected with Gdebi! Success!

For local system it may be pinned using the following long command:

```
cat <<EOF | sudo tee /etc/apt/preferences.d/pin-meld
Package: gir1.2-vte-2.91
Pin: version 0.62.3-1ubuntu1
Pin-Priority: 1337

Package: libvte-2.91-0
Pin: version 0.62.3-1ubuntu1
Pin-Priority: 1337

Package: libvte-2.91-common
Pin: version 0.62.3-1ubuntu1
Pin-Priority: 1337

Package: libvte-2.91-dev
Pin: version 0.62.3-1ubuntu1
Pin-Priority: 1337

Package: libvte-2.91-doc
Pin: version 0.62.3-1ubuntu1
Pin-Priority: 1337
EOF
```

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Please.. Downgrading VTE for this reason won't happen. Many other packages are built with the latest version (running "apt rdepends libvte-2.91-0" gives you a hint).

Rewriting the patch or fix gdebi so the patch isn't needed on Ubuntu are two reasonable options. If you want to help fix this, please concentrate on one of those options.

Revision history for this message
Norbert (nrbrtx) wrote :

Dear Gunnar Hjalmarsson (gunnarhj)!
I agree. But the VTE package is maintained or signed by yours signature as shown in its changelog (http://changelogs.ubuntu.com/changelogs/pool/main/v/vte2.91/vte2.91_0.64.2-1ubuntu1/changelog). Then please do this work with 100% effort. You make Ubuntu better.
I'm not familiar with VTE codebase, my main priority is user comfort. I see the method from comment 18 useful, it does not break packages which depend on VTE.
Period.

Revision history for this message
Dani Llewellyn (diddledani) wrote :

Identical to patch added to #1756238.

Revision history for this message
Dani Llewellyn (diddledani) wrote :

With this patch we can drop the 91_keep_fds.patch in vte

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

The downgrade idea would need to be approved by some leading member of Ubuntu's desktop team, and since 21.10 is released today, also the SRU team would need to approve it. (You already know what I think the answer will be.)

It's correct that I have helped with some routine packaging of VTE a couple of times, but that does not make me "familiar with VTE codebase". I'm not. Packaging and tweaking upstream code are different things.

So it boils down to neither you nor me has the sufficient skill to dig into the code, and that somebody who has needs to give it priority. Maybe Martin W., maybe somebody in Ubuntu's desktop team.

Revision history for this message
Dani Llewellyn (diddledani) wrote (last edit ):

https://launchpad.net/~diddledani/+archive/ubuntu/gdebi-fix-1946499/+packages contains my patch above (the debdiff of gdebi) for reference once it's built by LP.

I agree that downgrading VTE is not gonna fly. We might be able to convince SRU managers to rebuild without the patch now it's not needed, but won't convince them on an outright downgrade.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Dani: Needless to say I didn't see your patch before submitting my latest comment.

This sounds very promising! :) And suddenly I understand why gdebi behaves differently in Ubuntu compared to Debian...

Will test is in a minute.

And yes, this means that we can simply start sync'ing vte2.91 from Debian in the jj cycle.

Thanks a lot!

Revision history for this message
Norbert (nrbrtx) wrote :

Thanks.
I have packaged old VTE from Hirsute in the PPA ( https://launchpad.net/~nrbrtx/+archive/ubuntu/vte-impish ).

```
sudo add-apt-repository ppa:nrbrtx/vte-impish
sudo apt-get update
sudo apt-get dist-upgrade
```

will fix the issue temporarily.

Revision history for this message
Dani Llewellyn (diddledani) wrote :

For Norbert, this is the same debdiff without the localisation changes

Revision history for this message
Norbert (nrbrtx) wrote :

Great. So there is no need in my PPA. I have deleted it.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Patch to drop ubuntu-specific hack from gdebi because it is not needed any more" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
no longer affects: ubuntu-mate-meta (Ubuntu)
Changed in ubuntu-mate:
status: Confirmed → Invalid
Changed in gdebi (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
status: Triaged → In Progress
Changed in gdebi (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

I just uploaded Dani's gdebi fix to Debian unstable. Tested it in a PPA first:

https://launchpad.net/~gunnarhj/+archive/ubuntu/gdebi/+packages

With that, and for impish+1, we will be able to sync the source from Debian for both gdebi and vte2.91.

The gdebi change must of course be SRUed to impish. As regards the now obsolete VTE patch, and assuming that it doesn't hurt, SRUing vte2.91 is probably not needed.

no longer affects: vte2.91 (Ubuntu Impish)
Mathew Hodson (mhodson)
Changed in gdebi (Ubuntu Impish):
status: Fix Committed → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.9.5.7+nmu6

---------------
gdebi (0.9.5.7+nmu6) unstable; urgency=medium

  * Non-maintainer upload

  [ Christian Ehrhardt ]
  * GDebi/GDebiGtk.py:
    - Don't call gio_copy_in_place if there is no path / uri being
      passed (LP: #1931394, closes: #989647).

  [ Dani Llewellyn ]
  * GDebi/GDebiGtk.py:
    - Drop Ubuntu-specific changes - no-longer needed
      (LP: #1756238, LP: #1946499)

 -- Gunnar Hjalmarsson <email address hidden> Thu, 14 Oct 2021 23:45:16 +0200

Changed in gdebi (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Nikola M (nikolam) wrote :

When I do right-click on .deb package and open it with Gdebi-gtk,
and try to install a package on 21.10 (also used to happen od 21.04)
program closes.

I have downloaded 0.9.5.7+nmu6 and I think I have built it with dpkg-buildpackage - us -uc and still happens the same.

0.9.5.7+nmu6 works of gdebi-gtk is called from Terminal and .deb opened via File>Open ,
but it does not when on right-click and install in Thunar.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Nikola: If that issue happened also in 21.04, it's not the same issue as the one dealt with in this bug report. The latter is about a regression due to an upgrade of vte2.91.

So you may want to submit a new bug report (with more details, exact error messages, etc.).

Revision history for this message
Robie Basak (racb) wrote : Proposed package upload rejected

An upload of gdebi to impish-proposed has been rejected from the upload queue for the following reason: "Missing SRU information. This looks like it wasn't intended for SRU, and the changes are now in Jammy?".

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote : Re: installation of deb-packages with gdebi-gtk shows "dpkg: error: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor" in gdebi terminal, package is not installed

My understanding is that it was intended for impish as well. If so, can somebody (@Norbert, @Martin, anyone...) please edit the bug description to comply with the SRU template:

https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Another thing: When uploading to Debian, I picked Dani's small debdiff, i.e. the one without translation changes. gdebi is a universe package which is normally sync'ed from Debian, so we should avoid to struggle with translations in an Ubuntu specific upload.

@Dani: From where did you pick the translation changes in your first bigger debdiff? I'd say that if there are additional translations available, they'd better be added to the Debian version of gdebi.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

It looks like also bug #1926697 is coincidentally about to be fixed through the fix of this bug.

Revision history for this message
Dani Llewellyn (diddledani) wrote (last edit ):

The localisation changes were adjusting the translation files to match the line numbers of the amended python source code. It was picked up accidentally by my compiling in the checked-out source when testing the fix - the compile generated new templates with the change. There are zero changes made to the strings themselves, only the line numbers used to generate the templates changed.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2021-10-20 22:58, Dani Llewellyn wrote:
> There are zero changes made to the strings themselves, only the line
> numbers used to generate the templates changed.

Thanks for explaining. Apparently I didn't look close enough. :/

Then I suppose we'd better use your small debdiff also for impish (once the bug description has been updated).

Revision history for this message
Brian Murray (brian-murray) wrote :

I'm unsubscribing the ubuntu-sponsors team as this has already been sponsored albeit rejected by Robie. However, the package can still be accepted from the rejected queue once the bug description has been squared away. I've subscribed to the bug and will accept the package once the SRU information has been added.

Revision history for this message
Dani Llewellyn (diddledani) wrote :

Brian, I've filled out the SRU template.

summary: - installation of deb-packages with gdebi-gtk shows "dpkg: error: unable
- to read filedescriptor flags for <package status and progress file
- descriptor>: Bad file descriptor" in gdebi terminal, package is not
- installed
+ SRU: GDebi - installation of deb-packages with gdebi-gtk not working at
+ all
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Norbert, or anyone else affected,

Accepted gdebi into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gdebi/0.9.5.7+nmu5ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gdebi (Ubuntu Impish):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-impish
Revision history for this message
Norbert (nrbrtx) wrote :

Package from impish-proposed fixed the issue.
Thanks!

tags: added: verification-done-impish
removed: verification-needed-impish
Revision history for this message
Ranjan (ranjan-purbey) wrote (last edit ):

Yep the issue is fixed by impish-proposed package. Thanks!

Version:
gdebi - 0.9.5.7+nmu5ubuntu2

Revision history for this message
Bryan Snyder (bdsst7) wrote :

This resolved my issue installing my backup program Cloudberry backup. (version 3.2.2.125-01) Previously deb wouldn’t install on Impish with Bad file descriptor issue.
*Validated issue remained.
*Enabled proposed updates.
*Updated gdebi and gdebi-core from 0.9.5.7+nmu5ubuntu1to 0.9.5.7+nmu5ubuntu2
*deb file installed without issue.

Thanks everyone.

Revision history for this message
Roland Johnston (rolandjohnston) wrote : Re: [Bug 1946499] Re: SRU: GDebi - installation of deb-packages with gdebi-gtk not working at all
Download full text (5.2 KiB)

Thanks everyone, the issue is now resolved by installing the update from
Impish.

Regards,

Roland Johnston

On Sun, 31 Oct 2021 at 11:20, Bryan Snyder <email address hidden>
wrote:

> This resolved my issue installing my backup program Cloudberry backup.
> (version 3.2.2.125-01) Previously deb wouldn’t install on Impish with Bad
> file descriptor issue.
> *Validated issue remained.
> *Enabled proposed updates.
> *Updated gdebi and gdebi-core from 0.9.5.7+nmu5ubuntu1to
> 0.9.5.7+nmu5ubuntu2
> *deb file installed without issue.
>
> Thanks everyone.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1946499
>
> Title:
> SRU: GDebi - installation of deb-packages with gdebi-gtk not working
> at all
>
> Status in Ubuntu MATE:
> Invalid
> Status in gdebi package in Ubuntu:
> Fix Released
> Status in vte2.91 package in Ubuntu:
> Confirmed
> Status in gdebi source package in Impish:
> Fix Committed
>
> Bug description:
> Steps to reproduce:
> 1. Install Ubuntu MATE 21.10
> 2. Open Firefox, navigate to discord.com
> 3. Download deb-file. At time of writing from the
> https://dl.discordapp.net/apps/linux/0.0.16/discord-0.0.16.deb link
> 4. Open Caja in ~/Downloads folder and use GDebi to install the
> discord-0.0.16.deb file
> 5. In the GDebi window click Install button
>
> Expected results:
> * Gdebi quietly install discord package, there are no error messages in
> its terminal
>
> Actual results:
> * Gdebi terminal shows the error in the last line
>
> ```
> Selecting previously unselected package gconf2-common.
> (Reading database ... 457178 files and directories currently installed.)
> Preparing to unpack .../0-gconf2-common_3.2.6-7ubuntu2_all.deb ...
> Unpacking gconf2-common (3.2.6-7ubuntu2) ...
> Selecting previously unselected package libgconf-2-4:amd64.
> Preparing to unpack .../1-libgconf-2-4_3.2.6-7ubuntu2_amd64.deb ...
> Unpacking libgconf-2-4:amd64 (3.2.6-7ubuntu2) ...
> Selecting previously unselected package gconf-service-backend.
> Preparing to unpack .../2-gconf-service-backend_3.2.6-7ubuntu2_amd64.deb
> ...
> Unpacking gconf-service-backend (3.2.6-7ubuntu2) ...
> Selecting previously unselected package gconf-service.
> Preparing to unpack .../3-gconf-service_3.2.6-7ubuntu2_amd64.deb ...
> Unpacking gconf-service (3.2.6-7ubuntu2) ...
> Selecting previously unselected package libappindicator1.
> Preparing to unpack
> .../4-libappindicator1_12.10.1+20.10.20200706.1-0ubuntu1_amd64.deb ...
> Unpacking libappindicator1 (12.10.1+20.10.20200706.1-0ubuntu1) ...
> Selecting previously unselected package libunwind-13:amd64.
> Preparing to unpack .../5-libunwind-13_1%3a13.0.0-2_amd64.deb ...
> Unpacking libunwind-13:amd64 (1:13.0.0-2) ...
> Selecting previously unselected package libc++abi1-13:amd64.
> Preparing to unpack .../6-libc++abi1-13_1%3a13.0.0-2_amd64.deb ...
> Unpacking libc++abi1-13:amd64 (1:13.0.0-2) ...
> Selecting previously unselected package libc++1-13:amd64.
> Preparing to unpack .../7-libc++1-13_1%3a13.0.0-2_amd64.deb ...
> Unpacking libc++1-13:amd64 (1:13.0.0-2) ......

Read more...

Mathew Hodson (mhodson)
affects: ubuntu-mate → ubuntu-translations
no longer affects: ubuntu-translations
no longer affects: vte2.91 (Ubuntu)
Mathew Hodson (mhodson)
tags: removed: verification-needed
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

For the record: Version 0.64.2-3 of vte2.91, without 91_keep_fds.patch, has migrated to jammy.

Changed in vte2.91 (Ubuntu):
status: New → Fix Released
Revision history for this message
Roland Johnston (rolandjohnston) wrote : Fwd: [Bug 1946499] Re: SRU: GDebi - installation of deb-packages with gdebi-gtk not working at all
Download full text (5.0 KiB)

Thank you everyone. The issue has now been resolved.

Regards,

Roland Johnston

---------- Forwarded message ---------
From: Gunnar Hjalmarsson <email address hidden>
Date: Sun, 7 Nov 2021 at 07:50
Subject: [Bug 1946499] Re: SRU: GDebi - installation of deb-packages with
gdebi-gtk not working at all
To: <email address hidden>

For the record: Version 0.64.2-3 of vte2.91, without 91_keep_fds.patch,
has migrated to jammy.

** Also affects: vte2.91 (Ubuntu)
   Importance: Undecided
       Status: New

** Changed in: vte2.91 (Ubuntu)
       Status: New => Fix Released

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1946499

Title:
  SRU: GDebi - installation of deb-packages with gdebi-gtk not working
  at all

Status in gdebi package in Ubuntu:
  Fix Released
Status in vte2.91 package in Ubuntu:
  Fix Released
Status in gdebi source package in Impish:
  Fix Committed

Bug description:
  Steps to reproduce:
  1. Install Ubuntu MATE 21.10
  2. Open Firefox, navigate to discord.com
  3. Download deb-file. At time of writing from the
https://dl.discordapp.net/apps/linux/0.0.16/discord-0.0.16.deb link
  4. Open Caja in ~/Downloads folder and use GDebi to install the
discord-0.0.16.deb file
  5. In the GDebi window click Install button

  Expected results:
  * Gdebi quietly install discord package, there are no error messages in
its terminal

  Actual results:
  * Gdebi terminal shows the error in the last line

  ```
  Selecting previously unselected package gconf2-common.
  (Reading database ... 457178 files and directories currently installed.)
  Preparing to unpack .../0-gconf2-common_3.2.6-7ubuntu2_all.deb ...
  Unpacking gconf2-common (3.2.6-7ubuntu2) ...
  Selecting previously unselected package libgconf-2-4:amd64.
  Preparing to unpack .../1-libgconf-2-4_3.2.6-7ubuntu2_amd64.deb ...
  Unpacking libgconf-2-4:amd64 (3.2.6-7ubuntu2) ...
  Selecting previously unselected package gconf-service-backend.
  Preparing to unpack .../2-gconf-service-backend_3.2.6-7ubuntu2_amd64.deb
...
  Unpacking gconf-service-backend (3.2.6-7ubuntu2) ...
  Selecting previously unselected package gconf-service.
  Preparing to unpack .../3-gconf-service_3.2.6-7ubuntu2_amd64.deb ...
  Unpacking gconf-service (3.2.6-7ubuntu2) ...
  Selecting previously unselected package libappindicator1.
  Preparing to unpack
.../4-libappindicator1_12.10.1+20.10.20200706.1-0ubuntu1_amd64.deb ...
  Unpacking libappindicator1 (12.10.1+20.10.20200706.1-0ubuntu1) ...
  Selecting previously unselected package libunwind-13:amd64.
  Preparing to unpack .../5-libunwind-13_1%3a13.0.0-2_amd64.deb ...
  Unpacking libunwind-13:amd64 (1:13.0.0-2) ...
  Selecting previously unselected package libc++abi1-13:amd64.
  Preparing to unpack .../6-libc++abi1-13_1%3a13.0.0-2_amd64.deb ...
  Unpacking libc++abi1-13:amd64 (1:13.0.0-2) ...
  Selecting previously unselected package libc++1-13:amd64.
  Preparing to unpack .../7-libc++1-13_1%3a13.0.0-2_amd64.deb ...
  Unpacking libc++1-13:amd64 (1:13.0.0-2) ...
  Selecting previously unselected package libc++1:amd64.
  Preparing to unpack .../8-libc++1_1%3a13.0-53~exp1_amd64.deb ...
  U...

Read more...

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.9.5.7+nmu5ubuntu2

---------------
gdebi (0.9.5.7+nmu5ubuntu2) impish; urgency=medium

  * Drop Ubuntu-specific patches - no-longer needed
    (LP: #1756238, #1946499)

 -- Dani Llewellyn <email address hidden> Thu, 14 Oct 2021 18:30:02 +0100

Changed in gdebi (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for gdebi has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers