package libstdc++6-armhf-cross 4.8.2-16ubuntu4cross0.11 failed to install/upgrade: trying to overwrite '/usr/share/gcc-4.8/python/libstdcxx/__init__.py', which is also in package libstdc++6:i386 4.8.4-2ubuntu1~14.04.1

Bug #1557205 reported by Bob Corner on 2016-03-14
172
This bug affects 35 people
Affects Status Importance Assigned to Milestone
gcc-4.8-armhf-cross (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

SRU info: the fix is to not ship these files in the cross packages. Validate by building and checking that these files are not available.

Did not install right. Think it is to do with the Nvidia Jetson board compiler hooked up to my Ubuntu system.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: libstdc++6-armhf-cross 4.8.2-16ubuntu4cross0.11
ProcVersionSignature: Ubuntu 3.16.0-65.85~14.04.1-generic 3.16.7-ckt24
Uname: Linux 3.16.0-65-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
Date: Mon Mar 14 16:41:18 2016
DuplicateSignature: package:libstdc++6-armhf-cross:4.8.2-16ubuntu4cross0.11:trying to overwrite '/usr/share/gcc-4.8/python/libstdcxx/__init__.py', which is also in package libstdc++6:i386 4.8.4-2ubuntu1~14.04.1
ErrorMessage: trying to overwrite '/usr/share/gcc-4.8/python/libstdcxx/__init__.py', which is also in package libstdc++6:i386 4.8.4-2ubuntu1~14.04.1
InstallationDate: Installed on 2015-03-22 (358 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.5
 apt 1.0.1ubuntu2.12
SourcePackage: gcc-4.8-armhf-cross
Title: package libstdc++6-armhf-cross 4.8.2-16ubuntu4cross0.11 failed to install/upgrade: trying to overwrite '/usr/share/gcc-4.8/python/libstdcxx/__init__.py', which is also in package libstdc++6:i386 4.8.4-2ubuntu1~14.04.1
UpgradeStatus: Upgraded to trusty on 2015-12-21 (84 days ago)

Bob Corner (bobbycorner) wrote :
tags: removed: need-duplicate-check
sfe1012 (1012955586-o) wrote :

sfe1012@sfe1012-ThinkPad-Edge-E540:~$ sudo apt-get install -f
[sudo] password for sfe1012:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
下列软件包是自动安装的并且现在不需要了:
  libdrm2:i386
Use 'apt-get autoremove' to remove it.
将会安装下列额外的软件包:
  libstdc++6-armhf-cross
下列软件包将被升级:
  libstdc++6-armhf-cross
升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 14 个软件包未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0 B/210 kB 的软件包。
解压缩后会消耗掉 77.8 kB 的额外空间。
您希望继续执行吗? [Y/n] y
(正在读取数据库 ... 系统当前共安装有 508605 个文件和目录。)
正准备解包 .../libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb ...
正在将 libstdc++6-armhf-cross (4.8.4-2ubuntu1~14.04.1cross0.11.1) 解包到 (4.8.2-16ubuntu4cross0.11) 上 ...
dpkg: 处理归档 /var/cache/apt/archives/libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb (--unpack)时出错:
 正试图覆盖 /usr/share/gcc-4.8/python/libstdcxx/__init__.py,它同时被包含于软件包 libstdc++6:i386 4.8.4-2ubuntu1~14.04.1
在处理时有错误发生:
 /var/cache/apt/archives/libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gcc-4.8-armhf-cross (Ubuntu):
status: New → Confirmed
sfe1012 (1012955586-o) on 2016-03-15
Changed in gcc-4.8-armhf-cross (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Chen Yosef (d-chen) wrote :

Same for me:
Ubuntu 14.04.4 LTS

Trying to install this package (as part of NVidia JetPack installer) yield the same error:

chen@maint-Latitude-E6330 nvidia$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libstdc++6-armhf-cross
The following packages will be upgraded:
  libstdc++6-armhf-cross
1 upgraded, 0 newly installed, 0 to remove and 52 not upgraded.
53 not fully installed or removed.
Need to get 0 B/210 kB of archives.
After this operation, 77.8 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 310567 files and directories currently installed.)
Preparing to unpack .../libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb ...
Unpacking libstdc++6-armhf-cross (4.8.4-2ubuntu1~14.04.1cross0.11.1) over (4.8.2-16ubuntu4cross0.11) ...
dpkg: error processing archive /var/cache/apt/archives/libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb (--unpack):
 trying to overwrite '/usr/share/gcc-4.8/python/libstdcxx/__init__.py', which is also in package libstdc++6:i386 4.8.4-2ubuntu1~14.04.1
Errors were encountered while processing:
 /var/cache/apt/archives/libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

sfe1012 (1012955586-o) wrote :

These commands Can repare it。
1、sudo dpkg -i --force-overwrite libstdc++6-armhf-cross*
2、sudo dpkg -i --force-overwrite libstdc++-4.8-dev-armhf-cross*

Changed in gcc-4.8-armhf-cross (Ubuntu):
status: Confirmed → Fix Committed
Sean Jones (neuralsandwich) wrote :

Unless you have downloaded those packages, those commands don't fix this issue.
Also this is an issue with the package, which is why I have changed the status back to confirmed

Changed in gcc-4.8-armhf-cross (Ubuntu):
status: Fix Committed → Confirmed
moriarty (alexander-moriarty) wrote :
Download full text (4.1 KiB)

I also started having increased issues after running the nvidia jetson setup

I downloaded the packages as mentioned by Sean Jones and ran the commands mentioned by sfe1012, however they did not solve the issue.

However, it lead to more useful error messages and in the end I was able get everything working.

Here is what worked:

    wget http://de.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.8-armhf-cross/gcc-4.8-arm-linux-gnueabihf-base_4.8.4-2ubuntu1~14.04.1cross0.11.1_amd64.deb
    wget http://de.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.8-armhf-cross/libgcc-4.8-dev-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
    wget http://de.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.8-armhf-cross/libgcc1-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
    sudo dpkg -i gcc-4.8-arm-linux-gnueabihf-base_4.8.4-2ubuntu1~14.04.1cross0.11.1_amd64.deb
    sudo dpkg -i libgcc1-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
    sudo dpkg -i libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
    sudo apt-get install -f

First tried:

    wget http://de.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.8-armhf-cross/libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
    wget http://de.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.8-armhf-cross/libstdc++-4.8-dev-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb
    sudo dpkg -i --force-overwrite libstdc++6-armhf-cross*
    sudo dpkg -i --force-overwrite libstdc++-4.8-dev-armhf-cross*

Output:

$ sudo dpkg -i --force-overwrite libstdc++6-armhf-cross*
(Reading database ... 469933 files and directories currently installed.)
Preparing to unpack libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb ...
Unpacking libstdc++6-armhf-cross (4.8.4-2ubuntu1~14.04.1cross0.11.1) over (4.8.2-16ubuntu4cross0.11) ...
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: trying to overwrite '/usr/share/gcc-4.8/python/libstdcxx/__init__.py', which is also in package libstdc++6:amd64 4.8.4-2ubuntu1~14.04.1
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: trying to overwrite '/usr/share/gcc-4.8/python/libstdcxx/v6/printers.py', which is also in package libstdc++6:amd64 4.8.4-2ubuntu1~14.04.1
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: trying to overwrite '/usr/share/gcc-4.8/python/libstdcxx/v6/__init__.py', which is also in package libstdc++6:amd64 4.8.4-2ubuntu1~14.04.1
dpkg: dependency problems prevent configuration of libstdc++6-armhf-cross:
 libstdc++6-armhf-cross depends on gcc-4.8-arm-linux-gnueabihf-base (= 4.8.4-2ubuntu1~14.04.1cross0.11.1); however:
  Package gcc-4.8-arm-linux-gnueabihf-base is not configured yet.
 libstdc++6-armhf-cross depends on libgcc1-armhf-cross; however:
  Package libgcc1-armhf-cross is not configured yet.

dpkg: error processing package libstdc++6-armhf-cross (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libstdc++6-armhf-cross

$ sudo dpkg -i --force-overwrite libstdc++-4.8-dev-armhf-cross*
(Reading database ... 469935 files and directories currently installed.)
Preparing to unpack libstdc++-4.8-dev-armhf-cro...

Read more...

Ivan Fedorov (oxyum) wrote :

Just use following command for temporary fixing this issue:

$ sudo apt-get -o Dpkg::Options::="--force-overwrite" install -f

csmcd5 (geek-n) wrote :

The following command also seems to temporarily resolve it.

sudo dpkg --force-all -i /var/cache/apt/archives/libstdc++6-armhf-cross_4.8.4-2ubuntu1~14.04.1cross0.11.1_all.deb

specialshoot (hanzhi911228-6) wrote :

The way Ivan Fedorov said is right.

iskenderoguz (iskenderoguz) wrote :

After I use Ivan Fedorov's command I get this:

The following packages were automatically installed and are no longer required:
   binutils-arm-linux-gnueabihf (2.24-5ubuntu13cross1.98.1)
   cpp-4.7-arm-linux-gnueabihf (4.7.3-11ubuntu1cross1.85)
   gcc-4.7-arm-linux-gnueabihf (4.7.3-11ubuntu1cross1.85)
   libc6-dev-armhf-cross (2.19-0ubuntu2cross1.104)
   libgcc-4.7-dev-armhf-cross (4.7.3-11ubuntu1cross1.85)
   libgomp1-armhf-cross (4.8.4-2ubuntu1~14.04.1cross0.11.1)
   linux-libc-dev-armhf-cross (3.13.0-12.32cross1.104)
Use 'apt-get autoremove' to remove them.

This did not happen before. Is it normal ?

Ivan Fedorov (oxyum) wrote :

iskenderoguz, don't worry. That's normal.

This message is just notification that says about gcc-4.7-armhf installed on your system. If your code doesn't depend on gcc-4.7 specifics and successfully compiles with gcc-4.8 you can safely remove that packages via autoremove feature of Apt.

Matthias Klose (doko) on 2016-03-30
description: updated

Hello Bob, or anyone else affected,

Accepted gcc-4.8-armhf-cross into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gcc-4.8-armhf-cross/0.11.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gcc-4.8-armhf-cross (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) on 2016-03-31
tags: added: regression-update
Matthias Klose (doko) wrote :

built as expected.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcc-4.8-armhf-cross - 0.11.2

---------------
gcc-4.8-armhf-cross (0.11.2) trusty-proposed; urgency=medium

  * Don't install libstdc++ pretty printer files. LP: #1557205.

 -- Matthias Klose <email address hidden> Wed, 30 Mar 2016 18:13:56 +0200

Changed in gcc-4.8-armhf-cross (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gcc-4.8-armhf-cross has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Everything is working great now, thanks for fixing things. :-)

On 16-04-01 06:53 PM, Steve Langasek wrote:
> The verification of the Stable Release Update for gcc-4.8-armhf-cross
> has completed successfully and the package has now been released to
> -updates. Subsequently, the Ubuntu Stable Release Updates Team is being
> unsubscribed and will not receive messages about this bug report. In
> the event that you encounter a regression using the package from
> -updates please report a new bug using ubuntu-bug and tag the bug report
> regression-update so we can easily find any regressions.
>

--

"What this country needs are more unemployed politicians."

--Edward Langley

http://www.members.shaw.ca/bobbycorner

Sent from my lowly PC

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers