Ubuntu

Digital simulation in qucs don't work

Reported by VladimirUA72 on 2008-10-30
16
Affects Status Importance Assigned to Milestone
freehdl (Ubuntu)
Undecided
Unassigned
qucs (Debian)
Fix Released
Unknown

Bug Description

Binary package hint: freehdl

Ubuntu 8.10 (29.10.2008)
qucs-0.0.14.1
freehdl-0.0.6 (/usr/lib/libfreehdl-kernel.la /usr/lib/libfreehdl-std.la)
Digital simulation break with next error:
...
running C++ conversion... done.
compiling functions... done.
compiling main... done.
linking...libtool: link: unable to infer tagged configuration
...
libtool: link: specify a tag with `--tag'

Aanjhan Ranganathan (aanjhan) wrote :

Confirmed. Unable to simulate digital stuff.

Changed in freehdl:
status: New → Confirmed
Jan-Pieter Jacobs (jpjacobs) wrote :

Hi, I got the same problem. a diff that fixes the problem is attached.
greetings,

Jan-Pieter Jacobs

Jan-Pieter Jacobs (jpjacobs) wrote :

of course, that's a patch for /usr/bin/gvhdl of the freehdl 0.0.6-2 package.
Jan-Pieter Jacobs

06.11.08 в 14:42 Jan-Pieter Jacobs в своём письме писал(а):

> of course, that's a patch for /usr/bin/gvhdl of the freehdl 0.0.6-2
> package.
> Jan-Pieter Jacobs
>

Thank your! It's work.

--
With best regards,
Vladimir N. Savchenko.

Ahmed Kotb (kotbcorp) wrote :

can any one illustrate how could apply this patch ??
Thanks and sorry my ignorance...

Jan-Pieter Jacobs (jpjacobs) wrote :

Hi Ahmed!

It's easy: save gvhdl.diff in a directory. If you don't need to use
gvhdl from within Qucs, you could copy the gvhdl script to the dir
where you need to use it, as I don't know
whether patching the gvhdl script in place will break updates.
If you want to use it directly from within Qucs, I guess you can patch
it anyway in the /usr/bin directory. Any how, go where gvhdl is, there
do:
 patch -b gvhdl < gvhdl.diff
That will change the script so it works. A backup is taken in case
something goes wrong (gvhdl.orig).
Now to use it just use ./gvhdl in that directory, or if you plan to
use it with qucs (As i don't find an option to change the vhdlsim
binary) i guess you need to copy the gvhdl script back to /usr/bin.

Hope this helps you!

Greets,

Jan-Pieter
* Ahmed Kotb <email address hidden> [090116 10:34]:
> can any one illustrate how could apply this patch ??
> Thanks and sorry my ignorance...
>
> --
> Digital simulation in qucs don't work
> https://bugs.launchpad.net/bugs/291075
> You received this bug notification because you are a direct subscriber
> of the bug.

--
You can check the integrity of this emailmessage with gpg.
Various gpg-frontends at http://www.gnupg.org/
My public key resides at http://jpjacobs.ulyssis.org/pubkey.asc
I use grml (http://grml.org/)

Ahmed Kotb (kotbcorp) wrote :

thanks for fast response but it didnt work....
qucs display this message
/usr/bin/qucsdigi: 82: libtool: not found

i think i have patched as u have said

ahmed@ahmed-pc:~/Desktop$ sudo patch -b /usr/bin/gvhdl < gvhdl.diff
patching file /usr/bin/gvhdl
ahmed@ahmed-pc:~/Desktop$

Ahmed Kotb (kotbcorp) wrote :

i was able to run it when i changed the model of the digital simulation component from VHDL to verilog
Sorry for wasting ur time

Jan-Pieter Jacobs (jpjacobs) wrote :

* Ahmed Kotb <email address hidden> [090116 12:56]:
> thanks for fast response but it didnt work....
> qucs display this message
> /usr/bin/qucsdigi: 82: libtool: not found

Then I guess you should file a bug against freehdl as gvhdl needs this
anyway, so it should be a dependancy.
The fix for this problem would just to install libtool, if you prefer
using vhdl instead of verilog...

Greets,

Jan-Pieter Jacobs
--
You can check the integrity of this emailmessage with gpg.
Various gpg-frontends at http://www.gnupg.org/
My public key resides at http://jpjacobs.ulyssis.org/pubkey.asc
I use grml (http://grml.org/)

scrad (ray-sinclair) wrote :

>>> The fix for this problem would just to install libtool,
>>> if you prefer using vhdl instead of verilog...

Just to say that I tried running a VHDL simulation in qucs
(that simulates OK with Verilog netlist format) returning:

    creating netlist... done.
    running C++ conversion... done.
    compiling functions... done.
    compiling main... done.
    linking...libtool: link: unable to infer tagged configuration

    error: libtool: link: specify a tag with `--tag'

using:
    ubuntu 8.10
    qucs 0.0.14-1
    freehdl 0.0.6-2
    libtool 2.2.4-0ubuntu4
    patched gvhdl with gvhdl.diff and checked that /usr/bin/gvhdl has:
              my $libtool_options = "--mode=link --tag=CXX";

VladimirUA72 (bearjr) wrote :

02.03.09 в 19:16 scrad в своём письме писал(а):

>>>> The fix for this problem would just to install libtool,
>>>> if you prefer using vhdl instead of verilog...
>
> Just to say that I tried running a VHDL simulation in qucs
> (that simulates OK with Verilog netlist format) returning:
>
> creating netlist... done.
> running C++ conversion... done.
> compiling functions... done.
> compiling main... done.
> linking...libtool: link: unable to infer tagged configuration
>
> error: libtool: link: specify a tag with `--tag'
>
> using:
> ubuntu 8.10
> qucs 0.0.14-1
> freehdl 0.0.6-2
> libtool 2.2.4-0ubuntu4
> patched gvhdl with gvhdl.diff and checked that /usr/bin/gvhdl has:
> my $libtool_options = "--mode=link --tag=CXX";
>

Just download freehdll from qucs.sourceforge.net, put it in usr/src/
compile and install, after patch gvhdl and it's work :)

--
With best regards,
Vladimir N. Savchenko.

Christopher Covington (cov) wrote :

(Pasted from my report for Gentoo bug #276611)

Digital simulations in QUCS 0.0.15 will fail because the qucsdigi script
expects freehdl-config to have the --linker option. The error seen by a user
is:

/usr/bin/qucsdigi: line 83: Usage:: command not found

The --linker option is available as of freehdl-0.0.7.

It is necessary to either modify the qucsdigi shell script, setting the LIBTOOL
variable to something valid or, preferably, bump freehdl and depend on the newer version.

Changed in debian:
status: New → Fix Released
affects: debian → qucs (Debian)
Sasa Paporovic (melchiaros) wrote :

Refering to

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=501768#10

this bug should be fixed with freehdl-0.0.6-3

Could someone confirm that it is fixed on Ubuntu13.04 developer branch with freehdl0.0.7 ?

tags: added: raring
Changed in freehdl (Ubuntu):
status: Confirmed → Incomplete
tags: added: patch
Changed in freehdl (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.