11.04 64bit Beta1 CD Installer crashed [no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so on amd64]

Bug #746758 reported by Jesse Palser on 2011-03-31
This bug affects 125 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
High
Canonical Desktop Team
Natty
High
Canonical Desktop Team
ia32-libs (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
ubiquity (Ubuntu)
High
Evan
Natty
High
Evan

Bug Description

Binary package hint: ubiquity

Hi,

I tried to install Ubuntu 11.04 64bit Beta1 CD
but it crashes during "Installing system".

I'll attach relevant logs next.
---
Architecture: amd64
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
Package: ubiquity 2.5.32
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
Tags: natty natty
Uname: Linux 2.6.38-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Jesse Palser (jessepalser) wrote :
Jesse Palser (jessepalser) wrote :
Jesse Palser (jessepalser) wrote :

My System Specifications:
- Dell XPS 420 (custom modified)
- Intel Core2Extreme 3.0GHz 4-Core CPU
- 8GB DDR2 RAM Memory
- nVidia GeForce GTS 450 1GB DDR5 VRAM PCIexpress Video Adapter
- Creative Sound Blaster Audigy SE PCI Sound Card
(hardware is working perfectly and I currently run 10.10 64bit on it)

tags: added: iso-testing
Jesse Palser (jessepalser) wrote :

I downloaded official 11.04 64bit Beta1 CD ISO
and verified its md5sum
and burned image to a CD
and verified the CD after burning.

I then rebooted computer with CD in drive.
CD boots fine and after a few minutes
I am greeted with the screen to run or install OS.

I click on install button
and it goes through install process
but at time of "Installing system"
the installer stops with an error message:
------------------------------------------------------------------------------------
(-) An error occurred while installing packages:
    E:Sub-process /usr/bin/dpkg returned an error code (1)
    The following packages are in a broken state:

     This may be due to using an old installer image, or it may be
     due to a bug in some of the packages listed above. More
     details may be found in /var/log/syslog. The installer will try
     to continue anyway, but may fail at a later point, and will not
     be able to install or remove other packages (possibly
     including itself) from the installed system. You should first
     look for newer versions of your installer image, or failing that
     report the problem to your distributor.

                                                                                      [OK]
------------------------------------------------------------------------------------
After I click [OK] the installer immediately says install finished
and the computer ejects the CD and it reboots
after which I just get a GRUB command prompt.
(The installation FAILED)

I've tried it 3 times, each time formatting the HDD.

What do I do now?
I participated in the Beta 1 testing here:
http://iso.qa.ubuntu.com/qatracker/result/5333/6

My System Specifications:
- Dell XPS 420 (custom modified)
- Intel Core2Extreme 3.0GHz 4-Core CPU
- 8GB DDR2 RAM Memory
- nVidia GeForce GTS 450 1GB DDR5 VRAM PCIexpress Video Adapter
- Creative Sound Blaster Audigy SE PCI Sound Card
(hardware is working perfectly and I currently run 10.10 64bit on it)

Hope someone can help and fix this
as I don't want to be force to wait until end of month
for the next Beta 2 release.

Thanks...

Jesse "JeZ+Lee"

Mar 31 21:29:17 ubuntu ubiquity: Download done.
Mar 31 21:29:17 ubuntu ubiquity: Flash Plugin installed.
Mar 31 21:29:17 ubuntu ubiquity: nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-installer/libflashplayer.so
Mar 31 21:29:18 ubuntu ubiquity: dpkg: error processing flashplugin-installer (--configure):
Mar 31 21:29:18 ubuntu ubiquity: subprocess installed post-installation script returned error exit status 1

summary: - 11.04 64bit Beta1 CD Installer crashed
+ 11.04 64bit Beta1 CD Installer crashed [error processing flashplugin-
+ installer]
affects: ubiquity (Ubuntu) → flashplugin-nonfree (Ubuntu)
Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
Jesse Palser (jessepalser) wrote :

I tried to install Ubuntu 11.04 64bit Beta1 CD into current VirtualBox, but the installer crashes at same point with same error on the virtual machine...

Evan (ev) wrote :

Jesse,

Your syslog is unfortunately cut off at the end. Are you able to reproduce this bug? If so, could I ask that you go through the following steps?
- Boot the latest daily-live CD (http://cdimage.ubuntu.com/daily-live/current) and press "Try Ubuntu" at the first screen.
- Open a terminal and type `ubiquity -d` followed by the enter key. Run through the installer exactly as you did before.
- When it crashes, open a terminal and type `sudo apport-collect 746758`. This will collect /var/log/syslog, /var/log/partman, and /var/log/installer/debug, then attach them to this bug report.
- Finally, open a terminal and type `sudo DEBIAN_FRONTEND=noninteractive chroot /target dpkg --configure -a`. If an error appears, copy and paste it into this bug report, along with /target/var/log/dpkg.log.

Thanks!

Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-2
status: New → Incomplete

apport information

tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

apport information

apport information

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ ubiquity -d
ubuntu@ubuntu:~$ sudo apport-collect 746758
The authorization page:
 (https://launchpad.net/+authorize-token?oauth_token=jjp4cj1LxHC0CrSnVNwg&allow_permission=DESKTOP_INTEGRATION)
should be opening in your browser. Use your browser to authorize
this program to access Launchpad on your behalf.

Waiting to hear from Launchpad about your decision...
Package flashplugin-nonfree not installed and no hook available, ignoring
Package flashplugin-nonfree not installed and no hook available, ignoring
ubuntu@ubuntu:~$ sudo DEBIAN_FRONTEND=noninteractive chroot /target dpkg --configure -a
Setting up flashplugin-installer (10.2.153.1ubuntu1) ...
Installing from local file /var/cache/flashplugin-installer/adobe-flashplugin_10.2.153.1.orig.tar.gz
Flash Plugin installed.
ubuntu@ubuntu:~$

Jesse Palser (jessepalser) wrote :

Uploaded failed installation logs according to your instructions...

Changed in ubiquity (Ubuntu Natty):
status: Incomplete → In Progress

Architecture: amd64
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
Package: ubiquity 2.5.32
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
Tags: natty natty
Uname: Linux 2.6.38-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

apport information

apport information

apport information

apport information

apport information

apport information

I was going to say that this was a duplicate of bug 745459. However, both Jesse's and Dan's logs show ia32-libs 20090808ubuntu11, which was supposed to have fixed that bug.

I have the same bug in both Virtualbox and native install if I check the box to install fluendo. If both boxes to install updates and fluendo are not checked the install finishes successfully in both virtual and native installs. Environment: AMD64, Phenom II X6, SATA 6GB, USB3, 8 GB Ram.

Dan Mordan (mordanda) wrote :

Not that I was expecting a fix, but I wanted to chime in and say I downloaded the daily build on 4-2 and the installer errors out at the same point. The flash error appears and about 30 seconds later the ubiquity crashes with the same error.

Changed in ubiquity (Ubuntu Natty):
status: In Progress → Triaged
Changed in flashplugin-nonfree (Ubuntu Natty):
importance: Undecided → High
status: Confirmed → Triaged
summary: - 11.04 64bit Beta1 CD Installer crashed [error processing flashplugin-
- installer]
+ 11.04 64bit Beta1 CD Installer crashed [no appropriate viewer found for
+ /usr/lib/flashplugin-installer/libflashplayer.so on amd64]
Bruce Miller (brm0423) wrote :

Earlier this week, I had a "day from hell" attempting to upgrade four different machines to natty. The moral of the story is to take detailed notes, which I failed to do and therefore the following is from memory.

This bug affects both the kubuntu and ubuntu beta1 amd64 releases. To the best of my painful memory, the i386 builds also suffer the same problem. The "alternate" versions of the .iso suffer a different bug (cannot mount CD-ROM) which I have reproduced on several machines and reported as another bug. It all contributed to making the effort to upgrade to natty an experience that I hope never to repeat :-(.

And I have almost thirty years experience at breaking development software --- and the battle scars to show for it <grin>.

Changed in flashplugin-nonfree (Ubuntu Natty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
milestone: none → ubuntu-11.04-beta-2
Joel Berger (joel-a-berger) wrote :

Since my bug has gotten merged several times I would like to mention that my bug occurred when installing 'ubuntu-restricted-extras' and specifically 'flashplugin-nonfree' on a completed install of Natty from a command line ('apt-get'), and thus is independent of Ubiquity and the system install process.

Evan (ev) on 2011-04-11
Changed in flashplugin-nonfree (Ubuntu Natty):
status: Triaged → Invalid
Changed in ubiquity (Ubuntu Natty):
status: Triaged → Invalid
Changed in ia32-libs (Ubuntu Natty):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 20090808ubuntu12

---------------
ia32-libs (20090808ubuntu12) natty; urgency=low

  * Set LDCONFIG_NOTRIGGER=y to cope with the ldconfig cache not being up to
    date (LP: #746758). Thanks Colin Watson!
 -- Evan Dandrea <email address hidden> Mon, 11 Apr 2011 11:33:48 +0100

Changed in ia32-libs (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers