Flashplugin-nonfree fails: downloads non-existing plugin

Bug #616670 reported by mhotze on 2010-08-12
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flashplugin-nonfree

Lucid; 10.04.

Flashplugin-nonfree wants to download http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.1.53.64.orig.tar.gz, but this does not exist.

Output sudo apt-get install:

:~$ sudo apt-get install flashplugin-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  flashplugin-installer
Suggested packages:
  konqueror-nsplugins msttcorefonts ttf-bitstream-vera ttf-dejavu
  ttf-xfree86-nonfree xfs
The following NEW packages will be installed:
  flashplugin-installer flashplugin-nonfree
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/22.1kB of archives.
After this operation, 233kB of additional disk space will be used.
Do you want to continue [Y/n]?
Preconfiguring packages ...
Selecting previously deselected package flashplugin-installer.
(Reading database ... 146470 files and directories currently installed.)
Unpacking flashplugin-installer (from .../flashplugin-installer_10.1.53.64ubuntu0.10.04.3_i386.deb) ...
Selecting previously deselected package flashplugin-nonfree.
Unpacking flashplugin-nonfree (from .../flashplugin-nonfree_10.1.53.64ubuntu0.10.04.3_i386.deb) ...
Setting up flashplugin-installer (10.1.53.64ubuntu0.10.04.3) ...
Downloading...
--2010-08-12 11:28:17-- http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.1.53.64.orig.tar.gz
Resolving archive.canonical.com... 91.189.88.33
Connecting to archive.canonical.com|91.189.88.33|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2010-08-12 11:28:17 ERROR 404: Not Found.

download failed
The Flash plugin is NOT installed.

Setting up flashplugin-nonfree (10.1.53.64ubuntu0.10.04.3) ...
:~$

mhotze (m-hotze) wrote :

To reproduce:

sudo apt-get remove flashplugin-nonfree
sudo apt-get autoremove
sudo apt-get install flashplugin-nonfree

Please fix, this is a show-stopper for Flash in Firefox.

mhotze (m-hotze) on 2010-08-12
description: updated
mhotze (m-hotze) wrote :

Issue is caused by an older version of Flashplugin-nonfree; the original plugin that would have been downloaded is removed from the server at Canonical, and the newer version installed.

Workaround: press "Reload" in Synaptic, or issue the command "sudo apt-get update", then re-install both Flashplugin-nonfree and Flashplugin-installer. This newer version downloads the correct Flash plugin from Canonical.

Changed in flashplugin-nonfree (Ubuntu):
status: New → Fix Committed
Hb (hbb) wrote :

Successful was here:

sudo rm /var/lib/dpkg/info/flashplugin-nonfree.prerm
sudo dpkg --remove --force-remove-reinstreq flashplugin-nonfree
sudo dpkg --purge --force-remove-reinstreq flashplugin-nonfree

as recommended in http://linuxundich.de/de/ubuntu/flashplugin-nonfree-in-schlechten-inkonsistenten-zustand/

JC Hulce (soaringsky) wrote :

This bug has been marked as Fix Committed for over a year. If the fix has made it into Ubuntu, please mark this bug as Fix Released. If the fix has been released upstream, but not Ubuntu, create a new bug asking for the new version and tag it with upgrade-software-version. If this bug has not been fixed anywhere, change the status back to Confirmed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers