Ubuntu

MASTER: Choppy Flash playback in full screen

Reported by exploder91 on 2009-03-21
232
This bug affects 35 people
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned

Bug Description

[Problem]
Adobe's Flash player can exhibit very poor playback behavior, due to issues in how it implements GPU
acceleration on Linux.

[Workarounds]
Each of these workarounds has its pros and cons. Some work for certain flash performance bugs but not others.

A. Disable compiz

B. Disable GPU validation. Note: Only works on 32-bit Flash
1. sudo mkdir /etc/adobe
2. sudo nano /etc/adobe/mms.cfg
3. Paste "OverrideGPUValidation=true" (without quotation marks)
4. Restart Firefox.

C. Switch to a different (open source) Flash implementation

D. Use the YouTotem Greasemonkey script to play flash videos, using Totem, mplayer, vlc, or other players
1. Install Greasemonkey - https://addons.mozilla.org/en-US/firefox/addon/748
2. install YouTotem Greasemonkey script - http://userscripts.org/scripts/show/25481

If none of these make any change to your Flash video playback
performance, you may well have a unique bug. In that case, do not add
comments to this bug report but instead file a NEW one against
flashplugin-nonfree.

[Discussion]
"Choppy flash playback" is actually a generic symptom which is caused by a collection of different bugs. This
is why a workaround that "solves" it for one person, doesn't work for another, and also why it may seem to be
video driver specific.

However, if you download the flash video (e.g. look in /tmp/Flash* while
the video is playing in firefox) and then play it in another video
player (like mplayer), it works fine.

As an example, Adobe Flash assumes that none of the open source video
drivers provide hardware acceleration, so it forces software
acceleration to be used in these cases. It determines this by looking
for "SGI" in the client glx vendor string. A long time ago, that was an
okay assumption to make - few open source drivers provided accelerated
OpenGL - but these days all the major drivers do supply it. It is
possible to turn off Flash's GPU validation to bypass this behavior (see
below).

Adobe also has found trouble making Flash video work with Compiz. So
even in situations where the video card does hardware acceleration for
OpenGL, it's possible this could cause instabilities if compiz was on.

For additional background and explanations by Adobe as to why it doesn't
use your graphics card's hardware acceleration in various circumstances,
see:

 http://blogs.adobe.com/penguinswf/2008/05/flash_uses_the_gpu.html

For more information including a series of different workarounds, please
see:

 http://firefox-tutorials.blogspot.com/2010/05/flash-optimization.html

[Upstream Status]
The problems with flash performance on Linux have been communicated to Adobe, and Adobe has communicated their
position on the issues. For example:

http://bugs.adobe.com/jira/browse/FP-83
http://bugs.adobe.com/jira/browse/FP-1692
http://blogs.adobe.com/penguinswf/2008/05/flash_uses_the_gpu.html
http://blogs.adobe.com/penguinswf/2010/01/solving_different_problems.html

[Ideas]
A. What if Ubuntu just forced OverrideGPUValidation in general? Just how much stability trouble would we be in
with Compiz?

B. Is there any way we could make the full screen function launch the
default video player in full screen rather than just let flash try to do
it and get choppy?

[Original Report]
I am running Ubuntu Jaunty 32 bit updated to March, 20th, 2009. Playback using Flash works as expected so long
as I do not run it in full screen. Playing youtube videos in full screen results in choppy playback and it acts
like it is out of sync. It does not appear to be an issue with Flash itself because the same version of Flash
works in Hardy and Intrepid. I believe the problem could be in the restricted modules because an update improved
the problem somewhat.

  I was unable to find an existing bug report for this problem for Ubuntu
  9.04 and I do of course understand that Jaunty is still currently in the
  alpha stage of development. If this has already been reported, please
  merge this with any existing report.

  My system is using on board Intel graphics and is using the supported
  open source driver.

I also have the same issue I am running Ubuntu 9.04 ALpha 6 03/24/09 and my full screen video is choppy.

exploder91 (d-cosner) wrote :

I thought I should mention that I have desktop effects turned off and I have Intel on board graphics. Full screen flash worked fine in Hardy and Intrepid. Just trying to provide complete information.

Bakon Jarser (jman88888) wrote :

Flash videos are choppy for me too utisn 32 bit jaunty. Flash videos ran flawlessly in Intrepid.

Solapse (solapse) wrote :

Having precisely the same issue, Dell Inspiron 1300 - Flash nonfree plugin, have tried repo version and adobe versions. Have tried with both Firefox, Opera 10 Alpha and Epiphany with the same results.

As with the other users, I didn't have any issue with Hardy with Compiz turned on or off. I am having a better time with the stuttering/sync problems with Opera if that is of any help. Running 2.6.28-11 Generic, have tried on several earlier kernels and no change.

I can very much confirm this bug.

I'm using a fully updated Jaunty and have an Intel Integrated Graphics Chipset on my machine I'm testing on.

Conn O Griofa (psyke83) wrote :

Please see the following post: http://blogs.adobe.com/penguin.swf/2008/08/secrets_of_the_mmscfg_file_1.html

Does the "OverrideGPUValidation=true" setting help?

exploder91 (d-cosner) wrote :

I looked at the post. The hidden Adobe folder in Home is just a bunch of empty folders. There is nothing in /etc either.

Conn O Griofa (psyke83) wrote :

You need to create the directory and file manually, e.g.:

$ sudo mkdir /etc/adobe
$ echo "OverrideGPUValidation=true" >~/mms.cfg
$ sudo mv ~/mms.cfg /etc/adobe/

For Flash 10 in Intrepid this worked very well for my Intel 855GM graphics, but it causes fullscreen crashes in Jaunty (probably due to the GEM/UXA mess).

exploder91 (d-cosner) wrote :

I followed your instructions and the problem is resolved! Is there a way to make this a fix for Jaunty?

exploder91 (d-cosner) wrote :

I spoke too soon, it works for youtube videos but the problem is still present in Fancast. In Fancast it even locks up Firefox.

Conn O Griofa (psyke83) wrote :

My suspicion is that it's not going to be "fixed" in Jaunty, as it's far too dangerous to force GPU acceleration of the Flash plugin on all systems. Most open-source drivers have flaky OpenGL acceleration at the moment.

Read the original post I linked, and this page as well: http://blogs.adobe.com/penguin.swf/2008/05/flash_uses_the_gpu.html

In a nutshell: Flash GPU acceleration doesn't mix well with compiz, and it doesn't work for every kind of Flash content in the wild.

exploder91 (d-cosner) wrote :

I hope your suspicions are wrong because flash videos pretty much cripples Firefox in this release. You are absolutely right about OpenGL acceleration being flaky, even playing a DVD movie is somewhat difficult at this time. Honestly, Jaunty has the potential to be the best release to date if it was not for the video acceleration issues and Evolution's extremely buggy behavior. I would guess that Evolution will receive fixes upstream.

What are the chances of seeing updates for xserver-xorg and xserver-xorg video drivers for the Jaunty release?

I ask that question because this release has a very good boot time, professional appearance, good memory use and up to date applications. The level of quality is exceptional with the exception of Evolution, which hopefully will get some attention upstream. In business, they say to be genuinely successful the key is to meet or exceed the customer's expectations. This release is so close to doing just that. I did not intend to go off topic but my thoughts are that Jaunty has the potential to achieve Cannonical's goal of being self supporting and profitable. It would be a real missed opportunity if the few remaining issues were not addressed.

exploder91 (d-cosner) wrote :

I tried installing the flashplugin-nonfree-extrasound package hoping to see some improvement, unfortunately there was no noticeable change.

nullack (nullack) wrote :

The root cause of this problem is that Linux has a broken video architecture (its being worked on for fixing). Its not really the fault of compiz, its symptomatic of compiz like functions not the cause. Fixing it requires video architecture changes and corresponding video driver changes that have already taken a long time to get this far, and the work is not completed yet.

This problem and a number of other related issues can be worked around by disabling compiz. Trying to force run these sorts of functions with composting on is dangerous.

exploder91 (d-cosner) wrote :

This is the on board Intel graphics I am using.

00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)

I have Compiz turned off. The problem also effects DVD playback as well.

I get exactly the same issue with a intel GMA 4500MHD chipset. I think this is a very important issue wich should be fixed before realesing Jaunty.

DarKnyht (darknyht) wrote :

I am experiencing Flash problems using AMD 64 and nVidia graphic chip. Only the playback issues also exist with non-full screen apps. Like others have said, recent updates seem to have improved the situation but some sites (picknik.com, hulu.com) still act strange.

I am not running Compiz, but I am using the compositing feature of Metacity. Mostly because I don't want all the extras of Compiz but i want to run Avant Window Navigator and I like shadowed windows.

zaphodbblx (zaphodbblx) wrote :

same thing here! Dvd playback is fine and dandy but flash video is choppy and laggy.
not running compiz on a onboard intell video card set to max for memory

zaphodbblx (zaphodbblx) wrote :

I should have added default sized playback is also fine

Bryan Moore (moore-bryan) wrote :

i seem to have been able to possibly solved this through some changes in my xorg.conf file and compizconfig settings manager; see ubuntuforum post (http://ubuntuforums.org/showthread.php?p=7038449).

kuser (nuca-nunca) wrote :

confirming, since upgrade to kubuntu jaunty alpha 32bit on 7th of april 2009, flash playback on fullscreen is choppy / laggy / jerky.
intel 915GM
this is new.
i tried upgrading to adobes newest release, no avail.
tried older 10 versions of adobe, no avail.
tried free alternative gnash and all its plugins, but unfortunately it did not playback any flash at all....
going to try UXA accel option mentioned here:
https://wiki.ubuntu.com/X/UxaTesting

kuser (nuca-nunca) wrote :

UXA accel option mentioned above works fine on my chipset i915gm, bUT unfortunately does not improve flash-playback@fullscreen a bit. it is really bad, now i cannot watch the news in fullscreen.. is there a reason for this new behaviour?
is this a flash-bug?

tryed reinstalling metacity as mentioned in anothr post...no dice!
--
Ubuntu..... Linux for human beings

I will try what was suggest above, but I have been having this issue since 9.04 Alpha 5 (that is when I switched). I guess I need to just bite the bullet and turn Metacity Compositing off that is the source of the issue.

I think the bigger issue is that it doesn't matter if we can tweak under the hood to fix it, but that someone new to Ubuntu would look at this and say, "Flash doesn't work on Linux." This is something that needs to be fixed before 9.04 goes out the door. As others have said, this version of flash worked in 8.10 and it should work properly in 9.04.

Majki-Fajki (miles-teg) wrote :

That's right. Final version is coming, and we have very depressing bug.

"Linux - you can't even watch Youtube"

I'm on beta and it's really annoyng bug.

kuser (nuca-nunca) wrote :

oh, i forgot to mention, that turning off composite in kwin (kubuntu) has no effect at all.
others mentioned that on ubuntu, turning off compiz, makes no difference, too.
i guess we will have to see were the real problem is...

yeah and: you can watch all flash movies without problems , as long as you don't watch them fullscreen... but this cant be too convincing...

DarKnyht (darknyht) wrote :

Definately not a flash issue. I just ran Hulu.com at fullscreen from within Epiphany and had no playback problems. Everything ran as it should.

So my guess is that this is an issue with Firefox.

kuser (nuca-nunca) wrote :

after today's updates which also shipped an adobe-flashplugin-nonfree-pkg update, things run somewhat better. now there are some choppy moments in the beginning of the playback and afterwards all 5 seconds the video-playback stucks a bit... i can not imagine how it could be firefox-related... my guess is that something changed within ubuntu and reveals somekind of an weakness in the flash-plugin!?

Funny I tryed running in Epiphany and had the same playback problem(choppy
fullscreen)

On Sat, Apr 11, 2009 at 8:48 AM, DarKnyht <email address hidden> wrote:

> Definately not a flash issue. I just ran Hulu.com at fullscreen from
> within Epiphany and had no playback problems. Everything ran as it
> should.
>
> So my guess is that this is an issue with Firefox.
>
> --
> Choppy Flash playback in full screen.
> https://bugs.launchpad.net/bugs/346289
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Ubuntu..... Linux for human beings

This is everything I did this morning.

First I removed all synaptics installed Flash packages (flashplugin-nonfree, flash installer, flash sound extras) and the ubuntu restricted extras.

Second, downloaded a fresh copy of Flash from adobe (.deb package)

Third, followed the instructions here http://www.psychocats.net/ubuntu/firefox to install the Firefox 3.1 beta 3. I did have to manually install it using sudo nautilus (sorry I am not terminal savy) and then running the commands listed

sudo mv /opt/firefox/plugins /opt/firefox/plugins.backup
sudo ln -s /usr/lib/xulrunner-addons/plugins /opt/firefox/plugins
sudo dpkg-divert --divert /usr/bin/firefox.ubuntu --rename /usr/bin/firefox
sudo ln -s /opt/firefox/firefox /usr/bin/firefox

Last, removed firefox 3.1 and directed links back to Ubuntu version:

sudo rm /usr/bin/firefox
sudo dpkg-divert --rename --remove /usr/bin/firefox
sudo rm -r /opt/firefox

The only difference I am noticing from a user endpoint is that Flash 10.0 r12 is no longer listed as a plugin after doing all this. Hopefully someone can streamline this process and make it easier to remove Flash 10.0 r12 because I think that is the source of the problem. (Flash won't play if 10.0 r12 is disabled when both are installed implying it is the version being used).

Majki-Fajki (miles-teg) wrote :

For example in Mandriva problem doesn't exists.
Canonical has to do something!

Gannin (spacesword) wrote :

I have this same problem in Ubuntu 8.10. I have the latest version of Flash and the nVidia driver installed, and I have an nVidia 8600GT card. I'm not using Compiz. Full screen videos from YouTube, Hulu, and South Park are all jerky. The above workaround for trying to force hardware acceleration doesn't do anything for me. The only thing I've found that works so far is to keep switching back and forth and back and forth between full screen and windowed mode, and if you do that enough times, eventually one of the times you switch to full screen it'll start running smoothly like it should.

That makes it sound like a caching problem, no?

On Sun, Apr 12, 2009 at 3:40 AM, Gannin <email address hidden> wrote:

> I have this same problem in Ubuntu 8.10. I have the latest version of
> Flash and the nVidia driver installed, and I have an nVidia 8600GT card.
> I'm not using Compiz. Full screen videos from YouTube, Hulu, and South
> Park are all jerky. The above workaround for trying to force hardware
> acceleration doesn't do anything for me. The only thing I've found that
> works so far is to keep switching back and forth and back and forth
> between full screen and windowed mode, and if you do that enough times,
> eventually one of the times you switch to full screen it'll start
> running smoothly like it should.
>
> --
> Choppy Flash playback in full screen.
> https://bugs.launchpad.net/bugs/346289
> You received this bug notification because you are a direct subscriber
> of the bug.
>

As an update to my earlier post, I enabled the UXA and it helped enormously with playback for most video streaming websites other than Megavideo. I'm wondering if perhaps the version of video Megavideo uses is older than that of other sites so that's the reason for sloppy playback...

kuser (nuca-nunca) wrote :

hi, i got it solved thanks to very smart people!!! fullscreen flash no problem anymore, here the links:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/314928
and here psyke83 explains it again:
http://ubuntuforums.org/showthread.php?t=1120129&page=3

Øyvind Stegard (oyvinst) wrote :

I have the exact same problem with the Adobe Flash plugin in Jaunty beta, both on a 32bit ATI-based laptop (radeon-driver) and a 64bit machine with nVidia proprietary driver. It's slower than ever in fullscreen .. Too bad this ugly problem reared its head so close to release .. :(

Jayhawk (brandoncolorado) wrote :

I am able to reproduce the problem in 9.04 UNR with GNASH as well.

cfrey (chrisdfrey) wrote :

I have a Dell Inspiron 1525, and after upgrading from 8.10 to the 9.04 RC I found fullscreen flash unusable (because of choppiness).

Enabling UXA fixed this for me, but it took a long time for me to find the solution.

molecule-eye (niburu1) wrote :

Just updated from 8.10 Intrepid to 9.04 RC Jaunty and I'm now getting the laggy fullscreen flash problem. On the upside, I am getting sound now! Interesting pay off. Haven't tried UXA or other fixes yet.

molecule-eye (niburu1) wrote :

Myself and numerous others have a found a solution to this (at least for Intel chipsets). Check out the bug report filed at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/314928.

Pappan (ppadman) wrote :

This maybe a dupe of bug 314928.

tags: added: likely-dup
DarKnyht (darknyht) wrote :

Similar but not a dupe. The original issue is that Flash is not working with the NVIDIA chipset. Everytime someone reports this issue, it is high-jacked by Intel Mobility Chipset people. This is not an issue with Intel Chipsets, it is an issue with the NVIDIA chipsets.

Granted, it may be related to the changes made on the Intel Chipset. However, I do not see how it is a duplicate of an issue with an entirely different chipset manufacturer.

Dušan Miletić (karl3) wrote :

i don't think it's related to any chipset - ppl with all kinds of chipsets face this problem, and i have tried virtually every intel tweak i could find and none worked. this is what solved the problem for me:

sudo mkdir /etc/adobe
echo "OverrideGPUValidation=true" >~/mms.cfg
sudo mv ~/mms.cfg /etc/adobe/

thnx conn

NickTouik (touikan) wrote :

I am running Jaunty official release I had the same problem and I confirm that

sudo mkdir /etc/adobe
echo "OverrideGPUValidation=true" >~/mms.cfg
sudo mv ~/mms.cfg /etc/adobe/

Fixed the problem

NickTouik (touikan) wrote :

By the way compiz was never running and I still had the problem.

panda (1eddie4) wrote :

Upgrade Jaunty to the latest kernel 2.6.30rc3. Adobe flash work much better.

The next procedure, only works for youtube videos (flash in full screen mode).

---------------------
sudo mkdir /etc/adobe
echo "OverrideGPUValidation=true" >~/mms.cfg
sudo mv ~/mms.cfg /etc/adobe/
------------------------

I have installed:

- Ubuntu 9.04, kernel 2.6.28-11-generic
- Intel Corporation 82945G/GZ Integrated Graphics Controller.

itemirus (itemirus) wrote :
Download full text (5.5 KiB)

Same problem here
Choppy video fullscreen on youtube, googlevideo, break.com, everywhere :-(

The procedure
---------------------
sudo mkdir /etc/adobe
echo "OverrideGPUValidation=true" >~/mms.cfg
sudo mv ~/mms.cfg /etc/adobe/
------------------------

did NOT solve any problems for me

Until Ubuntu and GNU/Linux doesn't solve these horrible issues, it has zero chance becoming the next desktop OS.
Everything should work out of the box - you can't expect the next door guy to tamper with kernels and stuff from the command line every time they want their system to perform basic stuff.

Here the config of my 2 year old system

Description: Ubuntu 9.04
Release: 9.04

~$ uname -a

Linux 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

~$ lspci

00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce 430 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control

~$ aptitude show xserver-xorg-video-intel

Pacchetto: xserver-xorg-video-intel
Stato: installato
Installato automaticamente: no
Versione: 2:2.6.3-0ubuntu9
Priorità: opzionale
Sezione: x11
Responsabile: Ubuntu X-SWAT <email address hidden>
Dimensione pacchetto installato: 1323k
Dipende: libc6 (>= 2.4), libdrm-intel1 (>= 2.4.5), libdrm2 (>= 2.3.1),
         libpciaccess0 (>= 0.8.0+git20071002), libxext6, libxv1, libxvmc1,
         xserver-xorg-core (>= 2:1.5.99.901)

Va in conflitto: 915resolution, xserver-xorg-driver-i810,
                 xserver-xorg-video-i810 (< 2:1.9.91-1),
                 xserver-xorg-video-i810-modesetting,
                 xserver-xorg-video-intel-modesetting

Sostituisce: xserver-xorg (< 6.8.2-35), xserver-xorg-driver-i810,
             xserver-xorg-video-i810 (< 2:1.9.91-1),
             xserver-xorg-video-i810-modesetting,
             xserver-xorg-video-intel-modesettin...

Read more...

Niri (m-niranjan) wrote :

This solution worked for me! :)

sudo mkdir /etc/adobe
echo "OverrideGPUValidation=true" >~/mms.cfg
sudo mv ~/mms.cfg /etc/adobe/

But the rendering is not as smooth as I'd expected.
Patch it with an update, guys.
Thanks.

Tested on Firefox and Opera with flash 10 on Jaunty 9.4

----{

Conn wrote on 2009-03-25: (permalink)

You need to create the directory and file manually, e.g.:

$ sudo mkdir /etc/adobe
$ echo "OverrideGPUValidation=true" >~/mms.cfg
$ sudo mv ~/mms.cfg /etc/adobe/

For Flash 10 in Intrepid this worked very well for my Intel 855GM graphics, but it causes fullscreen crashes in Jaunty (probably due to the GEM/UXA mess).
}----

This solution has worked for me as well(Intrepid 64-Bit with Atheros)

Censor (flottinews) wrote :

Also affects me on an ATI X700, 9.04, compiz activated.

The "OverrideGPUValidation..." did not solve the problem.

CPU' load is about 70% in normal youtube videos and above 100% (means slightly choppy video playback) during full screen flash video playback.

This has to be solved, should be seen as a major issue. People can not view the news in fullscreen on a linux pc.

Chad (dega704) wrote :

I have been having this same issue with Jaunty 64-bit and a geforce 8600 gt. Flash gets really choppy in fullscreen and in some cases even without going to fullscreen. Switching to metacity makes no difference. The "OverrideGPUValidation=true" fix seems to have worked somewhat, but it can still get choppy especially when I move the mouse.

What I find interesting is my CPU load goes through the roof whenever I switch flash to fullscreen. What is going on that can make an athlon X2 6000+ and the previously mentioned video card get pushed to their limits over something they have no problem with in windows?

On some sites like hulu I can right-click the flash player and set the quality to medium or low and that helps quite a bit, albeit at the cost of making the video look crappy.

I previously had no problems with this in hardy 8.04.

Aside from this jaunty has performed spectacularly and I have been extremely impressed with it, but it's really annoying when one of the most basic yet essential functions for the average user goes out of whack, and could send a new linux user running back to windows very quickly.

chocolateboy (chocolateboy) wrote :

@Chad: try installing the CPU Frequency Scaling Monitor applet and setting the governor to "performance" (rather than "ondemand").

See here for more information:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/367739

elijah (elijah) wrote :

I would just like to echo the sentiments here: this is a serious problem and ubuntu's silence and lack of movement on this is disturbing.

I have tried all the possible fixes listed everywhere on the internet, compiz on/off, all the available nvidia drivers, past versions of flash, etc. After reverting everything back to the way it was under ibex (except for the kernel), I think that people who blame the ubuntu 2.6.28 probably have it right. Reportedly, 2.6.28 does not have this problem under other distros, just ubuntu.

Chad (dega704) wrote :

Thanks chocolateboy. That completely fixed it for me. Funny thing is I already had that on my panel so it should have been obvious. I just had to do a dpkg-reconfigure to be able to change the governor. Works flawlessly now.

Pip (allred-b) wrote :

For me it seems to be more of a processor issue. I have posted a fix here.
http://allredb.wordpress.com/2009/05/07/speed-up-flash-and-firefox-in-ubuntu-jaunty-904/

Brett Alton (brett-alton) wrote :

I can confirm this with an nVidia GeForce 6800 and that flashplugin-nonfree has been extremelly choppy in fullscreen mode since Flash was available in Ubuntu.

Andres Mujica (andres.mujica) wrote :

@exploder91

This is a dupe from bug #314928 , however i would need the output from cat /proc/mtrr to confirm that.

Thanks in advance

PD: Please note that the solution to this problem is composed by a kernel update and a xorg update, more details at the linked bug

affects: ubuntu → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) on 2009-07-16
tags: added: jaunty
Bryce Harrington (bryce) wrote :

With the changes that have gone into Karmic, I believe this issue is long gone (I agree it's probably a dupe of 314928).

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
Shaya Potter (spotter) wrote :

I don't see how its gone on karmic.

I have the issue w/ ATI (FireGL card) on my T42p laptop. plays fine in 100% size, but when expanded to full screen, it goes all choppy. and the overridegpu doesn't help.

Dan Gilliam (geocritter) wrote :

Still here for me too in Karmic. I've got the intel 955 chipset. I was running fedora for a while, which didn't seem to suffer from this problem. Laptop is a toshiba M55.

Dan Gilliam (geocritter) wrote :

Thought I'd add in an observation: With Karmic, if I play a flash video in fullscreen, it starts off playing just fine (e.g., youtube). BUT...if I move the mouse, that's when it gets choppy. If I stop moving the mouse, it will usually resume playing properly. If I move the mouse and stop a few more times, it finally stops playing correctly even when the mouse is not moving. It almost acts like a memory issue between the mouse and the flash player, where the mouse fills up some buffer or something and takes up all the memory that flash is using. I don't know anything about the memory allocation, I'm just saying that that's what it makes me think of as I watch it.

Warren Elkins (wb-gci) on 2009-12-05
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Fix Committed
DanielRoesler (diafygi) wrote :

Why was this marked as fix committed? I am still having the problem and the upstream bugs have not been fixed.

http://bugs.adobe.com/jira/browse/FP-1692
http://bugs.adobe.com/jira/browse/FP-83
http://bugs.adobe.com/jira/browse/FP-1660
http://bugs.adobe.com/jira/browse/FP-2279

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Confirmed

I have the exact same issue as Dan Gilliam, videos get choppy when i move the mouse in Fullscreen, Changing the frequency to "performance" does help but does not correct the issue (video gets less choppy when mouse moves, but its still choppy)

pkchips (edric-chan23) wrote :

This bug is still present.

In Ubuntu 9.04, the OverrideGPUValidation trick worked for me, and Youtube/iplayer started playing even 1080p videos full speed in fullscreen mode, and other websites were noticeably faster. Before the fix, even 360p videos were very choppy on laptop (M1710 with 7900GTX, 2.16 GhZ)

In Ubuntu 10.04, the same fix no longer works. Why does Flash no longer look inside the /etc/adobe folder in Ubuntu 10.04? Perhaps there is a new location where the mms.cfg file needs to go?

Chris Conway (cconway) wrote :

I started having this problem on upgrade to Lucid with NVIDIA hardware. The OverrideGPUValidation fix doesn't do anything for me. The up_threshold trick described in Bug #367739 seems to be working, though. If I understand correctly, this is just a workaround: it makes sure the CPU can pick up the slack when Flash doesn't take advantage of hardware acceleration.

Ron_ (ronald-liebman) wrote :

This bug has been present on my Karmic amd_64 setup from the start. It seems to affect most NYTimes videos, though most YouTube videos come out clean.

I have tried all of the above fixes without success. I like some of the features of Compiz (e.g., Place Windows), and since disablng it does not improve my videos, I left it on.

This is probably an underpowered machine (e.g., GeForce 6150SE nForce 430, nVidia drivers), but since I use Compiz, I apparently can't take advantage of better hardware acceleration anyway.

I developed a crude workaround using Greasemonkey that enlarges the NYTimes' embedded Flash player by about 250%. (Find it at http://userscripts.org/scripts/show/90955 .) This gives me flicker-free, high quality video at an acceptable size.

Comparing the results from my work-around to full-screen, I notice that I get the most flickering not during the fastest motion, but during the most sound. Perhaps this will suggest a possible solution strategy.

Yan Lagacé (words4yan) wrote :

Hi all,
so as someone coming from Win7 having just decided Ubuntu 10.10 is to be my new choice as a primary OS, I have been doing what I always do to any OS I use...customizing to perfection or close lol.

In any case up until a few days ago I had spent a great deal of time researching how to address Youtube fulls screen freezing and HD playback issues.

So having tried all the fixes and workarounds I could find, including testing Youtube in Opera, Chromium, and Firefox 4 beta, I was about to forget about it because nothing was working.

Then I found the solution for me...simply remove compiz and its core then reboot! Afterwards Youtube HD playback and fullscreen mode worked flawless. Finally time to watch every preview for Tron Legacy in all their HD brilliance ;-)

So if nothing else is working for you and you can live without compiz effects, remove it completely, reboot and hopefully all will be running just fine for you.

I still have a great deal to learn about Ubuntu for sure, but for now its time to watch a little Youtube HD and relax...finally!

Cheers,
Yan

Bryce Harrington (bryce) on 2010-11-23
summary: - Choppy Flash playback in full screen.
+ Choppy Flash playback in full screen, solved by
+ OverrideGPUValidation=true
summary: - Choppy Flash playback in full screen, solved by
- OverrideGPUValidation=true
+ Choppy Flash playback in full screen
Bryce Harrington (bryce) on 2010-11-23
summary: - Choppy Flash playback in full screen
+ MASTER: Choppy Flash playback in full screen
Bryce Harrington (bryce) on 2010-11-23
description: updated
description: updated
Bryce Harrington (bryce) wrote :

Hello Gentlemen,

To hopefully quell the amount of comments this bug report is getting, I've taken some time to fill in the description of this bug report with a summary of the situation. Please take a moment to read it.

Really, this is not a video driver bug specifically, but rather an issue with how Adobe Flash is implemented to *use* the video driver. That's why the behavior can vary depending on the type or version of video driver being tested. Also, really it's not just one specific bug, but a collection of issues several of which are fundamental design flaws in Adobe's implementation. Adobe has provided some nicely written and illustrated materials explaining these design issues, which I've linked to in the description and would encourage you to check out.

I am not sure there is really anything we can do at the distro level. There are a couple workarounds I can think of, but I have a feeling they'd end up causing more breakages than they solve. It would be interesting to experiment with them, but unfortunately my plate is quite full with other projects so I will leave the experiments to any of you that would like to indulge your curiosity.

In the one case, where we would force OverrideGPUValidation=true as a default in flashplugin-nonfree, this is quite straightforward to implement - just include a config file in the flashplugin-nonfree debian/ directory to be installed to /etc/adobe/ when the package is installed. The challenge is that we would need this tested across a breadth of different video driver combinations, with and without Compiz and/or Unity enabled. This could be crowd-sourced, with results tabulated in a wiki similar to how we've done with other testing (see the results table on https://wiki.ubuntu.com/X/Testing/NouveauEvaluation ... something akin to that would be nice).

The other option I can think of would be to redirect the 'fullscreen' action in Flash, to launch Totem or whatever the default video player is. For this option, we'd need to see a working proof of concept that folks could play with. This has some obvious tradeoffs in terms of usability so the benefit would need to be quite striking. I think this would be a fairly straightforward project one of you could do.

There could well be other options as well I've not thought of. In any case, what we need are proof of concepts that demonstrate that they do indeed work. Please keep in mind that what works for you may not work as well for someone else, but for Ubuntu we need to address as broad a range of user needs as possible, so the more testing you can do of your concept, the better.

I hope all this information is useful, sorry this is not an issue we can trivially fix at the distro level. I am hopeful that this explanation inspires someone to produce a good proof of concept of some better solution, that would let the Desktop team invest resources into getting it integrated into Ubuntu proper for everyone.

affects: xserver-xorg-video-intel (Ubuntu) → flashplugin-nonfree (Ubuntu)
Changed in flashplugin-nonfree (Ubuntu):
status: Confirmed → New
chocolateboy (chocolateboy) wrote :

@Bryce Harrington: please don't change the original report (unless you're the original reporter), and please don't attempt to "resolve" the issue in the title of the bug report.

There are multiple suggestions/workarounds/solutions in this thread, and the Adobe developer who has discussed this issue makes it clear that the modification you keep advertising (which we're probably all using by now) doesn't work with Compiz:

"Another important note: Compiz and GPU-accelerated Flash on Linux do not mix. The Flash Player still works if you have Compiz as your window manager; you just won’t be able to make use of GPU-accelerated features."

http://blogs.adobe.com/penguinswf/2008/05/flash_uses_the_gpu.html

Bryce Harrington (bryce) on 2010-11-23
description: updated
summary: - MASTER: Choppy Flash playback in full screen
+ Choppy Flash playback in full screen

@chocolateboy, why did you delete the bug description?? That took a lot of time to research and write up, and your reversion of it is not appreciated.

summary: - Choppy Flash playback in full screen
+ MASTER: Choppy Flash playback in full screen
description: updated
Bryce Harrington (bryce) wrote :

@chocolateboy, I'll give you one last chance to stop.

description: updated
chocolateboy (chocolateboy) wrote :

@Bryce Harrington: you sent it to dozens of people, including yourself. Copy and paste it as a response rather than misleadingly ascribing it to exploder91.

FWIW: being spammed with a "solution" that fails to address the bulk of the discussion here is also "not appreciated".

chocolateboy (chocolateboy) wrote :

@Bryce Harrington. Re: "I'll give you one last chance to stop." Thanks for the invite to engage in an immaturity contest. I'll pass.

Gannin (spacesword) wrote :

Remember, if you're not the original poster of a bug, *do not* change its description. If you have more to add, add it as a comment.

Lesmana Zimmer (lesmana) wrote :

edit war FTW! see bug #540665 for my suggestion how to fix the problem of changing the original description.

Bryce Harrington (bryce) wrote :

Settle down guys. I am a developer on the Ubuntu-X team. It is standard policy to elaborate the description of the bug to summarize analysis and research, especially on lengthy bugs such as this one. C.f. https://wiki.ubuntu.com/X/Triaging/

I anticipate this bug report will soon grow to >100 comments, at which point only the first and last 40 comments will be shown, and users will not see the developer response at comment #70.

tags: added: omit
removed: likely-dup
tetsuo55 (akira146) wrote :

Why is this bug as of yet unconfirmed?

tetsuo55 (akira146) on 2011-02-23
Changed in flashplugin-nonfree (Ubuntu):
status: New → Confirmed
Ron Russak (rrlinux) wrote :

Ok, here is a stranger one. I upgraded from 10.10 to 11.4 via online update. Machine is HP 6910p 4 gig ram and 32bit OS version. Intel graphics. In earlier versions, playback withing Firefox was fine. When enlarging to full screen, playback was choppy, or froze, but was corrected by shrinking and enlarging again. Now I have the reverse!. It is choppy in the firefox window, and smooth in full screen. Very strange.

Omer P. (omerp) wrote :

Strange or not, I see the same behavior as described in comment #80.

Gannin (spacesword) wrote :

Just as a test, have you right-clicked on a flash object, chosen options, and disabled hardware acceleration? I've noticed some very, very strange behavior with recent versions of Flash which was taken care of by deselecting the hardware acceleration option.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers