Ubuntu

Difficult to find out how to use multiple profiles at the same time

Reported by Marius Gedminas on 2006-02-17
76
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Won't Fix
Medium
firefox-3.0 (Ubuntu)
Low
Unassigned
firefox (Ubuntu)
Low
Unassigned

Bug Description

Since I upgraded to Firefox 1.5 from Dapper, I can no longer use two different profiles at the same time.

When I run firefox for the first time, I see the profile manager window and I can choose a profile. If I then run 'firefox -P different-profile-name', I get a new browser window that uses the same profile. If I run 'firefox -ProfileManager', I also get a new browser window instead of the profile manager.

Marius Gedminas (mgedmin) wrote :

I have discovered a workaround: 'firefox -a anything' pops up a profile dialog. The -a option is not documented by 'firefox -h', nor by 'man firefox', but you can discover it by reading the /usr/bin/firefox shell script.

Marius Gedminas writes ("[Bug 31746] Impossible to use multiple profiles at the same time"):
> I have discovered a workaround: 'firefox -a anything' pops up a profile
> dialog. The -a option is not documented by 'firefox -h', nor by 'man
> firefox', but you can discover it by reading the /usr/bin/firefox shell
> script.

Thank you very much for your research. I will try it out and arrange
for it to be better documented and perhaps improve the script too.

Ian.

Ian Jackson (ijackson) on 2006-03-10
Changed in firefox:
status: Unconfirmed → Rejected

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects /distros/ubuntu/firefox
 status fixreleased
 done

I believe I have fixed these bugs in dapper, in one of the two uploads
listed below.

firefox (1.5.dfsg+1.5.0.1-1ubuntu7) dapper; urgency=low

  * Fix Norwegian translation in firefox.desktop. (Malone 30603.)
  * Fix trivial syntax problems in firefox.desktop. (Malone 33567.)

 -- Ian Jackson <email address hidden> Fri, 10 Mar 2006 15:59:39 +0000

firefox (1.5.dfsg+1.5.0.1-1ubuntu6) dapper; urgency=low

  * Replace Ubuntu Bugzilla bookmark with Launchpad's `Request
    support with Ubuntu' ticket creation page. (Malone 28896.)
  * Reinstate `Translate This Application' in Help menu, despite the fact
    that Launchpad doesn't do this yet - you just get a page saying there
    are no translations for Firefox. mdz assures us that this will be
    done some time during dapper's service life.
  * Make -P, -CreateProfile and -ProfileManager imply sensible
    values for -a, and document -a in firefox(1). (Malone 31746.)
  * Fix md5sum mismatch which causes spurious conffile prompt on
    bookmarks.html.
  * Set browser.startup.homepage_override.mstone to ignore,
    to avoid the silly thing where the first time after the upgrade,
    firefox looks like it has lost your home page because it is so keen to
    tell you about the release notes. (Malone 33895.)
  * Change `Latest Headlines' to `Latest BBC Headlines' to properly
    disclose the source up front, and use a corresponding RSS URL.
  * Revert the `you have chosen to open' dialogue, as discussed on
    ubuntu-devel.
  * Fix firefox-*.pc files to contain correct references to libs and
    includes, just like the mozilla-*.pc files. (Malone 34200.)

 -- Ian Jackson <email address hidden> Thu, 9 Mar 2006 19:56:58 +0000

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFEEakO8jyP9GfyNQARApPJAJ9qozfYi56VwhW0/tOehd18AQnCHQCdGpVv
GmdV+mkGCeLg4aUsTvjps14=
=w5u0
-----END PGP SIGNATURE-----

Changed in firefox:
status: Unconfirmed → Fix Released

This bug is back in Gutsy: when you have an open Firefox window, firefox ignores -P profilename and -ProfileManager command-line arguments and always opens a new window of your existing Firefox instance. A workaround is to also add -no-remote (or -a something) to the command line.

The regression is pretty recent, I think; I hadn't noticed it when I first installed Gutsy on August 8th.

Marco Fabbri (mrfabbri) wrote :

I confirm this bug is back and still present in Gutsy. Suggested workarounds are functioning.

Same here.

(That showed me to search launchpad before google.)

Fırat Küçük (firatkucuk) wrote :

i confirm it.

Fırat Küçük (firatkucuk) wrote :
Changed in firefox:
assignee: nobody → ijackson
Lakin Wecker (lakin) wrote :

A workaround is still to use -a along with -P:
firefox -a dev -P dev

Just make sure that the id in : -a <id> is unique for each profile.

Benjamin Rubin (bnrubin) wrote :

I also can confirm this in Gutsy, reopening bug.

Changed in firefox:
status: Fix Released → Confirmed
Ian Jackson (ijackson) on 2007-11-02
Changed in firefox:
assignee: ijackson → nobody

I do also confirm the (quite annoying) bug reappearing in Gutsy (upgraded yesterday), and the ``-a`` workaround working.

Fırat Küçük (firatkucuk) wrote :

-no-remote option works.

firefox -P <ProfileName> -no-remote

John Vivirito (gnomefreak) wrote :

Ok after searching upstream for bug report i found nothing related to this bug. Can one of you please file a bug upstream, If you have a bugzilla-mozilla account. If not let me know i do have one but i think some one that is seeing this bug should report it upstream in case of questions and you know exactly how the bug works, since i dont use 2 profiles at same time im not best to report it. If none of you have an account i will file it and expect you to give me all the info needed.
Steps to reproduce
what firefox package does this affect 2.0? 3.0? or both
what is expected results
what it does if differnent from what is expected results

John Vivirito (gnomefreak) wrote :

I am filing the bug but would love the info i asked for above to file a better report. but i will at least start one.

John Vivirito (gnomefreak) wrote :

Also what version of firefox do you see this on?

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

When I run firefox for the first time, I see the profile manager window and I can choose a profile. If I then run 'firefox -P different-profile-name', I get a new browser window that uses the same profile. If I run 'firefox -ProfileManager', I also a new browser window instead of the profile manager.

Reproducible: Always

Steps to Reproduce:
1.run firefox for first time
2.choose a profile
3.than run "firefox -P name of different profile"
Actual Results:
both Firefox processes are using same profile even after naming a different profile

Expected Results:
both firefox windows open should use different profiles

If I run 'firefox -ProfileManager', I also a new browser window instead of the profile manager.
firefox -a anything' pops up a profile dialog. The -a option is not documented by 'firefox -h', nor by 'man firefox', but you can discover it by reading the /usr/bin/firefox shell script.

Changed in firefox:
importance: Undecided → Unknown
status: New → Unknown
Changed in firefox:
status: Unknown → New

Reported this upstream please subscribe to upstream bug and we are gonna need more info on that bug please look at it and add as much info as you have including the above info i asked for.

By default, you can only start 1 copy per screen (the second one never started, but opened a window in the first copy).

See <http://www.hiveminds.co.uk/node/3114> for a workaround (it's about Windows, but it's the same environment variable in Linux). You can also use the -no_remote commandline flag

This is confirmed on Firefox-2.0 i reported it here for the reporter of the launchpad bug, I asked the reporter and other people seeing this from LP bug to add info to this bug report.

Does this mean its a bug or a feature and is there any changes to be made by mozilla to "fix"?

Hi John, here you are some of the info you requested:

* How to reproduce: With all Firefox sessions closed, launch Firefox; while it is running, open a command line interpreter and enter ``firefox -ProfileManager``.
* Expected results: The Profile Manager window should appear.
* Actual result: A new browser window of the currently running profile appears.
* Workaround: Run ``firefox -a NonExistingProfileName`` to force Firefox to show the Profile Manager window.
* My current (affected) version: 2.0.0.14+2nobinonly-0ubuntu0.7.10 (Hardy Heron w/ security updates, haven't tried 3.0)

As you see, you don't actually need to set up two profiles to trigger the error. Thanks!

Sorry, my current Ubuntu release is actually Gutsy Gibbon (7.10), but the version of the package is OK.

This is a dup of a WONTFIXed bug.

The bug currently (on 8.04) afflicts firefox (i.e. firefox 3 beta) and firefox-2 (i.e. firefox 2.0.0.14).

Step to reproduce the bug:
1. close every firefox instance
2. open firefox using a specific a profile, Run Command "firefox -P" select a profile
3. open firefox using a different a profile, Run Command "firefox -P"

Expected Behaviour:
At this point you should be presented with the same dialog at point 2, instead a new firefox window gets opened running on the same profile selected at 2 (i.e. a different window of the same firefox process started at 2).

Variations:
The same is true for every combination of the commands firefox firefox-2 run at points 2 and 3; i.e. if you run "firefox -P" and then "firefox-2 -P" you end up with two windows of firefox 3 running the profile selected after entering the command "firefox -P".

Workarounds:
Adding the "-no-remote" option to every firefox startup command ran after point 2; i.e. "firefox -P -no-remote".
The "-a" option it is no more working.

On Wed, May 14, 2008 at 05:48:53PM -0000, Marco Fabbri wrote:
> The bug currently (on 8.04) afflicts firefox (i.e. firefox 3 beta) and
> firefox-2 (i.e. firefox 2.0.0.14).
>
> Step to reproduce the bug:
> 1. close every firefox instance
> 2. open firefox using a specific a profile, Run Command "firefox -P" select a profile
> 3. open firefox using a different a profile, Run Command "firefox -P"
>
> Expected Behaviour:
> At this point you should be presented with the same dialog at point 2, instead a new firefox window gets opened running on the same profile selected at 2 (i.e. a different window of the same firefox process started at 2).
>
> Variations:
> The same is true for every combination of the commands firefox firefox-2 run at points 2 and 3; i.e. if you run "firefox -P" and then "firefox-2 -P" you end up with two windows of firefox 3 running the profile selected after entering the command "firefox -P".
>
> Workarounds:
> Adding the "-no-remote" option to every firefox startup command ran after point 2; i.e. "firefox -P -no-remote".
> The "-a" option it is no more working.
>

Thanks for the report. please add this to the bug summary.

Point about this is that multiple profile support is not actually
supported upstream. I remember that they wont-fixed a bug about this;
so i assume they only maintain it as a legacy feature and wont put any
work in this on their own. If anyone can come up with a patch, they
will most likely happily review and apply it.

 affects ubuntu/firefox
 status triaged
 importance low

 affects ubuntu/firefox-3.0
 status triaged
 importance low

If someone finds the bug upstream, we should add the bug id for
reference. opening an empty upstream task for now

 affects firefox
 status incomplete

 tag mt-upstream

 - Alexander

Changed in firefox:
importance: Medium → Low
status: Confirmed → Triaged
status: New → Incomplete
Changed in firefox:
status: Incomplete → New
John Vivirito (gnomefreak) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Alexander Sack wrote:
| On Wed, May 14, 2008 at 05:48:53PM -0000, Marco Fabbri wrote:
|> The bug currently (on 8.04) afflicts firefox (i.e. firefox 3 beta) and
|> firefox-2 (i.e. firefox 2.0.0.14).
|>
|> Step to reproduce the bug:
|> 1. close every firefox instance
|> 2. open firefox using a specific a profile, Run Command "firefox -P"
select a profile
|> 3. open firefox using a different a profile, Run Command "firefox -P"
|>
|> Expected Behaviour:
|> At this point you should be presented with the same dialog at point
2, instead a new firefox window gets opened running on the same profile
selected at 2 (i.e. a different window of the same firefox process
started at 2).
|>
|> Variations:
|> The same is true for every combination of the commands firefox
firefox-2 run at points 2 and 3; i.e. if you run "firefox -P" and then
"firefox-2 -P" you end up with two windows of firefox 3 running the
profile selected after entering the command "firefox -P".
|>
|> Workarounds:
|> Adding the "-no-remote" option to every firefox startup command ran
after point 2; i.e. "firefox -P -no-remote".
|> The "-a" option it is no more working.
|>
|
| Thanks for the report. please add this to the bug summary.
|
| Point about this is that multiple profile support is not actually
| supported upstream. I remember that they wont-fixed a bug about this;
| so i assume they only maintain it as a legacy feature and wont put any
| work in this on their own. If anyone can come up with a patch, they
| will most likely happily review and apply it.
|
| affects ubuntu/firefox
| status triaged
| importance low
|
| affects ubuntu/firefox-3.0
| status triaged
| importance low
|
| If someone finds the bug upstream, we should add the bug id for
| reference. opening an empty upstream task for now
|
| affects firefox
| status incomplete
|
| tag mt-upstream
|
|
| - Alexander
|
|
| ** Changed in: firefox (Ubuntu)
| Importance: Medium => Low
| Status: Confirmed => Triaged
|
| ** Also affects: firefox-3.0 (Ubuntu)
| Importance: Low
| Status: Triaged
|
| ** Changed in: firefox
| Status: New => Incomplete
|
I thought i reporte dthis bug upstream the other day.

- --
Sincerely Yours,
~ John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFILMUsqig4QTwcPCoRAgULAJ0fLanshXuIrUKqgBwj7nN/jM4hSQCeN01z
M/CK/qqxfXSTgLJjgSDAPAo=
=IjPS
-----END PGP SIGNATURE-----

John Vivirito (gnomefreak) wrote :

Changing triaged to confirmed for now

Changed in firefox-3.0:
status: Triaged → Confirmed
John Vivirito (gnomefreak) wrote :

Same here :)

Changed in firefox:
status: Triaged → Confirmed

Can you pleae provide a bug number so i can read up on it.

Alexander you are right it seems but i asked for bug number to seee why wont fix.

Does this mean its a bug or a feature and is there any changes to be made by
mozilla to "fix"?

Comment #4 [reply] Benjamin Smedberg [:bs] (bsmedberg) away until 20-May 2008-05-14 10:35:25 PDT

This is a dup of a WONTFIXed bug.

Comment #5 [reply] John Vivirito 2008-05-15 16:24:14 PDT

Can you pleae provide a bug number so i can read up on it.

Changed in firefox-3.0:
status: Confirmed → Invalid
Changed in firefox:
status: Confirmed → Invalid
John Vivirito (gnomefreak) wrote :

leaving status upstream for a little bit longer, I know this wont be fixed but there was a bug reported before mine and would like to read it. if i find it first i will mark it invalid upstream.

Marked as wont fix due to prior bug report on same issue.

i decided i can look for it myself upstream bug status wontfix

Changed in firefox:
status: New → Won't Fix
Jan Kunder (jan-kunder) wrote :

I can confirm all here already mentioned bugs - as of today.

ubuntu 8.10 == all updates installed

# firefox -v
Mozilla Firefox 3.0.5, Copyright (c) 1998 - 2008 mozilla.org

=======1)
~# man iceweasel
No manual entry for iceweasel

~# man firefox
No manual entry for firefox
See 'man 7 undocumented' for help when manual pages are not available.

I expect some man pages with "-a" option documented.

=======2)
~# firefox -h
Usage: firefox [ options ... ] [URL]
       where options include:

X11 options
        --display=DISPLAY X display to use
        --sync Make X calls synchronous
        --no-xshm Don't use X shared memory extension
        --xim-preedit=STYLE
        --xim-status=STYLE
        --g-fatal-warnings Make all warnings fatal

Mozilla options
        -height <value> Set height of startup window to <value>.
        -h or -help Print this message.
        -width <value> Set width of startup window to <value>.
        -v or -version Print Firefox version.
        -P <profile> Start with <profile>.
        -ProfileManager Start with ProfileManager.
        -no-remote Open new instance, not a new window in running instance.
        -UILocale <locale> Start with <locale> resources as UI Locale.
        -safe-mode Disables extensions and themes for this session.
  -jsconsole Open the Error console.

        -g or --debug Start within /usr/bin/gdb (Must be first)
==> not documented "-a" option
I expect some man pages with "-a" option documented.

=======3)
# firefox -ProfileManager
* Expected results: The Profile Manager window should appear.
* Actual result: A new browser window of the currently running profile appears.
* Workaround: Run ``firefox -a NonExistingProfileName`` to force Firefox to show the Profile Manager window.

=======4)
# firefox -P NonExistingProfileName
* Expected results: The Profile Manager window should appear.
* Actual result: A new browser window of the currently running profile appears.
* Workaround: Run ``firefox -a NonExistingProfileName`` to force Firefox to show the Profile Manager window.

=======5)
# firefox -P aaa (existing profile: aaa named "aaa")
* Expected results: A new browser window with "aaa" (or any other called <profile>) should appear.
* Actual result: A new browser window of the currently running profile appears.
* Workaround: Run ``firefox -a NonExistingProfileName`` to force Firefox to show the Profile Manager window, then pickup profile you wanted :(

All test were with 3 profiles created and only and exactly 1 running!

I also can confirm (from memory = AFAIR) that all that behaviour is correct (=no bugs from above) on WXP with FF3.0.4.

Jan Kunder (jan-kunder) wrote :

Now I tried the same test with the same results and same bugs if 7 profiles are created and 3 profiles already running/using:

==just instead of:
* Actual result: A new browser window of the currently running profile appears.
==you can replace:
* Actual result: A new browser window of the first one (run) running profile appears.

Jan Kunder (jan-kunder) wrote :

Also I tested it on other hardware on virtual Ubuntu 8.10 last stable, NOT updated == I tried the same test with the same results and same bugs. test run only with 5 profiles created and 4 running.

Jan Kunder (jan-kunder) wrote :

Also note, FYI:

I can NOT reproduce any of these bugs mentioned above in my bugreport on Debian Etch, last updated 06?/2008, FF2.0.0.x, no extensions.

I can NOT reproduce any of these bugs mentioned above in my bugreport on Debian Etch, all updates, FF2.0.0.x + above 200 extensions installed.

Michael Nagel (nailor) wrote :

could the original description of this bug be updated to reflect the current status?
could this be reopened as a wishlist priority bug?

ps: firefox 3 under a up-to-date intrepid does not allow browse using different profiles simultaneously for me.

Jan Kunder (jan-kunder) wrote :

Michael Nagel:::
> ps: firefox 3 under a up-to-date intrepid does not allow browse using different profiles simultaneously for me.
RU sure? Because NOT true for me. I can run (by workaround - see above&below, too ;))
did you try to run from CLI:
$ firefox -a blahblah -P nonexistingprofile

This bug should be reopened and marked as medium.
This is NOT mozilla problem as many other distros and FF under WXP has NOT these problems/bugs.
So (I think) it is an "Ubuntu FF feature"

Michael Nagel (nailor) wrote :

indeed, invoking firefox by

firefox
firefox -a BLACKMAGIC -P alternative

starts up two firefox instances using different profiles. i do not see why this bug is closed as invalid though.

Michael Nagel (nailor) on 2009-02-25
Changed in firefox-3.0:
status: Invalid → New
John Vivirito (gnomefreak) wrote :

As reported it works from command line what is it you are looking for it to do?

John Vivirito (gnomefreak) wrote :

It's normally better to mark as incomplete instead of new when reopening bugs as this aids us in tracking the bug.

Changed in firefox-3.0:
status: New → Incomplete
Michael Nagel (nailor) wrote :

i did reopen because i see adding the "magic -a switch" merely as a workaround and not as a fix;

however, i just found a manpage for firefox[1] at http://pwet.fr/man/linux/commandes/firefox and it reads:

-a application-id
    Check for a running Firefox started with the specified application-id. When firefox is invoked for the first time with a particular application-id, a new Firefox application is started; subsequent invocations of firefox with the same application-id will cause the already-running Firefox to bring up a new window.
The default is -a firefox.

now thing begin to make some sense. if i interpret this correctly, launching firefox with "-P anotherprofile" does not work as expected when another instance is running because they will both share the "firefox" application id that will take precedence over the selected profile.

from my point of view it would be more sensible to do one of this:
- make the selected profile take precedence over the application id / only consider the application id if profiles match
or
- default the application id not to "firefox" but to $SELECTED_PROFILE unless explicitly set otherwise

[1] see bug 115112 for missing man page

Marius Gedminas (mgedmin) wrote :

I guess the main issue here is this: it's unclear how someone could use multiple Firefox profiles.

'man firefox' says there's no man page. 'firefox -h' lists '-P profilename' and -'ProfileManager' options, but if you try to use them when you already have a Firefox window open (and who doesn't have one open all the time?), they will be silently ignored, leading users to assume they're broken. The '-a' option is not documented by 'firefox -h'. Only obscure googling/reading the wrapper shell script sources tells you that you should run 'firefox -a profilename -P profilename' to get a new window using a separate profile. The other workaround -- using '-no-remote' instead of '-a something' -- also suffers from the same lack of documentation.

Even when you discover that, it doesn't always do what you want if you want to open new windows in the firefox instance that uses a different profile from your main one, e.g. try:

  1. firefox -a selenium -P selenium &
  2. firefox -a selenium http://www.google.com

Step (2) will give you an error message "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system." This directly contradicts the bit of documentation that Michael quoted and makes certain borderline use cases hard or impossible (an automated test runner that wants to spawn new firefox windows and interact with them -- I'd rather it did that in a separate profile with all the correct language settings and js options to disable all the interactive popup confirmations).

I would suggest closing this long and meandering bug and instead opening a few new ones:

  1. please document the '-a' and '-no-remote' options in firefox --help
  2. please document that '-P' and '-ProfileManager' are ignored when firefox with the given application ID is already running
  3. please make 'firefox -a someappid url' successfully communicate with an already running firefox instance instead of showing an error

and perhaps, for better user friendliness

  4. please make 'firefox -ProfileManager' always open the profile manager (i.e. treat it as if -no-remote was implicitly requested)
  5. please make 'firefox -P profilename' open a browser window using that profile (e.g. treat it as if -a profilename was also specified)

Sounds good?

description: updated
Dave Gilbert (ubuntu-treblig) wrote :

Yeh, I think the important ones are:
   It should be documented how to do this - it's not that uncommon a request
  The interaction with -a and -P is just wrong, common options shouldn't 'sometimes work'.
  It seems to me that -P should just work irrespective of -a (possibly by implying -a)
    just because it's not useful without it.

Dave
P.S. Where is the firefox manpage?

Jan Kunder (jan-kunder) wrote :

https://bugs.launchpad.net/firefox/+bug/31746/comments/35
John Vivirito wrote on 2009-02-25: (permalink)
> As reported it works from command line what is it you are looking for it to do?

Nope!
1) > ps: firefox 3 under a up-to-date intrepid does not allow browse using different profiles simultaneously for me.
is NOT true for me
2) but all bugs related in
https://bugs.launchpad.net/firefox/+bug/31746/comments/28 are UNSOLVED and some of them have workarounds = not patch nor solution.

Jan Kunder (jan-kunder) wrote :

Marius Gedminas wrote on 2009-02-25: (permalink)
https://bugs.launchpad.net/firefox/+bug/31746/comments/38
<cite>
I would suggest closing this long and meandering bug and instead opening a few new ones:

  1. please document the '-a' and '-no-remote' options in firefox --help
  2. please document that '-P' and '-ProfileManager' are ignored when firefox with the given application ID is already running
  3. please make 'firefox -a someappid url' successfully communicate with an already running firefox instance instead of showing an error

and perhaps, for better user friendliness

  4. please make 'firefox -ProfileManager' always open the profile manager (i.e. treat it as if -no-remote was implicitly requested)
  5. please make 'firefox -P profilename' open a browser window using that profile (e.g. treat it as if -a profilename was also specified)

Sounds good?
</cite>

Sounds awesome. Excellent idea(s). Marius can you do it, pls?
Or you want some1 else to do it?

Jan Kunder (jan-kunder) wrote :

I just wanna point out, that this behaviour of FF is mostly Ubuntu FF behaviour/bugs/features!

More here:
https://bugs.launchpad.net/firefox/+bug/31746/comments/28
I also can confirm (from memory = AFAIR) that all that behaviour is correct (=no bugs from above) on WXP with FF3.0.4.

https://bugs.launchpad.net/firefox/+bug/31746/comments/31
I can NOT reproduce any of these bugs mentioned above in my bugreport on Debian Etch, last updated 06?/2008, FF2.0.0.x, no extensions.
I can NOT reproduce any of these bugs mentioned above in my bugreport on Debian Etch, all updates, FF2.0.0.x + above 200 extensions installed.

https://bugs.launchpad.net/firefox/+bug/31746/comments/33
This is NOT mozilla problem as many other distros and FF under WXP has NOT these problems/bugs.
So (I think) it is an "Ubuntu FF feature"

Micah Gersten (micahg) on 2009-05-19
Changed in firefox-3.0 (Ubuntu):
status: Incomplete → Confirmed
komputes (komputes) wrote :

Mozilla developers have marked the upstream bug as won't fix without pointing to the supposed "duplicate".

The fact still remains, there is an option called -no-remote which is supposed to allow a user to run two profiles. This does not work. If this is not a feature, take it out of the help/man. But since it is a possible feature, it would be preferred that it be fixed.

Firefox options
...
        -no-remote Open new instance, not a new window in running instance.

John Vivirito (gnomefreak) wrote :

We have to manually change upstream link to the new bug. Its rare if ever upstream comments on the bugs in launchpad

John Vivirito (gnomefreak) wrote :

Its not a duplicate of an open bug. the one you are seeing is also been marked as closed.
This is not something Ubuntu would fix. If you care to proceed please comment on the upstream bug that is at the top of this page.
closing our task as well.

Changed in firefox-3.0 (Ubuntu):
status: Confirmed → Won't Fix
komputes (komputes) wrote :

Ah, I see that you *can* successfully have multiple profiles running at the same time, I was just doing it wrong:

Let's say you have 3 profiles: profile1, profile2 and profile3

Simply run these commands to run each profile in a separate window:
firefox -no-remote -P profile1
firefox -no-remote -P profile2
firefox -no-remote -P profile3

Thank you.

I was going to follow up on this bug but after further testing I no longer see this issue as a bug. Let's say you have 3 profiles: profile1, profile2 and profile3. Simply run these commands to run each profile in a separate window:
firefox -no-remote -P profile1
firefox -no-remote -P profile2
firefox -no-remote -P profile3

firefox -no-remote -ProfileManager

This works just as well,if you want a graphical interface to pick the profile from). You can create a link to firefox using that command and every time you open from that link it will ask you which profile you would like to use.

komputes (komputes) wrote :

firefox -no-remote -ProfileManager

This works just as well,if you want a graphical interface to pick the profile
from). You can create a link to firefox using that command and every time you
open from that link it will ask you which profile you would like to use.

Dave Gilbert (ubuntu-treblig) wrote :

OK, kind of fair enough - but can someone explain to me why -no-remote is needed with -P ?
Is there any possible use for -P on it's own? If not why doesn't it imply -no-remote or at least error
telling you that you need to tell it what to do.

I think the reason why this (and other) similar bugs have got reported is because you do the --help and you see
an obvious -P option and try and use it and it doesn't work

Dave

komputes (komputes) wrote :

@Dave Gilbert

I though the same thing but then figured that
$ firefox -P profilename
would just start a specific profile, it does not mean that you want every window to have a different profile. Some people may have one of 100 profile that they want to open, this command makes it quick and easy.

Meanwhile the -no-remote enables running multiple instances of the application with different profiles. Although it is almost exclusively used with -P, it does not mean there is no use to -P alone.

Just a quick summary here at the end for anyone looking for an immediate answer:

This is not a bug; the documentation is just incomplete / unclear. If firefox is running already, you need to use slightly different commands from when it is not. Most of the docs assume you are not already running firefox.

To create a profile when firefox is *not* already running, use "firefox -ProfileManager &".
To create a profile when firefox is *already* running, use "firefox -ProfileManager -a blackmagic &".

To start firefox with a profile when firefox is *not* already running, use "firefox -P <profile name> &".
To start firefox with a profile when firefox is already running, use "firefox -no-remote -P <profile name> &".

Example:
I already have firefox running, showing this webpage. I want to create a new profile, so I open a terminal and enter firefox -ProfileManager -a blackmagic and create a profile called luser. I then run it by entering firefox -no-remote -P luser at the terminal. (I also created a launcher on my taskbar to do this without opening a terminal window)

Sebastian Kapfer (caci) wrote :

<RANT>
I'm sorry to burst your bubble, but Firefox ignoring a flag explicitly given by the user is a *bug*. I can understand how this behaviour arises from the implementation of Firefox, however, it still is and remains a bug. Denial does not make it a non-bug. Setting it to Wontfix (= not worth the effort) does not make it a non-bug. Arguing that this behaviour is "by design" does not make it a non-bug.

Enough people have independently reported this now to clearly indicate that this is unexpected behaviour, which, for an application interacting with mere users, constitutes a *bug*.

Sorry for the rant, but this flag is like an elevator whose '7' button goes to the seventh floor most of the time, except when it's on the fourth floor. It's just plain frustrating and obviously *wrong*.
</RANT>

Besides that, I wish you a nice day, and thank you for the summary. :-)

Ingo Ruhnke (grumbel) wrote :

I second this, the current behavior when running multiple profiles is just plain broken and confusing. Command line options shouldn't act completly different depending on if an application is already running. And the workaround of "-no-remote" doesn't really fix this issue, as the intended behavior of:

"firefox -P MyProfile http://www.example.org"

should be:

1) If no Firefox is running, launch one using MyProfile opening http://www.example.org
2) If Firefox with MyProfile is already running, open a new window of it displaying http://www.example.org
3) If only a Firefox with a different profile is already running, ignore it and act as in 1)

-no-remote gives you 1) and 3), but gives you a:

"Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

error message on 2).

And having "firefox -ProfileManager" just open a new window and not showing the ProfileManger really can't be considered the right behavior, as its so obviously wrong.

On top of that "-a" and "-no-remote" are really just ugly implementation details that shouldn't be required to simply run two profiles at the same time.

Changed in firefox:
importance: Unknown → Medium

I notice that more than 7 years have passed since this bug has been first reported and it is still happening here in Kubuntu Raring, Firefox 23.0. Will anyone ever take time to fix this?

Dave Gilbert (ubuntu-treblig) wrote :

In the end it's upto Firefox, and their upstream firefox bug 433717 that's linked is marked as won't fix with a note suggesting what to use; so it's upto them.

Or just use Chrome now that profiles are as simple as right clicking in the
top left corner...

Firefox is so 2005.

--
Chris Kelley
President
California Cycleworks, Inc
www.ca-cycleworks.com
619/501-2466

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.