Ubuntu

[MASTER] "Open With" dialog not user-friendly

Reported by Damon W on 2005-07-16
682
This bug affects 116 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
Declined for 3.0 by Micah Gersten
Nominated for 3.6 by Konstigt
firefox (Ubuntu)
Low
Unassigned
Nominated for Hardy by Konstigt
Nominated for Jaunty by caberg
Nominated for Karmic by caberg
mozilla-thunderbird (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Konstigt
Nominated for Jaunty by caberg
Nominated for Karmic by caberg

Bug Description

When choosing to open a file in Firefox, an "Open With" dialog appears.
You can choose to save the file or open it with a program from the list.
However, if the desired program to open the file with is NOT listed, the user
must navigate the filesystem to /usr/bin (or wherever) and select the
appropriate program.

A more user-friendly way would be to list all of the known programs installed
that are available to open files with, and then have an "Other..." or
"Advanced..." button for the user who would rather navigate the filesystem.

Jorge O. Castro (jorge) wrote :
David Farning (dfarning) wrote :

It does not look like much is happening upstream with this bug. It might make
more sense to make a gnome specific patch for Ubuntu until it is solved upstream.

-dtf

Dennis Kaarsemaker (dennis) wrote :

*** Bug 21248 has been marked as a duplicate of this bug. ***

Dennis Kaarsemaker (dennis) wrote :

*** Bug 21249 has been marked as a duplicate of this bug. ***

Matthew East (mdke) wrote :

*** Bug 24789 has been marked as a duplicate of this bug. ***

Alexandre Otto Strube (surak) wrote :

This should be fixed in firefox-gnome-support , which I don't know if it's valid upstream. https://bugzilla.mozilla.org/show_bug.cgi?id=56662 has this bug marked as "new" for about six years.

Alexandre Otto Strube (surak) wrote :

Unless it is done in firefox-gnome-support (and it's counterpart in kde), it seems we will not have it done soon.

Changed in firefox:
status: Unconfirmed → Rejected
Matthew East (mdke) wrote :

this bug was marked as rejected but I'm reopening it: it is clearly a bug, and unless the maintainer indicates clearly that he is not prepared to fix this in any future release, the bug shouldn't be closed. Ian, if you really think this won't be doable even for Dapper+1, close the bug.

Changed in firefox:
status: Rejected → Confirmed
Ian Jackson (ijackson) wrote :

I agree that it's a bug. However, I don't think we've got the effort available to fix this in Ubuntu, and we'd probably prefer not to maintain the resulting patch either. So this issue is best addressed upstream, I think.

So I'm setting the bug state for the `Ubuntu task' to `Rejected' again (the LP team assure me that `Rejected' is correct in this case, even though I think the complaint is valid).

Changed in firefox:
status: Confirmed → Rejected
Matthew East (mdke) wrote :

Fair enough. Does "upstream" mean mozilla in this case, given that the problem is the use of the wrong GNOME dialogue? Or should this be in the GNOME bugtracker?

Matt

Matthew East writes ("[Bug 18995] Re: "Open With" dialog not user-friendly"):
> Fair enough. Does "upstream" mean mozilla in this case, given that
> the problem is the use of the wrong GNOME dialogue? Or should this
> be in the GNOME bugtracker?

I think upstream means Mozilla in this case.

Ian.

Changed in firefox:
status: Unconfirmed → Confirmed

The upstream bug seems to be doing nothing here. Also, it seems to be addressed at a slightly different issue - this bug is that firefox should be able to use the Gnome application chooser, whereas the upstream bug is about creating a new application chooser, or something of that kind.

I'm fairly sure that a couple of Ubuntu releases ago firefox used the Gnome application chooser, whereas with the firefox-gnome-support package in dapper it now just uses a file chooser.

Has anyone investigated whether it would be difficult to use the Gnome application chooser when firefox-gnome-support is installed?

Matt

Ian Jackson (ijackson) on 2007-10-23
Changed in firefox:
assignee: ijackson → nobody
Konstigt (konstigt) wrote :
Rory McCann (rorymcc) wrote :

This is also a problem with Thunderbird opening email attachements. I think Firefox should include the applications menu from gnome.

Hauke Hoffmann (hauke-nxt7) wrote :

This bug should be fast fixed!

Today, an normal new Linux-User asked me how to open a (sending) pdf-file, because he had no idea. The Firefox-open-dialog suggests the program 'less' (Why???). He has tried it. => nothings to see.
After that, I helped and choose /usr/bin/acroread manualy and save it as default.

That's very unusable for _human_ users.

Holy crap, I can't believe I was about to report this bug and have come to find that it's been here since 2005!!! WTF? Seriously, WTF!

When I click on a link to a *.pls file (otherwise known as a "Shoutcast MP3 playlist") It presents the attached screenshot.

Lets say I don't want it to open it with Totem. Instead, I'd like it to play in VLC, (or XMMS for those die hard XMMS fans out there). So I click on the drop down where "Movie Player" is currently shown, and select "Other..." because NOTHING ELSE IS THERE.

Instead of being presented with a nice listing of installed applications, I'm asked to browse my root file structure. I, after 3 years of using this OS, still have little idea as to where I should even look to find VLC or any other app for that matter. New users, I would bet hard cash, HATE THIS. Sorry.

Michael Jones (jonesmz) wrote :

I (Obviously) experience this as well. It's insanely annoying. I don't even try to open the files through that dialog anymore, and instead just save them and open them from the nautilus desktop. This can't be that difficult to fix. Can't we patch the version of Firefox that we use for Ubuntu? Firefox is open-source. We can patch the program with or without the permission of Mozilla. Lets DO that.

John Vivirito (gnomefreak) wrote :

Voting on a Ubuntu site isnt going to help at all since we are waiting for upstream to fix it than we can add it,

John Vivirito (gnomefreak) wrote :

marked confirm

Changed in mozilla-thunderbird:
status: New → Confirmed
John Vivirito (gnomefreak) wrote :

This a bug in firefox as well it is a valid bug against the core of mozilla.

Changed in firefox:
status: Invalid → Confirmed
Konstigt (konstigt) wrote :

This should be linked to Mozilla bug https://bugzilla.mozilla.org/show_bug.cgi?id=370380 instead. I can't figure out how to change that though?

Matthew East (mdke) on 2009-02-17
Changed in firefox:
status: Confirmed → Unknown
John Vivirito (gnomefreak) wrote :

Changed firefox task to use 3.0. 2.0 will not get this fix. Marked as low importance since its a bug not a wish and it is not cuasing any security related issues nor does it crash.

Changed in firefox:
importance: Wishlist → Low
Changed in firefox:
status: Unknown → Confirmed
Coren (mloiseleur) wrote :

Hi *,

   With this small patch applied on Firefox 3 source code, (patch to apply on xulrunner-1.9 package), there's no more need to "open with" and no more problems with others Desktop environments like KDE or XFCE.
   It's based (and so requires) a really small dependency : xdg-open (~5Kb of perl script) and provides a unified way for opening files in Firefox, directly using System Defaults.

   It can be enhanced with a patch on this dialog, replacing "open with" label with something like "open file". We already applied this fix successfully for ~ 1000 users since 3 months, and no problem shown up.
   I am currently trying to push it upstream, but maybe an Ubuntu integration can help this process.

Regards,

Jan Claeys (janc) wrote :

Coren, I didn't test it, but I don't think your patch addresses this bug. What this bug is about is that you can't optionally choose other applications registered for the same file type (as is common in e.g. nautilus).

(Sorry if I'm wrong about your patch.)

ktulu77 (ktulu-highwaytoacdc) wrote :

Hi,
It is clearly a bug because this make "open with" unusable for non geek users. Firefox is one of the most used applications for them. My father simply cannot choose how to open downloaded files. He is totally lost when firefox asks him the "open with" dialog.

Coren (mloiseleur) wrote :

Jan Claeys,
   maybe you are wrong with my patch or maybe I am wrong from my point of view :). Let me explain : If you do not have to choose an application at all, you solve the problem with registrations of applications.
   There's already one place where one registers its application : the desktop environment. It seems enough to me, and it also seems the good place for doing this. Firefox should just shut up and use those preferences.

regards,

Jan Claeys (janc) wrote :

@Coren: there are often multiple applications for the same MIME-type registered with the desktop-environment, but currently in Firefox there is no way to select them from that list of registered applications, nor does it allow you to select from the other registered applications (e.g. because the MIME-type is/was unknown or wrong, but an application can still open it).

Changed in firefox:
status: Confirmed → Invalid
John Vivirito (gnomefreak) wrote :

Updated upstream task since that bug was marked a duplicate.

Changed in firefox:
status: Invalid → Unknown
summary: - "Open With" dialog not user-friendly
+ [MASTER] "Open With" dialog not user-friendly
Changed in firefox:
status: Unknown → Confirmed
Changed in firefox-3.0 (Ubuntu):
status: Confirmed → Triaged
Mat Tomaszewski (mat.t.) on 2009-06-11
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
sebek (sebeeek) wrote :

I flagged some other launchpad as duplicate of the current one.

As reported in one of the duplicates (LP #232046) :

"""This can be smoothly resolved in the mean time if Firefox is shipped with different defaults, namely to have xdg-open available as an option for all file types (which I believe is possible) and to have every file type which is not to be viewed internally instead opened using /usr/bin/xdg-open.
If possible, have xdg-open named "Default application" or some such in Firefox, so that something like the download method dialog says "Open with [default application]". """

Because it has an easy solution and it will greatly ease general user experience, I agree with Mat that it should be promoted as the hundredpapercuts project.

I guess it can be done in the ubufox extension.

Changed in hundredpapercuts:
milestone: none → round-5
KillerKiwi (killerkiwi2005) wrote :

An extension that shows how to alter the open with dialogue
https://addons.mozilla.org/en-US/firefox/addon/8207

Fethi DILMI (delphiexile) wrote :

I add this , when the open dialog is for seeking a type of files , it should show the extention of the needed file (the current one filters the files but it doesn't show the extention , which made the task somehow more difficult and boring)

Chris Bauer (cfbauer) wrote :

I'm not a programmer so I don't have anything productive to add to this discussion, I just want to say that this bug is important to me. I dread the moment when downloading a file in Firefox and the associated application I want to open with isn't in the drop down list. I've been using Ubuntu more than 2 years now and still have lots of trouble locating the application I want. It is a big problem for me, and likely for any non-programmer user who ever downloads files in Firefox.

Thanks everyone for your hard work.

-Chris

Patch looks good, but it's not trivial for us to apply it -- would require much testing, and, more importantly, upstream acceptance. Not a paper cut.

Changed in hundredpapercuts:
milestone: round-5 → none
status: Confirmed → Invalid

David & others,

As the original reporter of this UX issue I have to say that this surprises
me.

If this is not a "trivially fixable usability bug that the average user
would encounter on his/her first day of using a brand new installation of
the latest version of Ubuntu Desktop Edition.", then nothing is.

It appers you are rejecting a perfectly valid fix to a significant usability
issue because of technicalities. That the patch may require work to apply,
some testing work and work to accept upstream are not in my opinion good
arguments to reject what is essentially a giant stumbling stone for the use
and acceptance of the biggest Open Source browser on Linux by non-geeks.

I'm disappointed by that.

Just my 2 cents.

Kind regards,
Eivind Throndsen

2009/8/7 David Siegel <email address hidden>

> Patch looks good, but it's not trivial for us to apply it -- would
> require much testing, and, more importantly, upstream acceptance. Not a
> paper cut.
>
> ** Changed in: hundredpapercuts
> Status: Confirmed => Invalid
>
> ** Changed in: hundredpapercuts
> Milestone: round-5 => None
>
> --
> [MASTER] "Open With" dialog not user-friendly
> https://bugs.launchpad.net/bugs/18995
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The Mozilla Firefox Browser: Confirmed
> Status in One Hundred Paper Cuts: Invalid
> Status in “firefox-3.0” package in Ubuntu: Triaged
> Status in “mozilla-thunderbird” package in Ubuntu: Confirmed
>
> Bug description:
> When choosing to open a file in Firefox, an "Open With" dialog appears.
> You can choose to save the file or open it with a program from the list.
> However, if the desired program to open the file with is NOT listed, the
> user
> must navigate the filesystem to /usr/bin (or wherever) and select the
> appropriate program.
>
> A more user-friendly way would be to list all of the known programs
> installed
> that are available to open files with, and then have an "Other..." or
> "Advanced..." button for the user who would rather navigate the filesystem.
>

The bug is not being rejected. I pushed hard to get it through today,
but the upstream bug has been around for 4(?) years and we are blocking
on Mozilla on this one -- please express your disappointment in the
upstream bug report.

era (era) wrote :

@David Siegel: For those of us arriving late, could you point to documentation which explains why adding the patch to the Ubuntu build is not an option? Upstream is solving a significantly harder problem, that is, implementing everything in a uniform way across diverse platforms. Ubuntu does not have that problem, and the available patch seems to solve the less general problem for Ubuntu quite nicely. (Haven't tried it, but see nothing to indicate the opposite.)

John Vivirito (gnomefreak) wrote :

On 08/08/2009 03:51 AM, era wrote:
> @David Siegel: For those of us arriving late, could you point to
> documentation which explains why adding the patch to the Ubuntu build is
> not an option? Upstream is solving a significantly harder problem, that
> is, implementing everything in a uniform way across diverse platforms.
> Ubuntu does not have that problem, and the available patch seems to
> solve the less general problem for Ubuntu quite nicely. (Haven't tried
> it, but see nothing to indicate the opposite.)
>
This is more than something that we want to patch. We dont patch
features we let upstream handle that since it is not a trivial.

Implementing a KDE solution is important since KDE users use Firefox
this is not something we should leave out. This is one big reason
why we have upstream apply feature changes to upstream code.
Its always best to keep patches to a minimum if possible.

if we apply that patch we will have to remove it once it is implemented.
Also there is more than one bug that uses the same code section, so
applying this one is not something they would like until the patch is
updated for all peices of code. This will be implemented for
Xulrunner-1.9.2 + Firefox-3.6 as it looks atm.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

dotancohen (dotancohen) wrote :

I do not understand. Ubuntu has no problem patching Firefox [1] to show a Google search page, but cannot patch Firefox to use the proper Open With dialogue?

[1] http://ubuntuforums.org/showthread.php?t=1219501

Jan Claeys (janc) wrote :

@dotancohen:
I don't know all the details, but the default page in Firefox is simply a configuration option, not a patch that changes or replaces a significant amount of code. What (I think) the Ubuntu developers want is that the Mozilla/Firefox developers either include this into Firefox and/or provide a standard way to "plug in" different "open with" dialogs.

Vish (vish) on 2009-08-10
affects: hundredpapercuts → null
Micah Gersten (micahg) on 2009-08-11
Changed in firefox-3.5 (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in firefox-3.0 (Ubuntu):
status: Triaged → Won't Fix
68 comments hidden view all 148 comments

I agree that we have first to correct the bug for Gnome. But this is not simply supporting or not KDE. I explain myself.

First point, the bug report is about Linux in general. Final users don't care if Firefox has only Gnome support, they want something that works under Linux cause there is a Linux build. It brings me to my second point.

We need to know if it's technically possible to distinguish the desktop the user is using. If something for Gnome is made, it could simply break this dialog under KDE if we can't detect the desktop environment. Indeed, if we call the Gnome API (GIO) in this case, it is not intended to be embedded in KDE, and this call will simply fail and break the dialog. It's not acceptable.

So can we detect easily in Firefox the desktop environment of the user to set a correction for Gnome in a first time that doesn't break KDE?

(In reply to comment #32)
> So can we detect easily in Firefox the desktop environment of the user to set a
> correction for Gnome in a first time that doesn't break KDE?

No, and we don't want to and don't need to. We call the GTK file and print dialogs, we're using GNOME stuff in multiple places, we are using theming from GTK, we don't do anything to even care if KDE is there or not, and the solution for this bug should also just ignore the fact. We don't run without GNOME libraries in any case, and there are no immediate plans to change that.

Ok. Thanks for this clarification.

Note : The bug Robert Kaiser is speaking of seems to be bug 140751

Robert Kaiser (In reply to comment #35)
> Note : The bug Robert Kaiser is speaking of seems to be bug 140751

Yes, already seen that and also this thread on Launchpad : https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/220798 speaking of a malfunction of the applications preference tabs under KDE without the firefox-gnome-support package installed. It is why I care about that sort of thing. But, Robert Kaiser pointed that it is not the priority, so it's ok. One thing at a time.

Note that I'm a big KDE fan and user myself, but we need to stick with the way of things we have at Mozilla right now, and it's better to get one solution right (in Mozilla terms this needs to be the GNOME/GTK one) and only then work on improving it for others (like KDE) as well, in a new bug, and that might need some more general support code on a higher level than download file handling as well - but that's something to look at in a followup bug.

Let's first work constructively to come up with a solution on the GNOME/GTK terms Mozilla is already bound to (esp. as we already know that a really generic solution isn't possible at this moment, this is the next best thing for now).

Even as a KDE user, I agree that Firefox should code the support for Gnome. Firefox ignores everything KDE at the moment (such as File Chooser dialogues) and this is expected. Yes, it is annoying, but it is expected.

I'm also convince of this. I'm perfectly agree with you. I'm just quite new on this and I'm asking to get a clear view of the impacts of such a dev. It's know clear for me that we deal before with Gnome, will see in the future for KDE. A unified FreedDesktop spec would be a good way to alleviate the port of code from one to the other, but it's another debate.

New question now. About look-and-feel of this application selector dialog. Does it must stick with the native Gnome (or Nautilus in this case (attachment hereunder)) look-and-feel or does it must follow the Mozilla guidelines (https://wiki.mozilla.org/ContentHandling:User_Interface/Proposed_UI2) and what has made Jim Mathies on the subject for Windows (https://bug348808.bugzilla.mozilla.org/attachment.cgi?id=271748)?

Created attachment 394231
Nautilus 'open with…' dialog screenshot (french UI)

(In reply to comment #40)
> Created an attachment (id=394231) [details]
> Nautilus 'open with…' dialog screenshot (french UI)

Which is what the patch in attachment 314945 from bug 428382 (dupe of this one now) was implementing.

(In reply to comment #39)
> New question now. About look-and-feel of this application selector dialog.

I think we'd need the input of the Mozilla UI team for a firm decision on that (though I expect them to prefer not creating a Linux-specific dialog).
What we can do without them is getting the backend right to get the information we want from GNOME and feed it to the interfaces that are already there from all I know.
And I think that's what we should stick to in this bug, any UI change following this or extending functionality e.g. to get info from elsewhere should be in followup bugs.

You have a patch on this bug that is flagged for 'review?' and not assigned to any reviewer. If you want the patch to be reviewed please assign a reviewer. Thanks

Comment on attachment 373282
Removes file association mechanism of firefox and use xdg-open instead

I think Shawn is a better reviewer for this patch.

Comment on attachment 373282
Removes file association mechanism of firefox and use xdg-open instead

This wouldn't work on anything but linux but it's a cross platform file

Shawn : making it cross platform is not really difficult, since it's a tiny patch. What do you think of this approach ? If I make this patch cross-platform, would you integrate it ?

David Futcher (bobbo) on 2010-06-07
tags: added: patch-forwarded-upstream
Micah Gersten (micahg) on 2010-07-16
Changed in firefox (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in firefox:
importance: Unknown → Medium
Changed in firefox-3.5 (Ubuntu):
status: Triaged → Confirmed
Chris Wilson (notgary) on 2011-01-14
Changed in hundredpapercuts:
status: New → Confirmed

It seems this issue can be resolved using new features introduced in GTK 3.0

See: http://developer.gnome.org/gtk3/3.0/GtkAppChooser.html

and

http://developer.gnome.org/gtk3/3.0/GtkAppChooserDialog.html

The obvious first step that needs to be taken in the migration to GTK 3.0

This doesn't depend on GTK 3.0. The API's to get this information from the platform have existed already for a long time.

Is anyone interested in taking this? I'd like to get it fixed, so will take it if nobody steps up

There are bugs relating to this that dating back to 2004 I don’t think you will be treading on any toes by taking it up.

As you can see by the previous posts the issue here has been finding a way to implement this so that it can be cross platform. What are the API's you are purposing to use to implement a solution?

(In reply to comment #48)
> This doesn't depend on GTK 3.0. The API's to get this information from the
> platform have existed already for a long time.

There are API's to get this information, yes, but GTK3 comes with an application selector dialog which would make fixing this bug much easier.

I would have to agree with Michael, using the supplied GTK3 dialog is a good long term fix, it will require little maintenance once implemented, and will present the user with a consistent dialog across the desktop once other applications start to implement this generic application selector.

*** Bug 56662 has been marked as a duplicate of this bug. ***

Note that one of the dupes, (bug #56662) was filed in October 2000, and has had an unreviewed patch since August 2009. See patch details here:
https://bugs.launchpad.net/firefox/+bug/18995

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null

*** Bug 693318 has been marked as a duplicate of this bug. ***

*** Bug 535634 has been marked as a duplicate of this bug. ***

Chris Wilson (notgary) on 2012-06-10
Changed in hundredpapercuts:
milestone: none → quantal-9-internet
Chris Wilson (notgary) wrote :

It seems that any fix for this would require a significant investment of time from someone with significant technical knowledge - not really papercut material.

Changed in hundredpapercuts:
status: Confirmed → Invalid
milestone: quantal-9-internet → none
Timothy Arceri (t-fridey) wrote :

This is an easy fix once the firefox port to gtk3 is finished (its currently making good progress). Reconfirming as a papercut.

Changed in hundredpapercuts:
status: Invalid → Triaged
Mozaic (mozaic) wrote :

Is there an ETA on the port? Is it worth targeting to 12.10 or will it take
longer than that?

On 15 June 2012 09:47, Timothy Arceri <email address hidden> wrote:

> This is an easy fix once the firefox port to gtk3 is finished (its
> currently making good progress). Reconfirming as a papercut.
>
> ** Changed in: hundredpapercuts
> Status: Invalid => Triaged
>
> --
> You received this bug notification because you are subscribed to One
> Hundred Paper Cuts.
> Matching subscriptions: Papercut bug mail
> https://bugs.launchpad.net/bugs/18995
>
> Title:
> [MASTER] "Open With" dialog not user-friendly
>
> Status in The Mozilla Firefox Browser:
> Confirmed
> Status in One Hundred Paper Cuts:
> Triaged
> Status in “firefox” package in Ubuntu:
> Triaged
> Status in “firefox-3.0” package in Ubuntu:
> Won't Fix
> Status in “firefox-3.5” package in Ubuntu:
> Confirmed
> Status in “mozilla-thunderbird” package in Ubuntu:
> Confirmed
>
> Bug description:
> When choosing to open a file in Firefox, an "Open With" dialog appears.
> You can choose to save the file or open it with a program from the list.
> However, if the desired program to open the file with is NOT listed, the
> user
> must navigate the filesystem to /usr/bin (or wherever) and select the
> appropriate program.
>
> A more user-friendly way would be to list all of the known programs
> installed
> that are available to open files with, and then have an "Other..." or
> "Advanced..." button for the user who would rather navigate the
> filesystem.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/firefox/+bug/18995/+subscriptions
>

Timothy Arceri (t-fridey) wrote :

As far as I can tell the last upstream patch is just waiting on a review from Canonicals Chris Coulson. Although the patch has been waiting for the review for over a month already so who knows.

This is my view of the perfect "Open with/Save" dialog:

"File: <name of the file> (type, size)"
Two tabs: "Save as..." and "Open with..."
Under "Save as...", the typical "Save as" dialog. By default, displaying the last directory selected, or the default one (usually "Downloads").
Under "Open with...", a list of installed applications. The list will be headed by the 3 most used applications for that type. If possible, it would be nice that the rest of applications were grouped by categories (Linux) or mimic the Start menu (Windows); this is how PCManFM looks and it's quite handy. Under it, a "Custom command" box (which would allow to enter commands with arguments or paths to executables), optionally with a "Browse..." button.
At the bottom, the buttons "Ok" and "Cancel", and a "Do this automatically for this type" checkbox.

What do you think?

Chris Wilson (notgary) wrote :

According to comment #138, there's an upstream patch awaiting review.

Changed in hundredpapercuts:
milestone: none → raring-round-7
importance: Undecided → Medium
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Timothy Arceri (t-fridey) wrote :

comment #138 is about the patches to port firefox to GTK 3 which is a required before this bug is fixed.

Changed in firefox-3.5 (Ubuntu):
status: Confirmed → Invalid
Changed in hundredpapercuts:
milestone: raring-round-7 → none
no longer affects: firefox-3.0 (Ubuntu)
no longer affects: firefox-3.5 (Ubuntu)
Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: none → papercuts-s-gtk

The missing application selector is also an issue when clicking a link with a HTML5 custom protocol and content handler. This (html5) becomes quite common now and it is almost an impertinence to force users to dig through the whole file system (as a work-around one could at least set the dialog to start at /usr/bin ). This needs a fix soon, if not in this decade then at least a usable work-around.

1 comments hidden view all 148 comments

Willing to pay $150 to whoever fixes this issue. (or give it to the Mozilla foundation, whatever you prefer).

(In reply to Mathieu Comandon from comment #59)
> Willing to pay $150 to whoever fixes this issue. (or give it to the Mozilla
> foundation, whatever you prefer).
Within which timeframe? ;-)

(In reply to David Bruant from comment #60)
> (In reply to Mathieu Comandon from comment #59)
> > Willing to pay $150 to whoever fixes this issue. (or give it to the Mozilla
> > foundation, whatever you prefer).
> Within which timeframe? ;-)

Before end of April 2014. I'll give $200 if the bug is released with the firefox version shipped with Ubuntu 14.04 and $150 if the bugfix is still in Nightly by then.

3 comments hidden view all 148 comments
Xodetaetl (ovocean) wrote :

I care about getting this fixed, so I'm offering USD 15.00 via FreedomSponsors to the first person who fix it.

Offer link: http://www.freedomsponsors.org/core/issue/416/implement-application-selector-nsimimeinfopossiblelocalhandlers-for-linux

You can also join me and throw in a few bucks there and we'll get it fixed faster. :)

If you fix this issue (see my and other pledgers acceptance criteria there) please use that site to request your payment.

no longer affects: hundredpapercuts
4 comments hidden view all 148 comments
Murz (murznn) wrote :

+15 USD from me via FreedomSponsors

Displaying first 40 and last 40 comments. View all 148 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.