Firefox search bar bug -Auto highlight

Bug #428703 reported by Gschool on 2009-09-13
336
This bug affects 70 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
firefox-3.0 (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
firefox-3.5 (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
gnome-screensaver (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: firefox-3.0

I have a bug in the search bar to the right of the url bar. that highlights the 1st 2 characters typed, and can't type beyond them.

Using Firefox 3.0.14 on Ubuntu 9.04

To reproduce:

have manually changed "browser.urlbar.ClickSelectsAll=True" in "about:config" (this is the only setting I have changed)

 Happens when:

1. After my screensaver (AntInspect) has kicked in during any given session.

If I then start to type in the search bar (set to google), after i type in 2 characters they automatically highlight, then the 3rd character I type removes the highlighted characters, and becomes the 1st character. So I cannot type in more than 2 characters in the search bar.

To Fix, I have to close Firefox and re-start, but happens again if my screensaver comes on.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: firefox-3.0 3.0.14+build2+nobinonly-0ubuntu0.9.04.1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.28-15-generic x86_64

Gschool (sg456) wrote :
Gschool (sg456) wrote :

If I change in about.config "browser.search.suggest.enabled" to "false" it fixes the problem, but then I get the same bug in the url bar, which is worse much worse.

Michael (mike984) wrote :

This is happening on both my desktop and laptop and a friends laptop. We all have 32 bit Ubuntu 9.04 installed.

Everytime the screensaver kicks in, you cannot type in the search bar as it keeps highlighting and clearing what you've typed.

I've deleted my ~/.mozilla folder and it still continues to happen.

Richard Carter (ricket) wrote :

This happens in both firefox-3.0 and firefox-3.5 for me, and it happens on both the URL bar and the address bar. And it is triggered not only by the screensaver, but also by the lock screen or by resuming from standby. The problem can be "fixed" by opening a new window (Ctrl+n) and then closing it.

There is a thread started about this bug here: http://ubuntuforums.org/showthread.php?t=1261872 - as I said, "I have a theory - I think the bar highlights when normally the suggestion box would drop down - for example, when you start typing something, normally the location bar shows elements from your history that match what you're typing, or the same thing happens in the Google bar and normally it would show search suggestions. But when this bug occurs, if you type something so odd that no results would happen (and the drop-down would not normally appear), then the bug doesn't happen."

Let me know if there's any more info I can give or any log files I can attach to help fix the problem.

Michael (mike984) wrote :

I just upgraded to Ubuntu 9.10 and the problem is still present.

Open Firefox, wait until screensaver activates, try typing something in the Google search box at the upper right of the browser or try entering an address in the URL bar. What you type will immediately highlight and subsequent key presses will overwrite each other.

I was hoping this was going to work in Karmic. This behaviour started the day I loaded Intrepid.

Michael (mike984) wrote :

I meant to say, it started the day I loaded Jaunty.

thyeum (mchellat) wrote :

I have the exact same problem.
Although I had never traced it down to the screensaver.
It happens on my laptop and desktop, both are running Ubuntu 9.04 x64 with the latest firefox 3.0.
I can't really remember when it started but it's been a while.
I just hope it gets fixed with Karmic, because it's really annoying

Danny Green (green-dannym) wrote :

I have the same problem as well. I have had it since installing 9.04 32bit. I reformatted and installed 9.10 x64 and the problem is sill present. I opened a bug report with the Firefox folks several months ago but nobody is able to duplicate the problem. The bug can be views here: https://bugzilla.mozilla.org/show_bug.cgi?id=502988. The problem is not present on my wife's laptop with Linux Mint installed. This seems to be a Ubuntu only problem.

I can further say that it has nothing to do with a screen saver or any other plugins. This happens with a fresh install and no screen saver running. To duplicate it simply do the following:

1 Start Firefox
2 Leave machine sit idle for 5-10 minutes.
3 Attempt to type in the URL bar.

At this point the text will auto highlight after about 1/2 second making it impossible to type. Closing Firefox and restarting clears the problem. I have discovered a workaround to be able to type in the address bar without having to restart Firefox.

Quickly type the LAST 2 characters of the address you wish to type. For example if you are attempting to type www.ubuntu.com, type OM. The OM will get highlighted at this point. Press the HOME key then type the rest of the address. This puts the insertion point at the beginning of the line and bypasses the auto highlight. (well, most of the time). This has helped many times when I had tabs opened that I did not want to lose on closing

adamgmetzler (adamgmetzler) wrote :

I to have this problem but have not been able to narrow it down to the screen saver, but suspect that it is the cause like the auto complete not working problem after resuming from a locked screen or screen saver. I am on jaunty and have this problem ever since installing with firefox-3.0 and am now using firefox-3.5.5pre and it is still doing this. It seems like firefox gets worse each new version, not better!

Michael (mike984) wrote :

I have noticed now, that if the bug above appears, minimize and then restore Firefox and it allows the auto-complete to return and you can type in URL address bar and search box.

There is still a bug though - this should not happen in the first place.

cmccann (robot-colinmccann) wrote :

Still trying to find a fix for this horribly annoying behavior, but hitting alt+tab twice quickly is the fastest way I've found to get back to normal (I'd imagine the window just has to be redrawn, hence the minimize/maximize, close/open, etc. working as well).

Uwe Schilling (uschilling) wrote :

Same problem here. On my machine, it affects the search bar as well as the url bar, and, as Ricket described it, not only after the screen saver, but also after locking the screen or resuming.

Jack Voo (vwh88) wrote :

I have the same problem, but I think is due to upgrade of firefox. After upgrade it , i haven't restart the browser, the problem solve after restart the firefox.

Hilikus (hilikus) wrote :

is anyone taking care of this? do the developers have an idea of what's wrong?

Ryan O'Shea (rinoshea) wrote :

Just so you know, I've had this bug since I installed Ubuntu 6 months ago, on every version of Firefox and every fresh install of Ubuntu I've done on every system.

If you quickly type gibberish in the address bar, once you reach a certain length, it will stop highlighting, allowing you to type what you want and then delete the initial characters.

It's a pain but hopefully the bug will be fixed soon and at least for me, after a few minutes the issue goes away.

tags: added: x86
Hilikus (hilikus) wrote :

i can confirm #11 works as a workaround
i'm using ubuntu 9.10 64bit and FF3.5

Ryan O'Shea (rinoshea) wrote :

#11 is very clever. Thanks!

KevinR (kevin-rotz) wrote :

I can confirm this not only on Ubuntu 9.10, 32-bit on a Pentium 4, but also on Arch Linux 64-bit on a Core2 Duo, both running GNOME.

I've found that by making another window active then going back to Firefox fixes the issue. #11 works as well. It's still annoying, though.

timmans (timinbrazil) wrote :

The URL drop down arrow doesn't work when Firefox is having this problem.

Another workaround is to right-click on the toolbars, select Customise and then Done (without making any adjustments). This seems to reset Firefox back to normal.

Michael (mike984) wrote :

I've had this bug since the first day I installed Jaunty. I have also formatted and installed Karmic from scratch and it has the same problem. Is it because we all have manually changed "browser.urlbar.ClickSelectsAll=True" in "about:config"?

How can we know a developer is looking into this?

I encounter so few bugs in Ubuntu but this one, I encounter every day several times...

Hilikus (hilikus) wrote :

for what it's worth, i did change ClickSelectsAll
it can't be coincidence that so many people did that uncommon change and report this bug

so there, the bug is half discovered already :P

Richard Carter (ricket) wrote :

Yep, I had changed that setting too. And after upgrading to 9.10, the issue disappeared; and I didn't make my usual change of clickSelectsAll. That must be it.

So the current temporary workaround for this bug: turn off clickSelectsAll.

Micah Gersten (micahg) wrote :

This is the Firefox 2 source right now, so this task is won't fix.

Changed in firefox (Ubuntu):
status: New → Won't Fix
Micah Gersten (micahg) wrote :

This is confirmed with Bug #494316.

Changed in firefox-3.5 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 438868, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Tars (tars-ac) wrote :

I believe the duplicate status is wrong. Please take another look - the other bug does not only happen when the click select all is true, and there is no mention of the auto-highlight behavior mentioned in this bug. If you think otherwise, please provide an explanation.

varanasi (mark-hugheshome) wrote :

I agree with Tars. This isn't an autocomplete bug. It happens on any entry into the address bar after a pause in using Firefox. #11 is a workaround.

Michael (mike984) wrote :

If I have "browser.urlbar.ClickSelectsAll=True" then after a pause it keeps highlighting and clearing what I've typed in the search box. I set "browser.urlbar.ClickSelectsAll=Fasle" then after a pause, I can type in the search box just fine but it won't autocomplete or offer suggestions. Fixing one bug will probably fix the other since they are probably closely related and obviously related to about:config setting.

neural_oD (nutter78) wrote :

agreed - this should be sorted out - very annoying!

wideyes (tarunperkins) wrote :

Has anyone resolved this yet?

Alan (mrintegrity) wrote :

I have removed the duplicate flag as it is not the same issue at all.

The issue here is that any text entered in either the search or the URL bar can be randomly highlighted (sometimes affecting both text fields sometimes just one) so that the next key press removes any text already entered.

This is intensely irritating and seems to affect a wide variety of users (x86 / x86-64 etc.).

The other bug is regarding the autocomplete dropdown not appearing (which also affects me), it might be caused by the same underlying issue but that remains to be be seen.

Alan (mrintegrity) wrote :

Btw, i get this issue regardless of browser.urlbar.clickSelectsAll being true or false..

I confirm post #34 - this happens for me on a fresh install of 10.04 without modifying Firefox or any of its settings. Every time I close my laptop lid or the screensaver comes on, I either have to close Firefox or minimize/maximize it. Quite annoying. Make it a paper cut, please?

Locke (locke-db) wrote :

Lucid x86_64 here, current updates.
Firefox 3.6.6
browser.urlbar.clickSelectsAll=false

Anytime the screensaver kicks in, (idle, return from sleep, whatever) autocomplete and suggestions (things which put the "awesome" in awesome-bar) don't work. Closing and reopening Firefox brings back awesome-bar functionality.

Frank Gross (f-gross) wrote :

Wow, I finally found the right thread to drop my '+1' :)

Currently running FF 3.6.8 on Ubuntu Lucid. I have the same problem, be it on my laptop or my desktop pc (both running lucid and all current updates).

I found another thread describing the same problem here: https://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&comments_parentId=636752&forumId=1 -- Unfortunately I could not post a comment there, even if being logged in... :P

birdsnare (birdsnare) wrote :

+1 for me. Running Firefox 3.6.8 and Ubuntu Lucid Lynx. Frustrating. #11 does work, though.

stenzn (stenzn) wrote :

This is INCREDIBLY annoying. maverick AMD64 here (fresh install). #11 fixes it for me temporarily as well. I don't know exactly what triggers it, but I can confirm as well that it works for a while (it worked yesterday), then it breaks (today). I never reboot other than kernel updates.

Is there some way I can run a trace to see what the hell Firefox is doing that is causing this behavior? I'll try to fix it myself...

stenzn (stenzn) wrote :

Also, browser.urlbar.clickSelectsAll has nothing to do with it.

h3X (lennart-nilsen) wrote :

Same problem here on firefox 3.6.12 on Maverick x64. Alt-tab fixes, but this is like taking a headache pill instead of finding the cause of the pain. Please someone look into this! May it be related to desktop effects perhaps? I have Compiz enabled.

markbeverley (m-rkbev) wrote :

I also have this problem. In fact I've had it for some time with various past releases of Ubuntu and Firefox, it's really annoying and I'm surprised there is still no fix! I'm currently running Maverick and Firefox 3.6.12 on an AMD Athlon.

Ryan O'Shea (rinoshea) wrote :

For me at least, this problem stopped after I switched to Firefox (Minefield) 4.0 and Ubuntu 10.10

Andrew (arosborough) wrote :

I have this bug, I can't confirm that it happens after a screensave kicks in. I just locked the screen and unlocked it, and nothing bad happened. It is an intermittent issue that happens several times daily. How would I go about getting Firefox (minefield) 4.0 since it isn't in the normal repositories?

Damian Nadales (dnadales) wrote :

I upgraded to firefox 4 and I still have the same problem. Furthermore, after the screensaver is activated I cannot use the firefox menu. To workaround this I have to switch to a different workspace.

Ian Dunlop (ianwdunlop) wrote :

I get this on Lynx a lot. Seems to happen if Firefox boots before the wifi has connected or sometimes on wake from sleep. Very annoying.

Changed in firefox-3.0 (Ubuntu):
status: New → Confirmed
Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.