Ubuntu

"print selection only" option cuts multi-page text

Reported by Daniel Hollocher on 2008-11-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
firefox-3.0 (Ubuntu)
Wishlist
Unassigned

Bug Description

I tried selecting some text from a webpage that I wanted to print. The text was several pages long. When I printed it, I noticed that the last line of the text was cut horizontally, and the bottom part was on the next page, thus making that line very difficult to read.

I checked with just printing to a file (both postscript and pdf), and the same thing happens, and at the same proportions (the same amount of the line is cut off, and pushed to the next page)

Obviously, I think the line of text shouldn't be cut at all. It should be either squeezed into the current page (The "Ignore scaling and shrink page to fit width" option is selected, so maybe that could justify this?) or, just push the line to the next page.

Please only describe only one bug/feature request per bug filed. This allows us
to have a clear measure of when this bug is complete.

Your main problem is that the text between the first and second pages of print
outs is cut in half.

I am aware of bugs for Mozilla Browser that have this issue. I need to check if
we can dupe to that bug.

For print on right click menu there is already a bug, which is bug 204519.

As for the shrink to fit, I need to do some more searching on bugzilla.

In , Relf (relf) wrote :

*** Bug 252153 has been marked as a duplicate of this bug. ***

I can confirm this bug on
"Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.3) Gecko/20041027
Firefox/1.0RC1"

I can also cofirm this bug with RC2. Steps:

1. Goto: http://www.faqs.org/rfcs/rfc2616.html
2. Select a large portion of text
3. Print > Print Selection

Result:
Text is split in the middle of a line.

Expected result:
Text that doesn't fit at end of page gets bumped down to next page.

The happens for me for any site. The problem is especially evident when there
are images involved. Goto: http://www.zeldman.com/abc/, select all, and print
selection and you'll see what happens.

Pictures are cut in two pieces as well. That looks strange :-)

This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox: http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey: http://www.mozilla.org/projects/seamonkey/

at FF 1.0.7, there are still various problems with printing webpages
when printing "selection" is used. That might well have to do with
pages that are encoded to MS standards in some way, for all I know.
There is the sliced through text line at the bottom of one page and top
of next, there is the extra page with not much at the beginning or end,
and these happen at times, but perhaps the most radical problem is
that often, eg when printing a long newspaper article but using
"selection",only one page of the text appears, with perhaps
(usually) one of the junk pages, and the rest of the text utterly missing.
I've seen this with my windows XPH computers and a couple of printers.

In , Pygy (pygy) wrote :

*** Bug 310794 has been marked as a duplicate of this bug. ***

(In reply to comment #7)
> at FF 1.0.7, there are still various problems with printing webpages
> when printing "selection" is used. That might well have to do with

And in Firefox 1.5 beta 1 ?

(In reply to comment #9)
> (In reply to comment #7)
> > at FF 1.0.7, there are still various problems with printing webpages
> > when printing "selection" is used. That might well have to do with
>
> And in Firefox 1.5 beta 1 ?

I'm a bit nervous about trying to have 1.5 and 1.0.7 around simultaneously.
I was very disappointed that the printing bug doesn't seem to have gotten
much attention, and with that and time/energy considerations I'm planning
on just waiting for the final 1.5 to arrive.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051013
Firefox/1.4.1

With a text page as suggested initially, I still se this issue. Of the four
pages of print I ran off, one has the line split across two pages. The
suggestion of trying images gives me other issues - will investigate and may
report separately. I guess this bug is in Core -> Printing rather than FF.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
Firefox/1.0.7

can confirm that this bug effects splitting of images as well as text. This
happens commonly, and makes printing more than 1 page of text via the
Print-->Selected virtually impossible. Can the Core Firefox bug 194413 be reopened?

(In reply to comment #12)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
> Firefox/1.0.7
>
> can confirm that this bug effects splitting of images as well as text. This
> happens commonly, and makes printing more than 1 page of text via the
> Print-->Selected virtually impossible. Can the Core Firefox bug 194413 be
reopened?

I don't see the point of reopening bug 194413 - it is basically this bug, except
there is more detail here and this one is marked new. The reason it's in Core
(not FF) is that printing is handled by underlying code shared by FF, TB,
SeaMonkey, ...

As for the images, yes I agree the same problem is visible. But I had some
other effects with the example in comment #4, which possibly deserve a separate
bug. I thing the porblem is independent of what the content is - there is
clearly some kind of problem detecting the end of a page accurately.

I can confirm the problems on

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5

1) Only the first page of the selected text is printed
2) Only the top of the last line is shown i.e. the other half of the line would appear on the second page when there wouldn't be 1)

A possible clue. I've noticed this bug all along, and it's still there
in WinXPH and FF1.5. However, the following might be a clue. In my printer
properties, there's a checkbox for better grays. If I simply print a webpage,
it works nicely, but as soon as I'm printing a selection, this adjustment
is blatantly ignored. For what it's worth.

I've noticed another problem. Whenever an image is split, the part that goes on
the next page is taken from the *top*; the amount is the same as the amount
that would be taken from the rest of the image, but it's taken from the top
instead. This has been occuring through many versions (not sure how far back),
and is still in 1.0.7. I think I also saw it in one of the 1.5 RCs.

Anyway, I don't suppose there's already a bug for this...

Oh yeah, and I'm seeing this bug (the topic of this page, that is) on Linux. So it's not just a Windows problem. Don't know about the wrong splitting though. Could be Xprint?

Confirming that the text-cutting bug is still present.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2 - Build ID: 2006030804

I can confirm that the cutting bug is still present. Printing highlighted text is still broken. On by Xubuntu 6.10 machine it doesn't work neither.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0

*** Bug 372095 has been marked as a duplicate of this bug. ***

*** Bug 312417 has been marked as a duplicate of this bug. ***

Confirming that this bug is still present in 2.0.0.6.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Same happens with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.2pre) Gecko/2008070504 GranParadiso/3.0.2pre ID:2008070504

(In reply to comment #23)
(in other words, this bug is still around in Firefox 3.0)

Daniel Hollocher (chogydan) wrote :

I tried selecting some text from a webpage that I wanted to print. The text was several pages long. When I printed it, I noticed that the last line of the text was cut horizontally, and the bottom part was on the next page, thus making that line very difficult to read.

I checked with just printing to a file (both postscript and pdf), and the same thing happens, and at the same proportions (the same amount of the line is cut off, and pushed to the next page)

Obviously, I think the line of text shouldn't be cut at all. It should be either squeezed into the current page (The "Ignore scaling and shrink page to fit width" option is selected, so maybe that could justify this?) or, just push the line to the next page.

John Vivirito (gnomefreak) wrote :

Thank you for taking the time to file this bug report with us. Closing due to age. If this is still a problem in 3.0.7 please reopen this bug.
Also please reopen with all new information on how to reproduce this bug by giving us step by step instructions.
We also need what happens what is expected to happen.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

If it is still an issue please file a bug upstream about it and drop the link here.

Changed in firefox-3.0 (Ubuntu):
importance: Undecided → Wishlist
status: New → Invalid
Daniel Hollocher (chogydan) wrote :

mk, well, I'm setting this to confirmed, since it affects windows firefox also. I will have to file upstream at some point...

Changed in firefox-3.0:
status: Invalid → Confirmed
Changed in firefox:
status: Unknown → Confirmed
Daniel Hollocher (chogydan) wrote :

hahahaha, well, if age is a reason to invalidate bugs, then this one should be deleted! Its been reported and repeatedly confirmed since Firefox 1.5 Looks like this bug may never get fixed :(
https://bugzilla.mozilla.org/show_bug.cgi?id=240625

On the upside, I didn't have to sign up for a bugzilla.mozilla.org (yet-another) account!

Anyway, I think the appropriate status for this bug is Triaged - Low. This is what I've seen happen to other upstream bugs. Do what you see as fit.

If someone does give this bug report another look, can you answer this for me: Should I stay subscribed? I would like to only be subscribed to bugs for which whose status is important to me, or I feel I can offer something. Given that this bug is long standing and I can't fix it, there isn't much I can offer. Given that it doesn't look like anyone is trying to fix this, its status isn't important to me. If you have an opinion, and I'm still subscribed, please post it. Otherwise, I will probably unsubscribe the next time I go through my list o bugs.

joaowendel (joaowendel) wrote :

The same problem happened to me.

Windows XP Professional SP3 x32
Firefox 3.0.10

Printing to a PDF file with Ghostscript via Bullzip PDF Printer... the last line of the text in each sheet was cut horizontally...

I try to print in IE (OMG....) and everything was fine. The problem is Firefox. Hope that somebody correct this.

(sorry for my bad english - i'm brazilian)

Best regards,

João Wendel
Florianopolis, SC
Brazil

*** Bug 373163 has been marked as a duplicate of this bug. ***

*** Bug 491411 has been marked as a duplicate of this bug. ***

*** Bug 520158 has been marked as a duplicate of this bug. ***

*** Bug 552258 has been marked as a duplicate of this bug. ***

Changed in firefox:
importance: Unknown → Medium

*** Bug 642824 has been marked as a duplicate of this bug. ***

*** Bug 730258 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.