Firefox can't display error pages anymore in german localization

Bug #218563 reported by Christian Theune on 2008-04-17
42
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: firefox-3.0

This is what it displays instead:

XML-Verarbeitungsfehler: Fehler beim Verarbeiten einer Referenz auf eine externe Entität
Adresse: jar:file:///usr/lib/xulrunner-1.9b5/chrome/toolkit.jar!/content/global/netError.xhtml
Zeile Nr. 10, Spalte 3: %netErrorDTD;
--^

ProblemType: Bug
Architecture: i386
Date: Thu Apr 17 11:09:29 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: firefox-3.0 3.0~b5+nobinonly-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-12-generic i686

Christian Theune (ctheune) wrote :
cygnus (cygnus) wrote :

Same here...

Linux minime 2.6.24-16-generic
apt-cache policy firefox-3.0
firefox-3.0:
  Installiert:3.0~b5+nobinonly-0ubuntu2
  Mögliche Pakete:3.0~b5+nobinonly-0ubuntu2
  Versions-Tabelle:
 *** 3.0~b5+nobinonly-0ubuntu2 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Marcus Asshauer (mcas) on 2008-04-17
Changed in firefox-3.0:
status: New → Confirmed
Dmitri Bachtin (damg-dev) wrote :

I can confirm this bug.
2.6.24-16-generic

apt-cache policy firefox-3.0
firefox-3.0:
  Installiert:3.0~b5+nobinonly-0ubuntu2
  Mögliche Pakete:3.0~b5+nobinonly-0ubuntu2
  Versions-Tabelle:
 *** 3.0~b5+nobinonly-0ubuntu2 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Christian Theune (ctheune) wrote :

This is getting more serious. Similar error popping up for printing (can't show printing dialog) which results in later clicks to the 'Print' function to say 'not available'. :(

Christian Theune (ctheune) wrote :

This is what FF says (German, sorry):

XML-Verarbeitungsfehler: Fehler beim Verarbeiten einer Referenz auf eine externe Entität
Adresse: chrome://global/content/printProgress.xul
Zeile Nr. 6, Spalte 67:<!DOCTYPE window SYSTEM "chrome://global/locale/printProgress.dtd">
------------------------------------------------------------------^

This actually happens after the printing dialog when FF tries to actually print.

cygnus (cygnus) wrote :

Seems to happen in all cases were Firefox wants to Display a error message in based on a xml message. In my case it mentioned it, when the page isn't reachable or some kind of 40x error happens or a certificate warning should be displayed.

Daniel Lehmann (leh) wrote :

I can confirm this bug too:

Displaying network error (probably certificate issue):
XML-Verarbeitungsfehler: Fehler beim Verarbeiten einer Referenz auf eine externe Entität
Adresse: jar:file:///usr/lib/xulrunner-1.9b5/chrome/toolkit.jar!/content/global/netError.xhtml
Zeile Nr. 10, Spalte 3:

Trying to print:
XML-Verarbeitungsfehler: Fehler beim Verarbeiten einer Referenz auf eine externe Entität
Adresse: chrome://global/content/printProgress.xul
Zeile Nr. 6, Spalte 67:<!DOCTYPE window SYSTEM "chrome://global/locale/printProgress.dtd">

(sorry for the german error msgs)

schnittchen (schnittchen) wrote :

I have the same.

Bug #218563 seems to be a duplicate of this one. I will try the workaround there next.

schnittchen (schnittchen) wrote :

The workaround did it for me, and that means that in my case the bug is in the german localization.

rhi (rhi-deactivatedaccount) wrote :

Have this problem too. Ubuntu 8.04 RC1, AMD64, German, clean install.

I can't display pages with my own SSL certificates because the "do you trust this cert?" dialog doesn't appear. Instead I get the XML-Verarbeitungsfehler

Fabian T (ft82de-oss) wrote :

Bug #218563 is this one, so you're propbably talking about Bug #218908 - there is a workaround which helped me and Steffen Banhardt seems to have found the problem.

cygnus (cygnus) wrote :

Added 218908 as a duplicate of this bug.

I can confirm that the problem is not existent, when installing another language (like fr) and switching LANG variable to fr_FR.UTF-8 the correct french error page is presented.

Last update of package is from 16. April 2008 13:00:16 updated by Alexander Sack <email address hidden>. He also updated the fr package, but this works fine.

cygnus (cygnus) wrote :

The problem is caused by a wrong mozilla.tar.gz contained in data dir

It seems that within the mozilla.tar.gz the contained jar file is in the wrong directory (not chrome subdir) and has the wrong name. Should be de.jar and not xulrunner.... The problem is also existent in the firefox-3.0-de.jar file which should also be put into chrome/de.jar

I am currently checking whether fixing this also fixes the problem

cygnus (cygnus) wrote :

It seems that this is not the only problem. The chrome.manifest has the wrong links and in addition the contained dtd files are also wrong...

Kjell Braden (afflux) on 2008-04-19
Changed in firefox-3.0:
importance: Undecided → Medium
Fabian T (ft82de-oss) wrote :

The bug seems to have been fixed now. When I noticed that the distribution updates included a new version of the german gnome language pack, I installed them, disabled the Firefox and Xulrunner (en-GB) packages and reenabled the (de) ones. Error pages are now displayed correctly and in german as far as I have tested them.

Fabian T (ft82de-oss) wrote :

Note: I did the enabling and disabling within the Firefox Add-on management of course.

Timo Jyrinki (timo-jyrinki) wrote :

Fix released, see bug 218848 for more information.

Changed in firefox-3.0:
status: Confirmed → Fix Released
schnittchen (schnittchen) wrote :

I am still seeing this bug, having upgraded properly.

Can't access https sites with improper certificates when german localization is activated (in firefox add-ons->languages).

Am I the only one?

Fabian T (ft82de-oss) wrote :

I'm sorry to hear that, but I can confirm that I do get the correct error page for improper certificates of https sites (including the option to grant an exception) with the german localization activated.

Christian Theune (ctheune) wrote :

Hmm. Didn't help for me either, but the error is different now. When trying to print (after the print dialog):

An error window with: <window xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"

And when trying to view source: <window id="viewSource"

No other hints what's wrong though.

Christian Theune (ctheune) wrote :

Note: I'm not sure whether the `print` problem is totally different and would want to have a second bug opened or this one set back to 'new'.

Christian Theune (ctheune) wrote :

Re-opening to avoid it getting dropped accidentally, please close and tell me to open another bug if needed.

Changed in firefox-3.0:
status: Fix Released → New
Daniel Lehmann (leh) wrote :

Just for the archive:
The fix worked for me. Thanks :-)

Dmitri Bachtin (damg-dev) wrote :

The problem with error pages is away on my machine now, proper german messages are shown.

Will try to print once I'm at home.

 -- Thank you for fixing!

Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
apt-cache policy firefox-3.0
firefox-3.0:
  Installiert:3.0~b5+nobinonly-0ubuntu2
  Mögliche Pakete:3.0~b5+nobinonly-0ubuntu2
  Versions-Tabelle:
 *** 3.0~b5+nobinonly-0ubuntu2 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

cygnus (cygnus) wrote :

Bugfix also works for me. I have not yet checked print error.

schnittchen (schnittchen) wrote :

Today's upgrade fixed it for me.

Printing works as well :-)

Changed in firefox-3.0:
status: New → Confirmed
status: Confirmed → Fix Released

It works now! Thanks.
I set it to fixed. ;-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers