Firefox 3 does not focus on location bar when creating new tab in fullscreen if the location bar is not visible

Bug #215692 reported by Michael Rooney on 2008-04-11
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Low
firefox-3.0 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox-3.0

When you open a new tab in firefox, the address bar is typically focused so you can type the address you want, hit enter, and the page is loaded. However stating with Firefox 3 this doesn't happen in fullscreen mode so that you have to exit out of fullscreen, type the address, and go back to fullscreen.

In Firefox 2 this wasn't necessary. In fullscreen, you could hit Ctrl+T to open a new tab, type the address (even though you couldn't see the address bar, it was still focused and accepting characters), hit enter, and the page loaded.

For smaller screened laptops this is especially useful, where browsing is done entirely in fullscreen. And in general it is just annoying to have to toggle the fullscreen to type an address.

I imagine this is an easy fix. I don't know where the focus currently goes when creating a new tab in fullscreen, but it just needs to go to the address bar, like it did in FF2 and like it does now in FF3 when not in fullscreen.

To reproduce:
1. Open Firefox 3
2. Enter into fullscreen mode (F11, generally)
3. Ensure the location bar is NOT visible (by mousing away from it, if it is there)
4. Hit Ctrl+T to open a new tab.
5. Try typing an address such as google.com and hitting enter. Nothing happens because the bar wasn't focused when you created a new tab.

Another way to reproduce is to move the location bar to the menu area (File, Edit, etc) using the Customize option from View->Toolbar. This is useful again for smaller screened laptops, and this way the location bar is never visible in Fullscreen mode.

Again, Firefox 2 focused the location bar on a new tab in either of the above cases, and as such allowed you to type an address and hit ENTER and go to the URL, even without the location bar being visible. This was very useful.

Jonathan Thomas (echidnaman) wrote :

Move your mouse to the top of the screen and the address bar will come down. You can then click the address bar and type the address without leaving full screen.

I can confirm that the address bar doesn't have focus automatically in fullscreen mode, however.

Changed in firefox-3.0:
status: New → Confirmed
Michael Rooney (mrooney) wrote :

Thanks Jonathon for your idea, however I forgot that my address bar is a non-default location, which causes it to not be displayed when moving the mouse up. Only the tabs are displayed in my case.

Just using the Customize option under View, I moved the address bar to the top bar (with File/Edit/View etc.), and hid the Navigation and Bookmarks toolbar, to make more room when not in fullscreen as well.

So while this doesn't allow me to use Jonathan's workaround, I don't think it is the cause of the issue since he confirmed it doesn't gain focus on a new tab in fullscreen in the normal position as well.

Dimitrios Symeonidis (azimout) wrote :

I confirm this bug in ff3 rc1. I admit that pressing ctrl-l is not that much trouble, however it would be convenient. Note that (as pointed out in the title) the problem only exists in full screen mode; in normal mode ctrl-t opens a new tab and focuses on the location bar...

Thanks Dimitrios for pointing out Ctrl+L, I didn't know about that! Since this is a regression from FF2 I wonder if there is an upstream report about this, and if not, if one should be opened.

Changed in firefox-3.0:
importance: Undecided → Low

On Fri, Jun 06, 2008 at 08:42:38PM -0000, Dimitrios Symeonidis wrote:
> I confirm this bug in ff3 rc1. I admit that pressing ctrl-l is not that
> much trouble, however it would be convenient. Note that (as pointed out
> in the title) the problem only exists in full screen mode; in normal
> mode ctrl-t opens a new tab and focuses on the location bar...
>
> ** Summary changed:
>
> - Firefox 3 does not focus address bar when creating new tab in fullscreen
> + Firefox 3 does not focus on location bar when creating new tab in fullscreen
>

for me this works in firefox 3 rc1. pressing ctrl+t in full-screen
will open new tab and focusses location bar text field.

sure there are no extensions involved?

 status incomplete

 - Alexander

Changed in firefox-3.0:
status: Confirmed → Incomplete

If the location bar/tab bar stuff is not hidden when you crtl + t, then the location bar will be focused. If you crtl+t and then un-hide the bars it will not be focused.

Jonathan Thomas (echidnaman) wrote :

Oh, also happens with virgin FF3, no plugins installed.

Alexander Sack wrote:
> On Fri, Jun 06, 2008 at 08:42:38PM -0000, Dimitrios Symeonidis wrote:
>> I confirm this bug in ff3 rc1. I admit that pressing ctrl-l is not that
>> much trouble, however it would be convenient. Note that (as pointed out
>> in the title) the problem only exists in full screen mode; in normal
>> mode ctrl-t opens a new tab and focuses on the location bar...
>>
>> ** Summary changed:
>>
>> - Firefox 3 does not focus address bar when creating new tab in fullscreen
>> + Firefox 3 does not focus on location bar when creating new tab in fullscreen
>>
>
> for me this works in firefox 3 rc1. pressing ctrl+t in full-screen
> will open new tab and focusses location bar text field.
>
> sure there are no extensions involved?
>
> status incomplete
>
> - Alexander
>
>
> ** Changed in: firefox-3.0 (Ubuntu)
> Status: Confirmed => Incomplete
>
I am unable to confirm. When i opened a tab in full screen using the
site you gave i hit ^T and it opened a tab. Please let me know if there
is a better test case. Do all your sites that you go to have this issue
or is it one site?

--
Sincerely Yours,
     John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

Michael Rooney (mrooney) wrote :

Hi John, Alexander. I think I have added enough information in the description. Please re-read it and try following those steps, noting the crucial aspect is that the location bar is NOT visible when you hit Ctrl+T. It probably isn't proper to mark my own bug as Confirmed from Incomplete, so please do so if you agree that is enough information. I just duplicated this on a fresh install with no extensions.

description: updated

On Sat, Jun 07, 2008 at 04:16:51PM -0000, Mike Rooney wrote:
> Hi John, Alexander. I think I have added enough information in the
> description. Please re-read it and try following those steps, noting the
> crucial aspect is that the location bar is NOT visible when you hit
> Ctrl+T. It probably isn't proper to mark my own bug as Confirmed from
> Incomplete, so please do so if you agree that is enough information. I
> just duplicated this on a fresh install with no extensions.

 status confirmed

lets go upstream ...

 affects firefox
 status incomplete

OK, thanks. could you try to find this in bugzilla.mozilla.org and if
you dont find it open a new bug with the step by step instructions?

Let us know about the bug id.

Please try to choose a reasonable component when filing bug in
bugzilla as otherwise it will stay unseen. If you have questions ask
on #ubuntu-mozillateam.

 - Alexander

Changed in firefox-3.0:
status: Incomplete → Confirmed
Changed in firefox:
status: Incomplete → Confirmed
Michael Rooney (mrooney) wrote :

Hi Alexander, I found a few that seem sort of similar, but seem to be slightly different at https://bugzilla.mozilla.org/buglist.cgi?quicksearch=location+bar+focus+new+tab. That search yields 5 bugs, do any of them seem to be it to you? The title of 407852 seems close but the description is far off.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

pressing ctrl+t while in full-screen opens a new tab, but the focus is not on the location bar. ctrl-l brings the focus where it should be. this is not the case in normal mode (non-full-screen)

Reproducible: Always

Steps to Reproduce:
1.press f11 for full-screen
2.press ctrl+t for a new tab
3.type something
Actual Results:
nothing was written, because the focus was not in the location bar

Expected Results:
the focus should be in the location bar, just like outside full-mode

this report was initially filled downstream in ubuntu's launchpad:
https://bugs.launchpad.net/firefox/+bug/215692

I just want to mention explicitly that this is a regression from Firefox 2; you could hit ctrl+t and type URLs and hit enter just fine (even though you couldn't see the URL bar). This was a great boon to my netbook browsing productivity.

If you change browser.fullscreen.autohide to false, do you get the desired behaviour back? http://kb.mozillazine.org/About:config

Hi Ria. That option does not give me that behavior back. It just doesn't hide the tab bar. The bug doesn't have to do with what is shown or not, but whether the keyboard input goes to the hidden location bar or not and allows you to then visit websites. Thanks though!

Dimitrios Symeonidis (azimout) wrote :

mike, none of the above 5 bugs seemed relevant

i reported upstream:
https://bugzilla.mozilla.org/show_bug.cgi?id=459927

Changed in firefox:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in firefox:
status: Unknown → New
Michael Rooney (mrooney) wrote :

Thanks Dimitrios, I really appreciate you doing that, I had been meaning to but never got around to it.

Michael Rooney (mrooney) on 2008-10-14
Changed in firefox-3.0:
status: Confirmed → Triaged
Tom (tom6) wrote :

I get same result in Firefox 3.0.4 now that's been released.

Additionally i found the focus wasn't in the location bar even in just a maximised firefox let alone in full-screen. It was only in an unmaximised little window that firefox assumed i'd want to lookup an internet address in a new tab.

It's not a problem for me as i'm not using a laptop but it is very odd and quirky.

Good luck all :)

Just mentionning that it is still present in last Minefield 3.2 build.

Hi,

Just to confirm, this is reproduceable under FF3.x on Linux.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8. Slackware 12.1

It is highly annoying, if you prefer full-screen mode.
The only workaround is:
F6 (to show the location bar) + TAB (to focus on the text field for the location).

Mike Rooney's first comment doesn't work for me. You can't type in the field unless you hit the key combination I mentioned.

Thanks in advance!

Martin

Also confirming on Linux. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090407 Shiretoko/3.5b4pre

Changed in firefox:
status: New → Confirmed

*** Bug 500783 has been marked as a duplicate of this bug. ***

Another variant of this bug (reproduced with Firefox 3.5 20090624)
When moving the focus to location bar by clicking into the location bar, "Search bookmarks and history" can be edited, but the entered address is ignored when pressing enter. Only after moving the focus away and back to the location bar, a new address can be entered.
It is only reproducable, if the location bar is hidden when pressing Ctrl+t.

Bug 494373 has a patch, shouldn't this be a duplicate?

In , Dao (dao) wrote :

*** This bug has been marked as a duplicate of bug 439774 ***

Changed in firefox:
status: Confirmed → Invalid
Changed in firefox:
importance: Unknown → Low
status: Invalid → Unknown
Changed in firefox:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.