Ubuntu

fglrx 2:8.960-0ubuntu1: fglrx kernel module failed to build [error: ‘cpu_possible_map’ undeclared (first use in this function)]

Reported by Jonathon Fernyhough on 2012-05-02
216
This bug affects 28 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Unassigned
Quantal
High
Alberto Milone

Bug Description

Apport report. fglrx 8.960 fails to build with kernel 3.4.0-1-generic.

Module compilation failed with:
  CC [M] /var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.o
/var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.c: In function ‘kasInitExecutionLevels’:
/var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.c:4184:5: error: ‘cpu_possible_map’ undeclared (first use in this function)
/var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.c:4184:5: note: each undeclared identifier is reported only once for each function it appears in
/var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.c:4184:5: warning: left-hand operand of comma expression has no effect [-Wunused-value]
make[2]: *** [/var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.o] Error 1

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: fglrx 2:8.960-0ubuntu1
Uname: Linux 3.3.0-4.dmz.1-liquorix-amd64 x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
DKMSKernelVersion: 3.4.0-1-generic
Date: Wed May 2 16:31:41 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64+mac (20111012)
PackageVersion: 2:8.960-0ubuntu1
SourcePackage: fglrx-installer
Title: fglrx 2:8.960-0ubuntu1: fglrx kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

tags: removed: need-duplicate-check

The attachment "34.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
description: updated
Changed in fglrx-installer (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
summary: - fglrx 2:8.960-0ubuntu1: fglrx kernel module failed to build
+ fglrx 2:8.960-0ubuntu1: fglrx kernel module failed to build [error:
+ ‘cpu_possible_map’ undeclared (first use in this function)]
Paul Maseberg (pdmaseberg) wrote :

I can get the module to build with that 34.patch but then I get

fglrx: Unknown symbol old_rsp (err 0)

and I found someone else reporting that bug to amd

http://ati.cchtml.com/show_bug.cgi?format=multiple&id=495

Bryce Harrington (bryce) on 2012-05-16
Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
tags: added: rls-mgr-p-tracking

New patch from http://ati.cchtml.com/show_bug.cgi?id=495 added by Zenitur

(Testing on my system with AMD driver is in progress ;)

Using only the patch from #6 fglrx builds and X loads. glxinfo reports info as expected (as far as I can tell ;). Unity3D starts.

I had no luck with the new patch. It still gave compiler warnings. So I combined the two patches to one and that worked for my situation.

Daniel Letzeisen (dtl131) wrote :

fglrx-installer (2:8.960-0ubuntu2) quantal; urgency=low

  * replace-do_mmap-and-do_munmap-with-vm_mmap-and-vm_mu.patch,
    replace-for_each_cpu_mask-with-for_each_possible_cpu.patch:
    - Add support for Linux 3.5.
 -- Alberto Milone <email address hidden> Sun, 17 Jun 2012 17:20:49 +0200

Changed in fglrx-installer (Ubuntu Quantal):
status: Triaged → Fix Released
Christopher (soft-kristal) wrote :

Fix works for me on my AMD 64 bit system. Thanks.

Still gives on x86 system:

/var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.c: In function ‘KCL_fpu_begin’:
/var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.c:5859:5: error: implicit declaration of function ‘__thread_has_fpu’ [-Werror=implicit-function-declaration]
/var/lib/dkms/fglrx/8.960/build/2.6.x/firegl_public.c:5860:9: error: implicit declaration of function ‘__save_init_fpu’ [-Werror=implicit-function-declaration]

That was fixed in the combined patch:

@@ -187,6 +187,9 @@
 #include <linux/gfp.h>
 #include <linux/swap.h>
 #include "asm/i387.h"
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,4,0)
+#include <asm/fpu-internal.h>
+#endif

 #include "firegl_public.h"
 #include "kcl_osconfig.h"

Shabang (theshabang) wrote :

Guys,
Im with same problem installing fglrx AMD driver in 3.4 kernel from ubuntu mainline.
Can you explain me how to apply this patch?

Thank you

@Shabang: Check out the thread on ubuntuforums: http://ubuntuforums.org/showpost.php?p=12090910&postcount=26

There's also a new patch for kernel 3.5 which works for me (credited to Enrico Tagliavini).

Holm Dressler (velovity) wrote :

For everybody who is interested in: for my Kernel 3.5.1 and the newest
amd-driver-installer-12-6-x86.x86_64.run these patches work for me

get amd-driver-installer-12-6-x86.x86_64.run
get FGLRX-8-98-Kernel-3-5-1.zip

./amd-driver-installer-12-6-x86.x86_64.run --extract a
patch a/common/lib/modules/fglrx/build_mod/firegl_public.c Patch-FGLRX-8-98-Kernel-3-5-1_4_FireGL.patch
patch a/common/lib/modules/fglrx/build_mod/kcl_ioctl.c Patch-FGLRX-8-98-Kernel-3-5-1_4_KCL.patch
cd a
sh /usr/share/ati/amd-uninstall.sh --force
./ati-installer.sh 8.98 --install

Have fun,

Holm

Václav Šmilauer (eudoxos) wrote :

@Holm: patches much appreciated. Last hunk ("for_each_possible_cpu") from the firegl patch was meanwhile integrated upstream (version 12-8 downloaded today from ati site) and will not apply.

Perhaps the xorg-edgers guys might be interested in putting those patches to the fglrx-installer packages?

Changed in fglrx-installer (Ubuntu):
assignee: Alberto Milone (albertomilone) → Luke Raadschelders (luke-raadschelders)
assignee: Luke Raadschelders (luke-raadschelders) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.