X crashes on VLC open file dialog

Bug #663526 reported by Peter Júnoš on 2010-10-19
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

1. Using Maverick Meerkat with 2.6.35 kernel and closed fglrx driver.
2. Vlc is 1.1.4-1ubuntu1
3. I expected open dialog.
4. When using advanced open file, open stream etc (everything that brings advanced open dialog), my X server crashes and I have to log in again.

Vlc produces no logs (vlc > vlclog), but I have strace of the crash till X closed it (enclosed). If you want, I can produce similar logs with nohup or give some gdb traces, if you will say which.
System is up-to date as of October 19, 2010.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: vlc 1.1.4-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-muj
Uname: Linux 2.6.35.4-muj101015 x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Tue Oct 19 22:37:18 2010
ProcEnviron:
 SHELL=/bin/bash
 LANG=sk_SK.UTF-8
SourcePackage: vlc

Peter Júnoš (petoju) wrote :
Rémi Denis-Courmont (rdenis) wrote :

From that trace, VLC is _not_ crashing. It's aborting because the X server disconnected it.

As for why X crashes, I don't know but that's not a VLC bug. Most probably a video driver bug.

affects: vlc (Ubuntu) → xorg (Ubuntu)
summary: - Vlc crashes on open file dialog taking X down
+ X crashes on VLC open file dialog
Rémi Denis-Courmont (rdenis) wrote :

Unfortunately, this bug report only shows the VLC output. To further isolate the problem, some more tests can be done, notably:

1/ Try to use VLC with a different video output method, especially the plain X11 output.
# vlc -V x11
If that works fine, then it's most certainly a bug in the XVideo driver.

2/ Try to playback without the VLC user interface:
# vlc -I dummy MyMovie.mkv
If that works fine, then it means the user interface is triggering the crash. This is unlikely to be caused by Xorg itself, but could be a problem with the desktop environment or the window manager.

In any case, you should provide the Xsession log.

Changed in xorg (Ubuntu):
status: New → Incomplete
Peter Júnoš (petoju) wrote :

Video output works fine with any method. Only crash I noticed is in "Advanced open dialog".

I enclose Xorg.0.log.old that can help debuging. I have backed up Xorg.0.log, but it starts just after the end of .old log (when new X server is starting), so I'm not enclosing it - you can still request it.

After crash, only few lines appeared in dmesg (it was after log close, so it probably didn't cause the crash):
[ 223.900154] [fglrx] IRQ 49 Disabled
[ 224.339003] fglrx_pci 0000:01:00.0: irq 49 for MSI/MSI-X
[ 224.339613] [fglrx] Firegl kernel thread PID: 7815
[ 224.339854] [fglrx] IRQ 49 Enabled
[ 224.543218] [fglrx] Gart USWC size:1188 M.
[ 224.543221] [fglrx] Gart cacheable size:471 M.
[ 224.543226] [fglrx] Reserved FB block: Shared offset:0, size:1000000
[ 224.543229] [fglrx] Reserved FB block: Unshared offset:fc47000, size:3b9000
[ 224.543231] [fglrx] Reserved FB block: Unshared offset:1fffb000, size:5000

--------------------------
Here are my thoughts, that are hard to verify and will probably give a false trace (but I think it could also help):
I left my computer running today at GDM login screen and I ran vlc from my school over ssh -X at school computer. Advanced open dialog worked fine, but after returning from school, my GDM login screen was black and not reacting; I could still work in ttyX after switching with ctrl+alt+fX. I don't know, what caused screen to be black or whether it is tied to VLC, but I know it isn't the proper behauvior. I cannot check it at same time when running vlc from remote computer, because I have only one computer to test at home. And maybe another part of bug is, that terminal, which was running vlc command said something about buggy X server or shm (but it could be caused by ssh -X).

Rémi Denis-Courmont (rdenis) wrote :

So it is a segmentation fault in X.

VLC complains about a buggy server because it exposes a non-functional MIT-SHM extension. This is a long-standing bug in the OpenSSH X11 display export. But this cannot justify that Xorg is crashing.

Changed in xorg (Ubuntu):
status: Incomplete → New
Peter Júnoš (petoju) wrote :

Bug still happens in
xserver-xorg 1:7.5+6ubuntu3 (natty)

Bryce Harrington (bryce) on 2010-11-04
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
James83 (giacomopennella) wrote :

I have same problem with Kmymoney every time I click on the "Report" view on the left. It's strange: It is the only action that show this behaviour!
My card:
lspci: 01:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]

James83 (giacomopennella) wrote :

Last messages from kmymoney before X restart:

<unknown>: Fatal IO error 11 (Risorsa temporaneamente non disponibile) on X server :0.0.
kdeinit4: Fatal IO error: client killed
klauncher: Exiting on signal 15
<unknown>: Fatal IO error 11 (Risorsa temporaneamente non disponibile) on X server :0.0.
KCrash: Application 'kmymoney' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit

James83 (giacomopennella) wrote :

I found that the problem is related with the Window-decorations "Ambience": if I replace it with someone else the problem disappear. Anyway I really don't remember if I had customized the original theme "ambience" in the past!

Peter Júnoš (petoju) wrote :

I tried changing the theme and problem persists (for me).

Timo Aaltonen (tjaalton) on 2011-04-19
affects: xorg-server (Ubuntu) → fglrx-installer (Ubuntu)
Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Jiri Grönroos (jiri-gronroos) wrote :

vlc: Version: 1.1.11-2build1
xserver-xorg: Version: 1:7.6+7ubuntu6
xserver-xorg-video-ati: Version: 1:6.14.99~git20110811.g93fc084-0ubuntu1
compiz: Version: 1:0.9.5.92+bzr2791-0ubuntu1
unity: Version: 4.10.2-0ubuntu2

I'm having this same problem with up-to-date Oneiric. I'm using Ati 5770 GPU with FLOSS drivers so I'm pretty sure it's not a FGLRX problem per se.

abc@xyz:~$ grep -i R600 /var/log/Xorg.0.log
[ 30522.986] (II) RADEON(0): [DRI2] DRI driver: r600

X crashes with any other "Open..." option than "Open file..." - mainly with network stream. It happens only with Unity and Ambiance. If I change the theme to Radiance and try open network stream, VLC (and basically Unity) hangs and I have to killall vlc to get response from desktop.

With other window decorations and gnome-shell I can open Open network stream window without X.org crash but the window does not have any options and the window is too wide for my 1920x1080 desktop. I'll add a screenshot later on.

When running KDE all "Open..." options work just fine. No X.org crashes and because of KDE, no Compiz crashes. With this information this is probably a problem in GTK/Compiz/X.org/GPU drivers. Not easy to say. Very irritating and one more reason to use KDE.

Jiri Grönroos (jiri-gronroos) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers