Ubuntu

package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel module failed to build [Error: kernel includes at ... do not match current kernel. they are versioned as "" instead of "2.6.32-23-generic". you might need to adjust your symlinks: ...]

Reported by Shane on 2010-07-03
624
This bug affects 71 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
High
Unassigned

Bug Description

(New bug was reported because other was not only abandoned, but it was also for the 32bit version, rather than 64bit version.)

tried sudo apt-get clean, but did nothing.

If in the very least this cannot be solved, is there any way to make it stop trying to install? It's quite annoying that it tries to install even if i install some completely different package.

kernel includes at /lib/modules/2.6.32-23-generic/build/include do not match current kernel.
they are versioned as "" instead of "2.6.32-23-generic".

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: fglrx 2:8.723.1-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic x86_64
NonfreeKernelModules: r8192se_pci
Architecture: amd64
Date: Sat Jul 3 15:08:53 2010
DkmsStatus: fglrx, 8.723.1: added
ErrorMessage: fglrx kernel module failed to build
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: TOSHIBA Satellite L645D
PackageVersion: 2:8.723.1-0ubuntu4
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-23-generic root=UUID=98c46357-8333-4901-a7ac-09774321b0d2 ro quiet splash
SourcePackage: fglrx-installer
Title: package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel module failed to build
dmi.bios.date: 04/16/2010
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.40
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Guam
dmi.board.vendor: AMD Corp.
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.40:bd04/16/2010:svnTOSHIBA:pnSatelliteL645D:pvrPSK0QU-00K001:rvnAMDCorp.:rnGuam:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Satellite L645D
dmi.product.version: PSK0QU-00K001
dmi.sys.vendor: TOSHIBA
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-23-generic

Shane (kohlrak-kohlrak) wrote :
Bryce Harrington (bryce) on 2011-04-28
description: updated
summary: package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel
- module failed to build
+ module failed to build: kernel includes versioned as "" instead of
+ "2.6.32-23-generic"
Bryce Harrington (bryce) on 2011-04-28
Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
importance: Undecided → High

I could install the package without error-messages again after uninstalling alll newer kernel versions than: 2.6.32.32. now fglrx-amdcccle seems to be installed properly but imo it does not do its work.

summary: package fglrx 2:8.723.1-0ubuntu4 failed to install/upgrade: fglrx kernel
- module failed to build: kernel includes versioned as "" instead of
- "2.6.32-23-generic"
+ module failed to build [Error: kernel includes at ... do not match
+ current kernel. they are versioned as "" instead of "2.6.32-23-generic".
+ you might need to adjust your symlinks: ...]
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers