[fglrx] logging in after dist-upgrade results in broken ui

Bug #1068739 reported by Jaakko Linnosaari on 2012-10-19
108
This bug affects 15 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
ubuntu-release-upgrader (Ubuntu)
High
Michael Vogt
Quantal
High
Michael Vogt
Raring
High
Michael Vogt

Bug Description

fglrx not automatically removed during update -> broken ui after login

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: update-manager 1:0.174.3
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Aptdaemon:

Architecture: amd64
Date: Fri Oct 19 20:24:47 2012
GsettingsChanges:
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'launch-time' b'1350593607'
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to quantal on 2012-10-18 (0 days ago)

Jaakko Linnosaari (jlinnosa) wrote :
Jaakko Linnosaari (jlinnosa) wrote :
Jaakko Linnosaari (jlinnosa) wrote :
Jaakko Linnosaari (jlinnosa) wrote :
Jaakko Linnosaari (jlinnosa) wrote :
Timo Aaltonen (tjaalton) wrote :

hey Michael, this is the bug we discussed earlier today

Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Jaakko Linnosaari (jlinnosa) wrote :
affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Brian Murray (brian-murray) wrote :

Its worth noting the xorg_fix_proprietary failed to ruN;

2012-10-19 00:21:25,140 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
2012-10-19 00:21:25,151 ERROR got error from PostInstallScript ./xorg_fix_proprietary.py (Failed to execute child process "./xorg_fix_proprietary.py" (No such file or directory))

Steve Langasek (vorlon) on 2012-10-19
Changed in ubuntu-release-upgrader (Ubuntu Raring):
status: New → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu Raring):
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu Quantal):
assignee: nobody → Michael Vogt (mvo)
Jaakko Linnosaari (jlinnosa) wrote :

I guess it's worth noting, that I got my system back to usable state by executing 'dpkg --purge fglrx fglrx-amdcccle' and rebooting.

skipper (attila-egri-nagy) wrote :

Thanks for the instructions! I managed to get unity working. I had to purge/reinstall many packages, but I guess that was due to the fact that at some point I tried this ppa: https://launchpad.net/~makson96/+archive/fglrx (which did not work 3 days ago).

summary: - logging in after dist-upgrade results in broken ui
+ [fglrx] logging in after dist-upgrade results in broken ui
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu Quantal):
status: New → Confirmed
Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
DsXack (dsxack) wrote :

unity not started after install any fglrx driver (from official repo and from amd site).

I have hibryd video cards:

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler XT [AMD Radeon HD 6700M Series]
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

On 12.04 works fine. On 12.10 not started unity with propritary driver

Changed in ubuntu-release-upgrader (Ubuntu Quantal):
assignee: Michael Vogt (mvo) → Opoku Mensah Benjamin (kellis-omb2009)
Changed in ubuntu-release-upgrader (Ubuntu Raring):
assignee: Michael Vogt (mvo) → Opoku Mensah Benjamin (kellis-omb2009)
Changed in ubuntu-release-upgrader (Ubuntu Quantal):
assignee: Opoku Mensah Benjamin (kellis-omb2009) → Michael Vogt (mvo)
Changed in ubuntu-release-upgrader (Ubuntu Raring):
assignee: Opoku Mensah Benjamin (kellis-omb2009) → Michael Vogt (mvo)
thanassis05 (thanassis05) wrote :

I have laptop hp pavillion g6 (1170sv model) and I have the same problem. With open source drivers my laptop is overheating up to 80C... When I install propritary driver my laptop have 70C, but the unity not appear. Now I have installed gnome classic to work and I think the ati driver not work correct also.
I hope this help a bit. thank you a lot!

GeekSmith (lixo-geeksmith) wrote :

Busted for me:

% lspci | grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880 [Radeon HD 4200]

Nick Andrik (andrikos) wrote :

I think this is due to some paths missing in the fglrx package for amd64 architectures.

A workaround is using the fglrx-* packages from my PPA:
https://launchpad.net/~andrikos/+archive/ppa

Could you please give it a try and let me know if they fix your issue?

Nick Andrik (andrikos) wrote :

And probably duplicate of Bug: #1068404

sindhu (sindhu-h) on 2013-11-09
Changed in fglrx-installer (Ubuntu):
status: Confirmed → Fix Released
Changed in fglrx-installer (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in fglrx-installer (Ubuntu Raring):
status: Confirmed → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu Raring):
status: Triaged → Fix Released
Changed in fglrx-installer (Ubuntu):
status: Fix Released → Confirmed
Changed in fglrx-installer (Ubuntu Quantal):
status: Fix Released → Confirmed
Changed in fglrx-installer (Ubuntu Raring):
status: Fix Released → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Released → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Quantal):
status: Fix Released → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Raring):
status: Fix Released → Triaged
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in ubuntu-release-upgrader (Ubuntu Quantal):
status: Triaged → Won't Fix
Rolf Leggewie (r0lf) on 2014-12-05
Changed in fglrx-installer (Ubuntu Quantal):
status: Confirmed → Won't Fix
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in ubuntu-release-upgrader (Ubuntu Raring):
status: Triaged → Won't Fix
Rolf Leggewie (r0lf) on 2014-12-05
Changed in fglrx-installer (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers