2 Typos in case_Wellcome.pdf

Bug #342362 reported by Keith Worrell
6
Affects Status Importance Assigned to Milestone
example-content (Ubuntu)
Undecided
Keith Worrell
Declined for Dapper by Daniel Holbach
Declined for Gutsy by Daniel Holbach
Declined for Hardy by Daniel Holbach
Declined for Intrepid by Daniel Holbach
Declined for Jaunty by Daniel Holbach

Bug Description

Binary package hint: example-content

There are other reports of typos in documentation, but I did not see any that addressed these:

case_Wellcome.pdf

"Users log in to a set of dual book Linux/Windows workstations." -- 'book' should be 'boot'

"In June 2006, the Trust ran the first of their workshop project in Uruguay. The courseprovided an introduction" -- 'courseprovided' should be 'course provided'

Revision history for this message
Keith Worrell (keith-penguin) wrote :

I would be happy to provide a patch, but I do not see how to get the source.

Revision history for this message
Keith Worrell (keith-penguin) wrote :

err... nevermind. I mistyped the name of the package.

Revision history for this message
Jouni Mettala (jouni-mettala) wrote :

You can get source by command: apt-get source example-content. Bug 209776 is also about Wellcome.pdf.

Changed in example-content:
status: New → Confirmed
Revision history for this message
Keith Worrell (keith-penguin) wrote :

Ok, after installing the OpenOffice PDF editor, managed to correct some typos and able to track down the bug crashing pdfedit. There were a significant number of objects that were not properly "closed". None of the PDF's crash pdfedit anymore. One side effect: The portions of the logo that were completely outside of the margins are removed when exported to PDF from OpenOffice. This does not effect anything other than when you open the pdf up to edit again.

Since these were binary files, I used 'diff -r -a example-content-35 example-content-35-fix' to create the patch. I can also upload the entire patched package if that would be preferred.

Revision history for this message
Keith Worrell (keith-penguin) wrote :

Ok, new patch fixing the following bugs (in total):
#342362
#223382
#209776

There are several bugs talking about pdf files crashing inkscape and pdfedit. Also fixed by "closing" some corrupted(?) objects.

Sorry for the multiple postings.

Revision history for this message
Keith Worrell (keith-penguin) wrote :

patch submitted.

Changed in example-content:
assignee: nobody → keith-penguin
status: Confirmed → Fix Committed
Changed in example-content:
status: Fix Committed → In Progress
Revision history for this message
Keith Worrell (keith-penguin) wrote :

After doing some more research, this is a proper patch. Followed directions @ https://wiki.ubuntu.com/Bugs/HowToFix

This is a patch for example_content-35 from the repository, not Vcs-Bzr: http://bazaar.launchpad.net/~ubuntu-art-pkg/example-content/ubuntu. The versions from the repo and bzr are very different; the bzr version doesn't even have any of the case studies. This patch also corrects more errors that were mentioned in the comments in the related bug reports mentioned above. See changelog for specifics.

Removing improper patch.

Revision history for this message
Endolith (endolith) wrote :

> The versions from the repo and bzr are very different; the bzr version doesn't even have any of the case studies.

The version at
https://code.launchpad.net/~ubuntu-core-dev/example-content/ubuntu
has the case studies.

I'm not sure what the difference is between that and
https://code.launchpad.net/~ubuntu-art-pkg/example-content/ubuntu

Revision history for this message
Endolith (endolith) wrote :

The changed versions also have a different font, and some elements have been shifted in position, and the color balance? gamma? has changed (most noticeable with photos in Wellcome). I tried running these through the OpenOffice PDF editor, too, and abandoned it because of things like this.

Also you changed the logos to the one with the tagline so they are all consistent, right?

Revision history for this message
Keith Worrell (keith-penguin) wrote :

I did not intentionally change those elements, but I am noticing that the fonts come up sharper in the 'fixed' version. It took some time to discover why the files could not be opened / were crashing other pdf editors. Initially, I copy and pasted working elements from pdfs that were opening correctly and replacing the parts that came up seemingly "damaged" when I opened them with Open Office (Sun pdf importer extension) Until I found I could not replicate the blue logo at the bottom with the same color. By some luck / guessing I right clicked in an area where there should have been an element and a new context menu item came up that said "close object". When I did that, the seemingly missing object reappeared. I went through the rest of the case studies and applied the same change and then exported them. Open Office imports pdf to svg/odg, so that translation may have had an effect. From your example, the color range appears improved and the fonts appear sharper. I had not intended on that change, but I hope it is an improvement, albeit an unintentional one on my part.

When I did the copy/paste, I adjusted the elements using the exact coordinates from the properties given by the "damaged" ones. I checked to ensure that the elements rendered exactly the same way after exporting the files, so there my methodology for correcting those issues did change, but at the time I saw no noticeable effect.

One issue as mentioned in some of the other bug reports, it is obvious that these files were created with the proprietary Adobe Acrobat. It is a known issue that Adobe Acrobat, while producing files that render correctly, they do not follow the published specification as implemented in open source alternatives. This is why a pdf file created in Adobe Acrobat can crash software such as Inkscape and pdfedit. In my humble opinion, the slight unintentional changes that bring the document to compliance with the open source specification are reasonable, and the benefits ideal. There was a certain irony to the difficulty in fixing these problems.

Would people generally agree? Were there any other unintentional changes I may have over looked? Given that I have spent the better part of two days getting up to speed with this whole bug / patching issue, I would really like to get it perfect.

Revision history for this message
Keith Worrell (keith-penguin) wrote :

Looking through things again, I had thought that part ot the logo in the footer was missing due to the same bug and thus "corrected" it, but now knowing how to correct the problem more directly, it appears case_ubuntu_locatrix_v1.pdf does indeed use a different footer from the other case files, even though it really looks like it is a bug due to the orientation of the "ubuntu" text in relationship to the cosponsoring logo.

I think keeping it consistent among the documents is preferable, not to mention more balanced ("Ubuntu" with "Linux for Human Beings" is perfectly centred).

Revision history for this message
Endolith (endolith) wrote :

> I did not intentionally change those elements, but I am noticing that the fonts come up sharper in the 'fixed' version.

Well, the font is changed completely. The original looks more like an "Ubuntu font"? I don't think that should be changed.

> From your example, the color range appears improved and the fonts appear sharper. I had not intended on that change, but I hope it is an improvement, albeit an unintentional one on my part.

I agree that the colors on the fixed version look better, but I wonder what caused that change. Maybe the gamma information was lost?

> One issue as mentioned in some of the other bug reports, it is obvious that these files were created with the proprietary Adobe Acrobat.

They were created with "Adobe InDesign CS3 (5.0)", according to the metadata in the files. It would be nice (and probably necessary for legal reasons) if copyright information were included with the files, so we could contact the original author. It would be even nicer if the files were created in an open source program so that we could edit them to fix errors like this.

> I think keeping it consistent among the documents is preferable, not to mention more balanced ("Ubuntu" with "Linux for Human Beings" is perfectly centred).

Yeah, I don't see any problem with making them consistent. I don't know who makes the final decision on these things, though.

Changed in example-content:
status: In Progress → Fix Committed
Changed in example-content:
status: Fix Committed → Fix Released
Revision history for this message
Endolith (endolith) wrote :

The text is not just "slightly sharper", it's in a completely different font. I don't think this is so trivial that it should just be ignored.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Declined all other tasks for old releases. Fixing typos would not go through https://wiki.ubuntu.com/StableReleaseUpdates and wouldn't be worth it.

Thanks a lot for your work though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers