Ubuntu

wrong mail displayed

Reported by Mathias Kende on 2008-04-20
126
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Critical
evolution (Fedora)
Fix Released
Unknown
evolution-data-server (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evolution

Sometime the mails that are displayed when selecting a mail in the message list of evolution is not the good one.

That is to say: the list of mail is correct (or at least it seems) but when I select a mail in the list, the message shown in the preview pane (I am not sure of the name, but it's the pane the comes with ctrl+m) is not the same one. It's in fact a completely different message that can be some months old and located in a different folder.

If I double-click on the message, or press "reply", it's the wrong message that appears.

I already experienced this bugs some months ago and it eventually disappeared but it is very disturbing because I have no way to access to some of my emails.

On the attached screenshot you can see a selected mail and the header of the displayed mail that mismatch. There is also a localization problem with the date being in French in the message list and in English in the header panel. But I believe that these issue are separated because the localization problems only showed up after the upgrade to hardy whereas I already had this issue (the mail mismatch) in gutsy.

$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

$ apt-cache policy evolution
evolution:
  Installé : 2.22.1-0ubuntu2
  Candidat : 2.22.1-0ubuntu2
 Table de version :
 *** 2.22.1-0ubuntu2 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

$ apt-cache policy evolution-data-server
evolution-data-server:
  Installé : 2.22.1-0ubuntu1
  Candidat : 2.22.1-0ubuntu1
 Table de version :
 *** 2.22.1-0ubuntu1 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Mathias Kende (mathias-kende) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

Changed in evolution:
status: New → Invalid
Mathias Kende (mathias-kende) wrote :

I did not find any similar bug in the system. Could you point me to the proper bug report?

thank you.

Sebastien Bacher (seb128) wrote :

it's not easy to find the exact number in the bugs list and we don't have the ressources to spend hours doing that for all the duplicates filed right now, do you get the issue all the time, do you have steps to trigger it? that's a weird one. do you have gtk-qt-engine installed?

Mathias Kende (mathias-kende) wrote :

I understand that, but as neither you nor I can find the duplicate bug, maybe this one should stay open.

I do not have gtk-qt-engine installed, I do not have steps to trigger to bug, but it happens "all the time". That is to say, there is some mails that I can never see (they always shows, when selected, an other mail - which is always the same for a given email that is selected).

I can't remember how the bugs has solved last time it happened. It is possible that it has never ended, but just that I stopped paying attention to the problematic mails.

The problem is that if I am moving one of these mail from my inbox to an other folder, the mail that is being moved is the wrong one: in the other folder the message in the message list correspond to the displayed mail but is not the mail I moved. If I move the mail back, it is still the wrong one and the good one is lost. So as I archive my mail periodically, it is possible that all the problematic emails have just been destroyed in this process. Which would qualify this bug to be "critical".

I am willing to help this bug being solved, let me know if there is something that I can do.

Sebastien Bacher (seb128) wrote :

reopening since you insist, nobody else is getting this issue though and that's not going to be easy to debug, might be something specific to your server or a datas corruption on your installation, could you try to add the same account to an another user, does it behaves the same way?

Changed in evolution:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Invalid → Incomplete
Mathias Kende (mathias-kende) wrote :

I don't think that it is related to the server because I download the mail with pop3 and thay are properly downloaded. It is only later (some days after) that some mails became corrupted. But at this time there is no communication with the ervere for these emails.

What I will try to do is to produce a mbox file with corrupted emails into it, and see if they are also corrupted if moved to a new installation, and if so I will upload them.

Caro Mathias,
Na verdade, eu só quero que você me aqueça neste inverno e que tudo
mais, vá para o inferno!
Não sei se você me entende...
Eu não entendo bulhufas de inglês e isso dói que dá dó...

Em Qui, 2008-04-24 às 19:33 +0000, Mathias Kende escreveu:

> I don't think that it is related to the server because I download the
> mail with pop3 and thay are properly downloaded. It is only later (some
> days after) that some mails became corrupted. But at this time there is
> no communication with the ervere for these emails.
>
> What I will try to do is to produce a mbox file with corrupted emails
> into it, and see if they are also corrupted if moved to a new
> installation, and if so I will upload them.
>

Sebastien Bacher (seb128) wrote :
Changed in evolution:
status: Unknown → Confirmed
Changed in evolution:
status: Incomplete → Confirmed
darkangel88 (tipat88) wrote :

Well, I just had the same exact problem and let me tell you, it's quite annoying !! I created a message filter and had some issues on getting it to work so I moved the mails that I wanted the filter to do manually and after that exact moment, all my mails were mixed up : the header isn't the same as the mail itself. Quite frustrating if you ask me !!

Using version 2.22.1-0ubuntu3.1 0.

Matt Austin (mattaustin) wrote :

I'm getting the same problem now i've installed hardy (and restored an evolution backup).

The message that appears selected in the folder list is not really the message that has been selected - the preview window and all other functions (delete, junk, reply, forward etc) affect a different message.

Matt Austin (mattaustin) wrote :

Also, this has happened the last couple of days when checking my mail in the morning (and it receiving 10+ emails). Throughout the day new emails are not affected. However the messages which were fetched in the morning are permanently messed up.

Mathias Kende (mathias-kende) wrote :

I believe that this bug is triggered when one uses the "stop processing" rule in a "message filter" that is moving mails from one folder to another.
Can those who encounter this issue check if this apply to their situation ?

Senekur (janwulff) wrote :

I'm suffering from this bug and I'm also using some filters, but not the "stop processing" rule.
By the way, I can't help but wondering why this bug, which is really critical for a lot of people, has got so little attention.
At the moment, I have to search through hundreds of spam mails, just to find the content of a single important mail.
This is consuming way to much time.

Sebastien Bacher (seb128) wrote :

the ubuntu desktop team has no member knowing the evolution code and there is no easy way to trigger the issue so that's hard to work on this bug, there is also some thousand other bugs open to work on, you might want to comment on the upstream bugzilla, they write the code and know it better so they might have better ideas on the issue

Senekur (janwulff) wrote :

Thanks, Sebastien. I can understand the problem, but in the end this will fall back on Ubuntu. At least in the eyes of common office users, who can't use their email software any more, after an Ubuntu update.
By the way, I deleted the ev-summary and ev-summary-meta files in ~home/.evolution/mail/local. After a restart, everything works fine for now at least 12 hours. Of course I don't know, what this will do on other installations or if the bug will appear again. So use at own risk.

Chris Coulson (chrisccoulson) wrote :

I've just been hit by this bug I think. I'm getting the "Detected a corrupt mbox file or an invalid 'From' header" error, and my mailbox seems completely screwed. A lot of my mails seem to be duplicated. Mail from years ago seem to be unread, and all my labels and follow up flags and follow up dates have completely disappeared. On 3000+ e-mails!

I'm having the same problem. I've been using Evolution for about a month, and it just surfaced this evening. It affected messages downloaded hours earlier which had been working fine when they first came in. It happened to about 15 messages in my inbox, but they are not in a row. There doesn't seem to be any predictable logic to it. New messages that have come in since it happened seem fine.

Senekur (janwulff) wrote :

My "solution" (see above) does at least work for 2 days (for me).
The problem has occurred again after 2 days, but I could repair the list again, by deleting all the ".ev-summary" and ".ev-summary-meta" files.
This is really annoying.

DanBerry (dberry86) wrote :

The same thing happen to me and the way I resolved it was to create a temporary folder and move all items from the inbox to the temporary folder and then back to the inbox. This has fixed the problem for me.

Sebastien Bacher (seb128) wrote :

could anybody getting the issue report it directly to bugzilla.gnome.org?

Changed in evolution:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

thanks for sent this upstream.

Changed in evolution:
status: Confirmed → Triaged
Changed in evolution:
importance: Low → Medium
Andre Klapper (a9016009) wrote :

upstream maintainers (gnome bug 533122) request to provide such a broken mbox file - if anybody can send this to srini (and does not provide confidential data by doing this), please mail him directly.

Changed in evolution:
status: Unknown → Confirmed
Changed in evolution:
status: Confirmed → Invalid

Ive just encountered this for the first time. Its corrected its at moment.

Its has reoccured and I have copy the Inbox files.

The above link to bug 533122 doesnt work

found the bug 533122 its here http://bugzilla.gnome.org/show_bug.cgi?id=533122

Latest append there indicates srini has reproduced and doesnt need input.

Andre Klapper (a9016009) wrote :

Evolution 2.22.3 contains a fix for this according to GNOME bug 213072.

Pedro Villavicencio (pedro) wrote :

great, marking it as fix committed.

Changed in evolution:
status: Triaged → Fix Committed
Changed in evolution-data-server:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evolution-data-server:
status: Confirmed → Fix Committed
roots (roots) wrote :

i can't find any evolution-related fix in the proposed reps?! am i doing sth. wrong?

i'm suffering of the very same bug, which i reported 2008/04/15 [Bug 217768].

roots (roots) wrote :

ok now there it is, i'll report back if the bug should occur again. cheers!

Charlie (charles-michie) wrote :

I installed Evolution 2.22.3 a couple of days ago and this has resolved the problem.

Steve Langasek (vorlon) wrote :

copied to hardy-updates.

Changed in evolution-data-server:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

there is a newer version in intrepid too, closing the bug

Changed in evolution-data-server:
status: Fix Committed → Fix Released
devedse (davydavidse) wrote :

thanx for solving the problem :)

Same problem as described by initial poster occurred for me to day. Running Evolution 2.22.3.1 (2.22.3.1-0ubuntu1). Please consider reopening this bug.

Terrrorr (terrrorr-gmail) wrote :

First of all... i'm apologizing my bad english, but let's try it anyway!

I did what senekur suggested (and some other places). I deleted all ev-summary and ev-summary-meta files from my evolution folder (exactly /home/%username%/.evolution/mail/local) and started evolution again. Now it seems that i haven't got any mails in four months.... The dates of all mails has changed between may to aug.

Some backgrounds: Before i run into this problem, i tested our companies NTP-server.... so... i changed my computers date and time settings back and forth quit many times.

Question: Is it possible that this indexing problem has something to do with computers time and dates.

My other info:

evolution:
  Installed: 2.22.3.1-0ubuntu1
  Candidate: 2.22.3.1-0ubuntu1

Description: Ubuntu 8.04.1
Release: 8.04

Changed in evolution:
status: Confirmed → Fix Released
surgey (gmsurgey) wrote :

I just wanted to put my two cents in and say that I ALSO have this bug/error on Evolution 2.22.3.1.
I click on an email from, say, eBay and it shows an email from Amazon.com in the preview pane lol.
I have to click a bunch of different emails until I find the one I want, it's a guessing game. Also, it does not fix it to close out and reopen the program. Nor does restarting the system help. In most cases the program just suddenly decides to play by the rules. Very strange. I've never seen this on any other program. Since I am a noob (but trying to learn) to ubuntu/linux I will have to let my boyfriend (the household expert on all that is linux) read over this thread and the bugfixes to try to resolve the issue. I'll letcha know if it works out for me. But I would go ahead and reopen the bug if you have not done so yet. My two cents. Keep up the great work.
-Surgey

job8 (jlballe) wrote :

This bug just occurred for me with Evolution 22.22.3.1 with Ubuntu 8.04. I installed evolution on several machines with the same POP mailserver with no problems. On the last machine the preview pane displayed the previous message to the one highlighted in the message pane. Restarting evolution or Ubuntu did not fix the problem.

Copying the all of the messages from the Inbox to a temporary folder and then back to the Inbox fixed the mismatch problem.
-job8

surgey (gmsurgey) wrote :

^Okay I will try doing that - copying and re-copying. Thanks.

symos (symos) wrote :

I can confirm this bug for version 2.22.3.1 (in Opensuse 11.0)
Please consider reopening so that a proper fix can be implemented.

My company decided to migrate from Windows/Outlook to Linux/Evolution some time ago, and this bug really IS a show stopper which is a shame.

Thanks in advance.

Martin Pitt (pitti) wrote :

Seems it is still an issue, reopening.

Changed in evolution-data-server:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

do you have any steps to trigger the issue? what account types do you use? could you look if any error is printed on the command line when you get the bug? could you also reopen the upstream bug?

Changed in evolution-data-server:
status: Confirmed → Incomplete
symos (symos) wrote :

I am using a POP account. This happened during migration where we had to download all 7500 messages in the account and then sort messages in different folders (SPAM etc.)

More specifically, Evolution downloaded all 7500 messages. Then I created and ran a filter to move ****SPAM**** messages (tagged by Spamassassin) to another folder. When this operation finished (I didn't tamper with it in the meantime) messages in Inbox were messed up. I could still see subjects with ****SPAM**** in the inbox, though the actual messages where from different emails.

However, the one described above was the second time we did this. The first time round my colleague tells me she didn't apply any filters, she just performed a search for ****SPAM**** and did a "massive" delete of these messages, resulting in a messed up inbox. So I'm not sure this happens only when filters are applied (as is mentioned in previous comments).

Finally, I tried the move-and-move-back trick and it worked. When I moved all messages from the inbox to another folder they were fine. Then I moved back and they remained fine.

Regarding the command line I'm not sure I can reproduce this cos now the messages in question have been deleted from the server. I'll let you know if I can reproduce with another account. Also, regarding reopening the upstream bug, not sure how to do it? Do I have to sign up in Bugzilla?

Sebastien Bacher (seb128) wrote :

the issue you are having might be a different one that the one described there, not easy to say without a way to trigger the bug and some debugging then too, you need a bugzilla account to reopen the upstream bug indeed

Changed in evolution:
status: Invalid → Fix Released
Sebastien Bacher (seb128) wrote :

closing the bug now since the upstream task has been closed too and there is no recent duplicate, if you still get the issue in jaunty open a new bug

Changed in evolution-data-server (Ubuntu):
status: Incomplete → Fix Released
Changed in evolution:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.