evince-thumbnailer with a 100% CPU usage

Bug #384062 reported by José Valim on 2009-06-05
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

Guys,

There are some complains about evince-thumbnailer with a 100% CPU usage, but none of them could be replicated. I think I was able to track down the problem.

Whenever I'm downloading a PDF and saving it on my desktop, the file changes at each second and every time it changes, evince-thumbnailer tries to create a new thumb for it, then having a 100% CPU usage.

[INFO]

Description: Ubuntu 8.04.2
Release: 8.04

evince:
  Installed: 2.22.2-0ubuntu2
  Candidate: 2.22.2-0ubuntu2
  Version table:
 *** 2.22.2-0ubuntu2 0
        500 http://br.archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     2.22.1.1-0ubuntu1 0
        500 http://br.archive.ubuntu.com hardy/main Packages

Pedro Villavicencio (pedro) wrote :

Thanks for the report, please attach the pdf in question otherwise is not easy for us to replicate the problem either and the developers cannot fix that, without an example there's nothing we can do.

Changed in evince (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
José Valim (jose-valim) wrote :

I cannot send the exact PDF.
But I've picked three random PDFs, downloading them with Transmission and saving the PDF on my desktop, and the bug could be reproduced.

Pedro Villavicencio (pedro) wrote :

well send the pdf files which are causing the issues, without one to test with there's not too much we can do.

I think this problem has nothing to do with any particular PDF but with the re-thumbnailing of partially downloaded files while they are being downloaded (same for videos etc.) - maybe there's a nautilus bug report for the issue, already?
Using a small bandwith download (e.g. with wget --limit-rate or scp -l ) I can at least reproduce evince-thumbnailer springing into action every second or so (although it does not use 100% CPU on my computer).

Dimitrios Symeonidis (azimout) wrote :

I think the cause for this is the same as for this one:
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/56738

Dimitrios Symeonidis (azimout) wrote :

switching back to new...
we should find a pdf sufficiently large and/or limit the download speed; otherwise my connection is too fast to reproduce this...

Changed in evince (Ubuntu):
status: Incomplete → New
Dimitrios Symeonidis (azimout) wrote :

ok, how about this:
wget --limit-rate=50 https://help.ubuntu.com/6.06/pdf/ubuntu/C/desktopguide.pdf

André Barmasse (barmassus) wrote :

Hello

I have discovered a similar problem while converting PS to PDF with ps2pdf. While converting evince-thumbnailer uses about the same amount of memory as ghostscript. It seems like evince-thumbnailer tries to refresh the PDF thumbmail after each page ghostscript has converted. And with together about 90% memory usage Ubuntu nearly stalls and converting takes much longer than before.

Happens with Ubuntu Karmic Koala 2.6.31-11-generic. Maybe disabling the evince-thumbnailer in gconf-editor makes this disappear - but this cannot be the solution. I have attached a screenshot of the "top" command.

Keep up the good work! Best wishes from André

André Barmasse (barmassus) wrote :

Hi

It seems that the evince-thumbnailer cannot be disabled! In gconf-editor I have checked the box under /desktop/gnome/thumbnailes/disable_all - without any effect. Furthermore, I have uninstalled evince, but after rebooting the evince-thumbnailer was still active and thumbnailing like crazy. Isn't there really any way to stop the evince-thumbnailer?

Best wishes! André

Sebastien Bacher (seb128) wrote :

did you try to change /desktop/gnome/thumbnailers/application@pdf/enable?

Changed in evince (Ubuntu):
status: New → Fix Released
Thiago Teixeira (tvst) wrote :

I just ran into this problem, but in my case the PS file that caused it is actually corrupted and cannot be read by any reader I know of. Of course, the thumbnailer should never freeze the CPU at 100%, not even if the file is bad.

I can provide the file by email, if anyone would like it. I just don't want to post it here since it contains slightly personal information related to my coursework.

Dan (dan-pologea) wrote :

I've encountered the same problem. I have Ubuntu 8.04 (yes, I will upgrade to 10.04 soon). The only application I was using at the time was Disk Usage Analyzer. So it seems the bug is not related to PS or PDF files as I have seen above.
I've just noticed that evince-thumbnailer is taking 100% CPU usage. This is to confirm that the bug exists at least in Ubuntu 8.04 with all the upgrades until to this date (6th of June 2010).

Gregory Shaw (gregs-fmsoft) wrote :

I ran into a similar issue, but found an alternate fix.

If I opened my home directory in file browser, evince-thumbnailer would hit 100%, and stay that way. Additionally, no thumbnails would show up in the window.

To make a long story short, I'd run some commands as root in my home directory. As a result, a few files were owned by root, with permissions that didn't give my account access.

Once I chown'd everything in my home directory to be owned by myself, the problem went away.

Personally, I think that evince-thumbnailer should deal with EPERM errors properly, but as usual YMMV.

yanglifu90 (yanglifu90) wrote :

This did not solve in Fedora 17.

Sebastock (sebastock) wrote :

The problem is still there in ubuntu 12.04.

ivainsencher (ivainsencher) wrote :

The problem is still there in ubuntu 14.10.
It seems to be intermitent.

Linux macbookair 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Adam Hallgat (hallgat) wrote :

Still present on Xubuntu 14.10 64bit. I only noticed this error with pdfs converted from PowerPoint slideshows.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers