Ubuntu

Monitor document changes

Reported by Nigel Cundy on 2007-09-27
62
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evince
Confirmed
Wishlist
evince (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

Latest gutsy, fglrx, ATI radeon XPRESS 200M, compiz

I create an article or presentation using latex
create a postscript using dvips
open the ps with evince
make changes to the .tex file, dvips again to overwrite the old postscript
evince often (not always) does not reload, or prints a message "loading ..." and hangs.

Pedro Villavicencio (pedro) wrote :

This is not fully implemented yet, http://bugzilla.gnome.org/show_bug.cgi?id=304249

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in evince:
status: Unknown → Confirmed
Vincenzo Ciancia (vincenzo-ml) wrote :

As strange as it may look, under lyx if you choose "view pdf" instead of "update pdf" (or dvi), evince will reload your document. This is because evince does not open a new window for the same pdf. This works around the bug report related to lyx.

Vincenzo Ciancia (vincenzo-ml) wrote :

Isn't this fixed in Jaunty? I think it is.

Dimitrios Symeonidis (azimout) wrote :

In fact, it seems to automatically reload the new file...

Simple way to reproduce this:
1) echo test > test.txt
2) a2ps test.txt -o - | ps2pdf - test.pdf
3) evince test.pdf &
4) echo test2 >> test.txt
5) a2ps test.txt -o - | ps2pdf - test.pdf

Vincenzo Ciancia (vincenzo-ml) wrote :

Very good.

Changed in evince (Ubuntu):
status: Triaged → Fix Released
Pedro Villavicencio (pedro) wrote :

this is still an issue with lucid, re opening.

Changed in evince (Ubuntu):
status: Fix Released → Triaged
Changed in evince:
importance: Unknown → Wishlist
skipper (attila-egri-nagy) wrote :

This problem recently appeared in trusty. For working with tex/latex this is really disruptive.

tags: added: trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.