Ubuntu

eog fails to start with: GLib-GIO-CRITICAL **: Timeout was reached

Reported by Juha Siltala on 2011-10-23
226
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Critical
eog (Ubuntu)
Low
Unassigned

Bug Description

Whether clicking on a file in nautilus, started from the GNOME shell, or from the command line, eog fails to start at all. Error message in terminal is

GLib-GIO-CRITICAL **: Timeout was reached

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: eog 3.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Sun Oct 23 10:55:20 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
SourcePackage: eog
UpgradeStatus: No upgrade log present (probably fresh install)

Juha Siltala (topyli) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eog (Ubuntu):
status: New → Confirmed
tags: added: regression-proposed
Marian Tietz (nemo-ikkoku) wrote :

This also happens to me (oneiric, amd64, freshly set ICC profile and uninstalled appmenu-gtk*).

Attached strace. ltrace does not seem to provide any further details (waits in g_application_run and deallocates after timeout).

gdb backtrace also attached.

Ryan Kitty (gothickitty93) wrote :

I also have this issue. Is there any information I can provide to help fix this?

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in eog (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Ryan Kitty (gothickitty93) wrote :

Here are my logs for eog from strace, gdb, and valgrind

Changed in eog (Ubuntu):
status: Incomplete → Confirmed
Felix Riemann (friemann) wrote :

From comment #1:
> libglib2.0-0 2.31.0-0ubuntu1~oneiric1
From #6
> --4093-- Reading syms from /usr/lib/i386-linux-gnu/libgthread-2.0.so.0.3100.0 (0x4c97000)

Is there a reason you are running using unstable glib releases?

Anyway glib-2.31.0 is known to deadlock eog. See bug 662630 in GNOME Bugzilla.

Dmitry Shachnev (mitya57) wrote :

Thanks Felix, I can confirm that downgrading glib solves the problem.

Changed in eog (Ubuntu):
status: Confirmed → Invalid
Changed in eog:
importance: Unknown → Critical
status: Unknown → Confirmed
Christopher (sgashepp-u) on 2011-10-27
description: updated
tags: removed: regression-proposed
Coiby Xu (coiby) wrote :

with the same issue

Thomas D. (thfrdue) wrote :

Same problem here. Attached my gdb output.

Tobias Wolf (towolf) wrote :

Upstream is on the case I think. No need to debug here.

Changed in eog:
status: Confirmed → Fix Released
Christian Klumpp (chris211094) wrote :

It doesn't wor for me, als updates installed. When will there be a fix, or ist there a tutorial how to revert go glib 2.30.

Dmitry Shachnev (mitya57) wrote :
Changed in eog (Ubuntu):
status: Invalid → Fix Committed
rui (rui-abreu) wrote :

Fixed in eog_3.2.2-2ubuntu3. Download binaries here:

https://launchpad.net/ubuntu/precise/+package/eog

System restart may be necessary.

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
Forage (forage) wrote :

I'm giving up on reporting issues in Launchpad of packages included by Ubuntu. There's simply no point in doing so.

Like many issues, this one had a fix for a long time now and not a single attempt has been made to get it fixed in the current Ubuntu release. We should all just wait for half a year to get an insignificant code change to fix a highly annoying bug, after which we get presented with the next set of small but highly annoying bugs for yet another half a year.

Why provide a bug reporting facility if the end result is people leaving with the feeling to sod off and deal with it?

The amount of PPA's says enough: one can not depend on Ubuntu to get things done, you'd have to do it yourself.

Sebastien Bacher (seb128) wrote :

@forage: that bug was never an Ubuntu bug, it's due to the use of an unstable version of glib coming from a ppa, don't use unstable ppas if you have an issue with those...

Forage (forage) wrote :

Heh, ironically I had to update glib to get other issues fixed again...
In the end it changes nothing. Two bugs I had at hand: bug #870742, bug #881978. These are just two of the lot I came in contact with. Some I didn't even bother to respond to any more. There are plenty by others as well.

Atheg (hoganaj) wrote :

Hello, I face this bug, too. Can anyone tell me how to downgrade libglib2 to the correct version?

My understanding is you go into Symantec and Force Version to the downgrade. However, there are so many files that come up when you search for libglib2. Which one gets downgraded?
ie....

libglib2.0-doc
libglib2.0-dev
libglib2.0-cil
libglib2.0-0
libglib2.0-bin
libglib2.0-data

What about dependencies? Haven't things been downloaded around my current version? Does downloading break that?

Atheg (hoganaj) wrote :

If anyone wants to answer how to fix this, how to downgrade, there's an askubuntu question here:
http://askubuntu.com/questions/73092/how-do-i-downgrade-libglib2-from-glib-2-31-to-2-30

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.