Ubuntu

eog hangs when trying to display any image

Reported by MFeif on 2011-10-25
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
eog (Ubuntu)
Medium
Unassigned

Bug Description

EOG used to work; now trying to run it on any image, it just hangs.

Running in the console hangs too; there is no output.

After about 20 seconds, I get " GLib-GIO-CRITICAL **: Timeout was reached "

Nothing shows up in .xsession-errors.

Sorry this isn't probably a very useful bug report... but there's not much else I know how to look up.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: eog 3.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Tue Oct 25 13:11:24 2011
ExecutablePath: /usr/bin/eog
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110802.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: eog
UpgradeStatus: Upgraded to oneiric on 2011-08-17 (68 days ago)

MFeif (matt-feifarek) wrote :
Pedro Villavicencio (pedro) wrote :

Could you please get a backtrace? please read https://wiki.ubuntu.com/Backtrace#Already%20running%20programs to know how to get one, if you have any questions please don't hesitate in asking, thanks.

Changed in eog (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Richard Ayotte (rich-ayotte) wrote :

Maybe a duplicate of #880227

Lorem (lrmpsm) wrote :

In attachment my dbg log

Harry (harry33) wrote :

Lorem,
It seems you are using glib_2.31.0 series, which is not yet pulled into Precise repos.
Do you use Ricotz Testing PPA (Gnome-shell)?

I am using it, and eog does not work either.

It may also be that eog does not work in an environment with xserver 1.11 series.
Xserver 1.11 does not yet have utouch support and that is a problem with both eog and evince.

Lorem (lrmpsm) wrote :

glib come from gnome3-team ppa.

it seems an eog bug compiled with glib 2.31 (see bug 880227 on launchpad ), downgrading to glib 2.30 revolve the bug.

Pedro Villavicencio (pedro) wrote :

why are you using the ppa and no the official from 11.10? Please test it with the version from the official archives.

Lorem (lrmpsm) wrote :

for me the problem is solved, i've downgraded all the glib staff and now i live happily :)

>> why are you using the ppa and no the official from 11.10?

gnome3-team ppa was for gnome-shell-extensions-* and gnome-documents, but now i switched to WebUpd8 ppa that doesn't have glib staff

Dmitry Shachnev (mitya57) wrote :

Eog hangs with Glib 2.31 are tracked in bug 880227. Please open a new bug if you experience this with stable Glib.

Atheg (hoganaj) wrote :

@Lorem, can you post how you downgraded all the glib stuff to live happily? Which files did you downgrade, and how did you find them? I posted a question like this in the main area, here:
https://bugs.launchpad.net/ubuntu/+source/eog/+bug/880227/comments/18

My concern is identifying all the items necessary to downgrade, and then dealing with dependency problems once that's taken care of.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers