interface.py crashed with ImportError in <module>()

Bug #227717 reported by kulight on 2008-05-07
552
Affects Status Importance Assigned to Milestone
envyng-core (Ubuntu)
Undecided
Alberto Milone
Hardy
Undecided
Unassigned
Intrepid
Undecided
Alberto Milone

Bug Description

Binary package hint: envyng-core

after updating to envyng-core_1.1.1ubuntu14_all.deb from the proposed repo's envyng wont start
on gtk mode nor text mode

ProblemType: Crash
Architecture: i386
Date: Wed May 7 15:20:22 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/share/envy/interface.py
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: envyng-core 1.1.1ubuntu14
PackageArchitecture: all
ProcCmdline: python interface.py
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['interface.py']
SourcePackage: envyng-core
Title: interface.py crashed with ImportError in <module>()
Uname: Linux 2.6.24-17-generic i686
UserGroups:

Related branches

kulight (kulight) wrote :
Changed in envyng-core:
assignee: nobody → albertomilone
status: New → In Progress
Alberto Milone (albertomilone) wrote :

Thanks for reporting. envyng-core_1.1.1ubuntu15 will solve the problem.

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test.

Changed in envyng-core:
status: New → Fix Committed
Kame (jack-pot) wrote :

Same here:
 sudo envyng -t
Traceback (most recent call last):
  File "interface.py", line 8, in <module>
    from Envy import main
  File "/usr/lib/python2.5/site-packages/Envy/main.py", line 10, in <module>
    import classes
  File "/usr/lib/python2.5/site-packages/Envy/classes.py", line 34, in <module>
    from progress import TextProgress
ImportError: No module named progress

Waiting for -15 ;)

kulight (kulight) wrote :

"Accepted into hardy-proposed, please test."

I dont get the update via update manager. should it be there?

*thank you for the work you do in general and the quick reply

kulight [2008-05-08 9:24 -0000]:
> "Accepted into hardy-proposed, please test."
>
> I dont get the update via update manager. should it be there?

You need to enable updates from -proposed in System -> Administration
-> Software Sources -> Updates (sorry, translated from German, might
be slightly different).

kulight (kulight) wrote :

The proposed repo's are enabled but still i dont get the fix (envyng-core_1.1.1ubuntu15)

showgun (showgun) wrote :

Same here, Ubuntu updates are all selected with daily update with the option
Only notify about available Updates

I also do my daily update on my own more often when there is an OS upgrade <G>

There has to be something else

Kame (jack-pot) wrote :

Binary package has not yet been uploaded.

Installing the binary fixes the problem for me. I didn't get it via Ubuntu updates yet, having update repositorys enabled.

Alden (jason-alden-benoit) wrote :

FYI - I received update in USA this morning.

kulight (kulight) wrote :

"Installing the binary fixes the problem for me. I didn't get it via Ubuntu updates yet, having update repositorys enabled."

same here

showgun (showgun) wrote :

Update came on via Update manager problem is fix envyng start properly no more crash.

Kame (jack-pot) wrote :

Update doesn't fix everiything.

Envy does start... but cannot install any drivers.

Alberto Milone (albertomilone) wrote :

Kame: please wait until the new restricted-modules are uploaded to the servers.

Davide Corona (corona-davide) wrote :

Updated by using this package:
http://launchpadlibrarian.net/14386140/envyng-core_1.1.1ubuntu15_all.deb

fixed!
envyng doesn't crash anymore

Marco da Silva (igama) wrote :

Working with core ubuntu15 :)

Kame (jack-pot) wrote :

No luck on 64bit hardy.

apt-get report that envy version of fglrx kernel modules is in conflict with libGL1.so.

Here you are:
Spacchetto xorg-driver-fglrx-envy (da .../xorg-driver-fglrx-envy_1%3a7.1.0-8-4+2.6.24.500-500.28_amd64.deb) ...
dpkg-divert: `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/libGL.so.1.xlibmesa by xorg-driver-fglrx-envy' è in conflitto con `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/libGL.so.1.xlibmesa by xorg-driver-fglrx'
dpkg: errore processando /var/cache/apt/archives/xorg-driver-fglrx-envy_1%3a7.1.0-8-4+2.6.24.500-500.28_amd64.deb (--unpack):
 il sottoprocesso pre-installation script ha restituito un codice di errore 2
Selezionato il pacchetto fglrx-control-envy, che non lo era.
Spacchetto fglrx-control-envy (da .../fglrx-control-envy_1%3a8-4+2.6.24.500-500.28_amd64.deb) ...
Selezionato il pacchetto fglrx-amdcccle-envy, che non lo era.
Spacchetto fglrx-amdcccle-envy (da .../fglrx-amdcccle-envy_2.6.24.500-500.28_amd64.deb) ...
Selezionato il pacchetto xorg-driver-fglrx-dev-envy, che non lo era.
Spacchetto xorg-driver-fglrx-dev-envy (da .../xorg-driver-fglrx-dev-envy_1%3a7.1.0-8-4+2.6.24.500-500.28_amd64.deb) ...
Sono occorsi degli errori processando:
 /var/cache/apt/archives/xorg-driver-fglrx-envy_1%3a7.1.0-8-4+2.6.24.500-500.28_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
('\nEnvyNG ERROR: The following packages cannot be installed:',)

BTW: Grazie Alberto...

Kame (jack-pot) wrote :

PS It's a common error for 64 bit 2.6.24 kernel. Could be solved simply applying a patch to the fglrx kernel deb.

I've attached the patch...

Alberto Milone (albertomilone) wrote :

@Kame
Thanks for reporting. Removing diversions in the preinst (like I do for NVIDIA) should solve the issue. I'll work on it.

Alberto Milone (albertomilone) wrote :

@Kame
See if revision 29 solves your problem (when it's available).

Have a look at this bug report:
https://bugs.launchpad.net/ubuntu/+source/envyng-core/+bug/221304

Kame (jack-pot) wrote :

Sorry same error:

Spacchetto xorg-driver-fglrx-envy (da .../xorg-driver-fglrx-envy_1%3a7.1.0-8-4+2.6.24.500-500.29_amd64.deb) ...
dpkg-divert: il cambio del nome comporta la sovrascrittura di `/usr/lib/libGL.so.1' con
  un file diverso `/usr/lib/fglrx/libGL.so.1.xlibmesa', che non è consentito
dpkg: errore processando /var/cache/apt/archives/xorg-driver-fglrx-envy_1%3a7.1.0-8-4+2.6.24.500-500.29_amd64.deb (--unpack):
 il sottoprocesso pre-installation script ha restituito un codice di errore 2
Sono occorsi degli errori processando:
 /var/cache/apt/archives/xorg-driver-fglrx-envy_1%3a7.1.0-8-4+2.6.24.500-500.29_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
('\nEnvyNG ERROR: The following packages cannot be installed:',)

Look at the fix I've posted if you simply apply it to your .deb it will work on 64bits OS.

It's ATi's fault. While building the package they copied 2 lines without remembering to edit them afterwards...

Alberto Milone (albertomilone) wrote :

Kame: I can't reproduce the problem here. Did you use the deb packages generated by ATI's official installer?

Kame (jack-pot) wrote :

Right know I'm usig 8.4 from ATi's official installer, but I had to patch them with the fix I've posted to properly install them on 64bit kernel.

envy.deb package returns the same error I had with ati drivers without patch...

Trying to get your .deb and patch it to see if it solves the problem.

Alberto Milone (albertomilone) wrote :

Kame: my packages try to remove those diversions however I didn't take into account the diversions which the ATI installer creates. I'll have a look at such diversions.

Kame (jack-pot) wrote :

SOLVED.

My problem was dued to ATi drivers previously installed from ATi packager 's .debs and not to envy ones!
I had installed Cat 8.4 from ATi build .deb to test them out.
Unfortunatly diversion on file LibGL.so.1 wasn't removed by ATi deb uninstall.
The result was a "corrupted system".

Thanks to Alberto I've figured out how to solve it:

sudo mv /usr/lib/fglrx /usr/lib/bakfglrx
sudo dpkg-divert --rename --remove /usr/lib/libGL.so.1
sudo rm /usr/lib/bakfglrx

Now everything is back to normal. With envy packed drivers running great.

I think we could definitely close this bug...

Martin Pitt (pitti) wrote :

envyng-core copied to hardy-updates and intrepid.

Changed in envyng-core:
status: In Progress → Fix Released
status: Fix Committed → Fix Released
Keller Giacomarro (keller-g) wrote :

Still seeing this in Intrepid Alpha-4. Running envyng from the command line produces:

Traceback (most recent call last):
  File "interface.py", line 428, in <module>
    a = Interface()
  File "interface.py", line 126, in __init__
    self.abstract = abstraction.Abstraction(progress, True)
  File "/usr/lib/python2.5/site-packages/Envy/abstraction.py", line 39, in __init__
    self.driverDetails = self.hardware.selectDriver()
  File "/usr/lib/python2.5/site-packages/Envy/detection.py", line 248, in selectDriver
    if 173 in candidates['nvidia'] and 177 in candidates['nvidia']:
TypeError: list indices must be integers

Any ideas?

Alberto Milone (albertomilone) wrote :

Keller: I have uploaded a new release of envyng-core.

Type:
sudo apt-get --purge remove envyng-core

(don't worry if this command gives you an error)
sudo rm -R /usr/share/envy

sudo apt-get install envyng-core

then launch it with:
envyng -t

Let me know how it goes

castorgris (castorgris) wrote :

it's working with the CLI, but not with the gtk user interface.

Still having :

$ envyng -g
Traceback (most recent call last): File "/usr/share/envyng-gtk/envynggtk.py", line 7, in <module>
    from Envy import objects
ImportError: cannot import name objects

when i try to use graphic interface with intrepid alpha 4.

Alberto Milone (albertomilone) wrote :

castorgris: the GTK interface won't work on Intrepid.

You can try envng-qt (make sure that it's version 2.0) and launch it with envyng -k

SpeedyGonsales (stem) wrote :

Update of kernel to version 2.6.27.1 (Intrepid) today resulted in error msg nvidia: fail, resolve manually (I write from memory, thats not verbatim msg).

After that I tried envy, and get as above "envynggtk.py crashed with ImportError in <module>()"

I tried procedure you wrote above:

1.sudo apt-get --purge remove envyng-core
2.sudo rm -R /usr/share/envy
3.sudo apt-get install envyng-core
4.envyng -t

All went well, kernel at boot again loaded 177 module, everything is ok (and I know to test envyng in text mode next time before I start googling :-))

alienexplorers (dfsjr47) wrote :

sudo envyng -t and envyng both fail to load the nvidia drivers in 8.10.

Changed in envyng-core:
status: Fix Released → Invalid

@alienexplorers : please don't change the status of a report when it's marked fixed released by a dev. If you are facing a bug with this package then first check if there is an open report with the same problem. If you're unsure then fill a new report. We can mark it as duplicate if it's a known issue.

Thanks in advance.

Changed in envyng-core:
status: Invalid → Fix Released
Alberto Milone (albertomilone) wrote :

alienexplorers: I think it's not the same bug. Please follow Jean-Baptiste suggestion and file a new bugreport.

I did try from the Terminal, see that.

rolando@defiant:~$ envyng -g
  File "/usr/share/envyng-gtk/envynggtk.py", line 7, in <module>
    from Envy import objects
ImportError: cannot import name objects
SSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSrolando@defiant:~$

cipher27 (cipher27) wrote :

The gtk interface failed but text mode worked but there was a problem bulding fglrx.ko. here is the error i got

Error! Build of fglrx.ko failed for: 2.6.27-3-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.522/build/ for more information.
Installing initial module

the makelog contains the following lines

DKMS make.log for fglrx-8.522 for kernel 2.6.27-3-generic (x86_64)
Wed Sep 17 20:36:35 EDT 2008
/var/lib/dkms/fglrx/8.522/build

Alberto Milone (albertomilone) wrote :

Rolando: the gtk interface is broken and won't be fixed in time for Intrepid's release.
type:
sudo apt-get install envyng-qt

envyng -k

and you will use the qt interface.

cipher27: that doesn't depend on EnvyNG. Currently the fglrx driver doesn't work with Intrepid. See this bugreport:
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/247376

Ok Alberto, Thanks :D

2008/9/19 Alberto Milone <email address hidden>

> Rolando: the gtk interface is broken and won't be fixed in time for
> Intrepid's release.
> type:
> sudo apt-get install envyng-qt
>
> envyng -k
>
> and you will use the qt interface.
>
> cipher27: that doesn't depend on EnvyNG. Currently the fglrx driver doesn't
> work with Intrepid. See this bugreport:
> https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/247376
>
> --
> interface.py crashed with ImportError in <module>()
> https://bugs.launchpad.net/bugs/227717
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Saludos Fraternos Ubunteros!
________________________________________________________________
"No pases la vida tratando de hacer trabajar a tu computador,...
...haz que tu computador trabaje para ti, usa GNU/LINUX"
________________________________________________________________
Rolando F. Blanco C:. (Ubuntu Member)
Director-TIC MSC, Consultores Gerenciales,C.A.
User: 399645 (GNU) Ubuntu: 3715
http://www.blanco.net.ve/
Ubuntu 8.04 (Hardy)
_______________________________________________________________

daniel (daniel-marth93) wrote :

Textmode works, but gtk crashes after starting.

Alberto Milone (albertomilone) wrote :

daniel: have a look at this bug report: https://bugs.launchpad.net/bugs/262156

daniel (daniel-marth93) wrote :

Nice page ;-) :

Not allowed here

Sorry, you don't have permission to access this page.

You are logged in as daniel.

What is it about=

This bug now exists in Karmic. I wouldn't have noticed, but a recent upgrade trashed all nvidia users and I was trying to use this as a work around.

To post a comment you must log in.