Empathy does not support Google Application- Specific Passwords

Bug #754569 reported by Chris Wilson on 2011-04-08
162
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Empathy
Invalid
Medium
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

Recently, Google introduced 2-Step Authentication[1] to make their users accounts more secure. This works by requesting that the user enter a randomly generated 6 digit number when they log in from an unknown computer for the first time. Since not every application supports this, they also introduced 'Application Specific Passwords' which is a randomly generated 16 character alpha-numeric one-time only password that it entered when connecting an application to a Google account for the first time.

Since I have enabled 2-Step Authentication on my account, I am no longer able to sign into Google Talk using Empathy.

[1] http://googleblog.blogspot.com/2011/02/advanced-sign-in-security-for-your.html

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: empathy 2.34.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Fri Apr 8 13:13:34 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: Upgraded to natty on 2011-04-07 (0 days ago)

Changed in empathy:
importance: Unknown → Wishlist
status: Unknown → Invalid
Brian Curtis (bcurtiswx) wrote :

upstream was dup, fixing here

Changed in empathy:
importance: Wishlist → Unknown
status: Invalid → Unknown
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Incomplete
povniet (kevin-georgy) wrote :

You can add application specific password to your google account. It resolve the problem, but it will be great if empathy support this more secure authentication scheme...

Changed in empathy (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Keith Drummond (victor9098) wrote :

Adding the application specific password does not solve the problem. Next time you log in empathy can not connect, so you must go through the process of getting a new password. Empathy seems to be the only piece of software that I have this problem with.

Using this workaround solved it for me. In "Password and encryption keys", you'll be looking for "IM account password for jabber (<yourgtalkaccount>)
http://ubuntuforums.org/showthread.php?t=1692708

Changed in empathy:
status: Incomplete → Confirmed
Logan (zaza224) wrote :

Pidgin is a fine substitute if you are using 2-step verification and application-specific passwords.

summary: - Empathy does not support Google 2-Step Authentication
+ Empathy does not support Google Application- Specific Passwords
Jonas Platte (jplatte) wrote :

On my computer, it didn't work with my google-password before i activated the 2-Step Authentication but also doesn't work now with the app-specific password after i have activated it. Google Talk added automatically to Empathy when i updated to Ubuntu 12.04 alpha, for i have integrated my google account with the gnome-shell.

Riccardo Murri (rmurri) wrote :

The workaround suggested by Patrick Dessalle on 2011-07-07 worked for me as well.

Inspecting the saved passwords with Seahorse, I found out that the *account name, not the password* had been saved as "IM account password for jabber". No wonder it could not authenticate.

After deleting it, the correct "application password" is saved.

Installed software:

ii empathy 3.2.0.1-0ubuntu1.1 GNOME multi-protocol chat and call client
ii empathy-common 3.2.0.1-0ubuntu1.1 GNOME multi-protocol chat and call client (common files)
ii telepathy-gabble 0.13.5-0ubuntu2 Jabber/XMPP connection manager

Changed in empathy:
status: Confirmed → Invalid
Hendrik Knackstedt (hennekn) wrote :

So I came across this bug in Empathy today on Ubuntu Precise 12.04 LTS.

According to the GNOME bug report linked above, this is fixed in GNME 3.8. Could we get this fix backported to Precise since it is a LTS release?

tags: added: precise
Hendrik Knackstedt (hennekn) wrote :

Strange, but I tried to set up my Google account again today and it works fine. Still using Ubuntu Precise 12.04. So this is fixed for me.

Hendrik Knackstedt (hennekn) wrote :

I checked the upstream bug again and it seems this actually wasn't the bug I was having in Precise since it got fixed in Empathy 3.3 and Precise uses 3.4. So this bug report is obsolete and I am closing it as Fix Released since it is fixed in Precise. If you are still having issues you're probably experiencing a different bug. Maybe take a look at Bug #1069531 or file a new one.

Changed in empathy (Ubuntu):
status: Triaged → Fix Released
tags: removed: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.