python-xml removal: please drop/replace (build) dependencies

Bug #199014 reported by Scott Kitterman
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Medium
conduit (Ubuntu)
Undecided
Unassigned
elisa (Ubuntu)
Medium
Unassigned
emesene (Ubuntu)
Medium
Emilio Pozuelo Monfort
eric (Ubuntu)
Medium
Scott Kitterman
fonttools (Ubuntu)
Undecided
Matthias Klose
gdeskcal (Ubuntu)
Undecided
Unassigned
gdesklets (Ubuntu)
Undecided
Cody A.W. Somerville
genshi (Ubuntu)
Undecided
Iulian Udrea
gnomecatalog (Ubuntu)
Undecided
Christophe Sauthier
gramps (Ubuntu)
Undecided
Christophe Sauthier
gst-plugins-bad0.10 (Ubuntu)
Undecided
Unassigned
gst-plugins-base0.10 (Ubuntu)
Undecided
Unassigned
gst-plugins-good0.10 (Ubuntu)
Undecided
Unassigned
gst-plugins-ugly0.10 (Ubuntu)
Undecided
Unassigned
gstreamer0.10 (Ubuntu)
Undecided
Sebastian Dröge
hotwire (Ubuntu)
Undecided
Unassigned
html5lib (Ubuntu)
Undecided
Christophe Sauthier
imgseek (Ubuntu)
Undecided
Christophe Sauthier
kaa-base (Ubuntu)
Undecided
Unassigned
libopensync-plugin-google-calendar (Ubuntu)
Undecided
Unassigned
liquidwar (Ubuntu)
Undecided
Christophe Sauthier
livemix (Ubuntu)
Medium
David Futcher
ll-xist (Ubuntu)
Undecided
Scott Kitterman
memaid-pyqt (Ubuntu)
Undecided
Unassigned
mmpython (Ubuntu)
Undecided
Unassigned
mnemosyne (Ubuntu)
Undecided
Unassigned
opendict (Ubuntu)
Medium
Unassigned
penguintv (Ubuntu)
Undecided
Unassigned
pypar2 (Ubuntu)
Medium
Unassigned
pyragua (Ubuntu)
Undecided
Unassigned
pyslide (Ubuntu)
Undecided
Unassigned
python-4suite (Ubuntu)
Undecided
Unassigned
python-davlib (Ubuntu)
Undecided
Unassigned
python-reportlab (Ubuntu)
Undecided
Scott Kitterman
qm (Ubuntu)
Undecided
Matthias Klose
revelation (Ubuntu)
Medium
Michael Bienia
schooltool (Ubuntu)
Undecided
Unassigned
serpentine (Ubuntu)
Undecided
Scott Kitterman
skencil (Ubuntu)
Undecided
Matthias Klose
thuban (Ubuntu)
Undecided
Unassigned
tinyerp-server (Ubuntu)
Undecided
Christophe Sauthier
wxwidgets2.6 (Ubuntu)
Undecided
Unassigned
wxwidgets2.8 (Ubuntu)
Undecided
Adrien Cunin
xen-3.2 (Ubuntu)
Undecided
Unassigned
zsi (Ubuntu)
Undecided
Unassigned

Bug Description

---------------------------
SRU TEST CASE For pyslide

Version 0.4-10ubuntu2 in hardy is missing it's dependency on python-xml

Version 0.4-10ubuntu2.1 in hardy-proposed re-adds this dependency.

In order to test that this fixes pyslide, remove python-xml. Then install pyslide-0.4-10ubuntu2.1 from hardy-proposed to first verify that python-xml is correctly installed as a dependency.

Next, navigate to "/usr/share/doc/pyslide/examples"
Then, run "pyslide full.xml"

You should be able to navigate through the slide show.

Without python-xml installed, you will receive the following Traceback:

Traceback (most recent call last):
  File "/usr/bin/pyslide", line 30, in <module>
    m.action()
  File "/var/lib/python-support/python2.5/Pyslide/Main/__init__.py", line 71, in __call__
    fo = main.loadfile(fn)
  File "/var/lib/python-support/python2.5/Pyslide/Main/__init__.py", line 294, in loadfile
    from Pyslide.File import ReadFile
  File "/var/lib/python-support/python2.5/Pyslide/File.py", line 42, in <module>
    class ContentParser(xml.sax.saxutils.DefaultHandler):
AttributeError: 'module' object has no attribute 'DefaultHandler'
---------------------------

Debian is working to remove python-xml before the lenny release. If would be
good if Ubuntu could manage the same for Hardy. Since some time a subset of
python-xml is included in the standard python library, while the python-xml
package did not see any updates for years. It is time to drop it from the
distribution.

Update scenarios:

 - Just drop the (build) dependency, if the functionality is included
   in python. (Build)-depend on python (>= 2.4).

 - Copy missing code in the std library from the python-xml package.
   (e.g. for some installer packages: localechoose).

 - Use another xml library (python-4suite-xml, python-lxml).

This has been the subject of a recent mass bug filing in Debian, so in many
cases it's just a question of syncing an updated package from Debian. See

http://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=python-xml-removal;<email address hidden>

for the Debian bugs and their status.

Revision history for this message
Piotr Ożarowski (piotr) wrote :

sync with Debian unstable (1.4-3) wil close this bug in pypar2 package

Changed in pypar2:
status: New → Fix Committed
Changed in pypar2:
assignee: nobody → kitterman
status: Fix Committed → In Progress
Morten Kjeldgaard (mok0)
Changed in wxwidgets2.8:
assignee: nobody → mok0
Changed in wxwidgets2.6:
assignee: nobody → mok0
Revision history for this message
Scott Kitterman (kitterman) wrote :

Sync requested for pypar2.

Changed in pypar2:
assignee: kitterman → nobody
importance: Undecided → Medium
status: In Progress → Fix Committed
Revision history for this message
Scott Kitterman (kitterman) wrote :

I should have an eric upload to do next week. I'll deal with this at the same time.

Changed in eric:
assignee: nobody → kitterman
importance: Undecided → Medium
status: New → In Progress
description: updated
Morten Kjeldgaard (mok0)
Changed in serpentine:
assignee: nobody → mok0
Changed in python-reportlab:
status: New → Confirmed
Changed in xen-3.2:
status: New → Confirmed
Changed in gstreamer0.10:
status: New → Fix Released
Changed in gstreamer0.10:
status: Fix Released → Confirmed
Loïc Minier (lool)
Changed in elisa:
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

sync with Debian unstable (2.2.10-2) will close this bug in gramps package. A sync request has been made here : https://bugs.edge.launchpad.net/ubuntu/+source/gramps/+bug/199120

Changed in gramps:
assignee: nobody → christophe.sauthier
status: New → Fix Committed
Revision history for this message
Morten Kjeldgaard (mok0) wrote :

Not fixed in Debian unstable. This patch applies to the Ubuntu version: wxwidgets2.6_2.6.3.2.2-2ubuntu1

The patch removes python-xml from Suggests: in a couple of binary packages, and removes mention of python-xml in the long description of some packages.

Revision history for this message
Morten Kjeldgaard (mok0) wrote :

Patch available

Changed in wxwidgets2.8:
status: New → Confirmed
Changed in wxwidgets2.6:
assignee: mok0 → nobody
status: New → Confirmed
1 comments hidden view all 117 comments
Revision history for this message
Morten Kjeldgaard (mok0) wrote :

oops

Changed in wxwidgets2.8:
status: Confirmed → New
Changed in ll-xist:
assignee: nobody → kitterman
status: New → In Progress
Morten Kjeldgaard (mok0)
Changed in wxwidgets2.8:
status: New → In Progress
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

A sync request has been made for html5lib to fix it (https://bugs.edge.launchpad.net/ubuntu/+source/html5lib/+bug/199123)

Changed in html5lib:
assignee: nobody → christophe.sauthier
status: New → Fix Committed
Changed in wxwidgets2.6:
assignee: nobody → kitterman
status: Confirmed → In Progress
Changed in wxwidgets2.6:
assignee: kitterman → nobody
status: In Progress → Fix Released
Changed in conduit:
assignee: nobody → christophe.sauthier
status: New → In Progress
Revision history for this message
Morten Kjeldgaard (mok0) wrote :

wxwidgets 2.8 is not yet in Debian. The attached patch applies to Ubuntu version: wxwidgets2.8_2.8.7.1-0ubuntu1. It performs the same changes as the 2.6 patch above.

Revision history for this message
Morten Kjeldgaard (mok0) wrote :

Wxwidgets_2.6: I the debdiff above (1 hour ago), I forgot to set XS-Python-Version: >= 2.4 in debian/control. Attached interdiff fixes that.

Changed in wxwidgets2.8:
assignee: mok0 → nobody
status: In Progress → Confirmed
Changed in serpentine:
status: New → In Progress
Sebastian Dröge (slomo)
Changed in gst-plugins-bad0.10:
status: New → In Progress
Changed in gst-plugins-base0.10:
status: New → In Progress
Changed in gst-plugins-good0.10:
status: New → In Progress
Changed in gst-plugins-ugly0.10:
status: New → In Progress
Changed in gstreamer0.10:
assignee: nobody → slomo
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen-3.2 - 3.2.0-0ubuntu8

---------------
xen-3.2 (3.2.0-0ubuntu8) hardy; urgency=low

  * Removed python-xml from depends. (LP: #199014)
  * Conflict with python-xen-3.1. (LP: #196020)

 -- Chuck Short <email address hidden> Thu, 06 Mar 2008 09:08:08 -0500

Changed in xen-3.2:
status: Confirmed → Fix Released
Revision history for this message
Morten Kjeldgaard (mok0) wrote :

serpentine_0.9-1ubuntu2: python-xml not removed in Debian unstable. Attached patch removes references to python-xml in debian/control. Package builds and serpentine runs albeit with error messages not related to this issue.

Revision history for this message
Morten Kjeldgaard (mok0) wrote :

serpentine_0.9_1ubuntu3: attached log shows error messags when serpentine runs.

Changed in serpentine:
assignee: mok0 → nobody
status: In Progress → Confirmed
Changed in liquidwar:
assignee: nobody → christophe.sauthier
status: New → In Progress
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Emesene is fixed in Debian. I'll see if I can get a FF exception, and if not I'll upload a fix for this.

Changed in emesene:
assignee: nobody → pochu
status: New → Confirmed
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

A bug has been filled for liquidwar where the new version fixes it : https://bugs.edge.launchpad.net/ubuntu/+source/liquidwar/+bug/199171.

Changed in liquidwar:
status: In Progress → New
status: New → Fix Committed
Revision history for this message
David Futcher (bobbo) wrote :

Fix for livemix. This package doesnt have any other Python dependencies (!) so im not sure what python-xml was doing in there and i couldnt bump the Python. Here is the debdiff.

Changed in livemix:
assignee: nobody → rainct
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

emesene -> feature freeze exception requested at but 199218

Changed in emesene:
importance: Undecided → Medium
status: Confirmed → In Progress
Revision history for this message
Scott Kitterman (kitterman) wrote :

[14:57] <ScottK2> mok0: For you serpentine debdiff, I see that serpentine recently dropped from Main to Universe, so it needs maintainer adjusted and the earlier change "don't build the muine plugin since it's an universe package" can be reverted. Please give those a shot and then attach a revised debdiff.

Changed in serpentine:
assignee: nobody → kitterman
status: Confirmed → In Progress
assignee: kitterman → mok0
Revision history for this message
Tiago Cogumbreiro (cogumbreiro) wrote :

I'm the upstream of 'serpentine'. What is this issue with Muine?

Revision history for this message
Tiago Cogumbreiro (cogumbreiro) wrote :

Regarding comment 14:
> serpentine_0.9_1ubuntu3: attached log shows error messags when serpentine runs.

That bug is fixed in trunk. It is not related, however, with the python-xml.

Serpentine uses the XPath --- not sure if it's present in another package --- part to load/save its state (in the format of a XSPF playlists).

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 199014] Re: python-xml removal: please drop/replace (build) dependencies

On Thursday 06 March 2008 15:18, Tiago Cogumbreiro wrote:
> Regarding comment 14:
> > serpentine_0.9_1ubuntu3: attached log shows error messags when serpentine
> > runs.
>
> That bug is fixed in trunk. It is not related, however, with the
> python-xml.

If you could supply us with a patch, we could upload that at the same time.

> Serpentine uses the XPath --- not sure if it's present in another
> package --- part to load/save its state (in the format of a XSPF
> playlists).

It's my understanding that all of python-xml's functions are in Python2.4.

> I'm the upstream of 'serpentine'. What is this issue with Muine?

There's no upstream issue to worry about. When serpentine was in the Main
part of our Archive muine was disabled because it's in Universe. It can be
re-enabled now.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

>> Serpentine uses the XPath --- not sure if it's present in another
>> package --- part to load/save its state (in the format of a XSPF
>> playlists).
>
> It's my understanding that all of python-xml's functions are in
> Python2.4.

Unfortunately that's not true. There's quite some modules from python-xml which
aren't in python (and there are some more in python2.5 than in python2.4). You
need to check that the used modules are in python too. Otherwise the application
needs source changes.

xpath isn't in python, for example. Look at /usr/lib/python2.X/xml/ and
/usr/share/pycentral/python-xml/site-packages/_xmlplus/ to compare them.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Then serpentine will need choice 2 or 3 from the original bug.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

David Futcher: I'm not sure what the dependency there is for (on a fast look the only .py file in the source is one called stats.py which doesn't seem necessary for anything), but it would be good to investigate why it was added before removing it (perhaps asking Michael Bienia). Note that a python build dependency isn't really necessary (even if it needed it), as python-xml already depends on python.

Changed in livemix:
assignee: rainct → nobody
status: In Progress → New
Revision history for this message
Morten Kjeldgaard (mok0) wrote :

Re: serpentine, I merged the latest version from Debian unstable. The merge solves a few issues including the libxml dependency. Please see https://bugs.edge.launchpad.net/ubuntu/+source/serpentine/+bug/199277 and continue the discussion under that entry.

David Futcher (bobbo)
Changed in livemix:
assignee: nobody → bobbo
status: New → In Progress
Changed in gstreamer:
status: Unknown → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package liquidwar - 5.6.3-3ubuntu4

---------------
liquidwar (5.6.3-3ubuntu4) hardy; urgency=low

  * Remove build dependency on python-xml (LP: #199014).

 -- Christophe Sauthier <email address hidden> Thu, 06 Mar 2008 17:07:35 +0100

Changed in liquidwar:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package penguintv - 3.0-0ubuntu3

---------------
penguintv (3.0-0ubuntu3) hardy; urgency=low

  * debian/control: drop python-xml Depends. (LP: #199014)

 -- Daniel Holbach <email address hidden> Fri, 07 Mar 2008 12:49:03 +0100

Changed in penguintv:
status: New → Fix Released
Revision history for this message
Tiago Cogumbreiro (cogumbreiro) wrote :

IIRC, python-4suite-xml implements the python module 'xml.xpath'. I think I can't test it because when I install python-4suite-xml python-xml gets installed as well.

I am sending in attachment a patch of the current version. This patch contains only minor bug fixes and translations.

Revision history for this message
Tiago Cogumbreiro (cogumbreiro) wrote :

IIRC, python-4suite-xml implements the python module 'xml.xpath'. I think I can't test it because when I install python-4suite-xml python-xml gets installed as well.

I am sending in attachment a patch of the current version. This patch contains only minor bug fixes and translations.

Changed in html5lib:
status: Fix Committed → Fix Released
Changed in gramps:
status: Fix Committed → Fix Released
Revision history for this message
Morten Kjeldgaard (mok0) wrote :

Tiago,

Thanks for the patch. I've moved serpentine to a separate bug number, so I could do a merge of the most recent version from Debian, which closes a few Debian bugs. I have also merged the icon fix that had yet a third bug number in LP. I will take a look at your patch.

This procedure requires a feature freeze exception, but serpentine is queued to be processed.

Now please, watch this bug: https://bugs.edge.launchpad.net/ubuntu/+source/serpentine/+bug/199277
and let's clear this python-xml removal bug of any further serpentine discussion.

Revision history for this message
Tiago Cogumbreiro (cogumbreiro) wrote :

@Morten Kjeldgaard: I will attach a patch that moves the dependency from python.xml to python 4suite in the end of the day.

Changed in gnomecatalog:
assignee: nobody → christophe.sauthier
status: New → In Progress
Revision history for this message
Scott Kitterman (kitterman) wrote :

pypar2 synced from Debian.

Changed in pypar2:
status: Fix Committed → Fix Released
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

A new bug has been opened (https://bugs.edge.launchpad.net/ubuntu/+source/gnomecatalog/+bug/199479) to reflect the sponsoring process of the version that fix the gnomecatalog part of this bug.

Changed in gnomecatalog:
status: In Progress → Fix Committed
Michael Bienia (geser)
Changed in revelation:
assignee: nobody → geser
importance: Undecided → Medium
status: New → In Progress
Changed in imgseek:
assignee: nobody → christophe.sauthier
status: New → In Progress
Revision history for this message
David Futcher (bobbo) wrote :

Another patch for livemix. Repalces python-xml with python.

Changed in tinyerp-server:
assignee: nobody → christophe.sauthier
status: New → In Progress
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :

A separate bug has been created (https://bugs.edge.launchpad.net/ubuntu/+source/tinyerp-server/+bug/199487) to track the sponsoring of the new revision.

Changed in tinyerp-server:
status: In Progress → Fix Committed
Revision history for this message
David Futcher (bobbo) wrote :

Woops uploaded a dsc instead of a debdiff :/

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livemix - 0.49~rc2-0ubuntu3

---------------
livemix (0.49~rc2-0ubuntu3) hardy; urgency=low

  * Replace deprecated Build-Depend python-xml with python (LP: #199014)

 -- David Futcher <email address hidden> Fri, 07 Mar 2008 14:14:44 +0000

Changed in livemix:
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package revelation - 0.4.11-3ubuntu1

---------------
revelation (0.4.11-3ubuntu1) hardy; urgency=low

  * Merge from debian unstable (LP: #191154), remaining changes:
    + debian/patches/30_python.dpatch:
      + Use unversioned python interpreter.
    + debian/patches/50_panel_category.dpatch:
      + Change GNOME panel category from "Utility" to the correct "Utilities".
    + debian/rules:
      + Set the python version to 2.5.
    + debian/control:
      + Modify Maintainer value to match DebianMaintainerField spec.
  * debian/rules
    + Replace dh_iconcache with dh_icons.
  * debian/control:
    + Build-depend on debhelper => 5.0.51 (for dh_icons).
    + Drop python-xml from Depends (LP: #199014).
  * debian/patches/60_typo_de_translation.dpatch:
    + Fix typos in german translation (LP: #155768).
  * debian/patches/40_xhtml.dpatch:
    + Add this patch to 00list so it gets applied (fixes LP: #113728).

revelation (0.4.11-3) unstable; urgency=low

  * Updated to Policy version 3.7.3
  * changed Maintainer email address

 -- Michael Bienia <email address hidden> Fri, 07 Mar 2008 17:37:50 +0100

Changed in revelation:
status: In Progress → Fix Released
Mathias Gug (mathiaz)
Changed in tinyerp-server:
status: Fix Committed → Confirmed
Iulian Udrea (iulian)
Changed in genshi:
assignee: nobody → iulian
status: New → In Progress
Revision history for this message
David Futcher (bobbo) wrote :

Pyslide debdiff

Changed in pyslide:
assignee: nobody → bobbo
Iulian Udrea (iulian)
Changed in genshi:
status: In Progress → Confirmed
Iulian Udrea (iulian)
Changed in opendict:
assignee: nobody → iulian
status: New → In Progress
Michael Bienia (geser)
Changed in genshi:
status: Confirmed → Fix Released
Iulian Udrea (iulian)
Changed in opendict:
assignee: iulian → nobody
importance: Undecided → Medium
status: In Progress → New
Changed in pyragua:
status: New → Fix Released
Changed in gnomecatalog:
status: Fix Committed → Fix Released
Changed in gdeskcal:
status: New → Fix Released
Changed in gst-plugins-bad0.10:
status: In Progress → Fix Released
Changed in mmpython:
status: New → Fix Released
Changed in mnemosyne:
status: New → Fix Released
Loïc Minier (lool)
Changed in elisa:
status: In Progress → Fix Released
Changed in gst-plugins-base0.10:
status: In Progress → Fix Released
Changed in gst-plugins-good0.10:
status: In Progress → Fix Released
Changed in gst-plugins-ugly0.10:
status: In Progress → Fix Released
Changed in gstreamer0.10:
status: In Progress → Fix Released
Changed in eric:
status: In Progress → Fix Released
Changed in ll-xist:
status: In Progress → Fix Released
Changed in pyslide:
status: New → Fix Released
Changed in imgseek:
status: In Progress → Fix Released
Stefan Ebner (sebner)
Changed in skencil:
assignee: nobody → hellboy195
status: New → In Progress
Morten Kjeldgaard (mok0)
Changed in serpentine:
assignee: mok0 → nobody
status: In Progress → New
Changed in conduit:
status: In Progress → Confirmed
Changed in conduit:
assignee: christophe.sauthier → kitterman
status: Confirmed → In Progress
Changed in conduit:
assignee: kitterman → nobody
status: In Progress → Fix Committed
Changed in gdesklets:
assignee: nobody → cody-somerville
Changed in wxwidgets2.8:
assignee: nobody → kitterman
status: Confirmed → In Progress
Changed in wxwidgets2.8:
assignee: kitterman → nobody
status: In Progress → Fix Committed
Changed in tinyerp-server:
status: Confirmed → Fix Committed
Changed in wxwidgets2.8:
assignee: nobody → adri2000
status: Fix Committed → In Progress
Changed in python-reportlab:
assignee: nobody → kitterman
status: Confirmed → In Progress
Changed in gdesklets:
status: New → Fix Committed
Changed in zsi:
assignee: nobody → kitterman
status: New → In Progress
Changed in python-4suite:
status: New → Fix Released
Changed in conduit:
status: Fix Committed → Fix Released
Changed in gdesklets:
status: Fix Committed → Fix Released
Changed in tinyerp-server:
status: Fix Committed → Fix Released
Changed in python-davlib:
status: New → Won't Fix
Adrien Cunin (adri2000)
Changed in wxwidgets2.8:
status: In Progress → Fix Committed
Changed in wxwidgets2.8:
status: Fix Committed → Fix Released
Changed in python-reportlab:
status: In Progress → Fix Released
Stefan Ebner (sebner)
Changed in skencil:
assignee: sebner → nobody
status: In Progress → New
Changed in gstreamer:
status: New → Fix Released
Matthias Klose (doko)
Changed in skencil:
assignee: nobody → doko
status: New → Fix Released
Changed in zsi:
status: In Progress → Fix Released
Changed in kaa-base:
status: New → Fix Released
Matthias Klose (doko)
Changed in fonttools:
assignee: nobody → doko
status: New → In Progress
Changed in opendict:
status: New → Fix Released
Changed in hotwire:
status: New → Fix Released
Changed in memaid-pyqt:
status: New → Fix Released
Changed in libopensync-plugin-google-calendar:
status: New → Fix Released
Matthias Klose (doko)
Changed in qm:
assignee: nobody → doko
status: New → In Progress
37 comments hidden view all 117 comments
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thuban - 1.2.0-2.1ubuntu1

---------------
thuban (1.2.0-2.1ubuntu1) hardy; urgency=low

  * Drop (build) dependency on python-xmlbase. LP: #199014.
  * Set Ubuntu maintainer address.

thuban (1.2.0-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * pymem_del.dpatch. (Closes: #469007).
    + Use PyObject_Del instead of PyMem_DEL.

 -- Matthias Klose <email address hidden> Fri, 21 Mar 2008 17:54:53 +0000

Changed in thuban:
status: New → Fix Released
Revision history for this message
Artyom Pervukhin (logus) wrote :

Still depends on python-xml

Changed in zsi:
status: Fix Released → New
Revision history for this message
Artyom Pervukhin (logus) wrote :

  File "/var/lib/python-support/python2.5/ZSI/parse.py", line 53, in __init__
    from xml.dom.ext.reader import PyExpat
ImportError: No module named ext.reader

Changed in serpentine:
assignee: nobody → kitterman
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package serpentine - 0.9-5ubuntu1

---------------
serpentine (0.9-5ubuntu1) hardy; urgency=low

  * Merge from debian unstable, remaining changes (LP: #199014):
    - Use a recommends on gstreamer0.10-plugins-ugly, not a depends
    - Reformat Build-Dep and Build-Dep-Indep so source package builds
    - Modify Maintainer value to match the DebianMaintainerField
      specification.

serpentine (0.9-5) unstable; urgency=low

  * Only remove /usr/lib if it has been created by python-central (closes:
    #472027).
  * Depend on python-4suite-xml so that we don't need python-xml any more
    (closes: #471913).
  * Split Dependencies over multiple lines.

serpentine (0.9-4) unstable; urgency=low

  * fix-no-cd-crash.patch taken from upstream BZR: fixes a crash when
    Serpentine is launched on a system without any CD recorders (closes:
    #459527).
  * drop-pyxml.patch taken from upstream BZR: no longer use pyxml (closes:
    #468616). z99_automake.patch generated by running 'automake-1.9' and
    removing the autom4te.cache directory.
  * fix-borken-plparser.py.patch: comment out some useless code that prevented
    parsing of playlists by the totem-plparser plugin (closes: #455506).
  * Add README.Debian-source documenting where upstream's BZR repostiroy
    lives.

serpentine (0.9-3) unstable; urgency=low

  * Set gnome-vfs' autoburn_audio_cd_command so that the drive that the CD was
    inserted into is selected for burning by default.
  * Correct spelling of "GStreamer" in package description.
  * Remove empty directory /usr/lib from serpentine binary package.

serpentine (0.9-2) unstable; urgency=low

  * Register as a CD-audio burning application with gnome-volume-manager
    (closes: #450859).
  * Added plugsuspend_new-interface.patch: work with the new dbus interface
    provided by gnome-power-manager 2.20 (closes: #459239). Thanks Sebastian
    Dröge!
  * Build-Depend upon cli-common-dev 0.4.4 as needed by dh_clideps.
  * Add Dm-Upload-Allowed field to control fields.
  * No longer run the obsolete dh_python.
  * Split build dependencies over multiple lines.
  * Build-depend on gconf2 because the configure script tries to run
    gconftool-2.
  * Update to policy 3.7.3 (no changes).
  * Quote the '.' characters in the domain name in the watch file.
  * Relax build-dependancy on cdbs: remove the Debian revision.

 -- Scott Kitterman <email address hidden> Sun, 23 Mar 2008 18:08:56 -0400

Changed in serpentine:
status: In Progress → Fix Released
Revision history for this message
Scott Kitterman (kitterman) wrote :

Schooltool --> Invalid. Removed from Hardy.

Changed in schooltool:
assignee: nobody → kitterman
status: New → In Progress
assignee: kitterman → nobody
status: In Progress → Invalid
Changed in schooltool:
status: Invalid → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package emesene - 1.0~r1013-0ubuntu2

---------------
emesene (1.0~r1013-0ubuntu2) hardy; urgency=low

  * debian/control:
    - Remove python-xml dependency as the xml modules used by emesene
      are shipped in Python. LP: #199014.

 -- Emilio Pozuelo Monfort <email address hidden> Tue, 25 Mar 2008 02:06:56 +0100

Changed in emesene:
status: In Progress → Fix Released
Revision history for this message
Scott Kitterman (kitterman) wrote :

zsi is going to be complicated and take more time than I have to deal with.

Changed in zsi:
assignee: kitterman → nobody
status: New → Confirmed
Revision history for this message
Scott Kitterman (kitterman) wrote :

I'm assigning zsi to you based on our IRC conversation a few days ago. I think it's the last thing left.

Changed in qm:
status: In Progress → Fix Released
Changed in fonttools:
status: In Progress → Fix Released
Changed in zsi:
assignee: nobody → doko
status: Confirmed → In Progress
Changed in zsi:
milestone: none → ubuntu-8.04
Revision history for this message
Onkar Shinde (onkarshinde) wrote :

pyslide doesn't work when python-xml is not present. I tried one of the examples with command 'pyslide /usr/share/doc/pyslide/examples/full.xml'
It gives following error.

Traceback (most recent call last):
  File "/usr/bin/pyslide", line 30, in <module>
    m.action()
  File "/var/lib/python-support/python2.5/Pyslide/Main/__init__.py", line 71, in __call__
    fo = main.loadfile(fn)
  File "/var/lib/python-support/python2.5/Pyslide/Main/__init__.py", line 294, in loadfile
    from Pyslide.File import ReadFile
  File "/var/lib/python-support/python2.5/Pyslide/File.py", line 40, in <module>
    class ContentParser(xml.sax.saxutils.DefaultHandler):

Changed in pyslide:
assignee: bobbo → nobody
status: Fix Released → New
Changed in pyslide:
assignee: nobody → kitterman
status: New → In Progress
Changed in pyslide:
assignee: kitterman → onkarshinde
milestone: none → ubuntu-8.04
Revision history for this message
David Futcher (bobbo) wrote :

pyslide can be fixed by adding python-lxml to its Depends. Attached is a debdiff. I have tested it with a couple of the examples shipped in the package.

Revision history for this message
Scott Kitterman (kitterman) wrote :

On Monday 31 March 2008 10:31:31 David Futcher wrote:
> pyslide can be fixed by adding python-lxml to its Depends. Attached is a
> debdiff. I have tested it with a couple of the examples shipped in the
> package.
>

Try:

pyslide /usr/share/doc/pyslide/examples/full.xml

That still fails for me with python-lxml installed.

Revision history for this message
David Futcher (bobbo) wrote :

> That still fails for me with python-lxml installed.

True, i removed python-lxml from my system and it didnt work. Turns out i had forgotten to remove python-xml before testing :/ Will see if i can hunt it down a bit more and report back to Onkar.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zsi - 2.0-2ubuntu2

---------------
zsi (2.0-2ubuntu2) hardy; urgency=low

  * Revert last change, explicitely add the directory in sys.path,
    where the old _xmlplus module can be found. LP: #199014.

 -- Matthias Klose <email address hidden> Tue, 01 Apr 2008 14:04:12 +0000

Changed in zsi:
status: In Progress → Fix Released
Revision history for this message
enguerran (enguerrangillet) wrote :

A simple python script with those two lines doesn't work.
#!/usr/bin/python
import xml.dom.ext

I got the following message :
File "TGFXml.py", line 2, in <module>
    import xml.dom.ext
ImportError: No module named ext

Which package (exept python-xml), on a ubuntu, should provide this module ? I have python-4suite-xml and python-lxml installed.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

enguerran wrote:
> A simple python script with those two lines doesn't work.
> #!/usr/bin/python
> import xml.dom.ext
>
> I got the following message :
> File "TGFXml.py", line 2, in <module>
> import xml.dom.ext
> ImportError: No module named ext
>
>
> Which package (exept python-xml), on a ubuntu, should provide this module ? I have python-4suite-xml and python-lxml installed.
>

None does. You will need to change it to either use python's xml modules (which
are a subset of python-xml AFAIK) or use 4suite/lxml APIs.

Revision history for this message
enguerran (enguerrangillet) wrote :

Ok. Thanks for your quick answer.

Revision history for this message
Artyom Pervukhin (logus) wrote :

python-zsi still should have python-xml as dependency:
File /var/lib/python-support/python2.5/ZSI/parse.py contains:
from xml.dom.ext.reader import PyExpat
at line 55.

Changed in zsi:
assignee: doko → nobody
status: Fix Released → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zsi - 2.0-2ubuntu4

---------------
zsi (2.0-2ubuntu4) hardy; urgency=low

  * Readd dependency on python-xml. LP: #199014.

 -- Matthias Klose <email address hidden> Wed, 09 Apr 2008 15:25:46 +0000

Changed in zsi:
status: Incomplete → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyslide - 0.4-10ubuntu2

---------------
pyslide (0.4-10ubuntu2) hardy; urgency=low

  * Readd dependency on python-xml, explicitely add the directory in sys.path,
    where the old _xmlplus module can be found. LP: #199014.

 -- Matthias Klose <email address hidden> Wed, 09 Apr 2008 15:30:56 +0000

Changed in pyslide:
status: In Progress → Fix Released
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

python-xml is still not a Dep of pyslide:

andrew@andrew-laptop:~$ apt-cache policy pyslide
pyslide:
Installed: 0.4-10ubuntu2
Candidate: 0.4-10ubuntu2
Version table:
0.4-10ubuntu2 0
500 http://us.archive.ubuntu.com hardy/universe Packages

andrew@andrew-laptop:~$ apt-cache depends pyslide
pyslide
Depends: libc6
Depends: libsdl1.2debian
Depends: python
Depends: python
Depends: python-pygame
Depends: python-support
Suggests: python-imaging

andrew@andrew-laptop:~$ apt-cache rdepends python-xml
python-xml
Reverse Depends:
grnotify
mythvideo
xbel-utils
python-zsi
python-xml-doc
python-xml-dbg
opendict

Running pyslide without python-xml installed produces the following:

andrew@andrew-laptop:/usr/share/doc/pyslide/examples$ pyslide full.xmlTraceback (most recent call last):
  File "/usr/bin/pyslide", line 30, in <module>
    m.action()
  File "/var/lib/python-support/python2.5/Pyslide/Main/__init__.py", line 71, in __call__
    fo = main.loadfile(fn)
  File "/var/lib/python-support/python2.5/Pyslide/Main/__init__.py", line 294, in loadfile
    from Pyslide.File import ReadFile
  File "/var/lib/python-support/python2.5/Pyslide/File.py", line 42, in <module>
    class ContentParser(xml.sax.saxutils.DefaultHandler):
AttributeError: 'module' object has no attribute 'DefaultHandler'

Changed in pyslide:
status: Fix Released → New
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Debdiff attached.

 I've never tried to do a SRU before. Please let me know if the format is wrong. or if you want build or install logs.

All in all this is pretty straight forward. Can't run with out python-xml, so I add python-xml as a Dep. Supposedly this was done before, but apparently there was a mistake.

pyslide (0.4-10ubuntu2.1) hardy-proposed; urgency=low

  * Re-add dependency on python-xml. (LP: #199014)

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 199014] Re: python-xml removal: please drop/replace (build) dependencies

Did you confirm it works without further patching if python-xml is
installed?

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

I am able to successfully run the files in /usr/share/doc/pyslide/examples with python-xml installed. Attepting to run them with out it produces the above failure.

Revision history for this message
Luca Falavigna (dktrkranz) wrote :

ACK from motu-sru to upload pyslide 0.4-10ubuntu2.1 to hardy-proposed.
Please, manage similar upload in Intrepid ASAP.

Changed in pyslide:
status: New → Confirmed
Revision history for this message
Scott Kitterman (kitterman) wrote :

I'm going to upload this to proposed. Please edit the bug and add a test case that describes the exact procedure to verify this fix works.

Revision history for this message
Scott Kitterman (kitterman) wrote :

Uploaded. Now we wait for archive admins to accept.

Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test.

NB that I did *not* add hardy/intrepid tasks here, since that would cause the tasks to appear on all the source packages (tedious...). So please make sure that this is fixed in Debian and file a sync request, or upload the fix to intrepid, to make sure that it doesn't get lost.

Changed in pyslide:
milestone: ubuntu-8.04 → none
status: Confirmed → Fix Committed
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

The Debian package was never broken, so a sync should be fine for Intrepid. Sync request in Bug #224368.

description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyslide - 0.4-10ubuntu3

---------------
pyslide (0.4-10ubuntu3) intrepid; urgency=low

  * Re-add dependency on python-xml. (LP: #199014)

 -- Andrew Starr-Bochicchio (andrewsomething) <email address hidden> Fri, 02 May 2008 23:02:15 -0400

Changed in pyslide:
status: Fix Committed → Fix Released
Revision history for this message
Michael Kaliszka (desmont) wrote :

It seems that python-xml removal broke mmpython:

>>> import mmpython
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/mmpython/__init__.py", line 127, in <module>
    import image.jpginfo
  File "/usr/lib/python2.5/site-packages/mmpython/image/jpginfo.py", line 102, in <module>
    import ImageInfo
  File "/usr/lib/python2.5/site-packages/mmpython/image/ImageInfo.py", line 39, in <module>
    from xml.utils import qp_xml
ImportError: No module named utils

The issue was also reported on http://code.google.com/p/subdownloader/issues/detail?id=16 with a possible fix (I have not tested it).

Revision history for this message
Robert Collins (lifeless) wrote :

Reopening this task as the package is currently broken - it still depends on python-xml, see bug 214185

Changed in memaid-pyqt:
status: Fix Released → In Progress
Revision history for this message
Albert Damen (albrt) wrote :

+1 for sru-verification of pyslide

- Removed python-xml from my system
- With the hardy version "pyslide /usr/share/doc/pyslide/examples/effects.xml" gave the error message: AttributeError: 'module' object has no attribute 'DefaultHandler'
- Installing pyslide from hardy-proposed (0.4-10ubuntu2.1) pulled in python-xml
- Now "pyslide /usr/share/doc/pyslide/examples/effects.xml" correctly opened a presentation

Revision history for this message
Luca Falavigna (dktrkranz) wrote :

HARDY VERIFICATION:

Using version 0.4-10ubuntu2 from hardy-release:
Package returns output as per test case.

Using version 0.4-10ubuntu2.1 from hardy-proposed:
Package works correctly.

Revision history for this message
Martin Pitt (pitti) wrote :

pyslide copied to hardy-updates.

Revision history for this message
Marco Ferreira (mferreira) wrote :

Hi.

Unfortunetly I keep getting that ImportError message when import mmpython:

/usr/lib/python2.5/site-packages/mmpython/__init__.py in <module>()
    125 import video.asfinfo
    126 import video.movinfo
--> 127 import image.jpginfo
    128 import image.pnginfo
    129 import image.tiffinfo

/usr/lib/python2.5/site-packages/mmpython/image/jpginfo.py in <module>()
    100 import struct
    101
--> 102 import ImageInfo
    103
    104 # interesting file format info:

/usr/lib/python2.5/site-packages/mmpython/image/ImageInfo.py in <module>()
     37 import os
     38 import gzip
---> 39 from xml.utils import qp_xml
     40
     41 DEBUG = mediainfo.DEBUG

<type 'exceptions.ImportError'>: No module named utils

With or without python-xml installed.
Cheers

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote : Re: [Bug 199014] Re: python-xml removal: please drop/replace (build) dependencies

Marco Ferreira wrote:
> Hi.
>
> Unfortunetly I keep getting that ImportError message when import
> mmpython:

Reported as bug #248749, working on it. Thanks for spotting it.

Changed in pyslide (Ubuntu):
status: Fix Released → Incomplete
Steve Langasek (vorlon)
Changed in pyslide (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Kartik Mistry (kartik.mistry) wrote :

I can't see its 'Fix Released' in pyslide. 0.4-12 says,
+Depends: ${shlibs:Depends}, ${python:Depends}, python-pygame, python-xml

I am sorry that I changed status without commenting..

Revision history for this message
Steve Langasek (vorlon) wrote :

Ah - yes, I see that the pyslide "fix" involved declaring a dep on python-xml, which seems to not be the intent of this bug report. Reopening this task (as "Triaged", though - not "Incomplete", which implies there is information missing about the bug.)

Changed in pyslide (Ubuntu):
status: Fix Released → Triaged
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

memaid-pyqt is no longer around.

Changed in memaid-pyqt (Ubuntu):
status: In Progress → Won't Fix
Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Nor is pyslide

Changed in pyslide (Ubuntu):
assignee: Onkar Shinde (onkarshinde) → nobody
status: Triaged → Won't Fix
Changed in gstreamer:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 117 comments or add a comment.