Natty to Oneiric - failed to calculate the upgrade with gcj-4.4-jre installed

Bug #853688 reported by Jean-Baptiste Lallement on 2011-09-19
118
This bug affects 21 people
Affects Status Importance Assigned to Milestone
command-not-found (Ubuntu)
Medium
Ubuntu Installer Team
Oneiric
Medium
Michael Vogt
Precise
Medium
Ubuntu Installer Team
eglibc (Ubuntu)
High
Michael Vogt
Oneiric
High
Michael Vogt
Precise
Undecided
Unassigned
gcc-4.4 (Ubuntu)
High
Michael Vogt
Oneiric
High
Michael Vogt
Precise
Undecided
Unassigned

Bug Description

TEST CASE:
1. Install Natty and apply the updates
2. Install 'gcj-4.4-jre'
3. run 'update-manager -d' and proceed with the upgrade to 11.10

Result:
The upgrader fails to calculate the upgrade path.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: update-manager 1:0.150.3
ProcVersionSignature: Ubuntu 2.6.38-11.48-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
Architecture: amd64
CurrentDmesg.txt:
 [ 13.886286] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 18.490039] eth0: no IPv6 routers present
 [ 18.856529] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
Date: Mon Sep 19 09:15:25 2011
GConfNonDefault:
 /apps/update-manager/check_new_release_ignore=
 /apps/update-manager/first_run=false
 /apps/update-manager/window_size=(600,600)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to natty on 2011-09-19 (0 days ago)

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Changed in update-manager (Ubuntu Oneiric):
importance: Undecided → High
tags: added: rls-mgr-o-tracking
affects: update-manager (Ubuntu Oneiric) → gcj-4.4 (Ubuntu Oneiric)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gcj-4.4 (Ubuntu):
status: New → Confirmed
Changed in gcj-4.4 (Ubuntu Oneiric):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in gcj-4.4 (Ubuntu Oneiric):
status: Confirmed → Triaged
tags: added: iso-testing
Steve Langasek (vorlon) on 2011-09-22
Changed in gcj-4.4 (Ubuntu Oneiric):
assignee: Canonical Foundations Team (canonical-foundations) → Steve Langasek (vorlon)
Steve Langasek (vorlon) wrote :
Download full text (8.5 KiB)

Analysis from the resolver:

# apt-get -oDebug::pkgProblemResolver=true dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Starting
Starting 2
Investigating (0) console-setup [ amd64 ] < 1.57ubuntu20 -> 1.57ubuntu25 > ( utils )
Broken console-setup:amd64 Conflicts on console-terminus [ amd64 ] < 4.30-2 > ( fonts )
  Considering console-terminus:amd64 -1 as a solution to console-setup:amd64 11
  Added console-terminus:amd64 to the remove list
  Fixing console-setup:amd64 via remove of console-terminus:amd64
Investigating (0) gcc-4.4-base [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( libs )
Broken gcc-4.4-base:amd64 Breaks on gcj-4.4-base [ amd64 ] < 4.4.5-15ubuntu3 -> 4.4.6-2ubuntu2 > ( libs ) (< 4.6.1-4ubuntu2~)
  Considering gcj-4.4-base:amd64 8 as a solution to gcc-4.4-base:amd64 3
  Holding Back gcc-4.4-base:amd64 rather than change gcj-4.4-base:amd64
Investigating (0) cpp-4.4 [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( interpreters )
Broken cpp-4.4:amd64 Depends on gcc-4.4-base [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( libs ) (= 4.4.6-11ubuntu1)
  Considering gcc-4.4-base:amd64 3 as a solution to cpp-4.4:amd64 1
  Holding Back cpp-4.4:amd64 rather than change gcc-4.4-base:amd64
Investigating (0) gcc-4.4 [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( devel )
Broken gcc-4.4:amd64 Depends on gcc-4.4-base [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( libs ) (= 4.4.6-11ubuntu1)
  Considering gcc-4.4-base:amd64 3 as a solution to gcc-4.4:amd64 0
  Holding Back gcc-4.4:amd64 rather than change gcc-4.4-base:amd64
Investigating (1) libgcc1 [ amd64 ] < 1:4.5.2-8ubuntu4 -> 1:4.6.1-9ubuntu3 > ( libs )
Broken libgcc1:amd64 Breaks on gcc-4.4 [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( devel ) (< 4.4.6-4)
  Considering gcc-4.4:amd64 0 as a solution to libgcc1:amd64 422
  Upgrading gcc-4.4:amd64 due to Breaks field in libgcc1:amd64
 Try to Re-Instate (1) gcc-4.4-base:amd64
 Try to Re-Instate (1) cpp-4.4:amd64
Investigating (1) gcc-4.4 [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( devel )
Broken gcc-4.4:amd64 Depends on gcc-4.4-base [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( libs ) (= 4.4.6-11ubuntu1)
  Considering gcc-4.4-base:amd64 3 as a solution to gcc-4.4:amd64 0
  Holding Back gcc-4.4:amd64 rather than change gcc-4.4-base:amd64
Investigating (2) libgcc1 [ amd64 ] < 1:4.5.2-8ubuntu4 -> 1:4.6.1-9ubuntu3 > ( libs )
Broken libgcc1:amd64 Breaks on gcc-4.4 [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( devel ) (< 4.4.6-4)
  Considering gcc-4.4:amd64 0 as a solution to libgcc1:amd64 422
  Upgrading gcc-4.4:amd64 due to Breaks field in libgcc1:amd64
Investigating (2) gcc-4.4 [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( devel )
Broken gcc-4.4:amd64 Depends on gcc-4.4-base [ amd64 ] < 4.4.5-15ubuntu1 -> 4.4.6-11ubuntu1 > ( libs ) (= 4.4.6-11ubuntu1)
  Considering gcc-4.4-base:amd64 3 as a solution to gcc-4.4:amd64 0
  Holding Back gcc-4.4:amd64 rather than change gcc-4.4-base:amd64
Investigating (3) libgcc1 [ amd64 ] < 1:4.5.2-8ubuntu4 -> 1:4.6.1-9ubuntu3 > ( libs )
Broken libgcc1:amd64 Breaks on gcc-4.4 [ amd64 ] < 4.4....

Read more...

Changed in gcj-4.4 (Ubuntu Oneiric):
assignee: Steve Langasek (vorlon) → Matthias Klose (doko)

On 09/23/2011 02:40 AM, Steve Langasek wrote:
> The libc6-dev Breaks: is clear enough because the old compiler won't
> find libc.so or some of the headers; but why do we have a breaks: from
> libgcc1, the runtime lib? Matthias?

multiarch. the libgcc1 in the multiarch location makes the libgcc_s.so symlinks
in gcc-4.4 and gcc-4.5 invalid.

Erick Moreno (erickmoreno) wrote :

The same is happen with me but I think that I have problems with other packages. There's my apt.log attached.

Changed in gcj-4.4 (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
graingert (tagrain) wrote :

I un-installed gcj-4.4-jre and I still get the error

graingert (tagrain) wrote :

I un-installed gcj-4.4-jre and I still get the error

Matthias Klose (doko) wrote :

trying to understand why that many people do have gcj-4.4 installed ... command-not-found still recommends gcj, if java or javac are not found. so the default recommendations should be changed to default-jre and default-jdk.

graingert: please try to uninstall gcj-4.4-jre-headless or even libgcj-common

Changed in command-not-found (Ubuntu Oneiric):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → High
milestone: none → ubuntu-11.10
status: New → Confirmed
Zygmunt Krynicki (zyga) wrote :

Mvo, shall we add a priority file entry for java?

anatoly techtonik (techtonik) wrote :

From the Java apps I remember, I tried to use Eclipse and Netbeans IDEs. I also remember that Ubuntu version was outdated, so it was probably from 3rd party .deb Could this trigger installation of gcj?

Michael Vogt (mvo) wrote :

@zyga: yes, I think a priority file is a great idea.

Michael Vogt (mvo) wrote :
Changed in gcj-4.4 (Ubuntu Oneiric):
status: Triaged → In Progress

The attachment "I looked at the problem and it appears that the apt resolver needs a bit of help to understand whats going on" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Steve Langasek (vorlon) on 2011-09-30
affects: gcj-4.4 (Ubuntu Oneiric) → eglibc (Ubuntu Oneiric)
Changed in eglibc (Ubuntu Oneiric):
assignee: Matthias Klose (doko) → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.13-20ubuntu4

---------------
eglibc (2.13-20ubuntu4) oneiric; urgency=low

  * debian/control:
    - help the apt resolver with the gcc-4.4 upgrade by providing
      explicit breaks against {gnat,gcc,gcj}-{4.4,4.5}-base (LP: #853688)
 -- Michael Vogt <email address hidden> Fri, 30 Sep 2011 14:02:02 +0200

Changed in eglibc (Ubuntu Oneiric):
status: In Progress → Fix Released
Steve Langasek (vorlon) wrote :

The command-not-found side doesn't look like a blocker for release... we could always clean this up in SRU if it's important. (The real damage was already done when users installed gcj-4.4 pre-oneiric, fixing c-n-f in oneiric isn't critical-path.)

Changed in command-not-found (Ubuntu Oneiric):
milestone: ubuntu-11.10 → oneiric-updates
Michael Vogt (mvo) on 2011-10-04
Changed in command-not-found (Ubuntu Oneiric):
importance: High → Medium
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking

I'm reopening this report. It is still an issue with current packages in Oneiric from an uptodate natty with gcj-4.4-jre-headless installed.

Changed in eglibc (Ubuntu Oneiric):
status: Fix Released → Triaged
Michael Vogt (mvo) wrote :

It turned out that there is a incorrect breaks in gcc-.4.4-base:

Package: gcc-4.4-base
Breaks: gcj-4.4-rmadison gcj-4.4-base

aber:
gcj-4.4-base | 4.4.6-2ubuntu2 | oneiric | amd64, armel, i386, powerpc

So there is copy/paste errror: 4.4.6 vs 4.6.1

Changed in gcc-4.4 (Ubuntu Oneiric):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcc-4.4 - 4.4.6-11ubuntu2

---------------
gcc-4.4 (4.4.6-11ubuntu2) oneiric; urgency=low

  * debian/control.m4:
    - fix breaks of gcc-4.4-base against gcj-4.4-base
      (LP: #853688)
 -- Michael Vogt <email address hidden> Wed, 05 Oct 2011 16:19:53 +0200

Changed in gcc-4.4 (Ubuntu Oneiric):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

tags: added: rls-mgr-o-tracking
Changed in command-not-found (Ubuntu Precise):
importance: Undecided → Medium
tags: removed: rls-mgr-o-tracking
tags: added: rls-mgr-o-tracking
Steve Langasek (vorlon) on 2011-10-07
Changed in eglibc (Ubuntu Oneiric):
status: Triaged → Fix Released
Jacob Henderson (lmeditato) wrote :

I'm having the problem with ia32-libs on my system. I removed it, and the upgrade now works.

Martin Pitt (pitti) wrote :

Nothing to sponsor here any more, unsubscribing sponsors.

Steve Langasek (vorlon) on 2011-10-26
tags: added: rls-p-tracking
Steve Langasek (vorlon) on 2011-11-16
Changed in command-not-found (Ubuntu Precise):
milestone: none → ubuntu-12.04
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package command-not-found - 0.2.46ubuntu1

---------------
command-not-found (0.2.46ubuntu1) precise; urgency=low

  * merged from lp:command-not-found trunk:
    - add support for automatic install prompt (enable via the
      COMMAND_NOT_FOUND_INSTALL_PROMPT environment)
    - fix java recommends (LP: #853688)
    - add --no-failure-msg
    - improved zsh support from Alex Jurkiewicz
    - auto-installation support for root users from Serhiy Zahoriya
 -- Michael Vogt <email address hidden> Fri, 13 Jan 2012 10:39:15 +0100

Changed in command-not-found (Ubuntu Precise):
status: Confirmed → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in command-not-found (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers