Ubuntu

Unable to Install any plugins - 3.5.1+repack~1-0ubuntu1 on Karmic

Reported by Danny Tamez on 2009-11-08
86
This bug affects 21 people
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: eclipse

Kubutu Karmic 9:10 KDE 4.3
Install latest eclipse via KPackageKit 3.5.1+repack~1-0ubuntu1

run eclipse

Help > Install New Software

Choose a plugin to install

Security Warning Dialog box appears:
Warning: You are installing software that contains unsigned content. The authenticity or validity of this software cannot be established. Do you want to continue with the installation?

Choose OK

Dialog appears
Problem Occurred
An error occurred while installing the items
  session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.ant.ui 3.4.1.v20090901_r351, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
  The artifact file for osgi.bundle,org.eclipse.ant.ui,3.4.1.v20090901_r351 was not found.

-------

workaround : sudo apt-get install eclipse-pde

Related branches

Danny Tamez (zematynnad) wrote :

Here is the error log:
!SESSION 2009-11-06 23:04:16.439 -----------------------------------------------
eclipse.buildId=M20090917-0800
java.version=1.6.0_0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.equinox.p2.engine 4 4 2009-11-06 23:06:37.952
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2009-11-06 23:06:37.952
!MESSAGE session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.ant.ui 3.4.1.v20090901_r351, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2009-11-06 23:06:37.953
!MESSAGE The artifact file for osgi.bundle,org.eclipse.ant.ui,3.4.1.v20090901_r351 was not found.
!SESSION 2009-11-07 18:13:20.034 -----------------------------------------------
eclipse.buildId=M20090917-0800
java.version=1.6.0_0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.equinox.p2.engine 4 4 2009-11-07 18:17:28.695
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2009-11-07 18:17:28.696
!MESSAGE session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.ant.ui 3.4.1.v20090901_r351, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2009-11-07 18:17:28.696
!MESSAGE The artifact file for osgi.bundle,org.eclipse.ant.ui,3.4.1.v20090901_r351 was not found.

Benjamin Drung (bdrung) wrote :

Do you have eclipse-jdt installed?

No, my plan was install CDT. Should I install it anyway?

Danny

On Saturday 07 November 2009 06:45:36 pm Benjamin Drung wrote:
> Do you have eclipse-jdt installed?
>

--

Danny Tamez
Canonical Ltd.
+1 214.542.6153 (mob)
+1 972.463.9727 (home)
<email address hidden>
IRC nick: zematynnad
Ubuntu - Linux for human beings | www.ubuntu.com | www.canonical.com

I can confirm this bug. I ran into it when trying to install Eclipse XML Editors and Tools.

Changed in eclipse (Ubuntu):
status: New → Confirmed

After installing all the other eclipse packages (ie. eclipse-pde, eclipse-jdt, and eclipse-rcp), I stopped getting this error and was able to install plugins.

Benjamin Drung (bdrung) wrote :

We have moved org.eclipse.ant.ui from eclipse-jdt to eclipse-platform (will be in the next release).

For installing plugins you probably need eclipse-platform and eclipse-pde.

Changed in eclipse (Ubuntu):
status: Confirmed → Fix Committed
Benjamin Drung (bdrung) on 2009-11-08
Changed in eclipse (Ubuntu):
importance: Undecided → Low
Jasper Frumau (jfrumau) wrote :

@ Benjamin "For installing plugins you probably need eclipse-platform and eclipse-pde." Probably or certain? I just installed Eclipse and wanted to add the Ruby SDK plugin and ran into the same errors on Ubuntu 9.10 Karmic Koala just now..

jdahern (jeffery-ahern) wrote :

@rhand, just ran into this problem. Using Ubuntu 9.10 Karmic Koala
I installed eclipse-pde and eclipse-jdt. after that, worked fine

maheshjagadeesan (maheshj) wrote :

I had this problem too, and I can confirm that installing jdt and pde solves it.

EzNet (zeroezezero) wrote :

I have to echo this - was 100% true for me too:

"I had this problem too, and I can confirm that installing jdt and pde solves it."

Ubuntu 9.10 (x32).
I install exlipse-platform and eclipse-jdt (version 3.5.1).
Run exlipse and show error message:

An error occurred while installing the items
  session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.pde 3.4.100.v20090527, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
  The artifact file for osgi.bundle,org.eclipse.pde,3.4.100.v20090527 was not found.

Please, help me.

Niels Thykier (niels-thykier) wrote :

Anton Danilchenko:

Try installing eclipse-pde as well - it is required for most plug-in installations.

~Niels

Davide Targa (davide-targa) wrote :

Ubuntu 9.10 Karmic
Kernel 2.6.31-14-generic
Gnome 2.28.1

I confirm that the installation of the two packages eclipse-pde and eclipse-jdt fixed the problem.

sudo apt-get install eclipse-pde eclipse-jdt

Davide

I install eclipse-pdt and remove eclipse-jdt. Work well!

Thanks!

To those of us who thought the above suggestions to install eclipse-pde and eclipse-jdt and/or eclipse-platform were things we should do within the eclipse software > install new software screen, WE ARE WRONG!

We should be opening the terminal and doing

sudo apt-get install eclipse-pde

Koen Beek (koen-beek) on 2009-12-05
description: updated
Thorsten Kunz (sfire) wrote :

I am not sure if I am suffering from the same bug but the result is the same. I am unable to install lots plugins which renders Eclipse useless to me. For example here is the error I get when trying to install Eclipse Web Developer Tools from http://download.eclipse.org/releases/ganymede/:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Web Developer Tools 3.0.4.v200811190840-7A-8l8Qqcz0HyVgjXUE-iuOYZ9ai (org.eclipse.wst.feature.group 3.0.4.v200811190840-7A-8l8Qqcz0HyVgjXUE-iuOYZ9ai)
  Software currently installed: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
  Only one of the following can be installed at once:
    International Components for Unicode for Java (ICU4J) 3.8.1.v20080530 (com.ibm.icu 3.8.1.v20080530)
    International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.1 (Eclipse Platform 3.5.1)
    To: com.ibm.icu [4.0.1.v20090822]
  Cannot satisfy dependency:
    From: Web Developer Tools 3.0.4.v200811190840-7A-8l8Qqcz0HyVgjXUE-iuOYZ9ai (org.eclipse.wst.feature.group 3.0.4.v200811190840-7A-8l8Qqcz0HyVgjXUE-iuOYZ9ai)
    To: org.eclipse.wst.jsdt.feature.feature.group [1.0.4.v200812112112-6-E75BcMAAyDJGhFpNN]
  Cannot satisfy dependency:
    From: JavaScript Development Tools Core 1.0.104.v200901281939 (org.eclipse.wst.jsdt.core 1.0.104.v200901281939)
    To: bundle com.ibm.icu [3.8.1,4.0.0)
  Cannot satisfy dependency:
    From: JavaScript Developer Tools 1.0.4.v200812112112-6-E75BcMAAyDJGhFpNN (org.eclipse.wst.jsdt.feature.feature.group 1.0.4.v200812112112-6-E75BcMAAyDJGhFpNN)
    To: org.eclipse.wst.jsdt.core [1.0.104.v200901281939]

I both installed eclipse-pde and eclipse-jdt but the error stays the same.

Niels Thykier (niels-thykier) wrote :

Hi Thorsten Kunz

eclipse 3.5.X is codenamed Galileo, which is what you get from Ubuntu these days. The update site you list, however, is for Ganymede which was 3.4.X as I recall. Could you retry with the Galileo version?

~Niels

Thorsten Kunz (sfire) wrote :

Now how stupid was that.... just copy&pasted the site from my existing Eclipse installation into the new one without thinking. Of course it works once I changed it to the Galileo update site.
Thanks a lot for the hint and sorry for not using my brain before posting.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse - 3.5.1+repack~3-0ubuntu1

---------------
eclipse (3.5.1+repack~3-0ubuntu1) lucid; urgency=low

  * Rebase to packaging from pkg-java/eclipse:
    + Stopped using special hacks and work arounds to find JVMs.
      (Closes: #353360)
      - This removes the need for ~/.eclipse/eclipserc (Closes: #402077)
      - This makes eclipse read eclipse.ini (Closes: #491334)
    + Moved the executable to eclipse-platform from eclipse.
      (Closes: #358594)
    + Put the osgi jar-files into its own separate package. (LP: #102717)
    + Added workaround for gtk problems. (Closes: #552480)
    + Added missing API references. (Closes: #376850)
    + Moved org.eclipse.ant.ui to eclipse-platform. (LP: #477944)
    + Added information about how to create the orig.tar.gz.
      (Closes: #505553)
    + Rewrote symlink script to handle folders that are renamed on different
      archs/builds. (LP: #471859)
    + Move eclipse.ini into /etc (LP: #43162)
  * Drop versioned dependency on libcommons-el-java, libjetty-java,
    libservlet2.4-java; they are not yet available in Ubuntu.
 -- Benjamin Drung <email address hidden> Tue, 29 Dec 2009 18:48:17 +0100

Changed in eclipse (Ubuntu):
status: Fix Committed → Fix Released

I have installed "ecplise-platform" v3.5.1+repack~1-0ubuntu3 and get this error:

An error occurred while installing the items
  session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.ant.ui 3.4.1.v20090901_r351, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
  The artifact file for osgi.bundle,org.eclipse.ant.ui,3.4.1.v20090901_r351 was not found.

I can only install new eclipse plugins, after i installed the package "eclipse" v3.5.1+repack~1-0ubuntu3

Chris Morgan (chmorgan) wrote :

Also seeing this error with 'eclipse-platform 3.5.1+repack~1-0ubuntu3' and 'eclipse-rcp' installed.

Niels Thykier (niels-thykier) wrote :

Hi

A lot of eclipse plugins depend on things provided by eclipse-pde (which is also installed by the eclipse meta-package). Please install eclipse-pde and retry the install attempt.

~Niels

havoc86 (angelopuglisi86) wrote :

I have the same issue.
I installed eclipse-platform so I have:
$ dpkg -l 'eclipse*' | grep ^ii
ii eclipse-platform 3.5.1+repack~1-0ubuntu3 Eclipse platform without plug-ins to develop
ii eclipse-platform-data 3.5.1+repack~1-0ubuntu3 Eclipse platform without plug-ins to develop
ii eclipse-rcp 3.5.1+repack~1-0ubuntu3 Eclipse Rich Client Platform (RCP)

I got http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/galileo/SR1/eclipse-cpp-galileo-SR1-linux-gtk.tar.gz from eclipse website and it's all fine.

I can't understand why I have to install eclipse-jdt if I don't want it...

havoc86 (angelopuglisi86) wrote :

Sorry, plugins don't install either. There is no error, but the gui blocks and I can't press "next".
It seems the only way is to have jdt :(

Mazagatshy (mazagatshy) wrote :

I was trying to install CDT, installing eclipse-pde fixed the problem

Johnny Weedseed (jho4986) wrote :

I cant seem to find a workaround for this issue. I'm on Karmic w/ eclipse-pde, eclipse-jdt, and eclips-platform all installed but I still cant manage to get the ADT installed. The error I get is this:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Android Development Tools 0.9.5.v200911191123-20404 (com.android.ide.eclipse.adt.feature.group 0.9.5.v200911191123-20404)
  Missing requirement: Android Development Tools 0.9.5.v200911191123-20404 (com.android.ide.eclipse.adt.feature.group 0.9.5.v200911191123-20404) requires 'org.eclipse.gef 0.0.0' but it could not be found

I tried adding http://download.eclipse.org/releases/galileo to my update sources but still no luck. Eclipse seems to think that the repository is offline. :( Anyone else still having trouble with this?

Long Le (lelong88) wrote :

Just thought I should report:

I installed eclipse-pde and that fixed the problem! Many thanks, guys.

another_sam (anothersam) wrote :
Travis G (travis-gockelhut) wrote :

The problem I had was that Eclipse didn't come with any of its own software sites in its list, so it doesn't know where to find the things that your packages depend on.

To fix this, I added:

Galileo - http://download.eclipse.org/releases/galileo
The EPP Packages Repository - http://download.eclipse.org/technology/epp/packages/galileo
The Eclipse Project Updates - http://download.eclipse.org/eclipse/updates/3.5

After doing this, I could install all other packages without any problems.

Matthew Talbert (ransom1982) wrote :

For anyone who's still having this issue after installing all of the packages, see https://bugs.launchpad.net/ubuntu/+source/openjdk-6/+bug/445009. That fixed it for me.

marco noll (marco-noll) wrote :

Thanks Travis, that was it for me, too.
When installing eclipse with software update function it had no sites activated, though most are available (Help - Install new Software - klick on "Available Software sites")

I used Ubuntu 9.04 and tried to install the cdt packages into eclipse.

titi4u (titi4u) wrote :

I installed eclipse-pde and that fixed my problem too (on Ubuntu 9.10) ! Thank you !

Håkan Jonsson (hajons) wrote :

Hi I have the same problems on 3.5.1+repack~1-0ubuntu3 . I can't even install eclipse-pde:

An error occurred while installing the items
  session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.ant.ui 3.4.1.v20090901_r351, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
  The artifact file for osgi.bundle,org.eclipse.ant.ui,3.4.1.v20090901_r351 was not found.

Benjamin Drung (bdrung) wrote :

You should install the Ubuntu package eclipse-pde (apt-get install eclipse-pde).

Thanks Travis G!
My software sites list was empty too, so Eclipse wasn't able to find the required dependencies to install ADT (Android Developer Tools). After adding the URLs you provide, and the ADT URL, I could finally install the ADT plugins.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers