Eclipse SIGSEGVs in libpango

Bug #445009 reported by nh2
314
This bug affects 58 people
Affects Status Importance Assigned to Milestone
Eclipse
Fix Released
Unknown
eclipse (Fedora)
Fix Released
High
eclipse (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned
openjdk-6 (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

=============
BUG
=============
After having started Eclipse 3.5 on Karmic 32bit (openjdk-6-jre 6b16-1.6.1-1ubuntu2) and running it for some minutes, it terminates saying

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb7b62856, pid=24497, tid=3084424896
#
# JRE version: 6.0_15-b03
# Java VM: Java HotSpot(TM) Client VM (14.1-b02 mixed mode, sharing linux-x86 )
# Problematic frame:
# C [libpango-1.0.so.0+0x23856] pango_layout_new+0x36
#
# An error report file with more information is saved as:
# /home/niklas/hs_err_pid24497.log
[...]

Seems to be the bug in https://bugzilla.redhat.com/show_bug.cgi?id=522187 , but for the bug opener, the problem seems to be gone.
Please tell me if you need more information.

=============
WORKAROUND
=============
Disable assistive technologies:
System > Preferences > Assistive Technology Preferences > "Enable assistive technologies"

-OR-

Replace /usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.5.1.v3555a.jar (rename it to .backup or something) with
32bit Ubuntu: http://launchpadlibrarian.net/36500083/org.eclipse.swt.gtk.linux.x86_3.5.1.v3555a.jar
64bit Ubuntu: http://launchpadlibrarian.net/36643806/org.eclipse.swt.gtk.linux.x86_64_3.5.1.v3555a.jar
(See comment 44 and 47 for more info)

Related branches

Revision history for this message
In , Mark (mark-redhat-bugs) wrote :

After updating to rawhide on 28.09.2009 I have not noticed previous behaviour since then. I cannot reproduce any more Java (Eclipse) crash with these new rpms.

Revision history for this message
In , Matthias (matthias-redhat-bugs) wrote :

Could you reproduce them reliably before that update ?

Revision history for this message
In , Mark (mark-redhat-bugs) wrote :

Tell me what do you need. I have been updating every day but I did not check every day if all is ok with Java and Eclipse. I am sure that before that update Eclipse crashed but after that update doing the same things as I described above does not crash Eclipse.

Revision history for this message
In , Matthias (matthias-redhat-bugs) wrote :

Sounds good to me. I'm sure you'll open another bug if it starts crashing again...

96 comments hidden view all 134 comments
Revision history for this message
nh2 (nh2) wrote :
Revision history for this message
Matthias Klose (doko) wrote :

known problem with packages provided from eclipse.org. please use the one from the distribution (karmic)

tags: added: eclipse local-binary swt-gtk
96 comments hidden view all 134 comments
Revision history for this message
In , Jeff (jeff-redhat-bugs) wrote :

I'm seeing this with pango-1.26.0-1.fc12 and gtk2-2.18.2-1.fc12 and eclipse-swt-3.5.0-2.fc12

95 comments hidden view all 134 comments
Revision history for this message
Daniel (hackie) wrote :

Same problem, but slightly different software:

Eclipse is installed manually but up-to-date (3.5.1)

JRE version: 6.0_16-b01
# Java VM: Java HotSpot(TM) Client VM (14.2-b01 mixed mode, sharing linux-x86 )
(from package sun-java6-bin, version 6-16-0ubuntu1.9.04)

My question: WHY do i have to use eclipse from the distribution? There is nothing special to eclipse - it could also be every other SWT application...

libpango1.0-0, Version: 1.26.0-1

Also see strange behaviour when clicking buttons. Mostly they feel like i did not release the mouse button and then i have to press RETURN to start the action...

----

# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00d10856, pid=7497, tid=3078784704
#
# JRE version: 6.0_16-b01
# Java VM: Java HotSpot(TM) Client VM (14.2-b01 mixed mode, sharing linux-x86 )
# Problematic frame:
# C [libpango-1.0.so.0+0x23856] pango_layout_new+0x36

Revision history for this message
nh2 (nh2) wrote :

I also experience that button behaviour, but I think this is not related. Would you mind to create a bug report for that?

"it could also be every other SWT application" - ACK. If Eclipse is able to crash the JVM, every Java program could, right?

Revision history for this message
Daniel (hackie) wrote :

@nh2:
I see, you use openjdk 6. i use sun-java6-bin. and my eclipse is manually installed, so it uses only the standard dependencies from ubuntu. which package should I assign such a bug to?
I also see that eclipse process does not terminate anymore, but the all its windows and the profile lock were close correctly. system monitor tells futex_wait_queue_me.

And yes: I dont have any SWT testing application to check but i think it is a general problem.

94 comments hidden view all 134 comments
Revision history for this message
In , Michael (michael-redhat-bugs) wrote :

I as Jeff am seeing this bug on the same versions. A good way to reproduce this bug is to try to create (java) project. It usually happens when you click finish:)

Revision history for this message
In , Alexander (alexander-redhat-bugs) wrote :

Can someone try whether http://koji.fedoraproject.org/koji/taskinfo?taskID=1743496 fixes the problem?

Revision history for this message
In , Jeff (jeff-redhat-bugs) wrote :

(In reply to comment #13)
> Can someone try whether
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1743496 fixes the problem?

It works for my scenario which was to go into the New Project menu, select a C/C++ GNU Autotools project type but hit cancel before doing anything. This works now with the 3.5.1 build.

Revision history for this message
In , Mat (mat-redhat-bugs) wrote :

That 3.5.1 build seems to be working for me too, nice one.

96 comments hidden view all 134 comments
Revision history for this message
nh2 (nh2) wrote :

@Daniel:
You should create one bug for each problem (I see the futex_wait_queue_me, too) and assign it to the Eclipse package - if somebody knows that it belongs to another package, he will just change it.

By the way, I have these bugs with both OpenJDK and Sun's Java.

Revision history for this message
Daniel (hackie) wrote :

@nh2:
I see there are already bug reports, and workarounds for both too:
Termination: Bug #293849 & Bug #299828
Buttons: Bug #443004

96 comments hidden view all 134 comments
Revision history for this message
In , Michael (michael-redhat-bugs) wrote :

it doesn't for me :
$ rpm -ql eclipse*
package eclipse* is not installed
[mstoikov@ltm ~]$ rpm -qa eclipse*
eclipse-subclipse-1.6.5-1.fc12.noarch
eclipse-swt-3.5.1-1.fc12.x86_64
eclipse-changelog-2.6.7-3.fc12.x86_64
eclipse-jdt-3.5.1-1.fc12.x86_64
eclipse-cdt-6.0.0-10.fc12.x86_64
eclipse-dtp-1.7.0-5.fc12.noarch
eclipse-valgrind-0.3.0-1.fc12.x86_64
eclipse-cdt-sdk-6.0.0-10.fc12.x86_64
eclipse-rse-3.1-2.fc12.noarch
eclipse-gef-3.5.0-3.fc12.noarch
eclipse-svnkit-1.3.0-1.fc12.noarch
eclipse-platform-3.5.1-1.fc12.x86_64
eclipse-linuxprofilingframework-0.3.0-2.fc12.x86_64
eclipse-rpmstubby-0.3.0-1.fc12.noarch
eclipse-birt-2.5-1.fc12.noarch
eclipse-emf-2.5.0-4.fc12.noarch
eclipse-pydev-1.4.7-3.fc12.x86_64
eclipse-rpm-editor-0.4.3-1.fc12.x86_64
eclipse-rcp-3.5.1-1.fc12.x86_64

$ rpm -qa *pango*
pango-1.26.0-1.fc12.i686
pangomm-2.26.0-1.fc12.x86_64
pango-1.26.0-1.fc12.x86_64
pango-devel-1.26.0-1.fc12.x86_64
ruby-pango-0.19.3-2.fc12.x86_64
pangomm-devel-2.26.0-1.fc12.x86_64

$ eclipse
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007fc278920dfa, pid=4144, tid=140473951749904
#
# JRE version: 6.0-b16
# Java VM: OpenJDK 64-Bit Server VM (14.0-b16 mixed mode linux-amd64 )
# Distribution: Custom build (Thu Sep 10 17:06:47 EDT 2009)
# Problematic frame:
# C [libpango-1.0.so.0+0x24dfa] pango_layout_new+0x2a
#
# An error report file with more information is saved as:
# /home/mstoikov/hs_err_pid4144.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

The same way of testing this time the buttons didn't get highlighted and nothing happens but a second after I create the project and it shows in the left it crashes.And I am on x86_64

Revision history for this message
In , Michael (michael-redhat-bugs) wrote :

Created attachment 365116
the last log with 3.5.1

THis is the last log I get with 3.5.1

96 comments hidden view all 134 comments
Revision history for this message
Oleksandr Iuzikov (oiuzikov) wrote :

Confirm. I have installed eclipse from repo. And it's not working with both OpenJDK and Sun's Java.

Revision history for this message
Matthias Klose (doko) wrote :

the vm crash report in comment #8 seems to be incomplete

Revision history for this message
Matthias Klose (doko) wrote :

% opt/eclipse3.5/eclipse

you should report this problem where you got this version

Revision history for this message
nh2 (nh2) wrote :

@ Matthias:
It's the current "Eclipse IDE for Java Developers" available on eclipse.org.
I've filed the bug against OpenJDK because I do not know how a Java program can crash its JVM - why could that happen?

Revision history for this message
Matthias Klose (doko) wrote : Re: [Openjdk] [Bug 445009] Re: Eclipse SIGSEGVs in libpango

On 18.10.2009 21:22, nh2 wrote:
> @ Matthias:
> It's the current "Eclipse IDE for Java Developers" available on eclipse.org.
> I've filed the bug against OpenJDK because I do not know how a Java program can crash its JVM - why could that happen?

native code as distributed by eclipse.org, especially swt-gtk, xul and the like.

Revision history for this message
nh2 (nh2) wrote :
Revision history for this message
Oleksandr Iuzikov (oiuzikov) wrote : Re: [Bug 445009] Re: Eclipse SIGSEGVs in libpango

On Sun, 2009-10-18 at 18:03 +0000, Matthias Klose wrote:
> the vm crash report in comment #8 seems to be incomplete
>
attaching another one...

Revision history for this message
nh2 (nh2) wrote :

This happens with Karmic's Eclipse package, too.

To reproduce:
sudo apt-get install eclipse
eclipse
Click Help -> Install new Software -> Cancel -> You get the SIGSEGV

90 comments hidden view all 134 comments
Revision history for this message
In , Adam (adam-redhat-bugs) wrote :

This was discussed at the blocker review meeting today. As it seems clear this is a bug (or bugs) in Eclipse, not Pango or Java, we can't consider it a blocker for the final release, as it's not critical functionality and can just as easily be fixed as an update. Releng will accept a tag request to have a build included in F12 final to try and address these issues if you would like to do that, though.

--
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

89 comments hidden view all 134 comments
Revision history for this message
Guido Navalesi (eddiemolko) wrote :

This happens with Karmic 64bits too.
I've tried everything:
-Ubuntu's Eclipse package
-Install manually Eclipse
-Delete ~/.eclipse

And it's just like #15

90 comments hidden view all 134 comments
Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

*** Bug 531186 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

This puzzles me:

/home/mstoikov/.eclipse/793567567/configuration/org.eclipse.osgi/bundles/594/1/.cp/libswt-gnome-gtk-3555.so

The SWT .so files should be extracted into /usr/lib{,64}/eclipse and not get extracted (or re-extracted) at runtime.

Michael, did you happen to try with an eclipse.org download expanded into a read-only (to the running user) location at some point? Can you try to see if you can duplicate with a clean ~/.eclipse?

Ben, do you have any SWT .so files in ~/.eclipse?

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :
Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

Jim Hayward reports on fedora-devel-java-list [1]:

> I cannot reproduce that bug at all on a fully updated F12(rawhide) x86
> system. I don't currently have an x86_64 install to try. Eclipse 3.5.1
> has been working great since the dialog issue was fixed. I have been
> using 3.5.1 daily for Java/C/C++ projects with no issues at all.

I'm in the process on setting up an x86_64 system to see if I can track it down.

[1]
https://www.redhat.com/archives/fedora-devel-java-list/2009-October/msg00052.html

Revision history for this message
In , Ben (ben-redhat-bugs) wrote :

(In reply to comment #20)
> Ben, do you have any SWT .so files in ~/.eclipse?

No, the SWT shared libraries aren't in ~/.eclipse on my system.

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

I *finally* got rawhide x86_64 installed. So far, I can't duplicate the problem. I've tried adding the Pydev update site and it didn't crash (it didn't add the content but that's another issue :). I've also created and deleted a bunch of Java projects and haven't had any issues.

Revision history for this message
In , Mat (mat-redhat-bugs) wrote :

(In reply to comment #24)
> I *finally* got rawhide x86_64 installed. So far, I can't duplicate the
> problem. I've tried adding the Pydev update site and it didn't crash (it
> didn't add the content but that's another issue :). I've also created and
> deleted a bunch of Java projects and haven't had any issues.

Does the test case attached to the upstream Eclipse ticket work on Fedora?

Revision history for this message
In , Ben (ben-redhat-bugs) wrote :

(In reply to comment #24)
> I *finally* got rawhide x86_64 installed. So far, I can't duplicate the
> problem.

The crash happened for me on i686 so it may not be a 64-bit issue.

> I've tried adding the Pydev update site and it didn't crash (it
> didn't add the content but that's another issue :).

I had problems adding update sites too. Is there a bug report for this?

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

(In reply to comment #26)
> (In reply to comment #24)
> > I *finally* got rawhide x86_64 installed. So far, I can't duplicate the
> > problem.
>
> The crash happened for me on i686 so it may not be a 64-bit issue.

Odd.

> > I've tried adding the Pydev update site and it didn't crash (it
> > didn't add the content but that's another issue :).
>
> I had problems adding update sites too. Is there a bug report for this?

No, I'd appreciate you filing one. Thanks.

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

(In reply to comment #25)
> (In reply to comment #24)
> > I *finally* got rawhide x86_64 installed. So far, I can't duplicate the
> > problem. I've tried adding the Pydev update site and it didn't crash (it
> > didn't add the content but that's another issue :). I've also created and
> > deleted a bunch of Java projects and haven't had any issues.
>
>
> Does the test case attached to the upstream Eclipse ticket work on Fedora?

No. I've commented there. Thanks for pointing that out, Mat.

98 comments hidden view all 134 comments
Revision history for this message
nh2 (nh2) wrote :

(Un)Fortunately, this does not happen on every system.
My Karmic Netbook sigsegvs while my Karmic Desktop does not.

Revision history for this message
Oleksandr Iuzikov (oiuzikov) wrote :

Does your netbook have intel video? I have this problem on my HP 530
laptop. Can someone try it on non-intel video environment, please?

On Sat, 2009-10-31 at 13:31 +0000, nh2 wrote:

> (Un)Fortunately, this does not happen on every system.
> My Karmic Netbook sigsegvs while my Karmic Desktop does not.
>

--
Oleksandr Iuzikov
TECHISLE.NET

GPGKEY: 3C2B0980

Revision history for this message
NKjoep (nkjoep) wrote :

This appen to me too.

I'm running sun jdk from karmik repo, ati radeon 3200, intel core 2 (sony notebook).

Eclipse crashes everytime i click a "cancel".

So you if you want to reproduce this, just: File -> Import -> click cancel.

And you'll get this:

# SIGSEGV (0xb) at pc=0x002bd856, pid=4776, tid=3078371008
#
# JRE version: 6.0_16-b01
# Java VM: Java HotSpot(TM) Client VM (14.2-b01 mixed mode, sharing linux-x86 )
# Problematic frame:
# C [libpango-1.0.so.0+0x23856] pango_layout_new+0x36

Revision history for this message
nh2 (nh2) wrote :

We found a workaround in Bug 460104.
Click System -> Preferences -> Assistive Technologies -> Untick first checkbox and re-login, Eclipse should work now.

nh2 (nh2)
affects: openjdk → eclipse
Changed in eclipse (Ubuntu):
status: New → Confirmed
nh2 (nh2)
Changed in openjdk-6 (Ubuntu):
status: New → Invalid
Changed in eclipse (Fedora):
status: Unknown → In Progress
Benjamin Drung (bdrung)
Changed in eclipse (Ubuntu):
importance: Undecided → Medium
96 comments hidden view all 134 comments
Revision history for this message
In , nh2 (nh2-redhat-bugs) wrote :

See Ubuntu Bug 445009 (https://bugs.launchpad.net/bug/445009) for a possible workaround (turn of "Assistive Technologies").

Revision history for this message
In , nh2 (nh2-redhat-bugs) wrote :

Sorry, a typo. The URL is https://bugs.launchpad.net/bugs/445009.

96 comments hidden view all 134 comments
Revision history for this message
Arlo (arlo-white) wrote :

Confirming that disabling Assistive Technologies prevents the pango crash. However, I still have the button interaction issue where I need to use the keyboard to press a button.

Revision history for this message
Dario Bertini (berdario) wrote :

@Arlo:

isn't it bug 442078 ?

it should already be fixed in the repository version...

as a workaround for my old manual eclipse install i created a shell script with this line:

export GDK_NATIVE_WINDOWS=true && ./eclipse

Revision history for this message
Krzysztof Kolasa (kkolasa) wrote :

thanks nh2 and Dario Bertini
Eclipse Galileo ( and 3.6XX) is working properly in Ubuntu 9.10 32bit after these tips :)

Revision history for this message
Neil Grogan (dueyfinster) wrote :

I don't have Assistive technologies in my Preferences, does anyone know how to get it?

Revision history for this message
Dario Bertini (berdario) wrote : R: [Bug 445009] Re: Eclipse SIGSEGVs in libpango

Open (in a terminal or alt+f2) gnome-at-properties

Il giorno 04/nov/2009 23:01, "Neil Grogan" <email address hidden> ha scritto:

I don't have Assistive technologies in my Preferences, does anyone know
how to get it?

-- Eclipse SIGSEGVs in libpango https://bugs.launchpad.net/bugs/445009 You
received this bug notif...

Revision history for this message
Neil Grogan (dueyfinster) wrote :

Thanks, I also found:
$ gnome-control-panel

and then you can select and turn it off.

>Dario Bertini wrote R: [Bug 445009] Re: Eclipse SIGSEGVs in libpango #25
>Open (in a terminal or alt+f2) gnome-at-properties

Revision history for this message
Raivis Rengelis (raivisr) wrote :

turning off assistive technologies did not help me, eclipse (galileo SR1 from eclipse.org, not from repos) was still crashing when trying svn checkout (tigris.org subclipse plugin). The cure was as follows:
remove/rename libcairo-swt.so in eclipse folder to something that is not recognized as shared library, for example libcairo-swt.notsoso
apt-get install libswt-gtk-3.5-jni (i have karmic-proposed repos enabled so i got 3.5.1+repack~1-0ubuntu3 but it might work with earlier versions as well)
run eclipse and code away

Revision history for this message
Raivis Rengelis (raivisr) wrote :

apparently it did let me run checkout only once, now it crashes again :(

Revision history for this message
nh2 (nh2) wrote :

Can not confirm the workaround in #27 worked for me.
@Raivis: Did you restart your session after disabling assistive technologies?

Revision history for this message
Irios (irios) wrote :

The packages for Eclipse Galileo that are in Ubuntu's repositories (3.5.1+repack~1-0ubuntu1) do crash in Ubuntu, but do run in Kubuntu.

An example (that is not the only way of making Eclipse crash in Ubuntu in this way):

On Kubuntu:

Install Eclipse with K package manager or whatever.
Launch Eclipse
Click "Help" - "Install new software"
Setup Galileo repo
Select section "Programming Languages"
Select "Eclipse C/C++ Development Tools"
Click "Next" (Eclipse calculates dependencies, then shows you the packages you are going to install)
Click "Finish" (Eclipse downloads and installs CDT).

On Ubuntu:

Install Eclipse with Synaptic.
Launch Eclipse
Click "Help" - "Install new software"
Setup Galileo repo
Select section "Programming Languages"
Select "Eclipse C/C++ Development Tools"
Click "Next" (Eclipse calculates dependencies, then shows you the packages you are going to install)
Click "Finish" (Eclipse crashes and disappears).

If on Ubuntu Eclipse was launched from a console, at the moment it crashes you get this console output:

   #
   # A fatal error has been detected by the Java Runtime Environment:
   #
   # SIGSEGV (0xb) at pc=0x00277856, pid=6258, tid=3079112384
   #
   # JRE version: 6.0-b16
   # Java VM: OpenJDK Client VM (14.0-b16 mixed mode, sharing linux-x86 )
   # Distribution: Ubuntu karmic (development branch), package 6b16-1.6.1-1ubuntu3
   # Problematic frame:
   # C [libpango-1.0.so.0+0x23856] pango_layout_new+0x36
   #
   # An error report file with more information is saved as:
   # /home/nacho/hs_err_pid6258.log
   #
   # If you would like to submit a bug report, please include
   # instructions how to reproduce the bug and visit:
   # https://bugs.launchpad.net/ubuntu/+source/openjdk-6/
   # The crash happened outside the Java Virtual Machine in native code.
   # See problematic frame for where to report the bug.
   #
   Aborted

Pixie dust recipes that did not work:

* Install clean download from eclipse.org (same behavior)
* setting GDK_NATIVE_WINDOWS=1 before launching Ubuntu repo or eclipse.org version (same behavior)

I insist: It DOES work OK in Kubuntu.

Revision history for this message
NKjoep (nkjoep) wrote : Re: [Bug 445009] Re: Eclipse SIGSEGVs in libpango

07/nov/2009 18.31, Irios wrote:

> Pixie dust recipes that did not work:
>
> * Install clean download from eclipse.org (same behavior)
> * setting GDK_NATIVE_WINDOWS=1 before launching Ubuntu repo or eclipse.org
> version (same behavior)
>
> I insist: It DOES work OK in Kubuntu.
>

uhm, very interesting!

Does Kubuntu have "assistive technologies" ?

--
Andrea

Revision history for this message
Irios (irios) wrote :

Oh, I had missed the bit about relogging after disabling assistive technologies. I hereby confirm that disabling assistive technologies and relogging did make Eclipse work.

It is funny that it works out of the under Kubuntu, when it calls GTK just the same. I imagine GTK under Gnome does use Gnome libraries, and not only the other way around.

Revision history for this message
jose vilmar estacio de souza (vilmar-informal) wrote :

I can not turn off assistive tecnologies because I am blind and need to use eclipse with orca.
For while I'm using eclipse with windows. A solution would be welcome.
Thanks.

Revision history for this message
Oleksandr Iuzikov (oiuzikov) wrote : Turning "Assistive Technologies" off does not help

Now I cannot do checkout using Subversive plug-in. Turning "Assistive
Technologies" off does not help any more.

Revision history for this message
nh2 (nh2) wrote :

@ Oleksandr:
Could you tell us steps to reproduce?

Revision history for this message
jose vilmar estacio de souza (vilmar-informal) wrote :

To reproduce try the following steps:
1. Download and install eclipse 3.5.1 from http://www.eclipse.org
2. execute eclipse.
3. Press alt+h and chose install software.
4. press the cancel button.

Revision history for this message
Filippo De Luca (dl-filippo) wrote :

Hi I use the GDK_NATIVE_WINDOWS but it does not resolve the issue for me.

When I do an SVN update or commit, the eclipse GUI freeze and become blue with no interaction possible. It happen no every times but 50% of the times.

I think it is due to credential dialog but I'm not sure of this.

Anyone has my same issue?

Revision history for this message
nh2 (nh2) wrote :

@ Jose: This is clear to me, but it seems that Oleksandr's Eclipse crashes only on Subversive checkouts and not on the original bug on cancel buttons.
@ Oleksandr: Is this right?

Revision history for this message
Filippo De Luca (dl-filippo) wrote :

Hi, I solved my bug on #37 by use SvnKit instead of javaHL.

Revision history for this message
Jaromir Obr (jaromir-obr) wrote :

Another steps to reproduce:
1) Run Eclipse
2) Go to "Window -> Preferences -> General -> Keys"
3) Click on "Cancel" - Eclipse crashes
Disabling gnome assistive technologies helped me.

Used SW:
Ubuntu 9.10, amd64
Eclipse 3.5.1

Benjamin Drung (bdrung)
Changed in eclipse (Ubuntu):
status: Confirmed → Triaged
78 comments hidden view all 134 comments
Revision history for this message
In , Mads (mads-redhat-bugs) wrote :

*** Bug 547557 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Mads (mads-redhat-bugs) wrote :

Quick note after looking briefly at the discussion above and the pending needinfo: I can reproduce the duplicate on bug 547557 on x86 and after having moved .eclipse away.

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

I'm building some updated RPMs with a patch for this issue back-ported from
upstream:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1887104

If anyone can give those a shot with accessibility enabled and see if there are
still crasher bugs, I'd appreciate it.

I think bug #547056 is a dupe of this one.

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

Oops, there was an issue with my SRPM. Here's a better koji build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1887224

Revision history for this message
In , Mads (mads-redhat-bugs) wrote :

Re testing eclipse-*-3.5.1-27.fc13:

On f12 it also needs a new jetty. I tried with the one from http://koji.fedoraproject.org/koji/buildinfo?buildID=144142

It seems like the f12 pydev doesn't work with the new eclipse builds? I can only reproduce the crash with pydev.

Revision history for this message
In , Ben (ben-redhat-bugs) wrote :

I'm having the same problems as Mads - pydev is not working with 3.5.1-27.f13 and I needed to install a new version of jetty to get this eclipse version to install on f12. I see this problem with accessibility on and off.

description: updated
description: updated
Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

I'll try to get an F-12 build with these fixes.

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

Please try the RPMs from this koji build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1901359

You'll have to click the link for your architecture (i686 or x86_64, for example) and then download all the RPMs listed at the bottom of that page. Upgrade your existing package with something like:

# rpm -Uvh eclipse*3.5.1-22*.rpm

It fixes the "open update manager, click cancel -> crash" bug for me. I'd appreciate more feedback. Thanks.

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

*** Bug 553256 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Fabian (fabian-redhat-bugs) wrote :

Sorry, I'am on the CC list but did not receive any updates on this bug.

The koji build does not solve the problem for me.

Revision history for this message
In , Fabian (fabian-redhat-bugs) wrote :

I meant: It _does_ solve this problem.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

eclipse-3.5.1-22.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/eclipse-3.5.1-22.fc12

Revision history for this message
In , Andrew (andrew-redhat-bugs) wrote :

Thanks, Fabian.

All: I've proposed a Bodhi update and would appreciate you providing feedback in the form of a comment and karma there:

https://admin.fedoraproject.org/updates/eclipse-3.5.1-22.fc12

Note that you must be logged in with your Fedora account for the karma to get logged with the +3 required to push the update.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

eclipse-3.5.1-22.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update eclipse'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0353

Changed in eclipse (Fedora):
status: In Progress → Fix Committed
Changed in eclipse (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

eclipse-3.5.1-22.fc12 has been pushed to the Fedora 12 stable repository. If problems still persist, please make note of it in this bug report.

Revision history for this message
In , Michael (michael-redhat-bugs) wrote :

It works for me and it had for maybe two months I obviously forgot to reported it. But I'm using rawhide and current version is 3.5.1-28.fc13.x86_64. And From the timestamp on .eclipse I have tried the 'move .eclipse folder' move more then a month before my post. Thanks for the good work :)

Anand (anand243244)
Changed in eclipse (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in eclipse (Ubuntu):
status: Fix Committed → Fix Released
Changed in eclipse:
status: Unknown → Fix Released
Jeff Lane (bladernr)
Changed in eclipse (Ubuntu Karmic):
status: New → Invalid
Changed in openjdk-6 (Ubuntu Karmic):
status: New → Invalid
Changed in eclipse (Fedora):
importance: Unknown → High
status: Fix Committed → Fix Released
Displaying first 40 and last 40 comments. View all 134 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.