*** Error: couldn't find any ServerLayout sections

Bug #178061 reported by Patrice Vetsel on 2007-12-22
170
Affects Status Importance Assigned to Milestone
displayconfig-gtk (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: displayconfig-gtk

Displayconfig-gtk is unusable

sudo displayconfig-gtk
*** Error: couldn't find any ServerLayout sections

Patrice Vetsel (vetsel-patrice) wrote :

/etc/X11/xorg.conf

Patrice Vetsel (vetsel-patrice) wrote :

Screenshot

Changed in displayconfig-gtk:
importance: Undecided → High
Changed in displayconfig-gtk:
status: New → Confirmed
carseneau (craig-arseneau) wrote :

same problem here...

here is my xorg.conf

David Corrales (davidcorrales) wrote :

I'm having the same issue. Just installed hardy alpha on a Dell Inspiron 9300 (Ati x300).

Same issue here, blank Screen and Graphics Preferences panel.

Hardy Heron: Alpha 3
ATI Radeon 7200

I've attached my xorg.conf

Bart Cramer (bart-cramer) wrote :

Same here. xorg.conf seems almost empty/useless. Using Intel915.

mabovo (mabovo) wrote :

I got a similar error like this:

mabovo (mabovo) wrote :

after some changes in xorg.conf ....

Andrew (andrewabc) wrote :

I have the same problem. Screen and Graphics is blank, nothing to choose from. Trying to edit org.conf from terminal does not work, it only edits keyboard settings. My xorg.conf has no settings inside it other than keyboard settings, and some custom compiz settings I added to make compiz more stable.
I don't know if my log file is of any use. If you need any more info let me know and how to get it.

Hardy Alpha 3
Intel g965 x3000

jarondl (jarondl) wrote :

Same here.. And I know no manual way to change screen resolution since dpkg-reconfigure xserver-xorg stopped asking about screens and graphics
I use ubuntu hardy alpha 3

Changed in displayconfig-gtk:
milestone: none → hardy-alpha-4
pyknite (f4lken) wrote :

try to add this at the end of your xorg.conf:

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "NAME OF YOUR SCREEN"
EndSection

Glenn (glenn-v) wrote :

That works. displayconfig-gtk launches and all the fields are editable.

Steve Langasek (vorlon) wrote :
Changed in displayconfig-gtk:
milestone: hardy-alpha-4 → ubuntu-8.04-beta

That works.

Should we assign this bug to xorg ? -> and bad xorg.conf creation ?

pyknite (f4lken) wrote :

It can be a great idea... But I don't understand why the section "serverlayout" was forgotten?

Timo Aaltonen (tjaalton) wrote :

The bug is in displayconfig-gtk if it can't handle an xorg.conf without that section.

For those interested, here is the blueprint for hardy which states that xorg.conf should no longer have a "serverlayout" entry by default. https://wiki.ubuntu.com/DesktopTeam/Specs/HardyHardwareDetection
So I guess displayconfig-gtk needs to cope with this.

Kubuntu Hardy alpha 3 + 4

Andrew (andrewabc) wrote :

@ pyknite

How do I know what my screen name is? I have LG 20.1inch widescreen. I'm not sure what my xorg input would be. Even with ubuntu 7.10 when xorg was working it could not find my exact monitor or resolution, but resolution is working fine in Hardy without any xorg...

Azurit3 (azurit3) wrote :

Thanks pyknite,

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "NAME OF YOUR SCREEN"
EndSection

solve the problem, lets now wait a new release of displayconfig-gtk

pyknite (f4lken) wrote :

@andrew

check the screen section... you will find the name of your screen

Andrew (andrewabc) wrote :

I have no idea where this screen section is. If you mean under the system->"screen and graphics". that is completely blank. No way to choose screens or resolutions.

Even with Gutsy when screen+graphics worked, my monitor was not listed.

pyknite (f4lken) wrote :

no, not in system->...

this section is in your xorg.conf... you can find it in /etc/X11/xorg.conf

Chris Hamons (chris-hamons) wrote :

I can confirm this as well, on 8.4 installed in a vmware image. And yes, the ServerLayout in xorg.conf fixed it for me too.

pyknite (f4lken) wrote :

don't forget, the bug it's not corrected... It's just a solution to pass over the bug...

Andrew (andrewabc) wrote :

I'm still not sure what you guys are talking about. Are you wanting me to add
Section "ServerLayout"
 Identifier "Default Layout"
 Screen "NAME OF YOUR SCREEN"
EndSection

to the end of my xorg.conf? I do not have that currently. Attached is my current xorg.conf
I will try this.

Andrew (andrewabc) wrote :

I added that to end of xorg.conf and screen and graphics now works. :)

Andrew (andrewabc) wrote :

Sigh, my monitor is not listed, s*o I am trying every LG monitor.
My monitor native resolution is 1680*1050. But it keeps reseting back to 800*600.
Hopefully one of these monitor settings will work. Otherwise I am better off with a broken xorg.conf.

Here is my old bug report
https://bugs.launchpad.net/ubuntu/+bug/154412

pyknite (f4lken) wrote :

add this at the end of your xorg.conf:

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Configured Monitor"
EndSection

Andrew (andrewabc) wrote :

Yah I did, and I can now edit screen+graphics.
But now the other bug appears. screen+graphics constantly crashes, and I try as many different LG monitors and all generic monitors but none work.

Here is my new messed up xorg.conf that I am currently using that is not working. I tried manually editing xorg.conf to make it use only the things I want, but it didn't fully work.

pyknite (f4lken) wrote :

try a sudo dpkg-reconfigure xserver-xorg-video-intel

or

replace in your xorg.conf "i810" by "intel"

Andrew (andrewabc) wrote :

I'd like to but not I cannot get screen+graphics working again (I went back to original xorg.conf after breaking ubuntu). I add

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Configured Monitor"
EndSection

to xorg.conf, but it crashes ubuntu and I have to go into recovery mode and repair X (which brings it back to autodetect settings, which make xorg.conf almost blank). No idea why it worked the once before.
I get "too much work for IRQ17" error and unable to input anything from keyboard.

I try your sudo dpkg-reconfigure xserver-xorg-video-intel but it does nothing since screen+graphics is not working anymore (.

I'll have to wait and try alpha 5. But I doubt that will help since I've had this problem since last October.
Best solution for me is to have a non configured xorg.conf :(

Andrew (andrewabc) wrote :

I remembered how to get screen+graphics working again (I have to go into screen/graphics and choose anything before restarting computer otherwise it crashes ubuntu)

Your sudo dpkg-reconfigure xserver-xorg-video-intel
does absolutely nothing, nothing pops up, it stays in terminal with a new line.

Andrew (andrewabc) wrote :

I am happy to report that I got
replace in your xorg.conf "i810" by "intel"
to work. Now screen+graphics works, and I have proper resolution.
Thank you. Here is my latest working xorg.conf

@GABOR CZIGOLA :

Are you sure that this bug is really a duplicate of #144641 ? Waiting your explications I remove the duplicate.

The problem here is that displayconfig-gtk can't use an xorg.conf (generated by the installation) without ServerLayout sections.

#144641 is when you use displayconfig-gtk to generate xorg.conf.

 xorg (1:7.3+10ubuntu6) hardy; urgency=low
 .
   * dexconf: Write a section for synaptics and ServerLayout again, since
     input-hotplug is not ready for public consumption. (LP: #173411

Changed in displayconfig-gtk:
status: Confirmed → Fix Released
sibidiba (sibidiba) wrote :

@Patrice Vetsel :

X.org 7.2 does not require you to have a ServerLayout section. As it does not require you anymore to have inputdevice, device, monitor, display or screen (sub)sections.
Everything should be hotpluggable and configurable from userspace (with tools like xrand).
The problem is not just that displayconfig-gtk requires the serverlayout section, but it parses and generates old X.org conf files.
So even if you have a serverlayout section, displayconfig-gtk might start up, but it can break your X, generating a now illegal xorg.conf.

This bugreport is a subset of #144641.
#144641 is also more straightforward because it points out, that currently Ubuntu Hardy has no GUI for setting up/configuring displays devices.
(displayconfig-gtk is outdated, grandr just segfaults every time)

Savvas Radevic (medigeek) wrote :

confirming on ubuntu hardy heron 8.04 amd64 alpha 5 updated

http://launchpadlibrarian.net/12179056/empty-displayconfig-gtk.png

When running screens and graphics in terminal, I've noticed this nice error:
$ displayconfig-gtk
*** Error: couldn't find any ServerLayout sections
$ gksudo displayconfig-gtk
*** Error: couldn't find any ServerLayout sections

My info:
01:00.0 VGA compatible controller [0300]: nVidia Corporation G70 [GeForce 7300 GT] [10de:0393] (rev a1) (prog-if 00 [VGA controller])
 Subsystem: Micro-Star International Co., Ltd. NX7300GT-TD256EH [1462:0412]
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
 Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Memory at fc000000 (64-bit, non-prefetchable) [size=16M]
 I/O ports at cc00 [size=128]
 [virtual] Expansion ROM at fe9e0000 [disabled] [size=128K]
 Capabilities: [60] Power Management version 2
 Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 Capabilities: [78] Express Endpoint IRQ 0

$ apt-cache policy nvidia-glx-new displayconfig-gtk
nvidia-glx-new:
  Installed: 169.12+2.6.24.10-11.29
  Candidate: 169.12+2.6.24.10-11.29
  Version table:
 *** 169.12+2.6.24.10-11.29 0
        500 http://uk.archive.ubuntu.com hardy/restricted Packages
        100 /var/lib/dpkg/status
displayconfig-gtk:
  Installed: 0.3.7
  Candidate: 0.3.7
  Version table:
 *** 0.3.7 0
        500 http://uk.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Attached all the logs in a tar.gz file

Changed in displayconfig-gtk:
assignee: nobody → desktop-bugs

@Sawas : fix have been released, xorg.conf have to be re-generated. Test Alpha6 http://iso.qa.ubuntu.com/

Id2ndR (id2ndr) wrote :

@Patrice Vetsel,
How to re-generate xorg.conf ?

@all
Is displayconfig-gtk still usefull with new gnome-display-properties ?

DFreeze (dfreeze) wrote :

I also had this empty Screens and Graphics, so I tried the fix suggested here. I wasn't that fortunate... My X was all garbled up, and displayconfig-gtk showed up (almost unreadable) to help me fix the problem. In the end, it couldn't fix it, so I had to do a dpkg-reconfigure xserver-xorg to get the system back.

BUT, after all this, xorg.conf had gotten a Server Layout from the reconfigure, and now my Screens and Graphics is populated. It wasn't the easiest way to get it fixed, but the result is satisfactory, nonetheless.

To post a comment you must log in.