Precise non-pae mini.iso installation results in incomplete language support warning

Bug #931191 reported by Erick Brunzell
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

This is my first bug report regarding a mini.iso so apologies in advance if I do everything wrong.

I've completed 3 installations using the 20120209 non-pae mini.iso, two of which I completed with the Ubuntu desktop, and the third I completed with Ubuntu LXDE desktop (which is actually Lubuntu). After completing all three installations and booting into the new DE I was immediately presented with the warning "Incomplete language support".

After following the instructions I just get "Could not install full language support". After that it's just rinse and repeat. I'm clueless about how to see if that error warning is just bogus or if there is in fact a problem with language support.

Please let me know what additional info might be needed.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: debian-installer (not installed)
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic 3.2.5
Uname: Linux 3.2.0-15-generic i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Sun Feb 12 17:36:35 2012
MachineType: IDOT ID-PCM7E PC2500
MemoryUsage:
 total used free shared buffers cached
 Mem: 959840 627864 331976 0 26784 318608
 -/+ buffers/cache: 282472 677368
 Swap: 980988 0 980988
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-15-generic root=UUID=67d8e830-eeb9-46f7-8640-3aedd245e7ea ro splash quiet vt.handoff=7
SourcePackage: debian-installer
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/26/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: ID-PCM7E PC2500
dmi.board.vendor: IDOT
dmi.board.version: 1.x
dmi.chassis.type: 3
dmi.chassis.vendor: IDOT
dmi.chassis.version: 1.x
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd09/26/2006:svnIDOT:pnID-PCM7EPC2500:pvr1.x:rvnIDOT:rnID-PCM7EPC2500:rvr1.x:cvnIDOT:ct3:cvr1.x:
dmi.product.name: ID-PCM7E PC2500
dmi.product.version: 1.x
dmi.sys.vendor: IDOT

Revision history for this message
Erick Brunzell (lbsolost) wrote :
summary: Precise non-pae mini.iso installation results in incomplete language
- support
+ support warning
Revision history for this message
Erick Brunzell (lbsolost) wrote :

I posted four screenshots along with some explanation in a forum thread if that's helpful:

http://ubuntuforums.org/showpost.php?p=11687248&postcount=14

BTW that was using the standard PAE version of the Precise mini.iso just to be sure it wasn't limited to the non-pae version.

I'll soon test the Oneiric version just for comparative purposes.

Revision history for this message
Erick Brunzell (lbsolost) wrote :

This actually happens even with the Oneiric mini.iso, but with Oneiric I don't get the endless loop. So my best guess is that something is just incomplete regarding Precise language packs. This wouldn't be surprising since we're in Alpha 2, and given some of the "lack of spell-check" bugs that we've seen recently.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Revision history for this message
Justin Jereza (justinjereza) wrote :

Hello.

I noticed that there hasn't been much activity with this bug. Just chiming in to say that this error still occurs every time I do a network install with 12.04.

Revision history for this message
roelof van der kleij (r-g-van-der-kleij) wrote :

Ditto for me with the network install.

Revision history for this message
roelof van der kleij (r-g-van-der-kleij) wrote :

I included a

check-language-support | xargs apt-get -y install

in my post install tasks. After that, gnome-language-support does not find any missing packages, but I still get the pop-up in precise.

Revision history for this message
David Partain (david-partain) wrote :

This is biting me, too. In my installer/syslog, I'm seeing something similar to what's in Erick Brunzell's log:

Feb 12 23:01:05 in-target: Setting up language-pack-gnome-en-base (1:12.04+20111229) ...
Feb 12 23:01:09 in-target: Reading package lists...
Feb 12 23:01:09 in-target: Building dependency tree...
Feb 12 23:01:10 in-target: Reading state information...
Feb 12 23:01:10 in-target: E
Feb 12 23:01:10 in-target: Unable to locate package language-support-en
Feb 12 23:01:11 pkgsel: finishing up
Feb 12 23:01:12 pkgsel: dpkg-query -W language-pack-en language-pack-gnome-en language-support-en failed; assuming incomplete language support

I would _guess_ that this is where the popup is coming from. language-support-en has not existed as a package in either oneiric or in precise, so that would explain why it cannot be found. I cannot find where this dpkg-query is being run, though.

Revision history for this message
Ballock (ballock) wrote :

Just linking: The issue has been discussed and worked around on http://ubuntuforums.org/showthread.php?t=2029774

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers